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Introduction
cnMaestro is Cambium Networks next-generation network management platform. It is available in two versions:
cnMaestro Essentials and cnMaestro X.

l cnMaestro Essentials is free and provides basic network management support for Cambium Networks
devices.

l cnMaestro X is a paid service that includes advanced features such as long-term statistics.

l Both versions are available in cloud and on-premises deployments.

This section covers the following topics:

l Supported Devices and Features

l Quick Start

l Creating a Cloud Account

l cnMaestro X

l UI Navigation

l Device Onboarding

Supported Devices and Features

Devices and minimum software versions
The following table lists the device model and the minimum software version supported by cnMaestro (not the
recommended software version).

Device Minimum Software Version

60 GHz cnWave V1000 1.1

60 GHz cnWave V2000 1.2.2

60 GHz cnWave V3000 1.1

60 GHz cnWave V5000 1.1

cnMatrix 2.0.4-r1

cnPilot e400/e500 3.2.1-r6

cnPilot e425H/e505 4.0

cnPilot e430W/e410/e600 3.5.2-r4

cnPilot e501S 3.2.1-r6

cnPilot e502S 3.2.1-r6

cnPilot e510 3.11.4-r9

Table 1: Supported devices and minimum software versions
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Device Minimum Software Version

cnPilot e700 3.7-r9

cnPilot r190 4.4.2-R2

cnPilot r195P 4.7

cnPilot r195W 4.5.2

cnPilot r200/r201 4.4.2-R2

cnRanger Sierra 800 1.0.1.0-r1

cnRanger Tyndall 101 1.0.1.0-r1

cnRanger Tyndall 201 2.0-r1

cnReach N500 5.2.17e

cnVision Client 4.6

cnVision Hub 4.6

cnWave 5G Fixed B1000 2.0

cnWave 5G Fixed C100 2.0

ePMP 1000 2.6.2

ePMP 1000 Hotspot 3.2.1-r6

ePMP 2000 3.0.1

ePMP 3000 4.4.1

ePMP 4600 5.4.0

ePMP4600L 5.4.0

ePMP Elevate 3.2

ePMP Elevate SXGLIT5/LHG5 4.3.2.1

ePMP Elevate XM/XW 3.2

ePMP Force 130 2.4 GHz 4.4

ePMP Force 130 5 GHz 4.3.2

Table 1: Supported devices and minimum software versions



Device Minimum Software Version

ePMP Force 180/200 2.6.2

ePMP Force 190 3.5

ePMP Force 200L 4.7.0

ePMP Force 300 4.1

ePMP Force 300-13 4.4

ePMP Force 300-13L 4.5.2

ePMP Force 300-13LC 4.6

ePMP Force 300-19 4.4

ePMP Force 300-19R 4.4

ePMP Force 300-22L 4.6

ePMP Force 300-25L 4.6

ePMP Force 300 CSM 4.3.2

ePMP Force 400 5.1.0.18

ePMP Force 425 5.1.0.18

ePMP Force 4500 5.4.0

ePMP Force 4525 5.4.0

ePMP Force 4600C 5.4.0

ePMP Force 4625 5.4.0

ePMP MP 3000 4.5

ePMP PTP 550 4.1

ePMP PTP 550E 4.4.2

Machfu 7.1.2-1.1.0.5

NSE 3000 1.0

PMP 15.0.1

PMP 450 MicroPoP Omni 16.2.1

Table 1: Supported devices and minimum software versions
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Device Minimum Software Version

PMP 450 MicroPoP Sector 16.2.1

PMP 450b Retro 16.2.2

PMP 450v 23.0

PTP 650 01-47

PTP 670 (650 Emulation) 01-47

PTP 670, PTP 700 02-67

PTP 820, PTP 850 11.9

XE3-4 6.4

XE3-4TN 6.5.1

XE5-8 6.4.1

XV2-2 6.1

XV2-2T0 6.4

XV2-2T1 6.4.1

XV2-22H 6.5

XV2-21X 6.5

XV2-23T 6.5

XV3-8 6.0

PON 1.1.0

RV22 Home Mesh Router 1.0.0

Table 1: Supported devices and minimum software versions



Device Model Minimum Software Version

Wave 2 APs:

l XA4-240

l XD2-230

l XD2-240

l XD4-240

l XH2-240

8.7.0

Wave 1 APs:

l XD4-130

l XH2-120

l XR-630

l XR-620

8.7.0

Wave 1/2 Modular 4-radio

l XR-2436/Wave 2

l XR-2426

l XR-4436

l XR-4426

l XR-2226

l XR-2236

l XR-2247

l XR-2447

l XR-4447

8.7.0

Wave 1 Modular 8-radio:

l XR-4836/Wave 2

l XR-4826

8.7.0

Table 2: Supported Xirrus device models

Supported browsers
The following table lists browsers supported by cnMaestro on different operating systems:
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Operating System Browser Version

Linux Chrome 49 and above

Firefox 45 and above

macOS Safari 9 and above

MS Windows Chrome 49 and above

Firefox 45 and above

Microsoft Edge 44.17763.1.0 and above

Table 3: Supported browsers

Network connectivity
Cambium devices use https://cloud.cambiumnetworks.com over port 443 to access cnMaestro in the cloud.
The devices initiate the connection, and they can be located in a private subnet behind a NAT firewall.

cnMaestro shared features
The following table lists the features shared between the on-premises and cloud deployments.

cnMaestro
Essentials

cnMaestro X Feature Description

Advanced
Troubleshooting

Display tower-to-edge status in a single graphic,
which is used to:

l View Wi-Fi client details and health.

l Troubleshoot client connectivity directly on the
AP.

AP Group
Configuration

Support configuration of Enterprise Wi-Fi and cnPilot
Home devices.

AP Group
Dashboard

Display aggregate Wi-Fi AP statistics for the
configured AP Group.

Assists Assists scans the configurations and generates assists
scores.

Audit Logs Record administrator activities.

60 GHz cnWave
Auto Manage
Routes

Support automated IPv6 routes for Distribution Node
(DN) and Client Node (CN) based on topology and
status of Point of Presence (PoP) Node.

Automatic Device
Software Updates

Automatically update device software during
onboarding or reconnection.

Table 4: Primary features supported by cnMaestro

https://cloud.cambiumnetworks.com/#/


cnMaestro
Essentials

cnMaestro X Feature Description

Bulk Acknowledge
Alarms

Acknowledge multiple alarms and clear them in a
single action.

Bulk Image
Upgrade

Schedule software image upgrades across sectors
and device groups.

Citizen Broadband
Radio Service
Subscription
(CBRS)

Support CBRS-compliant devices in the 3.6 GHz band
(from 3550 MHz to 3700 MHz).

Client -Application
Visibility

Allows methods to control, or block applications or
terminate based on consumption of applications.

Client - Renaming
the host-name

Rename wireless and wired client host-names to more
appropriate names for easy reference.

cnArcher
Installation
Summary

Displays the installation summary of PMP & ePMP SMs.

Data Reports Export device, performance, alarm, and event
statistics data in CSV format.

Device Inventory Aggregate inventory data for a group of devices at
the System, Network, Tower, Sector, or Site level in
PDF or CSV format.

Enterprise View Display a simplified UI tailored for Enterprise Wi-Fi.

Guest Access
Portal

Allow Wi-Fi Clients to access wireless service for free
or by using vouchers.

Guest Access
Portal (Paid
Access)

Allow Wi-Fi Clients to connect to wireless service
through paid access.

Guest Access
Portal (Enterprise)

Allow Wi-Fi clients to access wireless network using
one of the following access methods:

l Google
l Microsoft Azure
l Self Registration
l Sponsored Guest

Hierarchical
Dashboards

Visualize devices from tower to edge through
customized dashboards for each device type.

IPv6 Support Provide IPv6 support for cnPilot Enterprise devices.

Table 4: Primary features supported by cnMaestro
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cnMaestro
Essentials

cnMaestro X Feature Description

LTE Manage cnRanger LTE devices.

Managed Server
Provider (MSP)

Allow cnMaestro account owners to split their
installation into separate Managed Accounts. Each
Managed Account contains independent
administration and configuration.

Maps and Map
Modes—Street
View

Leverage maps to position devices and visualize their
health and connectivity. Change the map mode to
display various wireless key performance indicators.

Maps and Map
Modes—Satellite
and Terrain

Mesh Peers Display details of available Mesh clients.

Multiple
Administrators

Invite colleagues by email to manage the account with
an assigned role.

Multiple UI Views Support the following tailored views in the cnMaestro
UI:

l Access and Backhaul View: Used for managing
Fixed Wireless and Wi-Fi deployments, including
the following:

l 60 GHz cnWave

l cnMatrix

l cnPilot Home (cnPilot R-Series)

l cnRanger

l cnVision

l cnWave 5G Fixed

l Enterprise Wi-Fi (E-Series and
XE/XV-Series) and cnPilot Enterprise
(ePMP 1000 Hotspot)

l Enterprise Wi-Fi (Xirrus-Series)

l ePMP

l NSE

l PMP

l PTP 650/670/700

l PTP 820/850

l RV22 Home Mesh

l PON

l Enterprise View: Used for managing Wi-Fi

Table 4: Primary features supported by cnMaestro



cnMaestro
Essentials

cnMaestro X Feature Description

deployments, including the following:

l cnMatrix

l Enterprise Wi-Fi (E-Series and
XE/XV-Series) and cnPilot Enterprise
(ePMP 1000 Hotspot)

l Enterprise Wi-Fi (Xirrus-Series)

l NSE

l Industrial Internet View: Used for managing Fixed
Wireless, Wi-Fi, and IIoT deployments, including
the following:

l 60 GHz cnWave

l cnMatrix

l cnPilot Home (cnPilot R-Series)

l cnRanger

l cnReach

l cnVision

l cnWave 5G Fixed

l Enterprise Wi-Fi (E-Series and
XE/XV-Series) and cnPilot Enterprise
(ePMP 1000 Hotspot)

l Enterprise Wi-Fi (Xirrus-Series)

l ePMP

l Machfu

l NSE

l PMP

l PTP 650/670/700

l PTP 820/850

l RV22 Home Mesh

l PON

Multi-Floor Plans Multiple floor plans for Sites.

Notifications Communicate immediate status with stateful alarms
and events. Notifications help troubleshoot customer
issues.

Organization Allow users to manage multiple accounts through a
single CBRS payment subscription.

Role-Based Access Assign the following roles to users:

Table 4: Primary features supported by cnMaestro
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cnMaestro
Essentials

cnMaestro X Feature Description

l Super Administrator

l Administrator

l Operator

l Monitor

l CPI

Scheduled
Configuration
Update

Specify a time to configure devices.

Scheduled
Software Update

Specify a time to install device software.

Site Dashboard Aggregate Wireless LAN AP statistics by location.

Statistics and
Trending

Present historical radio and network statistics.

Switch Groups Support shared configuration across cnMatrix
switches.

Template-Based
Configuration

Schedule configuration of single devices or a group of
devices across your network by using templates for
cnPilot Home (R-Series), cnMatrix, cnReach, cnVision,
ePMP, Machfu, PMP, and PTP 820/850 devices.

User Session
Management

Track current cnMaestro users and support forced
logoff.

Zero Touch
Onboarding

Allow cnVision Client, PMP SMs, and ePMP SMs to
automatically appear in the onboarding queue if the
parent AP is already onboarded.

Table 4: Primary features supported by cnMaestro

Differences between cnMaestro Cloud and On-Premises
The majority of features in cnMaestro On-Premises are identical to cnMaestro Cloud, but there are some
differences.

The following table lists the feature differences between cnMaestro Cloud and On-Premises:



cnMaestro
Essentials

cnMaestro X Feature Description

Account Recovery Password and account recovery issues are
resolved locally.

Auto-Provisioning New devices, such as cnPilot Home (R-Series),
cnVision, Enterprise Wi-Fi, Enterprise Wi-Fi
(Xirrus-Series), ePMP, and PMP, can
automatically be approved and onboarded using
the subnet.

Backup and Restore Backup or restore configuration and monitoring
data from cnMaestro.

Cloud Synchronization Allows to connect to the Cloud Anchor account
and also push announcements form Cloud
Anchor account to to On-Premises instances.

Certificate Management SSL certificate management is available for the
UI and Guest Access Portal.

cnMaestro Software
Upgrade

Enable three types of software upgrade:

l Virtual machine upgrade requires the
customer to replace the entire virtual
machine with a new instance. The
configuration and the data are exported from
the old instance and imported to the new.

l Package upgrade only updates the
cnMaestro software. It does not require a
virtual machine reinstallation.

l OVA upgrade only overwrites the OS
partition.

Configuration Backup Backup configuration from fixed wireless
devices (cnVision, PMP and ePMP) and cnReach
devices that are currently online.

Deployment l The Cloud version is fully hosted and
maintained by Cambium Networks at
https://cloud.cambiumnetworks.com.

l The cnMaestro On-Premises version is
released as an OVA (Open Virtualization
Archive) file that needs to be installed on
either VMware or VirtualBox.

Device Connectivity l In the Cloud version, all devices can be
accessed through
https://cloud.cambiumnetworks.com.

Table 5: Differences between Cloud and On-Premises
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cnMaestro
Essentials

cnMaestro X Feature Description

l In the cnMaestro On-Premises version, all
devices contact the local cnMaestro server.
The devices must be configured to access the
server before they can be managed.
Alternatively, DHCP options can be
configured to provide the cnMaestro URL
when the device boots up.

Device Image
Management

l In the Cloud, device images are automatically
available.

l In the cnMaestro On-Premises device, new
images need to be downloaded from Support
Center and added to the cnMaestro server.

l Device image can be downloaded from the
anchor.

Local and
Authentication Server
Administrators

Multiple types of administration access for local
administrators (with a username and password
maintained by cnMaestro) or authentication
services (including TACACS+, RADIUS, LDAP,
Active Directory, OpenID Connect, and SAMI).

Onboarding l In the Cloud version, devices onboard using
either the device Manufacturer Serial Number
(MSN) or through the Cambium ID or
Onboarding Key (entered on the device).

l In the cnMaestro On-Premises version, all the
cloud modes of onboarding or devices
contacting cnMaestro are added to the
Onboarding Queue, where they are approved
and managed.

On-Premises Console Configure networking parameters and update
the system password using the CLI available
through the virtual machine console.

Server Management Monitor virtual machine parameters such as disk,
memory, and CPU utilization through the UI.

SNMP Basic SNMP for inventory and alarms.

System Events System events for cnMaestro On-Premises
server instance.

System Log Forward events to a remote system log server.

Table 5: Differences between Cloud and On-Premises



cnMaestro
Essentials

cnMaestro X Feature Description

Webhooks Send alarm notifications to the external servers.

Wi-Fi Speed Test Test the speed between the Wi-Fi APs and
cnMaestro.

Topology Scan X Toposcan Discovery tool allows a user to select
a DN and scan for nodes on the same channel
sector.

Device Auto Refresh Device Auto Refresh allows to refresh data
automatically in the E2E Network.

Table 5: Differences between Cloud and On-Premises

Quick Start

This section guides users through the initial process of creating an account; logging into cnMaestro; and
claiming and onboarding devices.

You must perform the following procedures to create an account and onboard devices.

l For account management:

1. Create a Cambium Support Center login (if you do not have one already).

2. Create a cnMaestro account.

3. Login to cnMaestro.

l For claiming devices:

1. Claim devices using a Manufacturer Serial Number (MSN).

2. Claim devices using a Cambium ID.

Create and manage accounts
To access cnMaestro, you must create a Cambium Support Center account, which sets your username and
password.

Create a Cambium Support Center login
cnMaestro uses an existing Cambium Support Center account. If you do not have an account, you must create
one.

To create a Cambium Support Center account, perform the following steps:

1. Open a web browser and enter https://cloud.cambiumnetworks.com into the address bar.

The cnMaestro Main login page appears, as shown in Figure 1.

2. Click Register.
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Figure 1 The main login page

A registration form appears, as shown in Figure 2.

Figure 2 Initial registration form

3. Enter your email address and click the Register button.

An email from Cambium Support Center is sent with a link for validation.

4. Check email and click the validation link, as shown in Figure 3.



Figure 3 Email from Cambium Support to validate account

Note:

If you do not receive the email, check your spam folder.

The Finish registering form appears, as shown in Figure 4.
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Figure 4 Finish registering form

5. In the registration form, you must enter details such as your name, company name, country name, and
password.

6. Click Register to complete the process.

Create a cnMaestro account
Use the Cambium Support Center account to log on to cnMaestro and create a cnMaestro account.

1. Open a web browser and enter https://cloud.cambiumnetworks.com into the address bar.

The Main login page appears.

2. Log on to cnMaestro using your Cambium Support Center account.

Create a New Cloud Account window appears.

3. Click Add New Account.

The Create a New Cloud Account page appears, as shown in Figure 5.

https://cloud.cambiumnetworks.com/


Figure 5 Create a Cloud Account form

4. Enter the required details and complete the form.

Note:

The Cambium ID is the primary identifier of the account. It may optionally be used to
onboard devices.

5. Click Create Account to complete the process.

Log on to cnMaestro
To log on to the cnMaestro, perform the following steps:

1. Open a web browser and enter https://cloud.cambiumnetworks.com into the address bar.

The cnMaestro Main login page appears, as shown in Figure 6.

Figure 6 Main login page
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2. Click Sign In.

Please enter your email address page appears as shown in Figure 7.

Figure 7 Email address page

3. Enter your Email address.

4. Click Next.

Please enter your password page appears as shown in Figure 8.



Figure 8 Password page

5. Click Sign in.

Select Account page appears as shown in Figure 9.

Figure 9 Select account page

In Select Account page you can use search option to search the account.
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6. Click the selected account.

The cnMaestro Home page appears, as shown in Figure 10.

Figure 10 cnMaestro Home page

Claim and onboard devices
To manage devices in cnMaestro, it is necessary to claim and onboard them.

Claiming specifies who owns a device. After a device is claimed, it is listed in the Onboarding Queue, where it
can be pre-provisioned or approved. Once devices are approved, they are managed by cnMaestro.



Claim devices by serial number
You can claim a device by using the Manufacturer Serial Number (MSN). The system prompts the user to
validate the devices before applying them. After being claimed, devices are placed into the Onboarding Queue,
where they can be pre-provisioned to update software or configuration before onboarding.

To claim and onboard a device, perform the following steps:

1. From the Home page of cnMaestro, navigate to Onboard > Device tab.

The Onboard page appears with details of the devices and their serial numbers, as shown in Figure 11.

Figure 11 Onboard page

2. Click Claim Devices located at the right side of the Onboard page (as shown in Figure 11).

The Claim Devices with Serial Number page appears, as shown in Figure 12.

3. Enter the Serial Number(s) of the device(s) in the text box, as shown in Figure 12.

If MSP is enabled, select the Managed Account from the drop down and Enter the Serial Number(s) of the
device(s) in the text box.

Note

You can also place a cursor in the text box and use a barcode scanner to quickly claim the
devices.
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Figure 12 Claim Devices with Serial Number page

4. Click Claim Devices.

5. To onboard the device when it contacts cnMaestro, click the Approve Device ( ) icon or Approve All at the

right side of the Onboard page, as shown in Figure 13.

Figure 13 Onboarding Queue

Note

If you do not click the Approve Device button, the device remains in the Onboarding
Queue.

Claim devices by Cambium ID
The Cambium ID, set during the Cloud account creation can also be used to claim devices. You can see the
Cambium ID on the user drop-down, as shown in Figure 14.

Figure 14 Cambium ID



A Cambium ID with an Onboarding Key is:

l Required to claim legacy devices that do not have a 12-character serial number (these devices are usually 5+
years old).

l Optional for devices that have 12-character serial numbers (though generally not used).

The administrator must approve all devices added to the Onboarding Queue using the Cambium ID.

Cambium ID configuration
You must configure the Onboarding Key in order to claim devices with Cambium ID, as shown in Figure 15.

Figure 15 Cambium ID configuration

Onboarding Key configuration
Each Onboarding Key is mapped to an individual User account. This mapping allows Cambium Cloud to know
who is onboarding a device, and the key can be revoked if needed.

To configure the Onboarding Key, perform the following steps:

1. Log on to your cnMaestro account.

The Home page appears, as shown in Figure 16.
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Figure 16 Home page
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2. From the Home page, navigate to the Onboard > Settings tab.

Figure 17 Onboard settings page

3. Select the Allow device to be claimed using Cambium ID checkbox.

Enabling this feature allows one to add Onboarding Keys mapped to individual Users.

4. Click Add New to add a User and Onboarding Key.

A new row appears as shown in Figure 18.

Figure 18 New onboarding key

5. Select the User from the drop-down.

6. Enter the Onboarding Key.

7. Click Save.



Onboard device using Onboarding Key
The Cambium ID and Onboarding Key are entered into the Device UI (see the User Guide for the individual
devices to determine where; the section below demonstrates the process for cnPilot). Once entered, the Device
sends these credentials to Cambium Cloud, where it is mapped to the Onboarding Queue of the Cambium ID
account.

Device UI

To configure the Onboarding Key using cnPilot Device UI, perform the following steps:

1. Log on to the Device UI.

The Sign In page appears, as shown in Figure 19.

Figure 19 Login page

2. Enter your Username and Password.

3. Click Sign In.

The device home page appears, as shown in Figure 20.

Figure 20 Device home page

4. From the Home page, navigate to Configure > System > Management.

System configuration page appears, as shown in Figure 21.
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Figure 21 cnMaestro configuration

5. Enter URL in cnMaestro URL to connect the server (by default it will be cloud.cambiumnetworks.com), as
shown in Figure 21.

6. Enter the Cambium ID.

7. Enter the Onboarding Key.

8. Click Save.

Once in the Onboarding Queue, the devices can be provisioned and managed by clicking the Approve Device
button, as shown in Figure 22.

Figure 22 Device approval

Creating a Cloud Account

This section provides an overview of cnMaestro Cloud Accounts. This section includes the following:

l Overview

l Creating a Support Center User ID

l Creating a Cloud NMS Account

l Creating an Anchor Account

l Multiple Cloud Accounts

Overview
There are two types of accounts for cnMaestro cloud management.

http://cloud.cambiumnetworks.com/


Account Description

Cloud NMS Cloud NMS accounts allow users to manage their devices through
https://cloud.cambiumnetworks.com. Devices can be claimed, onboarded, and fully
managed through the cloud service.

Cloud Anchor Cloud Anchor Accounts are needed for on-premises installations of cnMaestro. After
cnMaestro is deployed in a local data center, it connects to a Cloud Anchor Account.
See the following section for more details on Creating an Anchor Account.

Table 6: Account types

Both Cloud NMS and Cloud Anchor Accounts require a Support Center ID to login.

Creating a Support Center User ID
New Cambium Cloud users need to register with Cambium Support Center to create a Support Center ID.

1. Navigate to https://cloud.cambiumnetworks.com and click Sign In.

2. In the Sign In page, click Register.

3. Enter your email address in the text box and click Register.

4. An email will be sent to the address provided. Open the email and click the link.

5. Fill in details on the registration completion form, such as your name, the name of your company, and a
password.

6. Click Sign in to log into the UI.

Creating a Cloud NMS Account
If you do not have a Cloud NMS Account, you will be asked to create one after logging in and accessing
cnMaestro Cloud. The NMS Account allows you to access cnMaestro functionality and start claiming devices.

1. Log in to the cnMaestro UI https://cloud.cambiumnetworks.com.

2. Click Add New Account. You will be redirected to the Create a New Cloud Account page.

3. Enter details such as Cambium ID, Friendly Name, Country, Time Zone, Account Type, and Account View.
The Account Type should be set to NMS.

4. Enable I agree to the cnMaestro Terms of Service.

5. Click Create Account.
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Figure 23 Create Cloud NMS account

The required fields are defined below:

Parameter Description

Account Type The Account Type is either NMS or Anchor. Select NMS to manage devices through
cnMaestro Cloud. Select Anchor if installing cnMaestro On-Premises.

Account View Select the Account View based on the devices you intend to manage. Select
Enterprise if only cnMaestro Enterprise devices will be managed (these include the
cnMatrix, Enterprise Wi-Fi (E-Series and XE/XV-Series) and cnPilot Enterprise (ePMP
1000 Hotspot), Enterprise Wi-Fi (Xirrus-Series), and NSE). The Account View can be
changed later by navigating to Administration > Settings > General.

Cambium ID The Cambium ID identifies this account externally. Once created, it can only be
changed by contacting Cambium Support.

Friendly Name The Friendly Name is generally the same as the Company that owns the devices. It is
informational.

Country The Country determines where to store the device data. Cambium has data centers in
North America, Europe, and Asia. If your devices are located in more than one region,
you should create a separate account for a country in each region.

Time Zone The Time Zone aggregates daily device statistics. Daily statistics are collected starting
at 12:00 AM in the time zone selected.

Table 7: NMS Cloud management fields

6. Click the drop-down next to the username or search option to view the created Cloud account.

Once you have created a Cloud NMS Account, you will be directed to the home page on subsequent login.



Creating an Anchor Account
An Anchor Account is required only if installing cnMaestro On-Premises.

1. Log in to the cnMaestro UI https://cloud.cambiumnetworks.com.

2. In Account Type, select Anchor.

3. Once the Anchor Account is created, an Onboarding Key must be set to allow On-Premises instances to
connect.

4. Navigate to the Manage Instances page as shown below and edit the Onboarding Key. This key needs to be
entered in the cnMaestro On-Premises UI to connect to the Anchor Account.
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5. Once the On-Premises server has been onboarded with the Key, it will be included in the Instances page.
Multiple On-Premises installations can be added to a single Anchor Account.

Clicking the instance host name displays the server information collected.

Multiple Cloud Accounts
Individuals can belong to multiple Cambium Cloud accounts. To create another Cloud Account (NMS or
Anchor), select Create Account from the drop-down in the top-right corner. Enter the ID name in the Search
field to filter the particular ID.



Figure 24 Multiple Cloud Management Accounts
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Account selection
To switch between accounts, use the drop-down in the top-right corner of the UI. It displays all accounts to
which the user has access.
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Figure 25 Account selection
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Concurrent access
The same user can access multiple accounts simultaneously; however, each account needs to be opened in a
separate browser window or tab.

Managing users
A user can add additional administrators to their cloud management accounts and assign roles such as Super
Administrator, Administrator, Operator, Monitor, and CPI.

Figure 26 Managing users

Creating Users and Configuring User Roles
To add a user:

1. Navigate to Administration > Users Page > Manage Users.

2. Click Add User.

3. Enter the Email address in the Email text box.

4. To configure user role, select from the Role drop-down:

l Super Administrator

l Administrator

l Operator

l Monitor

l CPI

For more details on user Roles, refer to Role-Based Access .

5. Click Send.

6. Cambium Cloud sends an email with directions on how to access the Cloud management account.



Note

The email does not need to match the email address of an existing Cambium user.

7. The email contains a link that directs you to the Cambium Cloud website
https://cloud.cambiumnetworks.com.

8. Login using an existing Cambium Support Center account or create a new Cambium Support Center
account.

Organization
Organizations allow multiple Cloud NMS Accounts and Anchor Accounts to consolidate CBRS billing into one
Primary Account.

l Primary Account: provides services such as Shared SAS ID and Unified Payments to multiple accounts.

l Secondary Account: shares services such as CBRS billing SAS ID; the Secondary Account is linked with the
Primary Account.

Organizations are currently only used with CBRS. Refer CBRS on how they can simplify CBRS management
across multiple accounts.

General details of Organizations include:

1. One Organization can include accounts created in different countries and regions.

2. The maximum number of accounts managed by an Organization is 5.

3. There is one required Primary Account in an Organization and optionally multiple Secondary Accounts.

4. Removing the Primary Account will dissolve the Organization.

5. Both NMS and Anchor Accounts can be included in an Organization, and either can be Primary.

cnMaestro X

cnMaestro works in two different modes: Essentials, and X. cnMaestro Essentials is free and supports basic
network management functionality. cnMaestro X is paid and requires subscriptions.

New accounts are created with cnMaestro Essentials capabilities. cnMaestro X features can be activated with
the Entitlement ID provided by Cambium Networks. For more details, refer to cnMaestro Features. You can
purchase the Entitlement ID from an authorized Cambium Reseller or Distributor. The subscriptions available for
1 year, 3 years, and 5 years per device type and device count. Pricing is based on Device Tiers. You need an
Entitlement ID with equal or more device counts for each tier shown in the Device Summary.

cnMaestro X part numbers are available at
https://www.cambiumnetworks.com/products/software/cnmaestro-x/. Once your order is processed, you will
receive an email from Cambium containing your Entitlement ID.

Note:

l Some features are tagged XA which indicate that cnMaestro will have a different
subscription mode for them in upcoming releases.
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Figure 27 Example of Entitlement ID

Note:

l If you are creating new accounts after cnMaestro 3.0.0, then you can request a 90-day
free trial either through the link available on the cnMaestro home page or
https://www.cambiumnetworks.com/cnmaestro-x/.

l The 90 days free trial gets activated automatically for the accounts created before
cnMaestro 3.0.0.

NSE Subscription:

l The NSE device subscription is supported in cnMaestro Essentials as well as cnMaestro X in the cnMaestro
Cloud deployment.

l You can avail the Entitlement ID for NSE with the required device slots according to the Device Tiers by
contacting the reseller or distributor.

l When you move other devices from cnMaestro Essentials to cnMaestro X, you can continue to use the same
NSE subscription.

l When you have only Free Tier devices and a subscription for NSE, you can manually upgrade to cnMaestro X
and downgrade to Essentials on your own.

cnMaestro X Activation
To activate the cnMaestro X account, perform the steps below:

1. Navigate to https://support.cambiumnetworks.com/entitlements, or from the cnMaestro home page click
the Licensing tile.

2. In the Licensing page under Entitlements select Activate Entitlements.

3. Enter the Entitlement ID received from licensing@cambiumnetworks.com.

4. Click Check.

https://www.cambiumnetworks.com/cnmaestro-x/
https://support.cambiumnetworks.com/entitlements
mailto:licensing@cambiumnetworks.com


5. Once the Entitlement ID is validated, the Activate button is enabled.

Note:

All subscribed part numbers must be activated under each Entitlement ID.

The part numbers subscribed with MSX must be activated together.

6. Click Activate.

7. Select the Cambium ID from the list and click Next.
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8. The Ready to Upgrade page displays.

9. Click Activate.

Note:

If a Slot Deficit error occurs (meaning there are more devices than slots available) occurs,
refer to Slot Deficit.

10. The Previous Activations page displays the Complete activation list.

11. Click any licensed description which is marked Complete.



The Subscription is activated with the number of requested slots.

In the cnMaestro page, a notification displays for a successful update, and the user is asked to wait for 15
minutes.

The user account upgrades to a cnMaestro X account.

Slot Deficit
A Slot Deficit occurs when the number of slots (one for each device) activated from the entitlement is less than
the slots required. This can occur if there are more devices in the account than slots.

Upgrading to cnMaestro X will be pending until either devices are removed to match the available slots or more
slots are added to cover the deficit.

1. Select the Cambium ID from the list and click Next.
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2. The Active Entitlement page displays Not enough slots when there is a slot deficit.

3. If the user activates even with the slot deficit warning.

l Activation process completes.



l cnMaestro X upgrade will be pending, since there are not enough slots to match the devices in
the account. Refer to Not enough slots in the Manage Subscriptions tab to identify the slot
deficit.

l It also displays the notification message shown below.

4. Once the user removes the deficit, the account automatically upgrades to cnMaestro X.

Subscription Management
A cnMaestro Essentials account can be identified as shown below.

If a subscription is active, the cnMaestro X banner will display.
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Manage Subscriptions
Users can view, edit, check the validity and status of subscriptions.

1. Navigate to the cnMaestro > Manage Subscriptions > Subscriptions page.

2. Click the Edit icon to edit the subscription Name and Description and click Save.

l Onboard devices according to the allotted slots.

l New devices are added to the subscription with the earliest expiration.



Usage Summary

Usage summary displays the number of slots that are Pending, Available, Used, and Expired.

Device Tiers
Device Tiers display the classifications allotted for each device.

Unlisted devices do not require paid subscription. They are part of the Free Tier (Tier 0). All Tier 0 through Tier
7 devices can be used with an Essentials account. Tier 20 and Tier 30 require paid subscription even in
Essentials mode.

NOTE:

To manage NSE devices under Essentials account, you need a subscription. If your account
is upgraded to cnMaestro X, the Essentials NSE subscription will automatically be
transferred to cnMaestro X. You will not need any additional subscription for NSE again.

Devices
The Devices page displays devices mapped to their subscription, and it allows changing or swapping a
subscription. Device Summary displays device counts per tier.
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Swap Subscription
Swap Subscription allows the user to swap one device subscription with another device of the same tier. It can
be performed at any time.

NOTE:

Swap subscription operation is not allowed for devices belonging to Free Tier, Tier 40, Tier
41, Tier 43, and Tier 60.

To swap subscriptions:

1. Navigate to the Subscriptions > Devices and copy the MAC address to which the device subscription needs
to be swapped.

2. Select the device to be swapped to another subscription.



3. Click Swap Subscription. Enter the MAC Address and click Swap.

Device updated successfully message displays on success.
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Change Subscription
Change Subscription changes the device from one subscription to another of the same tier when slots are
available.

NOTE:

Change subscription operation is not allowed for devices belonging to Free Tier, Tier 40,
Tier 41, Tier 43, Tier 60.

To change subscription:

1. Navigate to the Subscriptions > Devices and select the device and click Change Subscriptions.



2. Change Subscription window pops up, select the Subscription from the drop-down.

3. Click Change. Success notification pops up.
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Delete on Expiry

Note:

l Once a device state is changed to Delete on Expiry, this action cannot be undone.

l Tier 30 (NSE) devices also support Delete on Expiry in cnMaestro Essentials.

User can select the device and set the subscription state to Delete on Expiry, once the device is expired, it
automatically is deleted from the device list.

To set the Delete on Expiry:

1. Navigate to the Subscriptions > Devices and select the device.



2. Click Delete on Expiry.

3. Please Confirm window pops up.

4. Click Yes Delete On Expiry.

5. Subscription state changes to Delete on Expiry from Active.
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Expiry Notification
If the subscription validity is less than 90, in the Validity column the number of days left are highlighted in red
color. Also, a notification message will be displayed as shown below.

The expired subscription slots are automatically moved to the active subscription, if the number of expired
subscription slots is equal to or less than the number of available subscription slots.

Expired Device
Once the device expires, all device level features become inaccessible. The device should either be deleted from
the account or added to a new subscription as shown below:



Note:

In the expired device dashboard:

l If any free slots are available Change Subscription will be enabled.

l If free slots are not available Swap Subscription will be enabled with the specific device
MAC address.

l If you have an X account with expired devices, you can downgrade to Essentials and
manage all devices without X features. The activated subscriptions will be moved to
pending state.

Change Subscription at device level

1. Navigate to Manage > Network > and select the expired device.

2. Click Assign Subscription and select the Subscription from the list.

3. Click Save.

The following message displays if successful and the device becomes active.

Swap Subscription at device level

1. Navigate to Manage > Network > and select the expired device.
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2. Click Assign Subscription. The Swap Subscription window pops up.

3. Enter the MAC address and click Swap.

Retention of Data After Expiry and Reinstatement of Service
If subscriptions are not renewed in time, devices under those subscriptions will expire and are no longer
managed by cnMaestro. Once all subscriptions are expired, the account transitions to cnMaestro Essentials with
a data retention period for historical data of 90 days. All historical data beyond one week, and cnMaestro X
specific configuration, will be retained until the data retention period of 90 days, after which it will be deleted.
This is done to ensure no data loss if subscriptions are renewed before the data retention period ends.

cnMaestro X features behavior state
cnMaestro X subscriptions can be purchased for 1 year, 3 years, and 5 years. Pricing is based on device tiers.
Device slots are purchased for each device tier needed for a deployment. Devices require free slots in order to
onboard.

NOTE:

To manage NSE devices under Essentials account, you need a subscription. If your account
is upgraded to cnMaestro X, the Essentials NSE subscription will automatically be
transferred to cnMaestro X. You will not need any additional subscription for NSE again.

The following table describes about the cnMaestro feature behavior state in different modes such as cnMaestro
X, data retention period, and after data retention period.



Table 8: cnMaestro X Feature behavior state matrix

Feature cnMaestro X
On Downgrading cnMaestro
X to Essentials and Data
Retention Period

After Data Retention
Period

60 GHz cnWave Link Events

l Maintains link events
data up to 30 days.

Maps

l Channel and Polarity in
Device Overlay.

l Golay, SNR, MCS, RSSI,
Throughput(Mbps),
Airtime % and Link Fade
Margin in Link Overlay.

l Auto Refresh option
allows to add up to 10
devices.

l Topology Scan

l Node Throughput test

l Link Throughput test

l Current Best Route(s)

Link Events

l Only 7 days link events
data is exposed

l Data will still be collected
in retention period

Maps

l Status and Sectors in
Device Overlay

Link Events

l Not accessible

Maps

l Status in Link Overlay

l Status and Sectors in
Device Overlay

Administrator
Count

Administrator limit
increased from 10 to 200.

New users cannot be added
if the current count is 10 or
more.

Deletes cnMaestro users
with the lower privileges in
Super Administrator >
Administrator > Operator >
Monitor to maintain 10
users.

Application
Visibility

Assists Assists helps to isolate
configuration issues in a
deployment.

Not accessible Not accessible

Audit Logs Audit Logs record user
activity.

Audit log generation
continues through the data
retention period, but users
cannot access the logs.

Not accessible

Bulk Edit l Allows bulk edit of
device configuration
for Enterprise Wi-Fi
devices.

l Allows bulk edit
through import and

Not accessible Not accessible
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Feature cnMaestro X
On Downgrading cnMaestro
X to Essentials and Data
Retention Period

After Data Retention
Period

export of CSV files.

Client
Dashboard

l Displays Wi-Fi Client
application and
network statistics.

l Application statistics
are only available for
NSE, XV, XD, XE, and
XR series devices.

Not accessible Not accessible

cnArcher
Installation
Summary

Installation Summary for
PMP and ePMP SMs
installed using the
cnArcher Mobile
Application

Not accessible Not accessible

Configuration
Lock

Prevents changes to Wi-Fi
AP, cnMatrix, and NSE
device configuration, even
if the device is updated
directly.

The lock is no longer
enforced.

Not accessible

ePSK Limit ePSK limit increased from
300 to 2000.

New ePSK entries cannot be
added if the current count is
300 or more.

Only 300 entries will be
retained, and the rest will
be deleted.

Email
Notifications

Maximum up-to 10 email
recipients can be added
per scope (All Accounts,
Base Infra and per MSP)

l All the configured
email recipients are
retained

l None of the email
recipients are deleted.

l Only the 2 earliest
added subscribers per
scope would receive
email notifications.

Only the 2 earliest added
recipients are retained. The
remaining email recipients
are deleted automatically.

Guest Portal—
Access

Connect a wireless service
through following access
methods:

l Paid access

l Enterprise:

n Microsoft Azure

n Sponsored Guests

Configuration will be
retained, but the feature will
no longer be available.

Not accessible



Feature cnMaestro X
On Downgrading cnMaestro
X to Essentials and Data
Retention Period

After Data Retention
Period

n Self Registration

n Google

l Guests page— Allows
to view details of self
registered guests
connecting to the
wireless network.

Guest Portal—
Design

Allows to create email
templates to send email
confirmation and
password for enterprise
self registration and
sponsored guests.

Configuration will be
retained, but the feature will
no longer be available.

Not accessible

Guest Portal Allows 500 guest portals,
10,000 sessions, and
20,000 login event
session records for a
maximum of 1 year.

l If the count is more than
4 then, all portals are
read-only.

l Only portal delete option
is available to the user.

l All existing client
sessions will continue
without any disruption.

Only 4 portals will be
retained and rest will be
deleted.

Long term
Historical Data

Displays the devices
performance graph:

l Performance graphs
for Wi-Fi APs and
cnMatrix support
historical data for 14
months.

l Performance graphs
for Fixed Wireless
Broadband devices
support historical data
for 26 months.

l All performance graphs
for IIoT devices
support historical data
for 14 months.

Only 7 days of statistics will
be exposed, but existing
data will be maintained.
During the retention period,
data will be maintained.

Removes data beyond 7
days.
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Feature cnMaestro X
On Downgrading cnMaestro
X to Essentials and Data
Retention Period

After Data Retention
Period

Managed
Service Provider
(MSP)

MSP provides separate
Managed Accounts – each
with independent
administration and
configuration.

l Managed Account users
are logged out.

l Managed Services tab is
hidden.

l Managed Account
configuration changed to
read-only.

l Managed Accounts >
Users tab hidden.

l Managed Accounts are
changed to read-only.

All Managed services are
deleted, and they will no
longer be associated with
any managed accounts.

Multi-Floor Site
Plan

Allows to create 50 floor
plan per Site.

l All floor plans are
viewable as read-only.
Cannot create additional
floor plans or edit any
existing floor plans if
more than one
configured in a Site.

l Edit is available only
when all additional floor
plans are deleted.

l Additional floor plans is
deleted and devices on
those floors is
unmapped.

l Only the latest floor is
available.

NBI API Allowed to create API
clients and access token.

l Delete all access token
Block all APIs to do
actions on API client

l Block API to generate
access token

l Email out/alarm for the
deletion of API clients

Remove the API client

Clear alarm

Reports Schedule Devices,
Performance, Active
Alarms, Alarm History,
Events, Clients, Mesh
Peers, and Guest Access
Login Events Reports.

Reports tab will not be
accessible, and all previously
scheduled reports will be
skipped.

All jobs will be terminated
and Reports are not
accessible.

Graphical
Reports

6E Clients by Radio, Client
Count by Manufacturers,
Client Capability Trend,
Client Count over Time,
Top Applications by
Usage, Top Category by

Graphical Reports Template
option will not be accessible.

Graphical Reports
Template option will not
be accessible.



Feature cnMaestro X
On Downgrading cnMaestro
X to Essentials and Data
Retention Period

After Data Retention
Period

Usage, Client Count by
Band, Client Count by
Types, Peak and Unique
Clients, Top APs by
Unique Clients, Client
Traffic over Time

Satellite View It allows to view maps in
Satellite view.

Not accessible Not accessible

Session
Management

Tracks the current
cnMaestro user sessions
and optionally allows to
logout cnMaestro user
sessions.

Not accessible Not accessible

Spectrum
Analyzer

Analyzes and monitors the
wireless spectrum for
optimizing network
performance on PMP
devices.

Not accessible Not accessible

Terrain View It allows to view maps in
Terrain view.

Not accessible Not accessible

WIDS WIDS data is processed

APIs are supported

Statistics is not available
through API.

Not accessible

Webhooks Webhooks provide real-
time streaming for alarms
using a push notification.

Not accessible Not accessible

Navigating the cnMaestro UI

cnMaestro provides a number of ways to navigate the UI.

This section includes the following topics:

l Account View

l Home page

l Page structure

l Page navigation

l Access and Backhaul View

l Enterprise Account view

l Side menu

l Section tabs
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l System status

l Data Tables and Chart UI controls

l Logout

Account View
cnMaestro supports three different account views, based upon the composition of devices.

l Access and Backhaul view

l Enterprise view

l Industrial Internet view

The account view is selected when the account is created but it can be changed later through the
Administration > Settings page.

Figure 28 Account View

Access and Backhaul View
The Access and Backhaul View supports all Fixed Wireless and Wi-Fi devices. The device types include 60 GHz
cnWave, cnMatrix, cnPilot Home (cnPilot R-Series), cnRanger, cnVision, cnWave 5G Fixed, Enterprise Wi-Fi (E,
XE, and XV-Series) and Enterprise (ePMP 1000 Hotspot), Enterprise Wi-Fi (Xirrus-Series), ePMP, NSE, PMP, PTP
650/670/700, PTP 820/850, RV22 Home Mesh, and PON.

Enterprise View
The Enterprise View supports the Enterprise Wi-Fi portfolio, which includes the cnPilot Enterprise APs (ePMP
1000 Hotspot), cnMatrix, and Enterprise Wi-Fi APs (E, XE, and XV-Series), and Enterprise Wi-Fi (Xirrus-Series),
and NSE. It provides a simplified UI for Wi-Fi components (hiding fixed wireless features such as Towers).

Industrial Internet View
Industrial Internet View provides a single interface for Fixed Wireless, Wi-Fi, and IIoT deployments. The device
types include 60 GHz cnWave, cnMatrix, cnPilot Home(R-Series), cnRanger, cnVision, cnWave 5G Fixed, ePMP,
PMP, cnReach, PTP 650/670/700, PTP 820/850, Enterprise Wi-Fi (E, XE, and XV-Series) and cnPilot Enterprise
(ePMP 1000 Hotspot), Enterprise Wi-Fi (Xirrus-Series), Machfu, NSE, RV22 Home Mesh, and PON.



Home page
The Home page is displayed when the user logs into the cnMaestro. It provides links to the core functional areas
in the UI, such as Cambium Support Center, Community, Documents, and Licensing. It can be accessed from
any page in the UI by clicking the Home tab.

Figure 29 cnMaestro Home page

Page structure
cnMaestro follows a standard page structure, which consists of a left-side menu and a content area. In many
pages, tabs provide additional content navigation.
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Figure 30 cnMaestro page structure

Number Elements Description

1 . Left menu Shows the functional areas of the UI. This menu can be expanded or
collapsed to view the submenu by clicking the top arrow.

2 Header Shows the basic counters for Major Alarms, Devices Awaiting for
Approval, Software Updates Jobs, and Out of Sync Devices.

3 Right menu Provides links to Cambium Ideas, Support, Community, Documents,
and Licensing .

4 Functional area Shows the detailed view of the section selected in the left menu.

5 Announcements Displays announcements about availability of newer firmware
versions of devices.

Table 9: UI description

Page navigation
The cnMaestro pages include items such as Dashboard, Notifications, Configuration, Statistics, Report, Software
Update, Applications, Clients, Mesh Peers, and Assists. The content of a page differs depending upon its
context. For example, a Dashboard page will be different at the System/Network/Tower/Site/Device levels.
The context, or level in the hierarchy, is selected in the Device tree as shown in Table 12.



Access and Backhaul View

Overview
The Access and Backhaul view leverages a hierarchical tree to display device installations. In this view,
customers can group their fixed wireless devices into Networks, and display their Point-to-Multipoint devices in
Tower-based sectors. Navigation is performed using the tree. The device tree is segmented into two tabs:
Network and Wi-Fi AP Groups.

Networks tab
The Network tab displays a hierarchical view of the devices. It consists of Systems, Networks, Towers, Sites, and
Devices. There is a strict ordering for how nodes can fit in the hierarchy, and as one navigates through and
selects nodes, the pages display the node chosen.

Selecting an arrow icon will expand the node and display the next level of hierarchy.

NOTE

1. Towers are only visible in the Fixed Wireless view and 60 GHz cnWave devices are only
visible in the 60 GHz cnWave E2E Network. cnMatrix devices are visible only in Access
and Backhaul and Industrial Internet view

2. Japanese characters name is supported in Network, Tower, and Site.

3. Select a node in the hierarchy tree and expand to open the node.

4. Opening the node does not automatically select a node in the new hierarchy, instead the
desired node needs to be clicked.
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Figure 31 Networks

The structured hierarchy has the following nodes:

Icon Name Description

60 GHz cnWave
CN

CN is mapped to a Site in E2E Network.

60 GHz cnWave
DN

DN is mapped to a Site in E2E Network.

60 GHz cnWave
Onboard E2E
Network

60 GHz cnWave devices are located within a Network deployed through the
Onboard E2E controller.

Table 10: Structured hierarchy nodes



Icon Name Description

60 GHz cnWave
External E2E
Network

60 GHz cnWave devices are located within a Network deployed through the
external E2E controller.

60 GHz cnWave
PoP

PoP is mapped to a Site in E2E Network and deployed through the External
E2E controller.

60 GHz cnWave
PoP Onboard
E2E Network

PoP is mapped to a Site in E2E Network and deployed through the Onboard
E2E controller.

60 GHz cnWave
Unmanaged
Node

60 GHz cnWave Unmanaged Node

60 GHz cnWave
Site

Sites are located within E2E Networks. A site maps to a single area and
represents a location on a map that has 60 GHz cnWave devices.

cnMatrix cnMatrix devices are located within a Network. Optionally they can also be
mapped standalone to a Tower or a Site.

cnRanger RRH cnRanger RRH access points are located in a Network and are mapped to a
BBU.

cnRanger Sierra
800

cnRanger Sierra 800 are located in a Network and are optionally mapped to
a Tower.

cnRanger SM cnRanger SM devices are located in a Network and are optionally mapped
to a RRH.

cnReach cnReach device which could have zero, one, or two radios, and support one
or two roles, including Point-to-Point (PTP), Point-to-Multipoint (AP or EP)
(PTMP), or IO Expander.

cnPilot Home Wi-Fi devices are generally matched to a local SM and inherit its Network.
They can also be mapped standalone to a Network or a Site.

cnVision Client cnVision Client Subscriber Modules are located in a Network (if they are
standalone, which is only used for bootstrapping) or they are associated
with an AP. The SM will inherit the Network and Tower of the AP to which it
is associated.

cnVision Hub cnVision Hub are located in a Network and are optionally mapped to a
Tower.

cnWave 5G Fixed
BTS

cnWave 5G Fixed BTS devices are located within a Network.

cnWave 5G Fixed
CPE

cnWave 5G Fixed CPE devices connected through cnWave 5G Fixed BTS
device in a Network.

Table 10: Structured hierarchy nodes
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Icon Name Description

Enterprise Wi-Fi Enterprise Wi-Fi devices are generally matched to a local SM and inherits its
Network. They can also be mapped standalone to a Network or to a Site.

ePMP AP ePMP Access Points are located in a Network and are optionally mapped to
a Tower.

ePMP SM ePMP Subscriber Modules are located in a Network (if they are standalone,
which is only used for bootstrapping) or they are associated with an AP. The
SM inherits the Network and Tower of the AP to which it is associated.

Home Site Home sites are located within networks and contain RV22 Home Mesh
routers.

Machfu Machfu devices are located within a Network. Optionally they can also be
mapped standalone to a Network or to a Tower.

Network All devices are placed within Networks. Networks represens the
geographical regions or collections of devices with a shared responsibility.
Accounts can have one network or many networks. Networks allow one to
provide structure to accounts with many devices and also provides
aggregation buckets for cnMaestro statistics (essentially the system pre-
calculates statistics, so they are displayed quickly).

NSE 3000 NSE device located in the Network.

OLT Optical Line Terminal (OLT) device located in the PON network

ONU Optical Network Unit (ONU) device located in the PON network.

PMP AP Point-to-Multipoint Access Points (PMP AP) are located in a Network and
are optionally mapped to a Tower.

PMP SM Point-to-Multipoint Subscriber Modules (PMP SM) are located in a Network
(if they are standalone, which is only used for bootstrapping) or they are
associated with an AP. The SM will inherit the Network and Tower of the AP
to which it is associated.

PON Network All PON devices are placed within PON networks.

PON Site PON sites are located within PON networks and hold OLT and ONU devices.

PTP Master Point-to-Point (PTP) Master device located in a network and optionally
mapped to a Tower.

PTP Slave Point-to-Point (PTP) Slave device located in a network and optionally
mapped to a Tower.

PTP 820/850 Point-to-Point (PTP 820/850) device located in a network.

Table 10: Structured hierarchy nodes



Icon Name Description

RV22 Home Mesh
Router—Base

RV22 Home Mesh routers (deployed as a standalone or the base in a mesh
setup) located in the network and are mapped to a home site.

RV22 Home Mesh
Router—Node

RV22 Home Mesh routers (deployed as the node in a mesh setup) located in
the network and are mapped to a home site.

Enterprise Site Enterprise Sites are located within networks and hold Wireless Access
Points. A site maps to a single area and represents a location on a map that
has APs or a building.

System The System node is at the top level of the hierarchy, though it does not have
an explicit node in the tree. It's pages are displayed when the user logs in for
the first time, when one selects the System button in the hierarchical tree
(displayed when Networks are shown) or selects the System node in the
breadcrumbs. The System level aggregates data from all devices within the
account.

Tower Towers are located within networks and hold cnRanger, cnReach, PTP, or
Point-to-Multipoint APs. All the devices on a Tower are mapped to the same
Network, and all their children devices such as Subscriber Modules or Home
APs are also mapped to the same network.

GPON port GPON port of the PON OLT device. PON ONU devices are connected.

XGSPON port XGSPON port of the PON OLT device. PON ONU devices are connected.

Table 10: Structured hierarchy nodes

Default network

cnMaestro has a default network into which unmapped devices will be placed. These can remain in the default
network or moved to a named network. The default network cannot be deleted.

Tree menu

Each node in the device tree has a menu icon ( ) that supports node-specific actions.

For example, the system node lets you to Add Network or launch the Update Software page, while individual
devices allow you to Edit their cnMaestro settings, Reboot, or even Delete the device from management (so it
can be transferred to another account). The actions supported across the tree include the following:

Action Node Description

All Devices

Add Network System Add a new Network as a child to the System node.

Add Site Network Add a new Site as a child to the Network node.

Add Tower Network Add a new Tower as a child to the Network node.

Claim Devices Site Claim devices in a site

Table 11: Tree menu
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Action Node Description

Delete Most Nodes Delete a node from the tree. This is available for all nodes except System
and the default network. Deleted devices will be removed entirely from the
management system (along with their historical statistics). In order to
delete a container, such as Network or Site, all nodes inside the container
must be deleted first.

Edit Most Nodes Edit the cnMaestro settings, including node name and location. This is
available for all nodes except System.

For 60 GHz cnWave, edit option applies for E2E Network and nodes. Node
name can be edited.

Flash LEDs Enterprise
Wi-Fi

The LEDs of the device enables to identify and locate the device.

Reboot Devices Reboot the device.

Refresh All Refresh the node in the tree. This refreshes the node and its children only,
not the entire tree.

60 GHz cnWave Network

Add Link Network and
Most Nodes

Add a new link to the System.

Add Node Site Add a new Node as a child to the Site.

Add Site Network Add a new Site to the E2E Network.

Refresh Network Refresh the network details

Download PoP
(s)
Onboarding
Config

Network and
PoP Nodes

Download PoP(s) Onboarding Configuration data.

Edit Network Edit name of the network

Hide or Show
Sites

Network Allows to hide or show sites in the E2E Controller Network tree menu.

Sync
Topology

Network To sync the Topology of E2E Network and cnWave 60GHz device.

Update
Software

Network and
Nodes

Allows the user to update the 60 GHz cnWave nodes software.

Table 11: Tree menu



Wi-Fi AP Groups tab
The Wi-Fi AP Groups tab displays the Wi-Fi AP Groups configured in cnMaestro (and the devices mapped to
them). AP Groups allow you to share configuration across many access points. They also display the
aggregated statistics for the devices managed and present them within the AP Groups dashboard.

Figure 32 Wi-Fi AP Group tab

Map navigation
Maps are presented in Main menu with dedicated Map display. Maps often show Towers and Devices located in
proximity. You can double-click the map nodes to navigate to the Device, Site, or Tower. By selecting a node in
the map, the Device tree gets updated to reflect that node.

NOTE:

Map view is supported for devices 60 GHz cnWave, cnRanger, cnPilot Home, cnMatrix,
cnVision, ePMP, Enterprises Wi-Fi Series, PMP, PTP, and RV22 Home Mesh at the site- and
device-levels.
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Figure 33 Map navigation

Table navigation
Some tables display Networks, Towers, Site, or Devices and allow the user to click the node and navigate to the
location of the node in the tree.

Node search
Administrators can search for nodes within the device tree using the Search box. It allows the user to search
based upon Device Name and MAC Address. Once the node is found and selected, one can navigate to it in the
hierarchical tree.

Figure 34 Node search



Enterprise Account view

Overview
The Enterprise account differs from Access and Backhaul in that it is largely table-driven. It does not have the
Quick Buttons or the Device Tree, instead, it has direct navigation for Devices, AP Groups, WLANs, Switch
Groups, and Sites. Each of these is presented in tabular form.

System
Global functionality is presented in the System menu. It aggregates data across the entire installation.

Devices
The Devices section provides a searchable table listing all the devices in the system.

Selecting a device launches its management page.
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AP Groups
AP Groups manage shared configuration across APs. AP Groups also aggregate data for all the APs that map to
them. This includes consolidating statistics and events/alarms and presenting AP Group centered pages for
Dashboard, Notifications, Configuration, Statistics, Report, Software Update, Clients, and Mesh Peers.



Figure 35 AP Groups

WLANs
WLANs manage shared configuration across APs.

Figure 36 WLANs

Switch Groups
Switch Groups provide shared configuration for cnMatrix devices, and a subset of parameters can be
overridden for each device. Administrators can simultaneously edit individual/bulk ports across all physical
switches mapped to a Switch Group.
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Figure 37 Switch Groups

NSE Groups
NSE 3000s are configured by creating configuration profiles called NSE Groups.

Figure 38 NSE Groups

Sites
Sites are similar to AP Groups in that they aggregate statistics from many APs. The difference is a Site
represents APs installed at a single physical location (and mapped to a Floor Plan). Sites also have their own
Dashboard and aggregation pages.

Side menu
The side menu provides high-level navigation through the cnMaestro UI. Click the menu ( ) icon in the left
column to view the side menu names in the page.



Figure 39 Side menu

Section tabs
All management sections are displayed in the context of the managed item, including System, AP, AP Group,
Switch Groups, and Site. The options vary depending upon the menu selected. A breakdown is below:

Page Tabs

System Dashboard | Notifications | Configuration | Statistics | Report |Software Update |
Applications | Clients | Mesh Peers | Assists

Enterprise Sites Dashboard | Notifications | Configuration | Statistics | Reports | Floor Plan | Devices |
Applications | Clients | Mesh Peers | WIDS | Analytics | Assists | PON

Home Sites Dashboard | Notifications | Configuration | Reports | Software Update | Clients | Assists

PON Sites Dashboard | Notifications | Configuration | OLTs | ONUs | Ports

Table 12: Section tabs

System status
The UI header has the following System status icons.
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Icon Name Description

Announcements Notifies the latest Device Software images, Package, or OVA to
upload from Cloud.

Major Alarms The count of major alarms raised in the system.

Out-of-Sync
Devices

The number of Wi-Fi devices with unsynchronized configuration
(which can occur when automatic synchronization is disabled in the
AP Group or the configuration is changed directly on the device).

Table 13: System status icons

Clicking an icon navigates to the relevant management page.

Data Tables and Chart UI Controls
Familiarize with UI controls required for working with the data tables and chart UI pages. An example of the
data tables is displayed below:

NOTE:

Mouse Rollover Behavior—In the data tables, when some of the columns on the right side are
hidden, if you move the mouse pointer over the row, the action icons on the right most side are
displayed without having to move the scroll bar to the right.

Expand the options available under an entity.

Refresh the UI page or data table.



Search for the required value in a column.

set filters for based on different columns or values.

Select the columns that you want to have in the data table list.

Export the data in an excel or any other format.

View the data in a table format.

View the data in a chart format.

Select widgets from the list.

View the data in a grid format.

View the data in a list format.

Select an option from the list.

Reset the zoom in view.

Export

Clone

Update the software

Edit

Delete

View complete details

Configure

Terminate

93 | Navigating the cnMaestro UI Cambium cnMaestro Cloud 5.0.1 | User Guide



94 | Navigating the cnMaestro UI Cambium cnMaestro Cloud 5.0.1 | User Guide

Show history

Download

Block

Approve device

Deregister device

Undo approve

Go to the dashboard

Sync

Logout
Log out of cnMaestro by clicking on the user icon in the upper-right corner and selecting Logout. You can also
navigate to: Administration > Users > Session Management > Sessions.



Device Onboarding

Onboarding is the process of adding a device into cnMaestro Cloud management.

This section includes the following:

l Onboarding Overview

l Claiming Devices

l Device Onboarding

l Zero Touch Configuration

l Onboarding Examples

l Miscellaneous Onboarding Issues

l Device-Specific Onboarding Instructions

Onboarding Overview
The Onboarding flow includes claiming the device (which maps it to the correct management account) and
optionally pre-provisioning the device by selecting its software image and configuration. It also supports
setting Device Name, Location, Software Version, and Configuration. When the onboarding process completes,
the device will be under full cloud management.

Claiming Devices
A device is claimed when it is explicitly added to Cloud management using the Serial Number or Cambium ID.
The difference between the two is the Serial Number is entered through the Cloud management UI and
Cambium ID is entered via the Device UI or through SNMP.

NOTE:

l Only serial numbers with a length of 12 characters can be claimed through the Cloud
management UI.

l Devices with serial numbers less than 12 characters for example, 10 or 11 characters, need
to be claimed on the device UI using the Cambium ID.

All claimed devices are placed in the Onboarding Queue. The devices need to be approved in order to become
fully managed.
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Claiming Devices with Serial Number
Claiming with Serial Number means entering the serial numbers of devices, one per line, and clicking the Claim
Devices button. The system prompts the user to validate the devices before applying them. When complete,
they will be placed into the Onboarding Queue, where they can be pre-provisioned to update software or
configuration before onboarding.

Figure 40 Claiming Devices with Serial Number

To claim a device using the Serial Number:

1. Navigate to Onboard page > click Claim Device.

Claim Devices with Serial Number window appears.

NOTE:

The user should select a PON network manually before approving the device.



2. Enter the Serial Number of the device.

3. Click Claim Devices.

NOTE:

Slot Availability is available only for cnMaestro X account users.

l After clicking Claim Devices in a cnMaestro X account, if there is any Slot Deficit it displays the following
errors:

l No Slots Available:

If there are no slots available while claiming new devices, the No Slots Available window
displays:

The user need to purchase a new subscription with the required slots and reclaim the devices.

l Not Enough Slots Available:

If user tries to claim more devices than the available slots, the Not Enough Slots Available
window displays:

The user is given an option to select the devices from the list according to the available slots.

Select the devices and click Retry.

4. The device appears on the Onboarding page.

5. Click Approve.

New devices periodically query cnMaestro Cloud to see if they have been claimed (it generally takes between 1
to 15 minutes to show up in an account, depending upon when the device was last rebooted). Once a device has
been added to a Cloud management account, it will be visible in the Onboarding Queue.
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NOTE:
Devices must be able to access https://cloud.cambiumnetworks.com to be claimed and
onboarded. HTTPS proxies are currently not supported. If your device is not showing up in
the Cloud management UI, you should verify network connectivity and reboot the device to
prompt more frequent connection attempts.

l Not Enough Slots available in PTP 820/850 devices

User receive the license failure message in PTP 820/850 device dashboard, when no slots are available.

Approving Devices
Devices in the Onboarding Queue must be approved before they are updated and added to the Cloud
Management. Click the approval button in the device to onboard. Unapproved devices will remain in the
Onboarding Queue indefinitely.

NOTE:
l Once approved, connected devices are onboarded and added to the account

immediately, and all configuration or software updates are applied. Approved devices
will be onboarded as soon as they connect.

l To pre-provision devices, you should make all your changes before approving them.
After devices have been onboarded, additional configuration or software updates must
be done through the standard management user interface.

Devices that have completed onboarding remain in the Onboarding Queue for one week.

Claiming Devices with Cambium ID
The Cambium ID is defined when the Cloud management is created. You can view it on the Home page; it
uniquely identifies the account.

To claim a device with Cambium ID, you need to have access to the device. Cambium ID claiming is required for
devices that do not have a 12-character Serial Number, and it is optional for devices with a 12-character Serial
Number. There are two ways to claim a device with Cambium ID.

https://cloud.cambiumnetworks.com/


Type Description

Device UI Enter the Cambium ID/Onboarding Key directly into the Device User Interface. This
prompts the device to access Cambium Cloud and be placed in the Onboarding
Queue.

Device SNMP The Cambium ID/Onboarding Key can also be entered into the device over SNMP.
This allows one to quickly onboard existing devices using an SNMP manager. The
correct OID will be dependent upon the device type. The string entered into the OID
should be of the format “<Cambium ID>:<Onboarding Key>”.

Table 14: Types of Claiming Devices with Cambium ID

The directions for each specific device type are presented later in this chapter. Once devices are added to the
Onboarding Queue using Cambium ID, the administrator must approve them prior to them being onboarded.

Cambium ID Configuration
You must configure the Cloud Manager to support Cambium ID onboarding. Once enabled, Cambium ID
onboarding will work for all device types.

Figure 41 Cambium ID Configuration

Cambium ID Onboarding Key
An Onboarding Key must be associated with a Cambium ID before onboarding. This provides security and
tracking benefits for onboarded devices. The Onboarding Key can be configured at Onboard > Settings.

Each onboarding key is mapped to an account administrator. This allows Cambium Cloud to know who is
onboarding a device. Onboarding Keys can also be revoked if needed.

Onboarding Queue
The Onboarding Queue holds a list of pending and recent (last 24 hours) device onboards. It allows the
administrator to pre-provision device software and configuration, as well as signal a device is ready to be
onboarded. The process flows for how the Onboarding Queue is used are slightly different based upon how the
device was claimed.
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Serial Number flow
When onboarding with Serial Number, the device can be fully provisioned before it contacts Cambium Cloud
and is placed in the Cloud Management. This allows it to be added immediately upon connection.

Figure 42 Serial Number flow

NOTE:

When a user onboards using a Serial Number, the software update and configuration can be
defined even before the device physically accesses the account.

Cambium ID flow
The flow is a little different when using Cambium ID. Here devices must connect to Cambium Cloud before they
are added to Cloud Management. The administrator needs to then approve them in the Onboarding Queue after
optionally updating the software version and device configuration.



Figure 43 Claiming Devices Using Cambium ID

Onboarding fields
The following table details the columns in the Onboarding Queue. Some of these fields will be unknown or
uncertain until the physical device has contacted Cloud Management.

Parameter Description

Actions Before a device is onboarded, it must be approved. There are two buttons available:

l Approve: Click Approve to enable the device for onboarding. If the device is
connected, it will be onboarded immediately.

l Delete: If the device has been added in error, you can delete it from the Onboarding
Queue. This also disconnects the device and allows it to be added to another account.
The Delete button is only enabled before the device has started the onboarding
process.

Added By The user who added this device for onboarding.

Note: If the Device is claimed by a tenant user, the user information is not shown on the
Onboarding page.

Configure This highlights configuration that is applied to the device before onboarding. It is
presented as a set of icons that represent: software update, configuration update, and
map placement. The icons have the following colors:

l Gray: Indicates that nothing is applied.
l Green: Indicates that the parameter is set and applied when onboarded.

Device The name of the device. This is set manually, or, if unset, it will be read from the device.

Duration Displays when the status last changed for the device.

Table 15: Onboarding fields
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Parameter Description

IP Address The IP address of the device. This is only available after the device contacts cnMaestro.

MAC Address The MAC address of the device (if known).

Serial No The Serial Number of the device.

Status The current status of onboarding:

Waiting for Approval: The device has contacted cnMaestro, but it has not been approved,
so it is in a waiting state.

Waiting for Devices: The user has claimed the device, but the device has not connected.

Onboarded: The device has completed onboarding and must now be managed through
normal Configuration and Software Update processes.

Type The type of the device (if known or manually configured).

Table 15: Onboarding fields

Onboarding Configuration
Before a device has been approved, the administrator can pre-provision the device. This is presented through a
set of icons (depicted below), which represent configuration update, software download, and device map
position.

The color icon indicates the following:

l Gray: no changes are made to the device configuration [ ].

l Green: changes are applied successfully [ ].

NOTE:

Onboarding configuration can be modified until the onboarding process has begun. The
approval however needs to be turned off before any changes can be made.

Basic Details
The basic configuration includes Serial Number, MAC, Device Name, Mode, and Description. A Comment can
also be specified to provide additional context to the device.

Configure Device
Configure Device follows the standard template system (see the section on Template Configuration for full
details). The administrator can select an existing configuration template and set any required variables.

cnMatrix Configure Device

The administrator can select configuration method with the existing template or Switch Group.

User can configure the following Switch Group options while onboarding the devices:

l General

l IP Routes

l Spanning Tree



l VLANs

Software Update
Software Update pushes a software image to the device. The administrators can select an image version and
push to all ePMP (AP or SM) device selected in a job.

Device Location
The Device location configuration includes Network, Tower, Latitude, and Longitude on a map.

Onboarding Actions

Approve Device
An administrator needs to approve devices before onboarding can begin. This is done by selecting Approve. As
soon as a device is approved, it is eligible to start the onboarding process. This occurs immediately with
connected devices. Any changes to the Onboarding Configuration need to be completed before Onboarding
begins; the Approval check must also be disabled.

Delete Device
Devices deleted from the Onboarding Queue are removed from Cloud management. They can then be added to
other accounts. See below for how to delete devices that have already onboarded.

60 GHz E2E Controller Onboarding
The Onboarding Queue has a separate tab for 60 GHz cnWave E2E Controllers, which must be approved by the
user before they are added to cnMaestro as an E2E Network and can manage 60 GHz cnWave devices. This
approval can be done either through the Onboarding Queue or the Hierarchical Tree (where the E2E Network is
placed).

Once the onboarding is approved, the 60 GHz cnWave E2E Network (and its devices) can be managed by
cnMaestro.
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NOTE:
If Auto Generate IPv6 Addresses is enabled, E2E Controller fetches the IPv6 addresses
automatically.

Refer to 60 GHz E2E Controller Onboarding chapter for details on how to onboard E2E devices.

For details on how to onboard Edge Controller and PTP 820/850 refer to Onboard Edge Controller

Header Notification
The header bar in cnMaestro displays the following UI controls:

These UI controls are located on the top right side of the UI page. The Search UI control allows you to provide
keywords and search for the required knowledge base information (for example, onboarding devices to
cnMaestro) available in Cambium community. The Notifications UI control provides the count of major alarms.
The Out of sync devices UI control provides the count of devices that are out of sync. The Administrator UI
control supports a drop-down list, which you can use to search and view account names, create account, edit
profile, and log out.

Zero Touch Configuration
Zero Touch Configuration allows PMP SMs and also ePMP SMs to automatically appear in the Onboarding
Queue, provided parent AP is already onboarded.

Claim Your First Wi-Fi AP (Cloud)
Irrespective of the account type, the Claim Your First Wi-Fi AP option has been introduced to simplify the Wi-Fi
AP deployment. This option allows the claiming of Wi-Fi APs. This option is available when no APs have been
claimed for your device.

Consider the following points for using the Claim Your First Wi-Fi AP option:

l For the access and backhaul account type, navigate to the Wi-Fi AP Group tree view. You can see this
option for claiming your first Wi-Fi AP.

l For the Wi-Fi account type, the Wi-Fi AP Groups tree menu (available on the Monitor and Manage page) is
launched with the Claim Your First Wi-Fi AP option automatically (as shown in Figure 44).

l For Cloud users who want to claim Wi-Fi AP for a single device (after onboarding the device for the first
time and if no AP has been claimed), navigate to the main Home page. You can locate the Claim Your First
Wi-Fi AP widget on the right side of the Home page (as shown in Figure 45).



Figure 44 The Claim Your First Wi-Fi AP option

Figure 45 The Claim Your First Wi-Fi AP widget on the Home page

If there are any APs claimed already for the Wi-Fi devices, this Claim Your First Wi-Fi AP option is not available
on Home and Monitor and Manage UI pages

Claiming for a single Wi-Fi device from the Home page
To claim your first Wi-Fi AP for a single device, perform the following steps:

1. On the main Home page, locate the Claim Your First Wi-Fi AP widget on the right side of the page and click
Get Started (as shown in Figure 45).

The Claim Wi-Fi Access Point screen appears.

2. Enter a valid value in the AP Serial Number (MSN) text box (for example, AxCx4040Q2V8) and click Next.

The Configure Wireless LAN (Optional) screen displays multiple settings, which are applicable to Wi-Fi APs
(home and enterprise Wi-Fi).
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You can update the following settings based on your requirements.

l Country: Name of the country (used for the regulatory purpose).

l WLAN SSID: Unique name or ID that identifies your wireless network. Do not leave this field blank.

l WLAN Passphrase: The passphrase is supported only if the WPA2 Pre-Shared Keys option is selected as the
security method. The minimum length of the passphrase is eight characters.

If you skip configuring this settings section, the default SSID and the security configuration of the device are
retained.

3. Click Next.

The Onboarding AP screen displays the onboarding status (for example, waiting) for the device. If the device is
successfully onboarded, the Onboarding AP screen displays the following message:

If the onboarding fails, the Onboarding AP screen displays a message indicating the failure status.



Claiming for a single Wi-Fi device using the AP Group menu
To claim your Wi-Fi AP using the Wi-Fi AP Groups tree menu, perform the following steps:

1. Navigate to Monitor and Manage > Wi-Fi AP Groups tree menu, and click Claim Your First Wi-Fi AP (as
shown in Figure 44).

The Claim Wi-Fi Access Point screen appears.

2. Enter a valid value in the AP MSN text box and click Claim.

The device is successfully claimed.

3. Click Next.

The Configure Wireless LAN (Optional) screen displays the following fields for configuration: Country, WLAN
SSID. and WLAN Passphrase.

4. Enter the configuration details.

You can configure the following settings based on your requirements:

l Country: Name of the country (used for the regulatory purpose).

l WLAN SSID: Unique name or ID that identifies your wireless network. Do not leave this field blank.

l WLAN Passphrase: The passphrase is supported only if the WPA2 Pre-Shared Keys option is selected as the
security method. The minimum length of the passphrase is eight characters.

If you skip configuring this settings section, the default SSID and the security configuration of the device are
retained.
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5. Click Finish.

The Onboarding AP page displays the onboarding status and configured actions for the device.

The device is mapped to the default Wi-Fi AP Group, and the configuration is updated in the Default Enterprise
WLAN.

Claiming multiple Wi-Fi devices from AP Group
To claim multiple devices from the AP Group, navigate to the Wi-Fi AP Groups tree view and click the

drop-down menu for the selected AP Group.

1. Click the Claim Devices option.

2. In the pop-up dialog select the Network and Site under which these devices should be placed and by default
devices claimed under this group will have its configuration settings.



3. Specify the Manufacturing Serial Numbers (MSNs) of the devices line-by-line or comma-separated, or click
the Import .csv option to import the MSNs of the devices from a file.

4. Click Claim Devices to add to the selected AP Group with the configuration applied.

NOTE:

In cnMaestro On-Premises the procedure is the same as Cloud, but instead of MSN, the user
should use the Device MAC Addresses.

Claiming multiple Wi-Fi devices from Enterprise Site Dashboard
To claim multiple devices from the Site Dashboard, perform the following steps:

1. Navigate to the Manage > Network tree view and select the drop-down menu for the Site.

2. Click Claim Devices from the drop-down.

3. In the pop-up dialog select the AP Group that should be applied for Enterprise Wi-Fi devices. The devices
claimed under this site will have the configuration settings from the selected AP Group.

4. Specify the MSNs of the devices line-by-line or comma-separated, or use the Import .csv option to import
the MSNs of the devices from a file.

5. Click Claim Devices to add the devices to the selected AP Group and click Apply Configuration.

Miscellaneous Onboarding Issues

Configuring Devices After Onboard
When Onboarding completes, the device will no longer be managed through the Onboarding Queue. Instead,
Configuration and Software Upgrade needs to be performed through the standard cnMaestro UI sections.

Deleting Devices
While a device is in the Onboarding Queue, it can be removed from the account by deleting it from the queue.
After Onboarding, the device needs to be manually deleted. The device can be deleted either by right-clicking
the device node in the tree and selecting the Delete option or from the Inventory page.

Transferring Device Ownership
When a device is sold to a third-party, the device ownership needs to be transferred. This is done by deleting
the device in one account, thereby opening it up to being claimed by another.

NOTE:

When the device is in Reset or Delete state, the device can onboarded without re-approval
when using a Cambium ID or Onboarding Key.

Onboarding Examples
This section provides the following topics:

l Onboarding Existing Networks

l Onboarding New Devices
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Onboarding Existing Networks
Existing networks can be onboarded by setting Cambium ID on already-deployed devices over SNMP (see the
section on Device-Specific Onboarding for details on the OID). These devices will contact Cambium Cloud and
be mapped to the corresponding Cloud Management. To complete onboarding, the administrator should
navigate to the Onboarding Queue and approve all devices.

Onboarding New Devices
New devices are onboarded either using Cambium ID (which is a requirement for serial numbers less than 12
characters in length) or through the Serial Number.

Claiming Devices using Cambium ID and Device UI
l Configure cnMaestro to Support Cambium ID

First, make sure Cambium ID support is enabled, and a password field is set.

1. Navigate to Home > Onboard Devices and click Claim from Device.

2. Select Allow device to be claimed using Cambium ID.

3. Click Add New.

4. Choose the name of the user from the Name drop-down list.

5. Enter the key for the user in the Onboarding Key textbox. The minimum length of characters for the key is 8.

6. Click Save.

l Set Cambium ID on the Device UI

Launch the device UI and enter the Cambium ID and password. The example below defines how to set for ePMP.

1. Login to the device UI and navigate to Configuration > System > cnMaestro tab.

2. Enable the radio button for enabling Remote Management.

3. Enter the cnMaestro cloud URL in the cnMaestro URL textbox.

4. Enter Cambium ID in the Cambium ID textbox.

5. Enter the Onboarding key in the Onboarding Key textbox.

6. Click Save the device.

l Approve the Device for Onboarding:

1. Navigate to Home > Onboard Devices and click the Onboard tab.

2. Find the device and onboard using the Cambium ID.

3. You can able to see who onboarded the device.

4. The Status field should display Waiting for Approval.

5. Make any additional onboarding configuration changes you want.

6. Approve the device by clicking the Approve button under Actions.

7. The device status will change to Onboarded after onboarding finishes under the Status.

Claiming Devices Using Cambium ID and SNMP
Devices can be claimed over SNMP by using the Cambium ID and Onboarding Key. See Claiming Devices with
Cambium ID section for devices you would like to onboard in this way.



Device-Specific Onboarding Instructions

Onboarding cnMatrix
You can onboard cnMatrix through device CLI and using the device UI.

Execute the following command to onboard cnMatrix device connection to cnMaestro:

cnMatrix(config) # cnMaestro url cloud.cambiumnetworks.com

Execute the following command to view the status of cnMatrix device connection to cnMaestro:

cnMatrix(config) # show cnMaestro

Onboarding cnMatrix through UI
In the cnMatrix device UI perform as follows:

1. Navigate to System > Remote Management.

2. Enter the details in Remote Management section.

3. Click Apply.
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Onboarding cnRanger
To view the status of Sierra 800 and Tyndall 101 connection to cnMaestro.

Setting static URL for cnMaestro on Sierra 800
1. Navigate to Configuration > cnMaestro.

2. Under cnMaestro section, enter the URL in the cnMaestro Address.

3. Click Save.

Setting static URL for cnMaestro on Tyndall 101
1. Navigate to Configuration > cnMaestro.

2. Under cnMaestro section, enter the URL in the cnMaestro URL.

3. Click Save.



Onboarding cnReach

Onboarding through UI
In the cnReach device UI,

1. Navigate to cnMaestro > Management Settings.

2. Enable cnMaestro Management in Settings section.

3. Enter your Cambium ID and Onboarding Key.

4. Click Save.

5. Navigate to home page to view the status of the cnReach device connection to cnMaestro.

Figure 46 Onboarding cnReach through UI

To view the status of the cnReach connection in the cnMaestro:
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Figure 47 Viewing the cnReach connection to cnMaestro

Onboarding cnPilot R-Series

Onboarding through UI
To view the status of the cnPilot R-Series device connection to cnMaestro:

1. Navigate to Administration > cnMaestro.

2. Under cnMaestro configuration section.

3. Enter the URL in the cnMaestro URL.

4. Click Save.



Figure 48 Viewing the cnPilot R-Series device connection

Onboarding through SNMP
The following OIDs can be configured:

l cambium_id

l cambium_token

l cns_staic_url

Onboarding cnVision

Onboarding cnVision Client
In the cnVision Client device UI,

1. Navigate to Configuration > System.

2. Under cnMaestro section, enter cnMaestro URL.

3. Click Save.
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Onboarding cnVision Hub
In the cnVision Hub device UI,

1. Navigate to Configuration > System.

2. Under cnMaestro section, enter cnMaestro URL.

3. Click Save.

Onboarding Enterprise AP

Onboarding through UI
In the Enterprise AP device UI,

1. Navigate to Configure > System.

2. Scroll to Management > cnMaestro.

3. Enable Remote Management.

4. Enable Validate Server Certificate if required.

5. Enter cnMaestro URL.

6. Enter Cambium ID and Onboarding Key.

7. Navigate to Dashboard to view the status of the Enterprise AP device connection to cnMaestro.

Figure 49 Onboarding Enterprise AP through device UI

To view the status of the device connection to cnMaestro:



Figure 50 Viewing the Enterprise AP connection to cnMaestro

Onboarding ePMP 1000

Onboarding through UI
In the ePMP device UI,

1. Navigate to Configuration > System.

2. Scroll to cnMaestro.

3. Select Enable and enter your Cambium ID and the user’s Onboarding Password.

4. Navigate to Monitor > System to view the status of the ePMP device connection to cnMaestro.

Figure 51 Onboarding ePMP 1000 through UI

To view the status of the ePMP device connection to cnMaestro:
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Figure 52 Viewing the ePMP device connection to cnMaestro

Onboarding through SNMP
The following OIDs can be configured:

l cambiumDeviceAgentEnable

l cambiumDeviceAgentCNSURL

l cambiumCNSDeviceAgentID

l cambiumCNSDeviceAgentPassword

The following OID can be used to check the status of the device’s connection to cnMaestro.

cambiumCnsServConsStat

Onboarding ePMP1000 Hotspot

Onboarding through UI
To onboard ePMP 1000 Hotspot device connection to cnMaestro:

1. Navigate to Configuration > System.

2. Scroll to Management.

3. Select Enable Cambium Remote Management.

4. Enter your Cambium ID and Onboarding Password.

Figure 53 Onboarding ePMP1000 Hotspot through UI



To view the status of the ePMP 1000 Hotspot device connection to cnMaestro:

Figure 54 Viewing the ePMP 1000 Hotspot device connection to cnMaestro

Onboarding Machfu
In the Machfu device UI,

1. Navigate to System > Device Management.

2. Under cnMaestro section, enter cnMaestro URL.

3. Click Save.

Onboarding PMP

Onboarding through UI
To onboard PMP device connection to cnMaestro:

In the PMP device UI,

1. Navigate to Configuration > cnMaestro.

2. Under Configuration, provide the following details:
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a. Select Enable under Remote Management.

b. Enter the URL to connect to cnMaestro in the cnMaestro URL textbox.

3. Under Credentials, enter the Cambium ID and the Onboarding Key in the respective textboxes. The Account
ID field displays the account id of the user.

Figure 55 Onboarding PMP through UI

To view the logs, navigate to Logs > Device Agent Log page:



Figure 56 Viewing Logs

Onboarding through SNMP
The following OIDs can be configured:

l cnMaestro Enable

l cnMaestro Url

l cambium ID

l cam Onboard Key
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The following OIDs can be used to check the status of the device’s connection to cnMaestro.

l cam AccID

l cnMaestro Status

Onboarding PTP 650/670/700
1. Navigate to Installation click Run Installation wizard button.

2. In the Management Configuration window, under cnMaestro, select Enabled.

3. Select cnMaestro Cloud radio button.

Onboarding Xirrus device
Perform the following steps to onboard Xirrus device through CLI.

1. Connect to the device using any SSH tool.

2. Login as admin, the default password is admin.



3. Execute the following command in ssh console:

#ssh admin <device IP address>
#password <admin>
#configure
#management
#cloud server cloud.cambiumnetworks.com scheme cnmaestro enable
#save
#Saving configuration...OK
#cnMaestro-onboarding id cambium_ID key onboarding_key
#save
saving configuration...OK
#show management
Cloud Management enabled Cloud Timeout 50 seconds Cloud Port 443 Cloud Retry 5 Cloud
Scheme cnMaestro Cloud Server cloud. cambiumnetworks.com
Cambium ID NOTSET Cambium Key Set cnMaestro Status Not Connected

4. Login to Cloud account.

5. Navigate to Home > Onboard > Devices.

6. In the Devices page, the device onboarded is shown in Figure 57

Figure 57 Xirrus Device Waiting for Approval

The Status field display Waiting for Approval.

It is optional to provision the device for location, software version update, and assign to an AP Group.

7. Click Save.

8. Click Approve.

For details to migrate Xirrus devices from XMS to cnMaestro X using a tool, refer to XMSE to cnMaestro X.

NOTE:
l Xirrus APs are onboarded only to cnMaestro X accounts not to cnMaestro Essentials.
l Tier 3 subscription is applicable to Xirrus APs.
l Xirrus devices can only be onboarded using Cambium Id and Onboarding Key for Cloud

account.
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Onboarding a cnWave 5G Fixed BTS device

Claiming the cnWave 5G Fixed BTS device
To claim the cnWave 5G Fixed BTS device, you must have access to the device GUI. In the cnWave 5G Fixed
BTS device UI, perform the following steps:

1. From the main home page, navigate to System > General.

2. In the cnMaestro section, enable Remote Management.

3. In the Address field, enter the cnMaestro URL or IP Address.

4. Enter your Cambium ID and Onboarding Key. Validate Server Certificate is an optional field.

Note

You can enter a valid Cambium ID and Onboarding Key in the cnWave 5G Fixed BTS device
UI, when Allow device to be claimed using Cambium ID option is enabled in the Settings
section in the cnMaestro Onboard page.

5. Click Save.

When the cnWave 5G Fixed BTS device is onboarded to the cnMaestro for the first time, the Connection Status
field in the cnWave 5G Fixed BTS device UI displays Device Approval Pending as shown in Figure 58.

Figure 58 Device Approval Pending status in cnWave 5G Fixed BTS

6. In the cnMaestro UI, navigate to Onboard > Devices and click Approve, as shown in Figure 59.



Figure 59 Approving the cnWave 5G Fixed device using the cnMaestro UI

The cnWave 5G Fixed BTS device is onboarded to cnMaestro.

Figure 60 Viewing the cnWave 5G Fixed BTS device onboarded in cnMaestro

The Connection Status field in the cnWave 5G Fixed BTS device UI displays Connected, on approval, as shown
in Figure 61.

Figure 61 cnWave 5G Fixed BTS device Connected

To view the cnWave 5G Fixed BTS device in cnMaestro, perform the following steps:

1. From the cnMaestro UI home page, navigate to Monitor and Manage > default network or navigate to
Onboard > Devices.

2. Click on the Onboarded link.

Registered cnWave 5G Fixed CPE devices are also onboarded along with cnWave 5G Fixed BTS device.
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Figure 62 Viewing cnWave 5G Fixed BTS device and registered CPE devices

Claiming the cnWave 5G Fixed BTS device with a Serial Number
To claim and onboard the cnWave 5G Fixed BTS device, perform the following steps:

1. From the home page of cnMaestro, navigate to Onboard > Devices tab.

The Onboard page appears with details of the devices and their serial numbers, as shown in Figure 63.

Figure 63 Onboard page

2. Click Claim Device located at the right side of the Onboard page, as shown in Figure 63.

The Claim Devices with Serial Number page appears, as shown in Figure 64.

3. Enter the serial number of the cnWave 5G Fixed BTS device in the text box, as shown in Figure 64.

Note

You can also place the cursor in the text box and use a barcode scanner to quickly claim
the devices.



Figure 64 Claim Devices with Serial Number page

4. Click Claim Devices.

5. To onboard the cnWave 5G Fixed BTS device, click Approve located at the right side of the Onboard page,
as shown in Figure 65.

Figure 65 Onboarding Queue

Note

If you do not click Approve, the device remains in the Onboarding Queue.

Onboard Edge Controller
To onboard Edge Controller perform the following steps:

1. Enter cnMaestro URL or IP address, Cambium ID, and Onboarding Key in CLI.

2. Navigate to Onboard > Edge Controller > Controllers.

3. Click Approve.

Figure 66 Edge Controller
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Onboard PTP 820/850 devices
To onboard PTP 820/850 devices perform the following steps:

1. Ensure SNMP rules are added in Edge Controller configuration.

2. Navigate to Onboard > Edge Controller > Devices.

3. Click Approve.

Figure 67 PTP 820/850 devices



Onboarding the NSE 3000 Devices to cnMaestro

Note

If the device needs static IP or other WAN configuration to be connected to the internet,
refer to Device UI Configuration.

This section describes the onboarding of NSE 3000 to the cnMaestro Cloud X account. The onboarding process
requires the device Manufacturing Serial Number (MSN). The MSN of the device can be found at the bottom of
the device as shown in Figure 68.

Figure 68 : MSN of device

To onboard the device, perform the following steps:

1. Open a web browser and type the URL https://cloud.cambiumnetworks.com.

The sign in page appears.

2. Create a new cnMaestro X account or select an existing cnMaestro X account. A tier 30 subscription is
required.

3. Navigate to cnMaestro Home > Onboard > click Claim Device.

Figure 69 Onboard page

4. Claim Devices with Serial Number window pops up.
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Figure 70 Claim devices with Serial Number

5. Select the Managed Account from the drop-down.

6. Enter the Serial Number (MSN) of the device in the text box.

7. Click Claim Devices.

The device will be listed in the Onboarding Queue.

8. Click the Approve Device ( ) icon or Approve All at the right side of the Onboard page, as shown in

Figure 71 Approve

When device is approved appears on the Onboard page as shown below in Figure 72.

Figure 72 NSE 3000 Device Onboard

Onboarding Home Mesh Routers to cnMaestro
To onboard the Home Mesh Router to cnMaestro, see Onboarding the Home Mesh Router to cnMaestro.

Claiming the Home Mesh Router on the cnMaestro Cloud's Onboard page is not supported.



Onboarding PON devices to cnMaestro
This section describes the onboarding of PON devices to the cnMaestro X account. The onboarding process
requires the device Manufacturing Serial Number (MSN). The MSN of the device can be found at the bottom of
the device as shown in Figure 73.

To onboard the router, complete the following steps:

1. Navigate to cnMaestro Home > Onboard.

Figure 73 Onboard page for PON devices

2. Click Claim Device.

The Claim Devices with Serial Number window is displayed.

Figure 74 Claim devices with Serial Number

3. Select the account from the Managed Account drop-down list .

4. Enter the Serial Number (MSN) of the device in the text box.

5. Click Claim Devices.

The device will be listed in the Onboarding Queue.

6. Click the Approve Device ( ) icon.
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Onboarding 60 GHz E2E Controller

There are two ways to deploy 60 GHz E2E Controller:

l External E2E Controller

l Onboard E2E Controller

External E2E Controller Onboarding
To Onboard the External E2E Network through Monitor and Manage page:

1. Navigate to Monitor and Manage > Network > select 60 GHz cnWave E2E Controller.

2. Click Approve and 60 GHz cnWave–Network Onboard window appears.

3. By default, Auto-assign is selected you can select Auto-assign or Manual to update IPv6 address in E2E
Network and wait for a while until IPv6 address gets updated.

4. Enable Layer 2 Bridge if required.

5. Click Apply.

6. Wait for a while till network onboard is successful.

7. After successfully onboarded, the External E2E Network UI shows the Dashboard of the network as shown
below:



External E2E Controller network icon will be indicated with icon as shown below:

Onboard E2E Controller (Running Onboard)
cnMaestro remote management details are configured through onboard E2E controller. The Onboard E2E
Controller is hosted on a 60Hz cnWave device. (E2E Controller option to be enabled in the device UI).

To approve proceed as follows:

1. Navigate to Monitor and Manage > Network > select 60 GHz cnWave E2E Network.

2. Click Approve.
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60 GHz cnWave-Network Onboard window appears. Edit network name and click Save.

3. Wait for a while till network onboard is successful.

4. After the successful Onboard E2E Network, it can be managed through cnMaestro.



If PoP Node is running the Onboard E2E Controller then the PoP icon will be indicated with as shown below:
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Onboard E2E Controller (Running Onboard) Onboarding with Serial
Number
From homepage click Onboard icon in the left pane, to claim Onboard E2E devices.

1. Navigate to Onboard > 60GHz cnWave Network > click Claim Onboard E2E.

Claim Onboard E2E Network with Serial Number windows appears.

2. Enter Serial Number and click Claim Devices.
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Monitoring
This section includes the following topics:

l Network Monitoring

l Network Service Edge

l Wireless LAN Dashboard

l Inventory

l Reports

NOTE:

Following are the retention period for various data in cnMaestro:

l Wi-Fi AP performance data—1 year

l Wireless clients data—1 week

l Guest Access session and login events—1 week

l Wi-Fi events—24 hours

Network Monitoring

The Monitoring tab displays the monitoring pane for cnMaestro. The section includes the following:

l Assists

l Dashboard

l Notifications

l Statistics and Details

l Performance

l Maps

l Tools

l WIDS

Assists
Assists displays scanned configuration scores and results for last 24 hours.
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Assists scans the configurations and generates assists scores. It evaluates specific issues that might occur
during deployment . Assists summarizes the scores and status results at System, Network, Site, Tower, and
Device levels as shown in Figure 75.

This enables prioritization of management traffic.

Figure 75 Assists home page

NOTE:

l Assists is a cnMaestro X feature available for cnPilot, cnMatrix, cnWave 5G Fixed, ePMP,
PMP, and Enterprise Wi-Fi devices except AOS devices.

l Minimum software version for cnWave 5G Fixed devices must be 3.1b5 for assist data to
be generated.

l For ePMP, and cnWave 5G Fixed devices, the Assists X page generates data every 24
hours.

l For PMP devices with software version 21.1 or higher, the Assists X page generates data
immediately after onboarding. For software versions lower than 21.1, this page continues
to generate data on a 24-hour schedule.

l For cnPilot Home R-series, cnMatrix, and Enterprise Wi-Fi, the Assists X page generates
data immediately after onboarding.

Assists scores are shown in percentage values. The Assists scores guide users to isolate issues by scanning an
environment and evaluating configuration and infrastructure. Assists scores are determined as shown in Table
16.

Score Value Description

0-61% Poor

61 % to 90% Good

91% and above Excellent

Table 16: Assist Scores



Fields Description

Status Status of the Assists are shown as follows:

l Passed

l Failed

l Disabled

Severity Severity level of the assists are shown as follows:

l Critical: Catastrophic problem that makes the feature unusable.

l Major: Issue that greatly degrades the feature, but it is still usable.

l Minor: Limited issue that alters functionality in a targeted way.

l Notify: Message used primarily for information.

Type Type of the device.

Title Short title describing the assist.

Category Type of category such as Security, Network, Infrastructure, and Performance.

Group Grouped based on Position, Access, and Configuration of cnMaestro.

Results Result of Assists such as Passed, Failed, and Disabled. For more details on assists
result description refer to Figure 76.

Table 17: Assists parameters

Hover the cursor on the Results column in the Assists home page. It displays a preview of the assist results as
shown in Figure 76.

Figure 76 Assists Results

Assist Result Description

Passed Assists recommendations are met.

Failed Assists has failed.

Disabled Assists is disabled.

Note: Only Super Administrator and Administrator have access to change disable
option.

Table 18: Assist Result Status
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Export Assist
The Assist table can be exported in a CSV or PDF file format. The following export options are available:

l Export page as CSV

l Export page as PDF

l Export all as CSV

Assist filter
To create custom filters for assists, perform the following steps:

1. In the Assists table, click Apply Filter(s).

2. Enter the values in the fields for applying the filters.

3. Click Apply Filter.

Figure 77 Assists: New Filter

You can manually filter or search by typing parameters in the column header of the Assists table.

4. Click Reset to reset the filter option in the Assists table.

5. Click Clear Filters to clear all the filter options.

If you do not receive expected filter details, click Change Filter(s) in the Assists table to apply new filters.

Assists Status
To evaluate the Assists Status, click on the Title column with Affected Devices in the Assists table. A detailed
Assists page appears with Description and Remediation as shown in Figure 78.

To disable Assists, perform the following steps:

1. In the Assist Status page, click Disable this Assist.



Figure 78 Assist Status page

A confirmation message appears for the assist to disable.

2. Click Yes, Disable.

Assists disabled are listed at the bottom of the Assists home page. The Results column do not indicate the
progress bar for the Assists Disabled as shown in Figure 79. The total number of enabled Assists in the home
page is reduced when Assists is disabled.

Figure 79 Assists Disabled

3. In the Assists Status page, click Devices tab to view the list of devices failed for the specific assist.
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Device filter
To create a custom device filters, perform the following steps:

1. In the Assists page, click Title.

2. Navigate to Details > Device.

3. Click Apply Filters button.

4. Enter the values in the fields for applying the filters.

5. Click Apply Filter.

Figure 80 Assists device filter

You can manually filter or search by typing parameters in the column header of the device table.

6. Click Reset to reset the filter option in the device table.

7. Click Clear Filters to clear all the filter options.

If you do not receive expected filter details, click Change Filter(s) in the device table to apply new filters.

Enable Assist
To enable assist, perform the following steps:

1. Click the disabled assist listed at the bottom of the Assists home page.



You will be directed to specific Assist page, as shown in the following figure.

2. Click Enable this Assist.

Assists fix now

NOTE:

l The Assists Fix Now feature is available only for ePMP and PMP
devices.

Assists Device page allows the user to fix the failed assists.

Perform the following steps to fix the failed assists:

1. Navigate to the Assists Device page.

2. Select the devices to be fixed.

3. Click Fix now.
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The Fix Now window pops up.

4. Select from the following options under the Update field, to fix the issue now or at a later date:

n Now—Fix the issue immediately when you click Apply on this page.

n Schedule—Fix the issue at the selected date and time. Select the required date and time from the Start
Date and Start Time fields.

5. Click Apply.

Success window pops up.



When the failed assists are fixed, the status is changed to Passed as shown in Figure 81.

Figure 81 Passed Assists

Dashboard
The Dashboard page in cnMaestro is customized for each device type and aggregation level (such as System,
Network, Tower, and Site). Pages representing devices provide information on location, significant
configuration parameters, and performance. System, Network, Tower, and Site nodes aggregate dashboard
data for devices they contain.

KPI (Key Performance Indicators)
Each page has a set of KPIs tailored to the node type. These display a current value and often historical trend
data over the last 24 hours.
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Figure 82 Device by Type

NOTE:

l KPI widgets at network and Tower-level show minimum four widgets when no data is
available in KPI's. Shows wireless clients KPI when at least one Wi-Fi device is available.
Wireless clients KPI is moved beside Wi-Fi KPI. Machfu KPI is not supported any more.

Application History
The Application History displays top client names and their top five application usage details for last 24 hours.



Figure 83 Application History

The System Dashboard page displays detailed system level application usage in Application History and
Category History. It displays the Top Clients names and their top five application usage details. The Application
Visibility parameter fields are explained in detail as shown below.

Figure 84 System > Application

NOTE:

l By default, the application statistics for last 24 hours is displayed.

l Application data is available for NSE and Enterprise Wi-Fi (XV, XD, and XE) devices only.

l Application data is available only for the clients connected to NSE in Essentials accounts.

Device Health
Device Health displays the health of the network from the Tower to the edge Device.
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Figure 85 Device Health

Connection Health
Connection Health displays the health of the devices connected to the network.

Charts and Graphs
Contextual charts and graphs provide details on important dashboard metrics.



Figure 86 Charts and Graphs

Notifications
The Notifications page displays details of alarms, alarm history, and events. These are synchronous messages
that provide real-time system status.

Type Description

Alarms Alarms indicate state and persist as long as the problematic activity continues; they
reflect the current health of the devices in the network.

Alarms History Expired Alarms are added to the Alarm History. The Alarm History page displays
historical active alarm counts.

Events Events are stateless, transient messages that occur in response to an input or
action, such as if the CPU exceeds a threshold or a device association fails. Events
are fire-and-forget; they are stored in an Event Table and provide a history of
device activity.

Wi-Fi Events Details of the Wi-Fi events are displayed.

Table 19: Notification overview

For PTP 820/850 devices, additional two other notifications are displayed as shown in Figure 87 and Figure 88:

l Device Alarms displays the following parameters:

l Alarm ID

l Severity

l Origin

l Description
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l Probable Cause

l Raised Time

l Device Events displays the following parameters:

l Raised Time

l Sequence Number

l Severity

l State

l Description

l Origin

Figure 87 PTP 820/850 Device Alarms

Figure 88 PTP 820/850 Device Events

Event/Alarm Source
Identity of the source device for the event or alarm.

Aggregation
Notifications are visible at every level of the device tree. Higher levels consolidate notifications for all devices at
lower levels in the hierarchy. For example, the network level displays the events and alarms for all devices
within that network. This aggregation is only available for System, Networks, Towers, and Sites. When a device
is selected, such as an AP, the notifications will only be for it, and not its associated SMs (even though they are
lower in the tree).

Storage
Events and Alarms are stored in cnMaestro for an extended period. They will be removed when the total count
across the account surpasses 1,000 multiplied by the number of devices in the account. The oldest entries are
cleared first.

Events
The Event Table stores a history of the most recent events for the selected node.



Event Severity
Event Severity is mapped to the following levels:

Severity Definition

Critical Catastrophic problem that makes the product/feature unusable.

Major Issue that greatly degrades the product/feature, but it is still usable.

Minor Limited issue that alters product functionality in a targeted way.

Notify Message used primarily for information.

Table 20: Event Severity

Event Export
The data in the Event table is exported in a CSV or PDF file format. The following export options are available:

l Export page as CSV

l Export page as PDF

l Export all as CSV

You can create custom filters for events. To create a custom filter, perform the following steps:

1. In the Events table, click Apply Filter(s).

2. Enter the values in the fields for creating the filters.

3. Click Apply Filter.

Figure 89 Events: New Filter

You can manually filter or search by typing parameters in the column header of the Events table.

4. Click Reset to reset the filter option in the Events table.

5. Click Clear Filters to clear all the filter options.

If you do not receive expected filter details, click Change Filter(s) in the Events table to apply new filters.
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Figure 90 Events: Source Type filter

The Source Type column header is grouped based on the Device or System events. The Name column header is
grouped based on the category names. The category name with corresponding subcategories and codes are
shown in Table 21.

Figure 91 Events: Name filter

Table 21: Category Names and Codes
Category Subcategory Codes

Auto_pilot Auto Pilot Status

AUTOPILOT_ADDED_AP

AUTOPILOT_AP_CONNECTED

AUTOPILOT_AP_DISCONNECTED

AUTOPILOT_REMOVED_AP



CBRS

CBRS Account CBRS_ACCOUNT

CBRS Grant

CBRS_GRANT_TERMINATE

CBRS_OPERATIONAL_PARAM_CHANGE

CBRS_GRANT_SUSPEND

CBRS_TX_ENABLE

CBRS_TX_DISABLE

SM_RECONNECT_FAILURE

CBRS_ATTEMPT_CHANNEL_EXPANSION

CBRS_START_CHANNEL_HUNT

CHANNEL_CHANGE

CBRS_EIRP_CHANGE

CBRS_ALARM_PROXY_TIME_MISMATCH

CBRS Payment CBRS_PAYMENT

CBRS SAS SAS_ID_GENERATION

Cloud_Sync Cloud Connectivity CLOUD_SYNC

Configuration Config Sync

CFG_IMP

CFG_EXP

CONFIG_SYNC

CFG_UPD_ST

SYSTEM_CONFIG_APPLIED
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Device

Configuration

SYSTEM_CFG_FALLBACK_REBOOT

SYSTEM_CFG_OVERWRITE_REBOOT

SYSTEM_CONFIG_APPLY_FAIL

SYSTEM_CONFIG_CAP_POWER

SYSTEM_CONFIG_DEFAULTED

Default AUTH Key DEF_KEY_USED_TRAP

Device Health

SYS_REB

SYS_UP

SA_MODE

STATUS_DOWN

STATUS_UP

Device Status

PMAC_UPD

THRESH_CPU_UTIL

THRESH_DEVICE_TRAFFIC

SYSTEM_CC_NOTSET

PBA_DYN_DATA

SYSTEM_AP_UPLINK_STATUS

IET8222_MPPHSDR_INFO

IET8222_MPPHSDR_NOTICE

IET8222_MPPHSDR_WARNING

CISCO_POWER_SUPPLY_STATUS

AP_REG

SYSTEM_RADIOS_ENABLED

SYSTEM_CRITICAL_LOW_POWER

Link Status REGULATORY_FAIL

Memory
SYSTEM_LOW_MEMORY_RESTART

SYSTEM_RESTARTING_PROCESS

Onboarding ONBOARDING

SM Events STA_REG_FAIL

Smart Antenna Events BSA_ST

Watchdog
SYSTEM_WATCHDOG_RESET

SYSTEM_WATCHDOG_UNRESP

Device_Agent Device Agent
COLD_START

WARM_START

E2E E2E Events E2E_CTLR_IMG_UPD

GPS GPS Status

GPS_SYNC_ST

GPS_FW_UPD_ST

GPS_VER

GPS_SYNC

HA Cluster Status
HA_STATE_CHANGE

HA_SERVICE

Mesh Mesh Events

WIFI_MESH_XTNDED_DEV

WIFI_MESH_CLIENT_CONNECTED

WIFI_MESH_CLIENT_DISCONNECTED

WIFI_MESH_BASE_REC_TRIGGERED



Misc Others unknown

Mon8zn

Monetization State Update

SUBSCRIPTION_FEATURE_STATE_CHANGE

SUBSCRIPTION_STATE_CHANGE

SUBSCRIPTION_FEATURE_STATE_TRANSITION

Monetization Subscription State

SUBSCRIPTION_DEFICIT

SUBSCRIPTION_SLOT_DEFICIT

SUBSCRIPTION_FEATURE_EXPIRY_NOTICE

Network

DHCP

DHCP_CLIENT_IP

DHCPSRVR_IP_ASSIGNED

DHCP_CLIENT_UPD

DHCP_COMPLETE_EVENT

Network - Others

NETWORK_INTERFACE_CHANGE

MGMT_VLAN_CHANGED

NETWORK_WWAN_DOWN

NETWORK_WWAN_UP

NETWORK_WWAN_BACKUP

NETWORK_STATUS_DOWN

NETWORK_STATUS_UP

PPPoE Status

NETWORK_PPPOE_AUTH_FAILED

NETWORK_PPPOE_CONNECTED

NETWORK_PPPOE_DISCONNECTED

NETWORK_RENEW_INTERFACE_IP

NETWORK_TUNNEL_DOWN

NETWORK_TUNNEL_UP

Notification eMail Notifications SYSTEM_EMAIL_NOTIFICATION

NSE Device Status

CONFIG_SYNC
IPS_THREAT_DETECTED
WANLB_LINK_UP
WANLB_LINK_DOWN
IPS_RULESET_UPDATE_FAILED
IPS_RULESET_UPDATE
IPS_START_FAILED
IPS_INVALID_CONFIG
SYSTEM_INVALID_LOGIN_ATTEMPT
WIFI_RADIUS_SERVER_CONFIG_REQUIRED
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PTP

Device Status

INCOMPATIBLE_REGULATORY_BANDS

WIRELESS_LINK_STATUS

NO_WIRELESS_CHANNEL_AVAILABLE

SNTP_SYNC

TDD_SYNC

UNIT_OUT_OF_CALIBRATION

CAPACITY_VARIANT_MISMATCH

INCOMPATIBLE_MASTER_SLAVE

INSTALL_ARM_STATE

LICENSE_REMAINING_TRIAL_PERIOD

LINK_MODE_OPTIMIZATION_MISMATCH

REGULATORY_BAND

DFS_IMPULSIVE_INTERFERENCE

LBT_DETECTED

Port Status

AUX_PORT_POE_OUTPUT_STATUS

AUX_PORT_STATUS

DATA_BRIDGING_STATUS

MAIN_PSU_PORT_STATUS

SFP_PORT_STATUS

AUX_PORT_CONFIG_MISMATCH

MAIN_PSU_PORT_CONFIG_MISMATCH

SFP_PORT_CONFIG_MISMATCH

SFP_ERROR

PORT_ALLOCATION_MISMATCH

Radio

DFS DFS_ST

Radar RADAR_DETECT

Radio Link LINK_ST

Radio Performance RF_OVER_LOAD

Radio Status
LINK_UP

LINK_DOWN

Rate_Limit Status

EVENT_RATELIMIT

EVENT_BLOCKED

EVENT_UN_BLOCKED

METRIC_RATELIMIT

METRIC_BLOCKED

METRIC_UN_BLOCKED

CLIENT_EVENT_RATELIMIT

CLIENT_EVENT_BLOCKED

CLIENT_EVENT_UN_BLOCKED

SM SM Events

STA_REG

STA_DROP

STA_REJECT



System

Login SYSTEM_LOGIN

Reboot SYSTEM_ADMIN_REBOOT

Status

SYSTEM_CPU_UTILIZATION

SYSTEM_MEMORY_UTILIZATION

SYSTEM_DISK_UTILIZATION

DISK_NOT_AVAILABLE_BACKUP

SYSTEM_BACKUP

SYSTEM_RESTORE

SYSTEM_ADD_AP_FIRMWARE

SYSTEM_PROCESS_STATUS

AUTHENTICATION_FAILURE

CAEM_VOLTAGE_NOTIFICATION

System Metrics
WEAK_ADMIN_PWD

SYSTEM_INSUFFICIENT_POWER_MITIGATING

Upgrade

Site Upgrade SITE_SW_SYNC

Status SYSTEM_UPGRADE

Upgrade Fail SYSTEM_FW_UPGRADE_SUCCESS

Upgrade Status FW_UPD_ST

Upgrade Status MIN_FW_VER

Upgrade Success SYSTEM_FW_UPGRADE_FAILED

Webhook Web Hook Status WEBHOOK_NOTIFY
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WiFi

Client Association WIFI_CLIENT_CONNECTED

Client Dissociation WIFI_CLIENT_DISCONNECTED

RADIUS Events

WIFI_CLIENT_RADIUS_ACCT_TIMEOUT

WIFI_CLIENT_RADIUS_AUTH_REJECT

WIFI_CLIENT_RADIUS_AUTH_SUCCESS

WIFI_CLIENT_RADIUS_AUTH_TIMEOUT

Wi-Fi AP Status

THRESH_CLIENT_COUNT

WIFI_MONITOR_HOST_DOWN

WIFI_MONITOR_HOST_UP

SYSTEM

SECURITY

SSID

Wi-Fi Channel

WIFI_NF_CHANNEL_SWITCH

WIFI_RADAR_DETECTED

WIFI_ACS_CHANNEL_SWITCH

WIFI_ACS_TRIGGERED_ON_RADIO

WIFI_AUTO_DETECT_BACKHAUL

WIFI_AUTORF_CHANNEL_SWITCH

WIFI_AUTORF_TRIGGER

WIFI_AUTORF_TXPOWER

WIFI_CHANWIDTH_CHANGE

WIFI_ACS_SELECTED_CHANNEL

WIFI_ACS_TRIGGERED

Wi-Fi Client

WIFI_CLIENT_DISCONNECT_INFO

WIFI_CLIENT_EROAM_DISCONNECTED

WIFI_CLIENT_GUEST_LOGIN_SUCCESS

WIFI_CLIENT_GUEST_LOGOUT_SUCCESS

WIFI_CLIENT_GUEST_SESSION_TIMEOUT

WIFI_CLIENT_WPA2_INVALID_PSK

WIFI_DISALLOW_CLIENT

WIFI_DYN_AUTH_COA_REQ

WIFI_DYN_AUTH_DISCONNECT_REQ

WIFI_CLIENT_LDAP_AUTH_REJECT

WIFI_CLIENT_LDAP_AUTH_SUCCESS

WIFI_CLIENT_LDAP_AUTH_TIMEOUT

WIFI_CLIENT

The following table describes the different types of system event categories and their descriptions.



System Event Category Description

Infrastructure Events related to infrastructure management – such as HA setup, interfacing
with Message Bus or Database servers, Subscription, etc.
Source: cnMaestro

Network Events related to networking issues, such as link up/down.
Source: Devices

Operations Event related to system-level processes, such as pushing configuration,
installing images, etc.
Source: Devices

Other Events related to miscellaneous categories.
Source: Devices

Registration Events related to managing/unmanaged devices.
Source: Devices

Security Events related to logging into the devices, establishing secure links, and
potentially recognizing scans and security breaches in the future.
Source: cnMaestro, Devices, and Clients

Services Events related to additional services that may be added to the product in the
future. There may not be any services events in the first release.
Source: cnMaestro and Devices

Wireless Events related to issues/notifications with the PTP/PMP radio connectivity,
Wi-Fi Clients, etc.
Source: Devices and Clients

Table 22: System Event Types and Definitions

Alarms

Alarm Life Cycle
The basic alarm life cycle has the following states:
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State Description

Acknowledged Active alarms can be acknowledged, which signifies they are known and being handled.
Acknowledged alarms are not included in the total alarm count.

Active The alarm remains active until the combination of inputs that generated it are cleared.

Inactive Inactive alarms remain visible in the active Alarm Table for 10 minutes, before they are
moved to Alarm History. An alarm becomes inactive when the inputs that generated it
are no longer present. An Inactive alarm can be pulled back to the
Active/Acknowledged states if a new event reactivates the alarm.

Raised The creation of the alarm.

Table 23: Alarm Life Cycle

Alarm Severity
Alarms have a severity that determines how they are handled.

Severity Definition

Critical Catastrophic problem that makes the product/feature unusable.

Major Significant issue that greatly degrades the product/feature, but it is still usable.

Minor Limited issue that alters product functionality in a targeted way.

Table 24: Alarm Severity

Alarm Types

Alarm Type Definition

Configuration Issues encountered during a device configuration update.

DFS State Issues related to DFS operational status.

GPS State Issues related to GPS synchronization.

Link State Issues related to the status of device interfaces.

Status Connectivity between cnMaestro and a device is lost.

Upgrade Issues encountered during device software upgrade.

Table 25: Alarm Types

Alarm Acknowledgment
Active alarms can be acknowledged in the Alarm Table. Acknowledgment makes the alarm less visible in the
table, and the administrator can further add a note describing how the alarm is being resolved. Acknowledging
an alarm will also remove it from the alarm counts. You can also select the Clear Alarm check box to clear the
acknowledged alarm when acknowledging the alarms.



Figure 92 Alarm Acknowledgment

Alarm Bulk Acknowledgment
To acknowledge multiple alarms at the same time, follow these steps: 

1. Navigate to the Monitor and Manage > Notifications > Alarms page.

Figure 93 Alarm Bulk Acknowledgment

2. Select the alarms from the alarms list and then click on the Bulk Acknowledge button on the top right corner
of the list.

3. Enter Notes about the selected alarms.

4. (Optional) Select the Clear Alarm check-box if you would like to remove those alarms from the Alarms list
after you acknowledge.

5. Click Acknowledge

You can filter the Acknowledged and Unacknowledged devices as shown below:
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NOTE:

Acknowledged alarms are not shown in Top Active Alarms.

Alarm filters
You can create custom filters for Alarms. To create a custom filter, perform the following steps:

1. In the Alarms table, click Apply Filter(s).

2. Enter the values in the fields for creating the filters.

3. Click Apply Filter.

Figure 94 Alarms: New Filter

You can manually filter or search by typing parameters in the column header of the Alarms table.

4. Click Reset to reset the filter option in the Alarms filter.

5. Click Clear Filters to clear all the filter options.

If you do not receive expected filter details, click Change Filter(s) in the Alarms table to apply new filters.



Alarm History
Expired Alarms are added to the Alarm History. The Alarm History displays historical active alarm counts.
Clicking the bar chart filters the table data underneath, allowing you to view which alarms were active at a
specific time in the past.

Figure 95 Alarm History

Alarm History filters
You can create custom filters for Alarms History. To create a custom filter, perform the following steps:

1. In the Alarms History table, click Apply Filter(s).

2. Enter the values in the fields for creating the filters.

3. Click Apply Filter.

Figure 96 Alarm History: New Filter

You can manually filter or search by typing parameters in the column header of the Alarm History table.
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4. Click Reset to reset the filter option in the Alarms History filter.

5. Click Clear Filters to clear all the filter options.

If you do not receive expected filter details, click Change Filter(s) in the Alarm History table to apply new filters.

Wi-Fi Events
Wi-Fi Events are listed as below:

.

Statistics and Details
Statistics provide a tabular aggregation of data, including general information on the devices monitored, as well
as Wireless, Network, and Traffic metrics. Details pages provide information on a single device, generally in a
page format.

The following table highlights the type of information that is generally found in cnMaestro Statistics and Details
sections (separated by Device Type):



60 GHz cnWave Nodes General

l Device
l IPv6 Address
l MAC
l Mode
l Model
l PoP Node
l Serial Number
l Site
l Software Version
l Status
l Status Time
l Network

GPS

l Fix Type
l Height
l Latitude
l Longitude
l Satellites Tracked
l Sync Mode

Network

l Ethernet Throughput (Rx)
l Ethernet Throughput (Tx)
l Main Aux SFP
l Radio Channel
l Sector Throughput (Rx)
l Sector Throughput (Tx)

cnMatrix General

l Device
l IP Address
l MAC
l Managed Account
l Product Name
l Serial Number
l Status

Traffic

l Throughput (DL)
l Throughput (Rx)

cnPilot Home General

l Device
l IP Address
l Product Name
l Serial Number
l Status

Wireless

l Radios (Channel)

cnRanger BBU General

Table 26: Device Statistics
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l Device
l IP Address
l Registered SM Count
l Serial Number
l Status

Traffic

l Throughput (DL)
l Throughput (UL)

cnRanger SM General

l Device
l IP Address
l IMSI
l Serial Number
l Status

Traffic

l Throughput (DL)
l Throughput (UL)

Wireless

l Bandwidth
l Frequency
l MCS (DL)
l MCS (UL)
l RSRP
l RSRQ
l RSSI

cnReach General

l Device
l IP Address
l Neighbors
l Radio
l Role
l Status

Radio

l Average Noise
l Radio Temperature
l RSSI
l SNR
l Tx Power

Traffic

l Throughput (DL)
l Throughput (UL)

cnReach XIO General

l Active S/W Version
l Device
l IP Address
l Product Name
l Serial Number

Table 26: Device Statistics



l Status

cnVision Client General

l Device
l DFS Status
l Distance
l IP Address
l Serial Number
l Session Time
l Status

Network

l LAN Interface
l LAN Interface 2
l WAN IP Address

Traffic

l Retransmission Rate (DL)
l Retransmission Rate (UL)
l Throughput (DL)
l Throughput (UL)

Wireless

l Antenna Gain
l Capacity
l Connected AP
l MCS (DL)
l MCS (UL)
l Quality
l RSSI (DL)
l RSSI (UL)
l SSID
l Tx Power
l Wireless MAC

cnVision Hub General

l Device
l DFS Status
l IP Address
l Registered SM Count
l Reregistration Count
l Serial Number
l Status

Network

l LAN Interface
l LAN Interface 2

Traffic

l Throughput (DL)
l Throughput (UL)

Wireless

l Antenna Gain
l Bandwidth
l DL/UL Ratio

Table 26: Device Statistics
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l Frequency
l Max Range
l SSID
l Tx Power

cnWave 5G Fixed BTS Overview

l Product Name
l MAC Address
l IPv4 Address
l Serial Number
l Software Version
l Connected CPEs
l Registered CPEs
l Site Location
l Site Contact
l Description
l Boot Loader details such as Git Tag, Build Name, and Hardware Version
l Boot - Startup Reason and Startup Count
l Shutdown date and time, reason, and detail

Interfaces

l Interface Configuration (SFP1 Speed and SFP2 Speed)
l GNSS (Tracking, Altitude, Location, Satellites In View)
l Tx/Rx Errors (In and Out Discards, In and Out Errors for Wireless, Main,

SFP1, and SFP2)
l Tx/Rx Counters (In and Out Octets, Unicast, Multicast, Broadcast

packets for Wireless, Main, SFP1, and SFP2)

Radios - Radio status of the BTS device

l Frequency
l Max EIRP
l Polarisation
l Link Symmetry
l Bandwidth
l Target Rx Power
l UL Tx Pwr Ctrl Initial Adjust
l UL Tx Pwr Ctrl Cont Adjust

cnWave 5G Fixed CPE Overview

l Product Name
l MAC Address
l IPv4 Address
l Serial Number
l Software Version
l Site Location
l Site Contact
l Altitude
l Coordinates
l Radio Details such as DL EVM (dB), UL EVM (dB), DL Rx Power (Data),

UL Rx Power (Data), DL MCS, and UL MCS
l Session such as Registration State, Registration Count, Link Uptime, and

IMSI

Interfaces

l Ethernet - Count of In and Out Discards, count of In and Out Errors,
count of In and Out Octets, Unicast, Multicast, Broadcast packets

Table 26: Device Statistics



l Wireless - Count of In and Out Discards, count of In and Out Errors,
count of In and Out Octets, Unicast, Multicast, Broadcast packets

Radios

l Alignment Active
l Range
l Current EIRP (dBm)
l UL Backoff (dB
l DL Backoff (dB)
l DL Sounding State
l UL Sounding State
l DL Channel Distortion (dB)
l UL Channel Distribution (dB)
l DL EVM (dB)
l UL EVM (dB)
l DL MCS
l UL MCS
l DL Rx Power (Data)
l UL Rx Power (Data)
l DL Spatial Frequency
l UL Spatial Frequency
l Polarization

Enterprise Wi-Fi General

l Device
l IP Address
l Product Name
l Serial Number
l Status

Wireless

l Radios (Channel)

ePMP AP General

l Device
l DFS Status
l IP Address
l Registered SM Count
l Reregistration Count
l Serial Number
l Status

Network

l LAN Interface
l LAN Interface 2

Traffic

l Throughput (DL)
l Throughput (UL)

Wireless

l Antenna Gain
l Bandwidth
l DL/UL Ratio
l Frequency
l Maximum Range

Table 26: Device Statistics
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l SSID
l Tx Power

ePMP SM General

l Device
l DFS Status
l Distance
l IP Address
l Serial Number
l Session Time
l Status

Network

l LAN Interface
l LAN Interface 2
l WAN IP Address

Traffic

l Retransmission Rate (DL)
l Retransmission Rate (UL)
l Throughput (DL)
l Throughput (UL)

Wireless

l Antenna Gain
l Capacity
l Connected AP
l MCS (DL)
l MCS (UL)
l Quality
l RSSI (DL)
l RSSI (UL)
l SSID
l Tx Power
l Wireless MAC

Machfu Cell

l Cell Enabled
l Cell ICCID
l Cell IMEI
l Cell IMSI
l Cell IP
l Cell Link
l Cell Manufacturer
l Cell Model
l Cell Network Type
l Cell RSSI
l Cell Rx Rate
l Cell Software Version
l Cell Tx Rate

Ethernet

l Ethernet
l Ethernet Enabled
l Ethernet Gateway
l Ethernet IP Address

Table 26: Device Statistics



l Ethernet Link
l Ethernet Link Speed
l Ethernet MAC
l Ethernet Mask
l Ethernet Mode
l Ethernet Rx Rate
l Ethernet Tx Rate

General

l Device
l IP Address
l Status

GPS

l GPS Accuracy
l GPS Altitude
l GPS Fix Time
l GPS Satellites in use
l GPS Status
l GPS Time

Wireless Access Point

l WAP Enabled
l WAP IP
l WAP Link
l WAP MAC
l WAP Mask
l WAP Mode
l WAP Rx Rate
l WAP SSID
l WAP Tx Rate

Wireless Client

l WC Enabled
l WC Gateway
l WC IP
l WC Link
l WC MAC
l WC Mask
l WC RSSI
l WC Rx Rate
l WC SSID
l WC Tx Rate

PMP AP General

l Device
l DFS Status
l IP Address
l Reregistration Count
l Registered SM Count
l Serial Number
l Status

Network

l LAN Interface

Traffic

Table 26: Device Statistics
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l Busy Index (DL)
l Busy Index (UL)
l Frame Utilization (DL)
l Frame Utilization (UL)
l Throughput (DL)
l Throughput (UL)

Wireless

l Antenna Gain
l Bandwidth
l Color code
l Connection Slots
l DL/UL Ratio
l Frequency
l Max Range
l Tx Power

PMP SM General

l Device
l DFS Status
l Distance
l IP Address
l Serial Number
l Session Time
l Status

Network

l LAN Interface
l WAN IP Address

Traffic

l Packet Loss (DL)
l Packet Loss (Error Drop) (DL)
l Packet Loss (Overcapacity) (DL)
l Packet Loss (UL)
l Packet Loss (Overcapacity) (UL)
l Packet Loss (Error Drop) (UL)
l Throughput (DL)
l Throughput (UL)

Wireless

l Antenna Gain
l BER (Average)
l Color Code
l Connected AP
l Horizontal SNR (DL)
l Horizontal SNR (UL)
l LQI (DL)
l LQI (UL)
l Modulation (DL)
l Modulation (UL)
l RSSI (DL)
l RSSI Imbalance
l Tx Power
l Vertical SNR (DL)
l Vertical SNR (UL)

Table 26: Device Statistics



PTP 650/670/700 System

l Device
l IP Address
l MAC
l Managed Account
l Product Name
l Status

Network

l Aux Interface
l Main PSU Interface
l SFP Interface

Wireless

l Antenna Gain
l Bandwidth
l Errored Seconds
l Licensed Country
l Maximum Transmit Power
l Receive Frequency
l Severely Errored Seconds
l Transmit Frequency
l Unavailable Seconds

PTP 820/850 General

l Device
l Edge Controller
l IP Address
l Model
l Radios
l Serial Number
l Status

RV22 Home Mesh General

l Device Name
l MAC Address
l Product Name
l Serial Number
l IPv4 Address
l IPv6 Address
l Status

Wireless

l Radios

Table 26: Device Statistics

Performance
Performance pages display a synchronized view of time-series data for devices. The data can be filtered using
the interval ranges in the upper left (last 1 hours to last 1 year) , or by dragging the cursor on the graph to select
a specific range. The data presented varies based upon device type.
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NOTE:

cnMaestro supports 14 months of historical data for devices:

l cnPilot Home (R-Series)
l Enterprise devices (Enterprise Wi-Fi and cnMatrix)
l IIoT devices

cnMaestro supports 26 months of historical data for devices:

l Fixed Wireless

Period = 1 day is available for a Time Range of more than 24 hrs.

The following images represent the sample performance graphs for 60 GHz cnWave, cnMatrix, cnPilot
Enterprise, cnPilot Home, cnRanger, cnReach, cnVision, cnWave 5G Fixed, ePMP AP, ePMP SM, Machfu, PMP AP,
PMP SM, PTP 650/670/700, and PTP 820/850 .



Device Fields

60 GHz
cnWave
(Links)

Displays the following graphs:

l Delta (Link Up/Link Available)
l EIRP
l Link Fade Margin
l Management Link Up
l RSSI
l Rx Frames (Per Second)
l Rx MCS
l Rx Packet Error Ratio
l Rx Scanbeams
l Rx Throughput
l SNR
l Tx Frames (Per Second)
l Tx MCS
l Tx Packet Error Ratio
l Tx Scanbeams
l Tx Throughput

60 GHz
cnWave
(Node)

Displays the following graphs:

l Ethernet Throughput (Rx)
l Ethernet Throughput (Tx)
l Sector Throughput (Rx)
l Sector Throughput (Tx)

Table 27: Performance graph
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Device Fields

cnMatrix Displays the following graphs:

l CPU
l Packet Error
l Rx Packets
l Throughput
l Tx Packets

cnPilot
Home

Displays the following graphs:

l CPU
l Stacked Clients by Band
l Stacked Clients by Radio
l Stacked Throughput by Band (Downlink)
l Stacked Throughput by Band (Uplink)
l Stacked Throughput by Radio (Downlink)
l Stacked Throughput by Radio (Uplink)

Table 27: Performance graph



Device Fields

cnReach Displays the following graphs:

l Neighbors
l Noise
l RSSI
l Throughput
l Transmit Power

cnRanger
BBU

Displays the following graphs:

l Available Memory
l CPU
l Interface (eth1)
l Interface (eth2)
l SMs Registered
l Temperature
l Throughput

Table 27: Performance graph
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Device Fields

cnRanger
RRH

Displays the following graphs:

l Ambient Temperature
l CPU
l Die Temperature
l Frame Utilization
l SMs Registered
l Throughput

cnRanger
SM

Displays the following graphs:

l Available Memory
l CPU
l MCS
l RSRP
l RSRQ
l RSSI
l SINR
l Throughput

Table 27: Performance graph



Device Fields

cnVision
Client

Displays the following graphs:

l CPU
l MCS
l Retransmission
l RSSI
l Session Drops
l SNR
l Throughput

Table 27: Performance graph
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Device Fields

cnVision
Hub

Displays the following graphs:

l CPU
l Frame Utilization
l Retransmission
l SMs Registered
l Throughput

cnWave 5G
Fixed BTS
device

Displays the following graphs:

l Throughput
l CPE Count

Table 27: Performance graph



Device Fields

cnWave 5G
Fixed CPE
device

Displays the following graphs:

l EVM
l MCS
l Throughput
l Rx Power
l Registration Count

Enterprise
Wi-Fi

Displays the following graphs:

l Airtime Radio 1
l Airtime Radio 2
l Available Memory
l Clients by Band
l Clients by Radio
l CPU
l Interference
l Noise Floor
l Stacked Clients by Band
l Stacked Clients by Radio
l Stacked Packet Rate by Band (Downlink)
l Stacked Packet Rate by Band (Uplink)
l Stacked Packet Rate by Radio (Downlink)
l Stacked Packet Rate by Radio (Uplink)
l Stacked Throughput by Band (Downlink)

Table 27: Performance graph
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Device Fields

l Stacked Throughput by Band (Uplink))
l Stacked Throughput by Radio (Downlink)
l Stacked Throughput by Radio (Uplink)

Enterprise
Wi-Fi
(Xirrus-
Series)

Displays the following graphs:

l Available Memory
l Clients by Band
l Clients by Radio
l CPU
l Stacked Packet Rate by Band (Downlink)
l Stacked Packet Rate by Band (Uplink)
l Stacked Packet Rate by Radio (Downlink)
l Stacked Packet Rate by Radio (Uplink)
l Stacked Throughput by Band (Downlink)
l Stacked Throughput by Band (Uplink))
l Stacked Throughput by Radio (Downlink)
l Stacked Throughput by Radio (Uplink)

Table 27: Performance graph



Device Fields

ePMP AP Displays the following graphs:

l CPU
l Frame Utilization
l Retransmission
l SMs Registered
l Throughput

ePMP SM Displays the following graphs:

l CPU
l MCS
l Modulation

Table 27: Performance graph
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Device Fields

l Retransmission
l RSSI
l Session Drops
l SNR
l Throughput

MachFu Displays the following graphs:

l Cellular RSSI
l Cellular Throughput
l CPU Load
l Disk Storage
l Ethernet 1 Throughput
l Ethernet 2 Throughput
l Flash Memory
l Wi-Fi Access Point Throughput
l Wi-Fi Client RSSI
l Wi-Fi Client Throughput

NSE 3000 Displays the following graphs:

l Available Memory
l CPU

Table 27: Performance graph



Device Fields

PMP AP Displays the following graphs:

l CPU
l Frame Utilization
l MU-MIMO Frame Utilization (for 450m)
l Multiplex Gain (for 450m)
l SMs Registered
l SU-MIMO Frame Utilization (for 450m)
l Throughput

PMP SM Displays the following graphs:

l BER
l CPU
l DL RSSI Imbalance
l LQI (Link Quality Indicator)
l Modulation
l RSSI
l Session Drops
l SNR (Vertical)
l SNR (Horizontal)
l Throughput

Table 27: Performance graph
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Device Fields

NOTE:

BER with zero values are not plotted on the logarithmic scale graphs.

Table 27: Performance graph



Device Fields

PTP and
HCMP
Masters

Displays the following graphs:

l Aux Throughput
l Capacity
l Channel Utilization
l Link Loss
l Main PSU Throughput
l Packet Error
l PCB Temperature
l Receive Power
l Receive Signal Strength Ratio
l Receive Vector Error
l SFP Throughput
l Throughput
l Transmit Power

PTP and
HCMP
Slaves

Displays the following graphs:

l Aux Throughput
l Capacity
l Channel Utilization
l Link Loss
l Main PSU Throughput
l Packet Error
l PCB Temperature
l Receive Power
l Receive Signal Strength Ratio
l Receive Vector Error
l SFP Throughput
l Throughput
l Transmit Power

Table 27: Performance graph
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Device Fields

PTP
820/850

Displays the following graphs:

l Modem MSE
l Modem XPI
l MRMC Profile
l Peak Throughput By Groups
l Peak Throughput By Radios
l Signal Level - RSL
l Signal Level - TSL
l Throughput By Groups
l Throughput By Radios

Table 27: Performance graph



Device Fields

PON Displays the following graphs:

l ONUs
l Memory
l CPU
l Temperature

RV22 Home
Mesh

Displays the following graphs:

l Stacked Throughput by Band (Downlink)

Table 27: Performance graph
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Device Fields

l Stacked Throughput by Band (Uplink)
l Stacked Clients by Band
l Noise Floor
l Interference
l Airtime 2.4 GHz
l Airtime 5 GHz
l Available Memory
l CPU
l SNR
l RSSI
l Data Rate

Table 27: Performance graph



Device Fields

Table 27: Performance graph
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Maps
Maps provide visualization for Towers, Sites, and Devices. They display proximity to other devices, connectivity
between devices, device health, and selectable status parameters. An example Map is presented below.

Three views are supported in System Maps and Network/Tower Dashboard Maps:

l Street View

l Satellite View

l Terrain View

Figure 97 Map Street View

The Satellite View is supported in limited US and EU regions.



Figure 98 Map Satellite View

Figure 99 Map Terrain View
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If latitude or longitudinal of Site or Tower or Device is (-90°, 90°, -180°, 180°) or (0,0) then they will not display
in the map.

NOTE:

l (0,0) is the default value for devices that do not have a location set cnMaestro does not plot
devices with this location.

l (x, 180°) and (x, -180°) require the user to zoom out in order to see the markers.

l (90°, y) and (-90° ,y) also displays incorrectly.

Map Navigation
There are a various ways to navigate the map display.

Action Description

Click Click the following items on the Map to auto-select the same item in the Tree.

l ePMP SM
l Tower

Double-click Double-click on the following items on the Map to auto-navigate to the
Dashboard of that item.

l ePMP SM
l Site
l Tower

Hover Hovering over a tower or device displays a tool tip that provides basic status
information. Hovering over an RF link displays status on the link.

Standard Components In the upper-left corner are generic map navigation components that allow one to
zoom in and out. Use the mouse to drag and reposition the view. as well as turn on
the satellite display.

Mode
The map can be placed in a number of different modes, which define how the device status is presented.

Mode Details

Alarm Status Highlights devices based upon alarm count (Critical, Major, Minor).

Average MCS  Displays the Uplink or Downlink average MCS per device.

Device Status Displays whether a device is Up (Green) or Down (Red).

Frequency Displays the device sector frequency.

Link Quality Indicator
(PMP )

Displays the Uplink or Downlink status.

Table 28: Mode



Mode Details

Packet Loss Displays the Uplink or Downlink packet loss per device.

Reregistration Count Displays the nodes based upon the number of re-registrations in the last 24
hours. The more re-registrations, the larger the node is display.

Retransmission
Percentage (ePMP and
cnVision)

Displays the Uplink or Downlink percentage status.

Table 28: Mode

Embedded Maps
Maps are embedded into some additional UI views (most notably, the Dashboard). These embedded maps do
not provide the full feature set of the map view.

Sector Visualization
cnMaestro presents a basic sector View for ePMP and PMP fixed wireless devices. This requires configuration of
Height, Azimuth, Elevation, and Beamwidth under cnRanger ePMP/PMP AP configuration. This configured data
is used to generate the Sector View. The presentation is not based upon link planning or geographic topology.

Figure 100 AP Configuration

Sector Visualization is available in Map View. By selecting the Show Sector option, the following map is
displayed:
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Figure 101 Sector Visualization

Show Subscriber Modules option is available at System, Network, Tower, and AP levels. User can also choose to
set the color of SMs based upon frequency or Online or Offline Status.

NOTE:
l By default Show Subscriber Modules is disabled.
l Map view is supported for PMP, ePMP, cnRanger, cnPilot Home, PTP, 60 GHz cnWave,

cnVision, cnMatrix, Enterprise Wi-Fi Series, and RV22 Home Mesh at site- and device-levels.

The Show Interfering sector option compares the frequency and bandwidth with all other devices in the
network. The map displays the devices that have overlapping frequencies.

NOTE:

Show Interfering Sectors is applicable only for PMP devices and is enabled only if the Show
Sector button is ON.

Maps are available for the Site and Device levels. The right pane displays the device details in the map. To view
the map device details, do one of the following:



l Click the (+) plus sign, next to Site or Device in the right pane of the Map page, to view the device and site
details as shown in Figure 102.

l Click the Dashboard( ) icon next to the Site or Device name, to view the site or device dashboard details.

Figure 102 Map: Enterprise Site level

Figure 103 Map: Home Site level
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Figure 104 Map: Device level

Figure 105 Map view: cnMatrix

Figure 106 Map view: Enterprise Wi-Fi (Xirrus-Series)



Figure 107 Map View: PTP 820/850

Tools
This section provides the following details:

l 60 GHz cnWave Tools

l cnMatrix Tools

l cnPilot Home Tools

l cnRanger Tools

l cnReach Tools

l cnVision Tools

l Edge Controller Tools

l Enterprise Wi-Fi Tools

l ePMP Tools

l Machfu Tools

l PMP Tools

l cnWave 5G Fixed Tools

l RV22 Home Mesh Tools

60 GHz cnWave Tools
In E2E Network Tools tab you can view Operations, Diagnostics, Debug, Remote Command, Services, and
Settings. Refer to E2E Network Tools.

In Nodes Tools tab you can view the Status, Debug, and Remote Command of the device. Refer to Node Tools.

cnMatrix Tools
In Status tab you can view the status of the device (either Online or Offline). It allows one to reboot the device.
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Field Description

Network Connectivity Executes Ping, DNS, or Traceroute tests.

Remote CLI Enter CLI command in the command text box to execute on device.

l Only Show command is allowed for Operator users.
l All CLI commands are supported by Super Admin and Admin users.

Status Displays the Status and Port Status.

Table 29: cnMatrix Tools

The Status tab displays the status of the device (either Online or Offline). It also allows one to reboot the device.

Port Status, presents the following data for the PoE Switches:

l Cable Diagnostic

l Port Enable

l Port Disable

l PoE Enable

l PoE Disable

l PoE Toggle

Cable Diagnostic
Navigate to Tools > Status > Port Status, select the Port and click Cable Diagnostic, the following output is
displayed:



l Download the generated output by clicking the download ( ) icon.

l Clear the generated output by clicking the delete ( ) icon.

Note: Cable Diagnostic is a cnMaestro X feature.

Port Enable or Port Disable
Navigate to Tools > Status > Port Status, select the Port and click Port Disable or Port Enable, the following
output is displayed:
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l Download the generated output by clicking the download ( ) icon.

l Clear the generated output by clicking the delete ( ) icon.

PoE Toggle
Navigate to Tools > Status > Port Status, select the Port and click PoE Toggle, the following output is displayed:



l Download the generated output by clicking the download ( ) icon.

l Clear the generated output by clicking the delete ( ) icon.

PoE Enable or PoE Disable
Navigate to Tools > Status > Port Status, select the Port and click PoE Enable or PoE Disable, the following
output is displayed:
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Port Status, presents the following port status for the non-PoE Switches:

l Cable Diagnostic

l Port Enable

l Port Disable



Remote CLI
Navigate to Tools > Remote CLI, when you select a command type and click Run, the following output is
displayed:
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l Download the generated output by clicking the download ( ) icon.

l Clear the generated output by clicking the delete ( ) icon.

cnPilot Home Tools
The Tools page for cnPilot Home devices consolidates a number of operations into a single troubleshooting
interface. The operations of cnPilot Home are listed in the table below:



Tools Description

Debug Displays the log details.

Network Connectivity Executes Ping, DNS, or Traceroute tests.

Packet Capture Lists packet capture details.

Status Displays the Status of device.

Wi-Fi Analyzer Displays radio traffic and signal.

Wi-Fi Performance Wi-Fi performance measures the backhaul speed across devices with respect
to cnMaestro.

Table 30: cnPilot Home

Figure 108 cnPilot Tools

Figure 109 cnPilot Debug Tools
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Figure 110 cnPilot Tools Status

Figure 111 cnPilot Tools > Packet Capture



Figure 112 cnPilot Tools > Network Connectivity

Figure 113 cnPilot Tools > Network Connectivity

cnRanger Tools

NOTE:

cnMaestro supports the tools page of cnRanger from device version 2.1.0.0-r3.

cnRanger BBU
In Status tab, user can view the status of the device either Online or Offline. It also supports downloading Tech
Support File and rebooting the device.
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cnRanger SM
In Status tab, user can view the status of the device (either Online or Offline), It also supports downloading the
Tech Support File, displaying the wired connectivity status, and rebooting the device.

cnReach Tools
The Tools page for cnReach devices consolidates a number of operations into a single troubleshooting
interface. The operations are listed below:

Tools Description

Ping Network ping to a hostname or IP address.

RF Ping RF reachability test between local radios that provides details on signal quality.

RF Throughput RF throughput test between local radios that provides details on throughput.

Table 31: cnReach Tools



Figure 114 cnReach Tools

cnVision Tools
The Tools page for cnVision devices consolidates a number of operations into a single troubleshooting
interface. The operations are listed below:

Field Description

Debug Displays the log details.

Network Connectivity Executes Ping, DNS, or Traceroute tests.

Status Displays the Status.

Table 32: cnVision Tools
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Field Description

Subscriber Modules Displays the SM linked to the Hub and supports reboot and download the Tech
Support File.

Link Test The Link Capacity Test measures the throughput of the RF link between two
cnVision modules. cnVision Link Test only utilizes the spare sector capacity for this
test; therefore, sector traffic will not be disrupted. For the most accurate wireless
link test results, it is best to run this test when there is minimal customer data traffic.

Displays the link related test result for Throughput. Link Test can be performed on
the cnVision Hub and its SM link. To run this operation, select the device and then
the Tools tab.

l If cnVision Hub is selected you can choose the SM from the list and start the test.

Displays the following fields:

Packet Size: Choose the Packet Size to use for the throughput test.

Duration: Choose the time duration in seconds to use for the throughput test.

l If a cnVision Client is selected, click Start Test to run the Link Test.

Displays the following fields:

Packet Size: Choose the packet size to use for the throughput test.

Duration: Choose the time duration in seconds to use for the throughput test.

Table 32: cnVision Tools



Figure 115 cnVision Tools

Edge Controller Tools
For details on Tools section, refer to Edge Controller User Guide.

Enterprise Wi-Fi Tools
The Tools page for Enterprise Wi-Fi devices consolidates a number of operations into a single troubleshooting
interface.

NOTE:

Both IPv4 and IPv6 addresses are supported for all the troubleshooting operations.

The operations of Enterprise Wi-Fi are listed below:

Tools Description

Debug Displays the log details.

Flash LEDs (only
Enterprise Wi-Fi
devices)

Flash LED indicates that a device is ready to receive the signal.

Network Connectivity Executes Ping, DNS, or Traceroute tests.

Packet Capture Lists packet capture details.

Remote CLI Enter CLI command in the command text box to execute on device.

l Only Show command is allowed for Operator users.
l All CLI commands are supported by Super Admin and Admin users.

Table 33: Enterprise Wi-Fi Tools
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Tools Description

Status Displays the Status of device.

Wi-Fi Analyzer Displays radio traffic and signal.

Wi-Fi Performance Wi-Fi performance measures the backhaul speed across devices with respect to
cnMaestro.

Table 33: Enterprise Wi-Fi Tools

Figure 116 Enterprise Wi-Fi Tools

Figure 117 Enterprise Wi-Fi Packet Capture



Figure 118 Enterprise Wi-Fi Remote CLI Tools

Figure 119 Flash LEDs

Packet Capture
Packet Capture allows the user to capture all packets on a specified interface. The user can trigger packet
capture on an interface (or multiple interfaces simultaneously).

NOTE:

Enhanced packet capture is available for version 6.4 or higher in Enterprise devices.
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To view Packet Capture, navigate to Network or Site > Wi-Fi AP > Tools > Packet Capture.

Field Description

Duration Represents packet capture running duration in seconds versus maximum duration
configured.

Expires In Expiry time of packet capture. The default is 24 hours.

Filter Type of filter.

Interface The following interfaces are supported:

l BRIDGE
l Ethernet
l PPPoE
l Radio
l SSID
l TUNNEL
l VLAN
l Wireless LAN

Packets Represents number of packets captured versus maximum limit of packet count
configured.

Table 34: Packet Capture fields



Field Description

Size Current packet capture size versus maximum packet capture size configured.

Start Time Start time of the capture.

Status Status of packet captured is as follows:

l Aborted
l Failed
l Queued
l Skipped

Table 34: Packet Capture fields

New Packet Capture

Perform the following steps to start a new packet capture:

NOTE:

l Filter options vary for different interfaces (Radio, Wireless LAN, VLAN, SSID, TUNNEL,
BRIDGE, and PPPoE. Radio, SSID has wireless 802.11 filters, other interfaces has wired
802.3 filters).

l User can also add custom filters if needed.

l Packet Capture on Radio interface is available only for online Enterprise Wi-Fi XV-Series
and XE-Series.

1. Click New Packet Capture to start packet capture.

2. Select the Interface type from the drop-down.

3. Select Ethernet as Eth1 or Eth2.

4. Choose the Direction as Both, In, or Out.

5. Select Filter options as Filter Builder or Custom.

You can filter the packets captured by specifying Cambium GRE, DHCP, DNS, ARP, ICMP, Radius, TCP, UDP, IP
Address, and MAC Address.
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6. Click Default Options to configure Packets, Duration, Packet Length, and File Size.

7. Click Start Now to capture the packets immediately, or start the capture later by selecting Start Later option.
The progress of packets captured can be seen in the Status field.

8. Click download icon to download the capture in PCAP file format.



NOTE:

For cnMaestro X, a maximum of four packet capture sessions are supported, whereas for
cnMaestro Essentials a maximum of two packet capture sessions are supported.

The user can Edit, Clone, and Delete the packets capture entry. Packet Capture entries can be cloned
depending on the type of interface selected for the capture.

The user can search the packet capture by Interface type and Status.

NOTE:

l User can start packet capture by clicking the Play button. This also works if the packet capture is
stopped at Not Started/Failed/ Expired.

l Bulk Start and Bulk Delete are performed by selecting multiple packet capture.

l Expired packet capture is deleted from cnMaestro after 7 days.

l Packet capture is removed immediately, when device (AP) is deleted from cnMaestro.

l Packet captures cannot be started on same interface simultaneously.

l Only Show command works for the Operator user.

Figure 120 Flash LEDs
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ePMP Tools
The Tools page for ePMP devices consolidates a number of operations into a single troubleshooting interface.
The operations are listed below:



Field Description

Debug Displays the log details.

Link Test The Link Capacity Test measures the throughput of the RF link between two ePMP
modules. ePMP Link Test only utilizes the spare sector capacity for this test, therefore,
sector traffic will not be disrupted. For the most accurate wireless link test results, it is
best to run this test when there is minimal customer data traffic.

Displays the link related test result with respect to Throughput. Link Test can be
performed on the ePMP AP and its SM link. In order to run this operation, select the
device and then the Tools tab.

l If an ePMP AP is selected, choose the SM from the list and start the test.

Displays the following fields:

Packet Size: Choose the Packet Size to use for the throughput test.

Duration: Choose the time duration in seconds to use for the throughput test.

l If an ePMP SM is selected, click Start Test to run the link test.

Displays the following fields:

Table 35: ePMP Tools
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Field Description

Packet Size: Choose the Packet Size to use for the throughput test.

Duration: Choose the time duration in seconds to use for the throughput test.

Network
Connectivity

Executes Ping, DNS, or Traceroute tests.

Status Displays the status.

Subscriber
Modules

Displays the Subscriber Modules details.

Table 35: ePMP Tools

Figure 121 ePMP Tools

Machfu Tools
The Status tab, displays the status of the device and allows downloading Tech Support File and rebooting.



PMP Tools
The Tools page for PMP devices consolidates a number of operations into a single troubleshooting interface.
The operations are listed below:
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Field Description

Debug Displays the log details.

Link Test The Link Capacity Test measures the throughput and efficiency of the RF link between two
PMP modules. Many factors, including packet length, affect throughput. Packets are added to
one or more queues in the AP to fill the frame. Throughput and efficiency are then calculated
during the test.

The Link Capacity Test tool has the following modes:

l Flood Link Test: Tests the link's performance by flooding it with heavy traffic and
assesses link's behavior under extreme network loads. An addition Multiple LUIDs option
is available in the Current SM drop-down list. The Multiple LUIDs feature allows users to
specify LUIDs, including single numbers (for example, 23, 32), or to conduct the flood
test with ranges (for example, 2-22) as shown in Figure 122.

Figure 122 Flood Link Test: PMP 450m AP

NOTE:

Flood Link Test is applicable only for 450m APs.

l Link Test without Bridging: Tests radio-to-radio communication, but does not bridge
traffic.

l Link Test with Bridging: Bridges traffic to “simulated” Ethernet ports, providing a status
of the bridged link.

l Link Test with Bridging and MIR: Bridges the traffic during test and also adheres to any
MIR (Maximum Information Rate) settings for the link.

l Extrapolated Link Test: Estimates the link capacity by sending few packets and
measuring link quality.

Table 36: PMP Tools



Field Description

Displays the link related test result with respect to Throughput and Interference. Link Test can
be performed on the PMP AP and its SM link. To run this operation, select the device and then
the Tools tab.

l If a PMP AP is selected you can choose the SM from the list and start the test.

l If a PMP SM is selected, click Start Test to run the Link Test.

Network
Connectiv
ity

Executes Ping, DNS, or Traceroute tests.

Status Displays the status.

Subscribe
r Modules

Lists all the SMs connected to the selected AP. This is available for PMP APs only.

Table 36: PMP Tools
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Figure 123 PMP Tools

cnWave 5G Fixed Tools
For cnWave 5G Fixed products (BTS and CPE), the Tools page in cnMaestro contains the following tabs:

l Status: Displays device connection state (online or offline) for the BTS and a CPE.

l Link Test (applicable only to the BTS device): Allows you to test the links (uplink, downlink, or both), and
analyze the link performance for a CPE. The test output helps in managing the traffic and troubleshooting
the links for the selected CPE.

Status
To access the cnWave 5G Fixed BTS Tools page, go to Monitor and Manage > BTS > Tools.

To view the status of the link between the BTS and CPE modules, access the Status page under Monitor and
Manage > BTS CPE > Tools > Status.



Link Test

NOTE:

Link Test is supported only on cnWave 5G Fixed devices running System Release version 3.1
or later.

Link test measures the throughput and utilization of RF link between the BTS and its CPE modules

To conduct a link test between a BTS and its CPE modules:

1. Go to Monitor and Manage > BTS > Tools > Link Test.

2. Select appropriate values in CPE, Duration (between 5 and 60 seconds), and Direction (Downlink, Uplink,
and Bidirectional) fields.

3. Click Start Test.

After the set duration completes, the Output window displays the results.
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RV22 Home Mesh Tools
cnMaestro provides the following tools to troubleshoot and debug RV22 Home Mesh routers:

l Status

l Debug

l Network Connectivity

l Wi-Fi Analyzer

l Speed Test

l Packet Capture

To access these tools, navigate to Monitor and Manage > <RV22-router-name> > Tools.

Status
To view the status of the link between the RV22 Home Mesh base and client routers, access the Status page
under Monitor and Manage > <RV22-router-name> > Tools.

Downloading tech support file

To download the tech support file, on the Status page, click the Download Tech Support File ( ) icon.

Debug
Displays log information of the RV22 Home Mesh router. To view the debug information:

1. Navigate to Monitor and Manage > <RV22-router-name> > Tools > Debug.



2. Click Start Logs.

The log information is displayed in the Output window.

Network Connectivity
Provides network connectivity information of the RV22 Home Mesh routers.

The following connectivity tests are available:

l Ping

l DNS Lookup

l Traceroute

To test network connectivity of the router:

1. Navigate to Monitor and Manage > <RV22-router-name> > Tools > Network Connectivity.

2. Select the test type and provide the corresponding parameters required for the test.

3. Click Start Test.

cnMaestro initiates the test and displays the result in the <Test Type> Result window as shown below.
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Wi-Fi Analyzer
Displays radio traffic and signal information for the selected band. It displays the interference and noise
measured for the selected band.

To view the Wi-Fi Analyzer details:

1. Navigate to Monitor and Manage > <RV22-router-name> > Tools > Wi-Fi Analyzer.

2. Select the required band (2.4 or 5 GHz).

3. Click Start Scan.

cnMaestro analyzes the band and displays the result in table as shown below.



Speed Test
Displays the internet speed provided by the RV22 Home Mesh router.

To know the speed of the router:

1. Navigate to Monitor and Manage > <RV22-router-name> > Tools > Speed Test.

2. Provide the details in the fields provided.

3. Click Start Speed Test.

cnMaestro checks the speed and displays both download and upload speeds in megabytes per second
(MBps).

Packet Capture
Packet Capture allows the user to capture all packets on a specified interface.
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To capture packet data:

1. Navigate to Monitor and Manage > <RV22-router-name> > Tools > Packet Capture.

2. Select the required interface and provide the source and destination IP address or MAC address.

3. Provide the number of packets to be captured.

4. Click Start Capture.

cnMaestro displays the information in the Ouput window.

5. To download the PCAP file, click the download ( ) icon.

Wireless Intrusion Detection System (WIDS)
This section provides the monitoring details of Rogue APs, Honeypot APs, and Known APs.

To view WIDS page, navigate to Network > Site > WIDS page.



Configuring WIDS
To enable WIDS feature perform the following steps:

1. Navigate to Configuration > Wi-Fi Profiles > AP Groups tab

2. Select the AP Group and navigate to Security page.

3. Enable the Wireless Intrusion Detection System (WIDS).

Wireless Flood Detection

NOTE:

You need to enable the WIDS to configure the Wireless Flood Detection and Rouge AP
detection.

Wireless Flood Detection is used to detect the flood attacks of Association, Authentication, Deauthentication,
Disassociation, and EAP.
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Wireless Flood Detection displays the following parameters:

Field Description

Association Detect floods of client associations from clients.

Authentication Detect floods of client authentication from clients.

Deauthentication Detect floods of client deauthentications from clients.

Disassociation Detect floods of client disassociations from clients.

EAP Detect floods of EAP messages from clients.

Table 37: Wireless Flood Detection parameters

Rogue APs
A Rogue AP is an unsanctioned AP, which is not onboarded to cnMaestro, which can be any Cambium or non
Cambium device interfering. The AP scans all the channels, collects the details about the neighbor APs and
sends them to cnMaestro.

Rogue APs scans for every 20 minutes and Count represents graphical data for every last week and list the
data.

The following Rouge APs parameters are displayed:



Field Description

SSID SSID of the Rogue AP.

BSSID AP MAC address.

Channel Channel in which the Rogue AP operates.

First Seen Time at which the Rogue AP is detected for the first time.

Last Seen Time at which the Rogue AP is detected last.

RSSI Signal strength of the Rogue AP detected by the device.

Nearest AP MAC
Address

AP MAC address nearby.

Nearest AP Host name AP host name nearby.

Detecting APs AP detection.

Manufacturer Manufacturer of the Rogue AP (Cambium, Cisco, Aruba and Others).

Whitelist Select the detected Rogue APs and mark them as Known APs.

Table 38: Rogue APs parameters

Honeypot APs
Honeypot APs are unauthorized APs advertising with same SSID as managed or onboarded APs. It should be
detected and monitored to prevent threats to the network.

The following Honeypot APs parameters are displayed:
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Field Description

SSID SSID of the Honeypot AP.

BSSID AP MAC address.

Channel Channel in which the Honeypot AP operates.

First Seen Time at which the Honeypot AP is detected for the first time.

Last Seen Time at which the Honeypot AP is detected last.

Manufacturer Manufacturer of the Honeypot AP (Cambium, Cisco, Aruba and Others).

RSSI Signal strength of the Honeypot AP detected by the device.

Nearest AP MAC
Address

AP MAC address nearby.

Nearest AP Host name AP host name nearby.

Detecting APs AP detection.

Whitelist Select the detected Honeypot APs and change them as Known APs.

Table 39: Honeypot APs parameters

Known APs
Known APs allows you to configure the SSID and MAC of Whitelist APs.

To add the Known APs, perform the following steps:

1. Navigate to WIDS > Known APs.

2. Click Add.

Add Whitelist window appears.

3. Enter the MAC.

4. Enter SSID.

5. Click Save.



The following Known APs parameters are displayed:

Field Description

BSSID AP MAC address.

Delete Click delete icon to delete the selected Known AP.

Delete ALL Allows to delete all Known APs in the list.

Manufacturer Manufacturer of the Known AP (Cambium, Cisco, Aruba and Others).

SSID SSID of the Known AP.

Table 40: Known APs parameters

Off Channel Scan

NOTE:

l OCS (on 2.4 GHz, 5 GHz and 6 GHz) and Rogue AP detection should be enabled for
WIDS option to work at Site level in cnMaestro.

l It will take 20 minutes to detect Rogue AP on AP boot up.

To enable OCS (Off Channel Scan):

1. Navigate to Configuration > Wi-Fi Profiles > AP Groups > Radio (Available on both radio 2.4 GHz and 5 GHz)
page.

2. Expand Channel Scan section and select Off Channel Scan option.

3. Click Enable OCS to periodically scan the network.

4. Enter Dwell time as required.

5. Click Save.
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Continuous Background Scan (CBS)
CBS reduces the dwell time, controls the channel switches and also monitors the voice data queues.

To enable CBS:

1. Navigate to Configuration > Wi-Fi Profiles > AP Groups> Radio (Available on both radio 2.4 GHz, 5 GHz, and
6 GHz) page.

2. Expand Channel Scan section and select Continuous Background Scan option.

3. Configure rest time in seconds (5-15).

4. Configure wait time in minutes to wait after all channels are scanned and before starting a new scan (1-10).

5. Configure dwell split time to spend on foreign channel.

6. Configure time interval between scans on same channel (100-1000).

7. Enable Channel Switch Announcement.

8. Click Save.

Network Service Edge

The Network Service Edge (NSE) delivers advanced security, routing and SD-WAN policies for small and
medium enterprises. NSE 3000 model has two Gigabit WAN ports and four Gigabit LAN ports. If offers WAN
throughputs of up to 1 Gbps. NSE 3000 is managed using the cloud-hosted cnMaestro (a management solution
from Cambium Networks).

This section describes the following tabs available in cnMaestro for NSE 3000 model:

l Dashboard

l Notifications

l Configuration

l Security

l Network

l Tools

l Clients

l Certificate



Dashboard
Dashboard widgets provides you a comprehensive overview of NSE device and network health. The dashboard
displays Details of NSE device, status of WAN-1 and WAN-2 usage, number of LAN Clients & VPN Sessions,
Alarms, Threats by Category, Threats and Vulnerabilities categorized as Critical, Major and Minor, Port Status,
Top Vulnerabilities, Top Vulnerable Clients, Top Active Alarms, WAN-1 and WAN-2 Throughput, and Clients and
VPN Sessions.

Figure 124 The NSE dashboard page

Notifications
Notifications consist of Alarms, Alarms History, and Events. They are synchronous messages that provide real-
time system status.

Figure 125 The Notifications page
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Type Description

Alarms Alarms have a state and persist as long as the problematic activity continues; they
reflect the current health of the devices in the network. The inactive alarms are
removed from the alarms page after 10 minutes.

Alarms History Expired Alarms are added to the Alarm History. The Alarm History displays
historical active alarm counts. The history contains both the outstanding (active)
and inactive alarms.

Events Events are stateless, transient messages that occur in response to an input or
action, such as if the CPU exceeds a threshold or a device association fails. Events
are fire-and-forget; they are stored in an Event Table and provide a history of
device activity.

Table 41: Notification overview

Configuration
To apply the Configuration Method, perform the following:

1. Navigate to Configuration page.

2. In the Device Configuration method, select NSE Group option from the drop-down list.

To view the jobs, click View Configuration Jobs or navigate to Administration > Jobs > Configuration Update.

In the Advanced Settings you can configure the following tabs:

l Management

l WAN

l VPN and Radius Server

Management

1. In the Management tab, select the Field Name to override the settings.



2. Click Apply Configuration.

WAN

In the WAN, you can override settings for WAN 1 and WAN 2.

WAN 1

1. Select Enable WAN Overrides option.

2. Select the fields to override.

3. Click Apply Configuration.

WAN 2

1. Select Enable WAN Overrides option.
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2. Select the fields to override.

3. Click Apply Configuration.

VPN and Radius Server

In the VPN and Radius Server tab you can override VPN and Radius Server settings.

1. Select VPN overrides field name.

2. Select Enable Radius User Overrides option.

3. Click Apply Configuration.

Factory Reset

To erase all the configuration on the device and bring the device back to the default factory configuration,
follow these steps:

1. .Navigate to the NSE > Configuration page.

2. Click Factory Reset.



3. In the pop-up window that appears, Click Yes, Factory Reset.

User-Defined Overrides

User-Defined Overrides are appended to the NSE groups before the configuration is applied to the device. This
allows setting configuration parameters which are not supported by GUI.

To configure overrides based on your customized requirements by using variables and macros, follow these
steps:.

1. Navigate to the NSE > configuration page.

2. Define your overrides in the text box.

Figure 126 The User-Defined Overrides page

3. Click Save.
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Configuration Lock

Configuration Lock forces the configuration on NSE and cnMaestro to be in sync always. If there is any
configuration change done directly on the device, then cnMaestro tracks that device and triggers a
configuration sync job to bring back the device to same configuration which is applied from the NSE Group.

To enable the configuration lock, follow these steps:

1. Navigate to the Configuration > Advanced Features.

2. Select the Lock NSE/cnMatrix/Wi-Fi AP Device Configuration check box.

3. Click Save.

Security
The Security page allows you to report the vulnerability and threats detected by the device.

Threats
1. Navigate to NSE > Security > Threats.

2. Select Time Range from the drop-down.

l Last 24 hours

l Last 7 Days

l Last 30 Days

The threat page displays Threat by Location, Total Threats, and threat categories based on Critical, Major,
Minor, and origin of the threat (country of origin). The bar graph on the left hand side displays the count based
upon the threat by Category. The pie chart displays the percentage of threats with respect to other threats. The
per day bar chart displays the threat count aggregated on per day basis.



Figure 127 The Threats page

Parameter Description

Severity The severity of threat such as Critical, Major, and Minor.

Date and Time The date and time of the threat occurrence.

Category Displays any of the following categories of threat:

l Application Attack

Table 42: Parameters on the Threats page
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Parameter Description

l DoS Attack

l Information Leak

l Malware

l Miscellaneous

l Suspicious Traffic

l Unauthorized Access

Country The source country of the threat is displayed for threats that originate from WAN to
LAN.

Source IP Source IP address of the flow which is resulted in the threat.

Destination IP Destination IP address of the flow which is resulted in the threat.

Details Displays the above details in a single window in addition to a description of the threat.

When you click the icon, the Threat Details window appears, as shown in Figure

128.

Table 42: Parameters on the Threats page

Figure 128 The Threat Details window

Vulnerabilities
The Vulnerabilities page displays Total Vulnerabilities, Unique Critical, Unique Major, Unique Minor, and
Vulnerable Clients.



Figure 129 The Vulnerabilities page

Parameter Description

Vulnerable Clients

Hostname Hostname of the client.

When you click the hostname, you can view the vulnerabilities discovered by the
NSE for the client, as shown in Figure 139.

IP Address Source IPv4 address of the vulnerable client.

MAC Address MAC address of the client.

Type Type of client. For example, Computer, or Switch.

OS Operating system running on the client. For example, Windows, or macOS.

Last Scan Date and time of the last security scan performed on the client.

Vulnerabilities Count Number of vulnerabilities found on the client during the security scan.

Severity Level of severity assigned to each vulnerability, such as Critical, Major, or Minor.

All Vulnerabilities

Severity The severity level of the vulnerability:

l Critical

l Major

Table 43: Parameters on the Vulnerabilities page
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Parameter Description

l Minor

Identifier CVE ID number for the discovered vulnerability.

Service Service of the vulnerability.

Port Port number of the service.

Known Exploit Indicates whether the vulnerability is exploited in the wild and is present in the
Known Exploited Vulnerabilities (KEV) catalog.

For information on KEV catalog, see Known Exploited Vulnerabilities Catalog.

Exploitation
Probability

The probability (in percentage) that a vulnerability will be exploited in the next 30
days. A higher value indicates a higher probability of the vulnerability being
exploited.

For information on Exploit Prediction Scoring System (EPSS), see Exploit Prediction
Scoring System.

Product Name of the product.

Product Version Version of the product.

Clients Impacted Number of clients impacted by the vulnerability.

When you click the number in the Clients Impacted column, the Impacted Clients
window appears as shown in Figure 132.

Details Displays the above details in a single window in addition to a short description of the
vulnerability.

A short description typically includes essential information, such as details on how an
attacker can potentially exploit the vulnerability and which product versions are
affected by it.

When you click the Details icon, the Vulnerability Details window appears, as

shown in Figure 130.

When you click the CVE Identifier link, you can access detailed information about the
specific vulnerability in the National Vulnerability Database (NVD) page, as shown in
Figure 131.

Table 43: Parameters on the Vulnerabilities page

https://www.cisa.gov/known-exploited-vulnerabilities-catalog
https://www.first.org/epss/
https://www.first.org/epss/


Figure 130 The Vulnerability Details window

Figure 131 The NVD page

Click the MAC address from the Impacted Clients window as shown in Figure 132 to view the Clients Dashboard.
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Figure 132 The Impacted Clients window

You can refine your search results using Apply Filter(s) option as shown in Figure 133.

Figure 133 Apply Filter(s) option

Network
Network page displays information about onboard DHCP servers, Route table, and WAN statistics.

LAN
LAN page displays Subnet and DHCP Leases. You can Apply Filters for the table header to search for a specific
parameter in the table.



Figure 134 The LAN page

Parameter Description

Subnet

VLAN VLAN ID.

IP Address Static IP address of the VLAN interface.

DHCP Mode Status of the DHCP server mode enabled or disabled.

Relay Server Status of the relay server mode enabled or disabled.

Start Address DHCP pool start IP address.

End Address DHCP pool end IP address.

Lease Used Active IP address issued by the DHCP server.

DHCP Leases

MAC Address MAC address of the client.

IP Address The leased IP address to the client.

Host Name The hostname of the client.

Expires On The duration for the leased IP.

VLAN The VLAN ID assigned to the client.

Table 44: Parameters displayed in LAN

Routes
Routes page displays layer 3 routing table of the device. You can Apply Filters for the table header to search for
a specific parameter in the table.
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Figure 135 The Routes page

Parameter Description

Routes

Destination Destination address of the routes.

Mask Subnet mask of the specific route.

Gateway Default gateway of the routes.

Flags Flags of the routes.

Metric Metric of the routes.

Interface Iinterface of the routes.

Table 45: Parameters on the Routes page

WAN
WAN page displays WAN Connectivity, WAN Details, graphical representation of Speed Test, Throughput in
WAN-1 and WAN-2 in selected Time Range (Last 24 hours or Last 7 Days).

Figure 136 The WAN page

l WAN connectivity: Provides the status of the periodic health check of WAN links.



l WAN speed test: Provides the status of the MAX uplink and downlink bandwidth of the WAN link.

l WAN throughput: Provides the usage of WAN uplink and downlink over a period of time.

WAN Details

Parameter Description

WAN Details

Status Status (online or offline) based upon the periodic WAN link health check.

Refresh time Last update of date and time.

IP mode Mode as DHCP or Static.

IPv4 Address IPv4 Address of the WAN.

Gateway Default gateway of the WAN interface.

Table 46: Parameters displayed on the WAN Details section

VPN Sites
The VPN Sites page displays the network traffic and connection details as shown in Figure 137.

Figure 137 The VPN Sites page

Parameter Description

VPN Sites

Name Name of the VPN site.

IKE State Current state of IKE protocol.

IPSec State Current state of IPSec protocol.

Remote Host IP address of the remote VPN endpoint.

Remote Port Port number of the remote VPN endpoint.

Duration Duration of the VPN connection.

Rx Bytes Number of bytes received by the local VPN endpoint from the remote VPN endpoint.

Tx Bytes Number of bytes transmitted by the local VPN endpoint to the remote VPN endpoint.

Remote Subnets IP address ranges assigned to the remote VPN endpoint's network.

Table 47: Parameters displayed on the VPN Sites page
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Debug Tools
You can capture logs, run remote CLI commands to see stats in real time, run traceroute, ping to check the
reachability, and run live packet capture on the NSE devices on the selected interface.

To display the NSE device status, navigate to NSE > Tools > Status page.

To access the logs, navigate to NSE > Tools > Debug tab and click Start Logs:

To run CLI commands, navigate to NSE > Tools > Remote CLI page, enter the Command and then click Run:



To do packet capture on the NSE device, navigate to NSE > Tools > Packet Capture page and follow these
steps:

1. Click New Packet Capture and complete the details.
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2. Click either Start Now or Start Later and then click Close.

3. If you had clicked Start Later, you can start the packet capture by clicking the right pointed triangle in the
right most column of the interface details list.

To check the network connectivity, navigate to NSE > Tools > Network Connectivity page, complete the details,
and then click Start Ping:



Clients
Clients page displays the Local and Remote clients (VPN clients).

Local
The Local page displays the total client count which are connected to the NSE on the LAN side. Using device
finger printing NSE provides Device Type, Device OS, and OS Version.

Click Host Name. It navigates to detailed Client Dashboard as shown in Figure 138.

Remote
The Remote page displays client count (vpn client) connected on the WAN side.
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Parameter Description

VPN Sessions

User VPN user name.

IP Address IP Address assigned to the VPN client.

Start Time VPN session start time.

End Time VPN session end time.

Duration Total session duration.

Status Session status as active or inactive.

Term Reason Terminated reason of the session disconnected or timeout.

Download Total download by the VPN user.

Upload Total upload by the VPN user.

Table 48: Parameters displayed in VPN sessions

Client Dashboard
Dashboard provides overview of the wired and wireless clients usage. Click the piechart to view specific
application usage.



Figure 138 Client Dashboard

The following parameters are displayed for NSE Clients:

l Total Vulnerabilities

l Critical Vulnerabilities

l Major Vulnerabilities

l Minor Vulnerabilities

l Client Details

l Top Applications

l Top Categories

Applications
The Applications tab displays Application History, Top Application, Top Category, and Total Bytes.

The Application data can be presented most for 24 hours or 7 days.

l Top Application: Represent the most used application by the client.

l Total Bytes: Represents the sum of Uplink and Downlink traffic across all applications used by the client.

l Top Category: Category of the top application used by the client.

Field Description

Application Name Name of the application.

Category Category of the application.

Downlink Total number of downlink bytes during the period selected.

Table 49: Parameters on the Applications page
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Field Description

Uplink Total number of uplink bytes during the period selected.

Total Bytes Total amount of application data (uplink plus downlink).

Productivity Index The estimate of the typical productivity of the application. A higher value means
better productivity.

Risk Index The estimate of the typical security risk of the application. A higher value means
greater risk.

Usage The percentage of usage by this application in comparison to all applications.

Table 49: Parameters on the Applications page

Vulnerabilities
The Vulnerabilities page displays the vulnerabilities discovered for the client by the NSE. Vulnerabilities are
categorized as Minor, Major, and Critical.

Figure 139 Vulnerabilities dashboard

Traffic Flows
Traffic flows can be referred to as a current snapshot of existing flows. The flow direction can be either LAN to
WAN or WAN to LAN.

The Traffic Flows page displays the active connections or flows of a client, as shown in Figure 140.

Figure 140 The Traffic Flows page



Parameter Description

Source IP Source IP address of the device or endpoint, based on the flow direction.
If the flow direction is from LAN to WAN, the source IP address is the source IP
address of the device.

If the flow direction is from WAN to LAN, the source IP address is the source IP
address of the endpoint to which the device has connection to.

Source Port Source port number.

Destination IP Destination IP address of the device or endpoint, based on the flow direction.
If the flow direction is from LAN to WAN, the destination IP address is the
destination IP address of the endpoint.

If the flow direction is from WAN to LAN, the destination IP address is the
destination IP address of the device.

Destination Port Destination port number.

Application Name of the application.

Tx Packets Transmitted packets.

Tx Bytes Transmitted bytes.

Rx Packets Received packets.

Rx Bytes Received bytes.

TTL Time to live. Time period during which a session or connection is active.

NAT'ed IP IP address after the Network Address Translation (NAT) process.

NAT'ed Port Port number after the NAT process.

Table 50: Parameters on the Traffic Flows page
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Parameter Description

Direction Direction of the communication, indication whether it is incoming or outgoing.

Outgoing: LAN to WAN

Incoming: WAN to LAN

State Current state of a connection. The following connection states are valid only if the
protocol is TCP.

l SYN_SENT

l SYN_RECV

l ESTABLISHED

l FIN_WAIT

l CLOSE_WAIT

l LAST_ACK

l TIME_WAIT

l CLOSE

Protocol Name of the protocol, such as TCP, UDP, ICMP, or any.

Table 50: Parameters on the Traffic Flows page

Certificate
To secure the communication between an NSE device and the VPN clients, you can encrypt the communication.
To apply the encryption certificate, navigate to NSE > Certificate, upload the certificate and the key files, and
then click Apply Certificate.

Note: Only certificates with ".der" and ".pem" file extensions are accepted.

Figure 141 The Certificate page



Wireless LAN Dashboards

Wi-Fi Monitoring
The Wi-Fi Monitoring pages include the following:

l Dashboard

l Clients

l Details

l Mesh Peers

l Wireless LAN Dashboards

Dashboard
The cnPilot Dashboard displays Stacked Clients by Radio, Stacked Clients by Band, Clients by Radio, Clients by
Band, Details, Status, Throughput, Top Active Alarms, Top Clients by Usage, Top Clients by Session, Top
WLANs by Clients, and Top WLANs by Throughput.
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Figure 142 Device > Dashboard

Clients
The Clients tab displays the details of all the Wireless and Wired clients.

The following parameters are displayed for Wireless clients for cnPilot Home (R-Series):

l Actions

l SSID

l Band

l Download

l Host Name

l Edit Name

l IP Address

l MAC

l Managed Account



l Manufacturer

l RSSI

l Upload

Figure 143 cnPilot Home: Device > Clients > Wireless Clients

The following parameters are displayed for Wired Clients for cnPilot Home (R-Series):

NOTE:

The historical clients are available for 24 Hours and 7 Days for cnMaestro X users.

Figure 144 cnPilot Home (R-Series): Device > Wired Clients

l Actions

l Edit Name

l Address Type

l Expires

l Interface

l IP Address

l MAC Address

l Name

l Status

The following parameters are displayed for cnPilot E-Series Wireless Clients:

l Actions

l AP

l Auth Status

l Authentication Type

l Band

l Capability

l Client Type

l Download

l Download Quota

l Download Quota Balance
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l Guest Access Type

l Host Name

l IP Address

l Last Duration

l Last seen

l MAC

l Managed Account

l Manufacturer

l OS

l Portal Mode

l Radio

l Radio ID

l Radio Mode

l RSSI

l Session Expiry

l SNR

l SSID

l Total Quota

l Total Quota Balance

l Upload

l Upload Quota

l Upload Quota Balance

l User

l VLAN-ID

Figure 145 Enterprise Wi-Fi: Device Dashboard > Wireless Clients

The following parameters are displayed for Wired clients for E-Series:

l Auth Status

l Client Type

l Download

l Download Quota

l Download Quota Balance



l Guest Access Type

l Host Name

l IP Address

l Last Duration

l MAC

l Manufacturer

l OS

l Portal Mode

l Total Quota

l Total Quota Balance

l Upload

l Upload Quota

l Upload Quota Balance

l VLAN-ID

NOTE:

The historical clients are available for 24 Hours and 7 Days for cnMaestro X users in System/
Network/ Site and Device level.

Figure 146 Enterprise Wi-Fi: Device Wired Clients

Figure 147 Enterprise Wi-Fi ( Xirrus-Series) Wireless Clients

NOTE:

Wired clients are not supported for Xirrus-Series.
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Client Dashboard
The user can view the applications used by client when the Application Visibility option is enabled as shown
below.

The Client Dashboard displays the details of the clients connected to the Wi-Fi device.

NOTE:
l Enable the Application Visibility feature to view Application page. It is supported only for

XE and XV Series devices.
l Dashboard is supported for all cnPilot devices.
l The historical clients are available for 24 Hours and 7 Days for cnMaestro X users.

To view the Dashboard, navigate to Clients > Wireless Clients and click Host Name.

Figure 148 XE and XV Series: Device Dashboard Wireless Client



It navigates to detailed Client Dashboard, refer to Client Dashboard.

Click the piechart to view specific application usage.

Renaming Client Host-names
You can assign friendly host-names for the clients. To edit the host-name of connected wired or wireless client,
follow these steps:

1. Navigate to Clients > Wireless Clients or Wired Clients tab.
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2. Scroll to the right most side of the clients list and click on the Edit icon under the Actions column.

3. In the Edit Client Name pop-up window, enter a friendly name for the client.

4. Click Save.

The new host-name is displayed in all the places such as the Client Dashboards, Audit logs, and Reports.

Details
Details page displays the Overview, Network Info, and Neighbors List.

Overview
Overview page provides the information such as System, RF Statistics(%), Configuration Update, Radio Details,
Software Update, and History.



Network Info
The Details > Network Info section displays following parameters for cnPilot Home (R-Series) router:

l Ethernet Ports

l Rx Bytes

l Rx Error Bytes

l Rx Packets

l Tx Bytes

l Tx Error Bytes

l Tx Packets

l Type

l FXS Ports

l Hook State

l Phone Number

l SIP Account Status

l Type

Figure 149 cnPilot Home: Device > Details > Network Info

The following parameter details are displayed in E-Series:

l Ethernet Ports

l PPPoE

l Routes

l Tunnels

l VLAN Pool
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Figure 150 Enterprise Wi-Fi: Device >Details > Network Info

IPv6 Routes

DNS Servers

The following parameter details are displayed in E-Series:

l Port

l Rx Broadcasts

l Rx Frames

l Rx Frames Oversize

l Rx Frames Undersize

l Rx Frames with Error

l Rx Octets

l Tx Broadcasts

l Tx Frames

l Tx Octets

Figure 151 Enterprise Wi-Fi (Xirrus-Series): Device > Dashboard > Network Info



Figure 152 PTP 650/670/700: Device >Details > Network Info

Neighbors List
The Neighbors List displays the BSSID, SSID, Channel, and SNR details of neighboring 2.4 GHz and 5 GHz radios.

Figure 153 Neighbors List

PTP 820/850 Details
The Details > Overview section displays following tabs for PTP 820/850:

l Overview

l Ethernet

l Security

l Activation Key

Overview
Overview page provides the information such as System, Radio Parameters and Software Version.
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Figure 154 PTP 820/850 : Device > Details > Overview

Ethernet
Ethernet page provides the information RMON.

Figure 155 PTP 820/850 : Device > Details > Ethernet

Security
Security page provides the information of General Parameters, Protocols, Login and Password Management,
User Account, and SNMP V3 Users.



Figure 156 PTP 820/850 : Device > Details > Security

Activation Key
Activation Key provides the information of Feature Name, Feature Description, Feature Usage, Feature Credit,
and Violation.

Figure 157 PTP 820/850 : Device > Details > Activation Key

cnWave 5G Fixed Details

cnWave 5G Fixed BTS
The Details > Overview section displays following tabs for cnWave 5G Fixed BTS device:

l Overview

l Interfaces

l Radios

Overview

Overview page provides the information such as Details, Boot Loader, Boot, and Shutdown.
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Figure 158 cnWave 5G Fixed: Device > Details > Overview

Interfaces

Interface page provides the information such as Interface Configuration, GNSS, Tx/Rx Errors, and Tx/Rx
Counters.

Figure 159 cnWave 5G Fixed BTS: Device > Details > Interfaces

Radios

Radios page provide the details of radios.

Figure 160 cnWave 5G Fixed BTS: Device > Details > Radios

cnWave 5G Fixed CPE
The Details section displays following pages for cnWave 5G Fixed CPE device:



l Overview

l Interfaces

l Radios

Overview

Overview page provides the information such as Details, Radio Details, and Sessions.

Figure 161 cnWave 5G Fixed CPE: Device > Details > Overview

Interfaces

Interface page provides the information such as Ethernet and Wireless.

Figure 162 cnWave 5G Fixed CPE: Device > Details > Interfaces

Radios

Radios page provide the details of radio details.
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Figure 163 cnWave 5G Fixed CPE: Device > Details > Radios

Mesh Peers
The Mesh Peers tab displays information related to mesh such as SNR, RSSI, and Band. This provides insight to
the performance between the Mesh Client and Mesh Base.

Figure 164 Device > Mesh Peers

Roaming History for Mesh Peers
To view the Information and Roaming History, perform the following:

In the Mesh Peers tab, click the Host Name.

A detailed Information and Roaming History window pops up.



Figure 165 Mesh Peers > Host Name > Information

Figure 166 Mesh Peers > Host Name > Roaming History
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Site Dashboard
The Site Dashboard provides the overview of site related parameters and devices.

The Site Dashboard displays the following graphics:

l AP Types

l Channel Distribution by Band



l Clients by Performance by Band (Enterprise Wi-Fi)

l Clients by SNR by Band (Enterprise Wi-Fi)

l Connected 6E Client Capability

l Radio Distribution by Band

l Stacked Clients by Band

l Throughput

l Throughput Graph

l Top Wi-Fi APs by Throughput

l Wi-Fi Devices Availability (Total and Offline)

l Wireless Clients Graph

l WLAN Distribution by Band

AP Types

Stacked Clients by Band

Channel Distribution by Band
Channel distribution displays usage of channels in 2.4 GHz, 5 GHz and 6 GHz. This helps in planning and
implementing WLANs within a high-density environment. It displays the usage details for last 5 minutes.

282 | Wireless LAN Dashboards Cambium cnMaestro Cloud 5.0.1 | User Guide



283 | Wireless LAN Dashboards Cambium cnMaestro Cloud 5.0.1 | User Guide

Clients Performance by Band (Enterprise Wi-Fi)
Clients performance details is displayed for last 5 minutes.

Clients SNR by Band (Enterprise Wi-Fi)

Connected 6E Client Capability
The Connected 6E Client Capability widget presents a point-in-time view of Wi-Fi 6E Clients associating to non-
6E radios. These Clients may experience better service if SDR radios are upgraded from 5 GHz to 6 GHz. A high
percentage of 6E Capable Clients connecting to non-6E radios is a signal to upgrade radios to 6 GHz. The
Connected 6E Client Capability widget is represented using different colors and corresponding percentage
values as described below:

l Non 6E Clients: represents non 6E clients connected across the devices at the Site level.

l 6E Clients on 6 GHz Radios: represents 6E clients connected across the devices at the Site level.

l 6E Clients on non 6 GHz Radios: represents 6E clients connected across the devices on non 6 GHz radios at
the Site level.

NOTE:

For best results, deploy a few radios in 6G mode in high traffic areas.



Figure 167 Connected 6E Client Capability

Clicking next to clients number navigates to Wireless Clients page.

Client Capability History
The Client Capability History graphic displays the highest detected Wi-Fi protocol for Clients active at a Site on
weekly basis. Wi-Fi 6E devices are grouped into a single 6E category. A large number of 6E Capable Clients are
a signal to expand infrastructure to include 6 GHz radios. If the period of evaluation extends more than a few
weeks, the bar chart converts to a line chart.

Figure 168 Clients History in line chart

Figure 169 Clients History in bar chart
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Radio Distribution by Band

WLAN Distribution by Band

RF Quality
Provides an indication of the current RF Quality across the Site.

Radio RF Quality Index is an indication of wireless clients and or MESH clients' RF link as seen by the access
point radio (AP). It is the average of all the wireless clients and or mesh clients SNR.

l If aggregated SNR is more than 45: RF Quality Index is marked as Excellent

l If aggregated SNR is more than or equal to 35 and below 45: RF Quality Index is marked as Good

l If aggregated SNR is more than or equal to 25 and below 35: RF Quality Index is marked as Average

l If aggregated SNR is less than 25: RF Quality Index is marked as poor

Throughput
Displays aggregated throughput for all the clients.



Throughput Graph
Throughput graph displays client traffic for the last week.

Top Wi-Fi APs by Throughput

Wi-Fi Devices Availability (Total and Offline)
Displays total number of Access Points in the Site and the devices that are Offline.

Top Clients by Session
Displays the top clients by session and the respective details.

Top Clients by Usage
Displays the top clients by usage and the respective details.
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Wireless Clients Graph
Wireless clients graph displays clients that are connected in Radio 1 (2.4 GHz),Radio 2 (5 GHz), and Radio 3 (6
GHz).

Floor Plan
A Floor Plan is used to view APs, device status, connected clients, and transmit power. This is done by creating
the floor plan and adding devices. You can upload a floor plan for each floor based on the selected environment
type.

To create a floor plan, perform the following steps:

1. Navigate to System > Network > Enterprise Site > Floor Plan.

Floor Plan can be uploaded when a Site is created.

2. Click Add New Floor.

The Add New Floor window appears.

3. Enter the parameters for a new floor plan.



Field Description

Name Name of the floor.

Level Level of the floor.

Environment Type Floor type such as the following:

l Apartment
l Hospital
l Hotel
l Office (Cubicle)
l Office (Walled)
l Outdoors
l School
l University
l Warehouse

Adjustment Device adjustment in dB.

Height Height of the ceiling in meters or feet.

Width Width of the floor in meters or feet.

Length Length of the floor in meters or feet.

Table 51: Fields in Floor Plan

NOTE:

Environment Type, Adjustment, and Height are currently unused by cnMaestro. They will
become important when RF Heat Maps are added in a later release.

4. Click Select File and browse the required floor plan for uploading.

NOTE:
l The minimum size of a floor plan is 1024 X 800 pixels.
l The maximum supported file size is 5 MB.
l The supported file formats are JPEG, JPG, PNG, and GIF.

A preview of the uploaded floor plan is shown below:
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Figure 170 Preview of Floor Plan

5. Click Add.

A successful message is displayed, as shown below:

The Zoom control lets you to zoom in and out of the floor plan.

NOTE:

l Only cnMaestro X users can upload more than one floor plan.

l You cannot duplicate the floor level for other floor plans.

l If the devices are in a default location and upgraded to 3.1.1, the devices are moved to
the Unmapped Devices option.

The right pane of the Floor Plan window provides details of uploaded floor plans, such as Floor View, Map
Opacity, Radio Details, Filters, and the devices in the floor plan.



Figure 171 Configure Floor Plan
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Field Description

Floors Indicates the floor level. The following actions are available:

1. Click Add to add new floor level.

Drag and drop the selected devices from the right pane to the required floor level. If
multiple floor levels are available, then select required floor level from the drop-down.

2. Select the floor level and click Edit( ) icon to edit the uploaded floor level.

3. Click the Delete ( ) icon to delete a uploaded floor level.

4. Click on the info icon, next to floor level uploaded, to view the floor details.

5. In the Devices on this floor drop-down, you can view the following options:

l Unmapped Devices: Devices not mapped to the floor plan.
l Devices on this floor: Devices available on the floor plan.
l Devices on other floors: Displays devices on the other floors.

6. Click Remove ( ) icon to remove device from the floor level.

Floor View Configure device presentation. The following options are available:

l Map Opacity: Increase or decrease the opacity for the better visibility of uploaded
floor plan.

l Device Names: Toggle to view device names on the floor plan.
l Radio Details: View the radio details such as Client Count, Channel, and Power.
l Band: Select the desired band 2.4 GHz, 5 GHz, and 6 GHz (radio frequency).

Filter Filter devices by Device Status, Channel, and Power.

Devices View and edit the device details. The following actions are available:

1. Select the device on the floor plan or type the device name in the search field.

2. Select the eye icon ( ) to Show or Hide the device on the floor plan.

3. Click on the device name to view device details, as shown below:

Table 52: Fields to configure floor plan page



Field Description

4. Click ellipsis ( ) icon next to the device name, to navigate to the device
homepage.

5. Click Edit on the top right corner and select the device in the current floor.

Table 52: Fields to configure floor plan page
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Field Description

Edit the AP Placement, AP Facing and Rotation options.

6. Click Update and Save.

7. Click Remove ( ) icon to remove device from the floor plan.

8. Click Save.

Table 52: Fields to configure floor plan page

Fiber OLT and ONU

The Fiber Optical Line Terminal (OLT) from Cambium Networks is a Passive Optical Network (PON) device that
connects to a core switch using either an Ethernet cable or a fiber cable. It supports Gigabit Passive Optical
Network (GPON), 10 Gigabit Symmetrical PON (XGS-PON), and combo-PON (GPON co-existing with XGS-
PON) Optical Defined Networking (ODN) access. The Fiber OLT is available in 8 and 16 ports, including All-in-
One (AIO) PON interfaces, allowing simultaneous support for multiple PON technologies. It is used for network
development with GPON and User Network Interface (UNI) ports. The high-performance access design of the
Fiber OLT focuses on Software-Defined Networking (SDN) deployments, providing open interfaces to all
control management functions for seamless integration with SDN environments.



cnMaestro provides management, configuration, and monitoring services for Fiber OLT. It includes the
following pages for Fiber OLT and ONU, providing comprehensive tools for efficient management and
optimization:

l Dashboard

l Notifications

l Configuration

l Details

l Performance

l ONU

l Ports

l Software Update

Dashboard
Displays the monitoring information of the OLT.

Figure 172 Fiber OLT dashboard

Dashboard has the following elements:

l Alarms

l Port Status

l ONU by Signal Level

l ONU by Signal Level per Port

l ONUs

l PON Downlink Utilization

l PON Downlink throughput

l PON Uplink throughput
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l Ethernet Downlink throughput

l Ethernet Uplink throughput

Alarms
Displays the critical, major, and minor alarms. Figure 173 shows the status of the alarms.

Figure 173 Alarms

To view the detailed information, click on the respective alarm count.

Port Status
Displays the connection status for Network-to-Network Interface (NNI) or Ethernet (uplink) ports and PON
ports (downlink). Small Form-Factor Pluggable (SFP) devices are connected to the Ethernet ports, and ONUs
are connected to the PON ports. The uplink NNI has four ports. Port 1 and port 2 support 100 Gbps speed. Port 3
and port 4 support 10 Gbps speed. There are 16 downlink PON ports, with each port supporting both GPON and
XGS-PON.



Figure 174 Port status

ONU by Signal Level
Displays the signal level received by the ONU.

Figure 175 ONU by signal level graph

ONU by Signal Level per Port
Displays the number of ONU connected and their corresponding power levels.

Figure 176 ONU by signal level per port

ONUs
Displays the number of ONUs connected to the OLT.

296 | Fiber OLT and ONU Cambium cnMaestro Cloud 5.0.1 | User Guide



297 | Fiber OLT and ONU Cambium cnMaestro Cloud 5.0.1 | User Guide

Figure 177 ONU

PON Downlink Utilization
Displays the utilization of GPON and XGS-PON.

Figure 178 PON Downlink Utilization

PON Downlink Throughput
PON Downlink throughput displays the downlink throughput information of GPON and XGS-PON.

Figure 179 PON Downlink Throughput

PON Uplink Throughput
Displays the uplink throughput information of GPON and XGS-PON.



Figure 180 PON Uplink Throughput

Ethernet Downlink Throughput
Displays the Ethernet Downlink information of GPON and XGS-PON.

Figure 181 Ethernet Downlink throughput

Ethernet Uplink Throughput
Displays the Ethernet Uplink information of GPON and XGS-PON.

Figure 182 Ethernet Uplink Throughput

Notifications
Displays the alarm information of the OLT.
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Figure 183 Notifications

Table 53: Parameters on the Notifications page

Parameter Description

Severity Severity level of the alarm. This parameter supports the following severity levels:

l Critical

l Major

l Minor

Source Name of the OLT.

Mode Type of the device. The following device types are supported:

l OLT

l ONU

Source MAC MAC address of the OLT.

IPv4 address IPv4 address of the OLT.

Name Name of the ONU.

Message A brief description of the alarm message.

Duration Duration of the alarm.

Status Status of the alarm. The following status values are supported:

l Active

l Inactive

Raised Time Time when the alarm was raised.

Configuration
Users can configure the OLT using the Configuration tab.



Figure 184 Configuration

Table 54: Parameters on the Configuration page

Parameter Description

Managed Account Name of the site where OLT is configured.

Name Name of the OLT.

Network Name of the network where OLT is configured.

Site Name of the site.

Description A brief description of the OLT.

Latitude Latitude of the OLT.

Longitude Longitude of the OLT.

Serial Number Serial Number (MSN) of the OLT.

MAC Address MAC Address of the OLT.

IPv4 Address IPv4 Address of the OLT.

Details
The Details page displays general configuration and runtime information of the OLT.
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Figure 185 Details

Table 55: Parameters on the Details page

Parameter Description

System

Device Name Name of the device.

Device Type Type of the device. This parameter supports the following device types:

l OLT
l ONU

System Uptime Date and time configured for the device.

Session Time Duration of the session.

Coordinates Latitude and longitude.

Software Version The current software version used.

DA Version Version of the device agent (DA).

Onboard Date Onboard date of the device.

Description A brief user-defined description of the onboarded device.

Software Update

Active Software Version Version of the active software.

Inactive Software Version Version of the inactive software.

History History of software version updates.

Network

MAC Address MAC Address of the device.



Parameter Description

IP Address IP Address of the device.

Subnet Mask Subnet Mask of the device.

Gateway Gateway address of the device.

Primary DNS Server IP address of the primary DNS server.

Secondary DNS Server IP address of the secondary DNS server.

Performance
Displays the performance graphs for ONU, CPU, memory, and temperature of the OLT and ONU.

Figure 186 Performance

ONU
Displays the number of ONUs connected to the OLT and their information.

Figure 187 ONU
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Table 56: Parameters on the ONU page

Parameter Description

Name Name of the OLT.

MAC Address MAC address of the OLT.

Status Status of the OLT.

OLT Port Port number of the OLT to which ONU is connected.

Connection Time Time during which ONU is connected to OLT.

ONU ID ID of the ONU.

OLT Rx Power Receive power of the OLT.

Ports
Displays the port details. Fiber OLT has 8 ports and 16 ports

Figure 188 Ports



Figure 189 Ports utilization

To filter selected ports, perform the following steps:

1. Click Apply Filter(s), type the port name.

2. Select the type of the OLT.

3. Select the status of the OLT and click Apply Filter(s).

Table 57: Parameters on the Ports page

Parameter Description

Port Port number of the OLT.

Type Type of the PON.

Status Status of the ONU.

Online ONU Number of ONUs online.

Temperature Temperature of the ONU.

Rx Power Receive power of the ONU.

PON Downlink Utilization Utilization percentage of the PON Downlink.
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Software Update
Users can upgrade the OLT firmware using the Software Update page. To upgrade the software, perform the
following steps:

1. Download the latest firmware from Cambium Networks Support Site.

2. Select the status of the OLT and click Apply Filter(s).

3. Click Add Software Job to upload the latest Firmware file.

4. Click View Update Jobs to view the history of the software updates.

Inventory

The Inventory page displays a list of devices under the selected Node. It presents health and maintenance
information in a tabular view that allows for sorting and filtering. When selected for a single device, it presents a
detailed customized page of that device.

Navigate to the Inventory tab on the left pane.

Figure 190 Inventory

Inventory Export
The inventory table can be exported in either CSV or PDF format. The values exported will match those in the
selected table columns. You can customize the health and maintenance views to add or delete columns.

https://support.cambiumnetworks.com/


Bulk Delete
The Bulk Delete option is available in the inventory page of System/Tower/Network/Site.

Figure 191 Bulk Delete

To delete devices using bulk delete, perform the following steps:

1. Navigate to Inventory page of System/Network/Tower/Site.

2. Select one or multiple devices.

3. Click Bulk Delete.

NOTE:

In Wi-Fi view, Bulk Delete can also delete devices waiting for Approval.

Bulk Reboot
The Bulk Reboot option is available on the inventory page of Tower/Network/Site. When the devices are
rebooted using Bulk Reboot, all the Network/Tower/Site Dashboards, Graphs, Clients, Reports, and Mesh Peers
will be updated accordingly.

Figure 192 Bulk Reboot

To reboot devices using bulk reboot, perform the following steps:

1. Navigate to Inventory page of Network/Tower/Site.

2. Select one or multiple devices.

3. Click Actions and choose Reboot Now.
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Schedule Reboot
Schedule a reboot of the device(s) by selecting Schedule Reboot from Actions drop-down.

To reboot devices using schedule reboot, perform the following steps:

1. Navigate to Inventory page of Network/Tower/Site.

2. Select one or multiple devices.

3. Click Actions and choose Schedule Reboot.

4. Enter Date and Time.

5. Click Schedule.

After creating a scheduled reboot job, can view the status in the Administration > Jobs > Actions.

Import Device Configuration
Import device(s) configuration is available from the inventory page at System/Network/Managed
Account/ePMP or PMP AP device levels.

NOTE:

The Import Device configuration is supported only for the Access and Backhaul account and
is applicable only on ePMP/PMP AP and SM devices.

The following parameters are supported for ePMP/PMP AP in the CSV file:

l Azhimuth

l Beamwidth

l Elevation

l Height

l Latitude

l Longitude

The following parameters are supported for ePMP/PMP SM is in the CSV file:



l Latitude

l Longitude

Figure 193 Import Device Configuration

Sample Configuration File

Sample Configuration File (60 GHz cnWave)
Figure 194 Sample Configuration file: 60 GHz cnWave

While importing the file, it automatically validates the data as shown below:

If any invalid fields are found, an error message pops up:

308 | Inventory Cambium cnMaestro Cloud 5.0.1 | User Guide



309 | Inventory Cambium cnMaestro Cloud 5.0.1 | User Guide

Uploading a Configuration File
To upload a configuration file (CSV) using the format specified in the sample template, perform the following
steps:

1. Click Download Sample Template or prepare a sheet in CSV file format with necessary column details.

2. Upload a configuration file (CSV) using the format specified in the sample template.

NOTE:

You must know the MAC address of the device to push the configuration.

3. Click Import.

Figure 195 Uploading Configuration file

4. A configuration job will be created.

5. You can view the completed status of the configuration import in the configuration update page.

The following table provides details on different errors that might occur while importing a CSV file:



Error Description

{Count of Devices}
Device(s) with
invalid MAC

This error is displayed if the uploaded CSV file contains an invalid MAC Address.

{Count of Devices}
Device(s) skipped
due to invalid data

This error is displayed if the uploaded CSV file contains invalid Data or data not
relevant for Latitude, Longitude, Azimuth, Height, and Elevation.

Devices were not
found for supplied
MAC Address

This error message is displayed if the devices were not found with correct MAC
address in the CSV file.

Info: 1 Devices(s)
accepted without
latitude/longitude
values

This error is displayed when the latitude and longitude values are tried to push on to
ePMP AP or PMP AP which are under a Tower.

Table 58: Importing Error
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Error Description

Table 58: Importing Error

Reports

There are two types of reports: Data Reports and Graphical Reports. Data Reports generate a CSV file and are
meant to be read by Excel, Power BI, or a custom application. Graphical Reports generate a PDF file meant for
human consumption.

The Scheduled tab displays reports that have not run. This includes reports executed periodically and those
meant to run a single time. The Completed tab lists all reports that have finished and are available for download.

Scheduled Reports include the Scheduled, Terminated, and Timeout status in the Status column. Completed
Reports include the Completed and Failed status is the Status column. Data reports are displayed only in a
tabular format while graphical reports include charts and graphs.

To view all scheduled data and graphical reports, navigate to System > Monitor and Manage > Reports X >
Scheduled.

To download completed reports, navigate System > Monitor and Manage > Reports X > Completed.



NOTE:

l You can have 50 reports in the Scheduled tab and any number in the Completed tab. Only 50
reports can be generated in parallel in a cnMaestro account.

l The completed reports are available for download for 30 days in the Cloud and 7 days in On-
Premises.

l While generating Alarm History, Events, Performance, Clients, and Guest Access reports, there
is a delay of up to 20-30 minutes for the recent entries to be available in the report.

Data Reports
Data Reports generate a CSV document that can be viewed in Excel, Power BI or other data analysis tools.

This section details how to schedule and generate different types of data reports in cnMaestro.

l Device Report

l Performance Report

l Active Alarms Report

l Alarms History Report

l Events Report

l Clients Report

l Guest Access Login Events

NOTE:

cnMaestro supports 14 months of historical data for devices:

l cnPilot Home (R-Series)

l Enterprise devices (Enterprise Wi-Fi and cnMatrix)

l IIoT devices

cnMaestro supports 26 months of historical data for devices:

l Fixed Wireless

Device Report
Device Reports are generated as CSV files and include all devices under the selected tree node.

To generate Device Reports, perform the following steps:
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1. Navigate to Report X > Scheduled tab within System, MSP, Site, Network, or Tower nodes in the hierarchical
tree.

2. Click Add New Data Report. The following window is displayed.

3. Enter a Name and Description for the report.

4. Enter email addresses (maximum of 5) in the Recipients field to send reports.

5. Select the Report Type as Devices..

6. Select the Device Type such as cnMatrix, cnPilot Home, and cnRanger.

7. Select the data parameters to include in the report.

8. Select the Schedule such as Now, Daily, Weekly, or Monthly.

9. Click Add. The report is added to the Scheduled Reports page.

If Device Type is All, then Basic data export parameters are available, rather than parameters specific to a
device type.

The device data parameters exported for the following devices are listed below:

l 60 GHz cnWave

l cnMatrix

l cnPilot Home (R-Series)

l cnRanger

l cnReach

l cnReach XIO

l cnVision



l cnWave 5G Fixed

l Enterprise Wi-Fi

l ePMP

l Machfu

l PMP

l PTP 650/670/700

l PTP 820/850

l RV22 Home Mesh

If 60 GHz cnWave device is selected as Device Type, then the following parameter sections are available:

l Basic

l Ethernet

l GPS

l Mode (CN or DN)

l Radio

Figure 196 Device Report: 60 GHz cnWave

If cnMatrix is selected as the Device Type, then Basic data export parameters will be exported.

Figure 197 Device Report: cnMatrix

If cnPilot Home (R-Series) is selected as the Device Type, then the following parameter sections are available:

l Basic

l Network

l Radio

l Location
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Figure 198 Device Report: cnPilot Home (R-Series)

If cnRanger is selected as the Device Type, then Basic, Network, Radio, Location, and CBRS parameter sections
can be exported.

Figure 199 Device Report: cnRanger

If cnReach is selected as the Device Type, then the following sections are available:

l Basic

l Network

l Radio

Figure 200 Device Report: cnReach

If cnReach XIO is selected as the Device Type, then the following sections are available:

l Basic

l Network

l Radio



Figure 201 Device Report: cnReach XIO

If cnVision is selected as the Device Type, then the following sections are available:

l Basic

l Location

l Network

l Radio

l Mode

Figure 202 Device Report: cnVision

If cnWave 5G Fixed device is selected as Device Type, choose the type of Mode (BTS or CPE) then the following
sections are available:

l Basic

l Location

l Radio

Figure 203 Device Report: cnWave 5G Fixed

If Enterprise Wi-Fi is selected as the Device Type, then the following sections are available:

l Basic

l Location

l Network
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l Radio

Figure 204 Device Report: Enterprise(Wi-Fi)

If ePMP is selected as the Device Type then the following sections are available:

l Basic

l Location

l Mode(s) (AP or SM)

l Network

l Radio

Figure 205 Device Report: ePMP

If Machfu is selected as the Device Type, then the following sections are available:

l Basic

l Cell

l Ethernet

l GPS

l VPN

l Wi-Fi Access Point

l Wi-Fi Client



Figure 206 Device Report: Machfu

If PMP is selected as the Device Type, then the following sections are available:

l Basic

l CBRS

l Location

l Mode(s) (AP or SM)

l Network

l Radio

Figure 207 Device Report: PMP

If PTP 650/670/700 is selected as the Device Type, then the following sections are available:

l Basic

l Location

l Network

l Radio
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Figure 208 Device Report: PTP 650/670/700

If PTP 820/850 is selected as the Device Type, then the following sections are available:

l Basic

l Radio

Figure 209 Device Report: PTP 820/850

The following sections are available for RV22 Home Mesh routers:

l Basic

l Network

l Radio

l Location



Figure 210 Device Report: RV22 Home Mesh

NOTE:

Reports are available for each of the following hierarchical nodes in the tree:

l System

l Managed Account

l Network

l Tower

l Site

l AP Group

Performance Report
The Performance Report generates device time-series performance data as a comma-separated value (CSV)
file. All devices of selected type under the tree node will be included in the export.

NOTE:
l You need to select the parameters.
l This feature may generate a large file if many devices are selected.

To generate Performance reports, perform the following steps:

1. Navigate to Report X > Scheduled tab.

2. Click Add New Data Report.

3. Enter a Name and Description for the report.

4. Enter email addresses (maximum of 5) in the Recipients field to send reports.
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5. Select Type as Performance.

6. Select the Device Type.

7. Select the data parameters to include in the report.

8. Select the following options:

l Schedule type (Now, Daily, Weekly, or Monthly)

l Time Range (Last Day, Last Week, Last Month, Custom Time Range)

l Period ( 5 Minutes, 1 Hour, or 1 Day)

9. Click Add . The report is added to the Scheduled Reports page.

60 GHz cnWave Performance Report

Figure 211 Performance Report: 60 GHz cnWave (Links Type)



Figure 212 Performance Report: 60 GHz cnWave (Node Type)

cnMatrix Performance Report

Figure 213 Performance Report: cnMatrix

cnPilot Home (R-Series) Performance Report

Figure 214 Performance Report: cnPilot Home (R-Series)

cnRanger Performance Report

Figure 215 Performance Report: cnRanger

cnReach Performance Report

Figure 216 Performance Report: cnReach

cnVision Performance Report

Figure 217 Performance Report: cnVision
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cnWave 5G Fixed Performance Report

Figure 218 Performance Report: cnWave 5G Fixed

Enterprise Wi-Fi

Figure 219 Performance Report: Enterprise Wi-Fi

ePMP Performance Report

Figure 220 Performance Report: ePMP

Machfu Performance Report

Figure 221 Performance Report: Machfu

PMP Performance Report

Figure 222 Performance Report: PMP

The modulation mappings for the PMP device are as follows:



Figure 223 Mapping PMP

Value Description

-1 N/A

0 1X MIMO-A

1 2X MIMO-A

2 3X MIMO-A

3 4X MIMO-A

4 2X MIMO-B

5 3X MIMO-B

6 4X MIMO-B

7 5X MIMO-B

8 6X MIMO-B

9 7X MIMO-B

10 8X MIMO-B

Figure 224 PMP 450m

Value Description

0 N/A

1 1X MIMO-A

2 2X MIMO-A

3 3X MIMO-A

4 4X MIMO-A

Figure 225 PMP 450m

Value Description

0 N/A

2 2X MIMO-B

3 3X MIMO-B
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Value Description

4 4X MIMO-B

5 5X MIMO-B

6 6X MIMO-B

7 7X MIMO-B

8 8X MIMO-B

Figure 226 PMP 430

Value Description

-1 N/A

0 1X SISO

1 2X SISO

2 3X SISO

Figure 227 PMP 450v

Value Description

0 N/A

2 2X MIMO-B

3 3X MIMO-B

4 4X MIMO-B

5 5X MIMO-B

6 6X MIMO-B

7 7X MIMO-B

8 8X MIMO-B

PTP 650/670/700 Performance Report

Figure 228 Performance Report: PTP 650/670/700



PTP 820/850 Performance Report

Figure 229 Performance Report: PTP 820/850

RV22 Home Mesh Performance Report

Figure 230 Performance Report: RV22 Home Mesh

Active Alarms Report
The Active Alarms Report will export the data for the active alarms at the report generation time. Active alarms
for all devices under the tree node will be included in the export.

To generate the Active Alarms reports, perform the following steps:

1. Navigate to Reports X > Scheduled tab.

2. Enter a Name and Description for the report.

3. Enter email addresses (maximum of 5) in the Recipients field to send reports.

4. Select the Report Type as Active Alarms.

5. Select data parameters to include in the report.

6. Select the following options:

l Schedule type (Now, Daily, Weekly, or Monthly)

7. Click Add. The report gets added to the Scheduled Reports page.
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Alarms History Report
The Alarms History Report will generate data for all alarms that were active at any time within the time period.
Alarms for all devices under the tree node selected will be included.

To generate the Alarms History reports, perform the following steps:

1. Navigate to Reports X > Scheduled tab.

2. Enter a Name and Description for the report.

3. Enter email addresses (maximum of 5) in the Recipients field to send reports.

4. Select the Report Type as Alarms History.

5. Select data parameters to include in the report.

6. Select the following options:

l Schedule type (Now, Daily, Weekly, or Monthly)

l Time Range (Last Day, Last Week, Last Month, Custom Time Range)

7. Click Add . The report gets added to the Scheduled Reports page.

8. Click View Jobs to view the reports.



Events Report
The Events Report is generated for the events raised during the time period. Events for devices under the tree
node will be included in the export.

To generate the Events reports, perform the following steps:

1. Navigate to Reports X > Scheduled tab.

2. Enter a Name and Description for the report.

3. Enter email addresses (maximum of 5) in the Recipients field to send reports.

4. Select the Report Type as Events.

5. Select data parameters to include in the report.

6. Select the following options:

l Schedule type (Now, Daily, Weekly, or Monthly)

l Time Range (Last Day, Last Week, Last Month, Custom Time Range)

7. Click Add. The report gets added to the Scheduled Reports page.

328 | Reports Cambium cnMaestro Cloud 5.0.1 | User Guide



329 | Reports Cambium cnMaestro Cloud 5.0.1 | User Guide

Clients Report
The clients report generates data for Wi-Fi clients.

NOTE:

Client Data is available for the last day, last 24 hours, and last week.

To generate the clients reports, perform the following steps:

1. Navigate to Reports X > Scheduled tab.

2. Enter a Name and Description for the report.

3. Enter email addresses (maximum of 5) in the Recipients field to send reports.

4. Select the Report Type as Clients.

5. Select data parameters to include in the report.

6. Select the following options:

l Schedule type (Now, Daily, or Weekly)

l Time Range (Last Day, Last Week. or Custom Range)

7. Click Add . The report gets added to the Scheduled Reports page.



Figure 231 Clients Report

Guest Access Login Events
The Guest Access Login Events represent Wi-Fi Guest Access Logins.

Guest access report can be generated only at system level.

To generate the Guest Access Login Events report, perform the following steps:

1. Navigate to Report X > Scheduled tab.

2. Enter a Name and Description for the report.

3. Enter email addresses (maximum of 5) in the Recipients field to send reports.

4. Select the Report Type as Guest Access Login Events.

5. Select the Managed Account, if applicable.

6. Select the Guest Access Portal, if applicable.

7. Select data parameters to include in the report.

8. Select the following options:

l Schedule type (Now, Daily, or Weekly)

l Time Range (Last Day, Last Week).

9. Click Add. The report gets added to the Scheduled Reports page.
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Report Jobs
The report jobs displays the list of scheduled jobs created by different users. To view jobs, navigate to
Administration > Jobs > Reports.

Figure 232 Report Jobs

A scheduled report job displays the following Action buttons:

l Edit: Visible only for Active Jobs which have not yet run. You can reschedule a job with this option.

l Terminate: Stop the Active Jobs.

l Show History: Display the detailed status of the generated reports and the file transfer status.

l Delete: Delete Active and Completed Jobs.



l Instant Download: Download the latest report without checking the Show History.

Graphical Reports
The data reports contain a lot of data that need to be represented graphically so that you can quickly
summarize and get a better visualization. In such cases, you can use the Graphical Reports. Graphical Reports
can be created by first building a template of the report you want to view, optionally with your own branding
such as your logo and brand name. Then, apply the template at a level in the hierarchical tree in cnMaestro such
managed service, system, or site. Each graphical report can consist of multiple pages called widgets. The
following widgets are available with applicable type of graphs and charts based on context. Each widget has
both a graphical and tabular representation of the data. The output is a PDF file.

l AnalyticsXA: Top APs Reporting Client Disconnections—Top APs by number of client disconnections.

l AnalyticsXA: Top Client Connection Failures—Top client connection failure types by number of failures

l 6E Clients by Radio— 6E Clients on 6GHz Radios Vs 6E Clients on Non 6GHz Radios.

l Client Count by Manufacturers—Top manufacturers by number of clients.

l Client Capability Trend—Client Capability Trend over time.

l Client Count over Time—Connected clients by band over time.

l Top Applications by Usage—Top applications by data usage.

l Top Category by Usage—Top application categories by data usage.

l Client Count by Band—Client count by band.

l Client Count by Types—Top client types by number of clients

l Peak and Unique Clients—Total unique clients and peak time number of unique clients.

l Top APs by Unique Clients—Top APs by number of unique clients.

l Client Traffic over Time—Client uplink and downlink traffic over time.

The standard process for graphical report generation includes the following:

1. Create a template using the widgets listed above.

2. Select a level of the hierarchy on which to apply the template.

3. Schedule the report to either execute one-time or periodically.

NOTE:

l Graphical reports are only supported for Wi-Fi Access Points and Clients, and they can only
be applied at the Managed Service, System, and Site levels.

l If there is no data for the specific period, then a blank page is displayed in PDF.

l The title page of the PDF has the date and time zone of the user who scheduled the report.

The Scheduled tab presents reports pending execution, and the Completed tab provides access to reports that
have finished running. The already generated reports are listed as Completed Reports (includes Success and
Failed status in the status column) and those that are not yet generated but scheduled for a future time are
listed as Scheduled reports (includes and Future and Terminated status in the status column).
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Refer to the following topics to create templates and schedule reports:

l Create Graphical Report Templates

l Generate Reports Based on Templates

Create Graphical Report Templates
To create a graphical report template, complete the following steps:

1. Navigate to Configuration > Graphical Report Template X page.

2. Click Add New and complete the following details:

l Name—Enter a meaningful name for the template.

l Scope—Select the scope of the report such as Systemor Site from the drop-down list.

l Title—Enter the title that you want to see in the Title page of the generated PDF document.

l Description—Optionally, describe the report in details.



3. Optionally, brand the report as per your requirement.

l Logo—To select an existing logo, click the down arrow and then click Select. You can also add a new logo
by clicking Add New.

l Brand Image—To select an existing brand image, click the down arrow, and then click Select. You can
also add a new brand image by clicking Add New.

l Theme—Select a theme for the title page of the report as either Vertical Lines, Brand Box, or Plain.

l Theme Color—Select the Theme Color by clicking the desired colored square.

4. Click Add.

The report template design page is displayed. You can add one or more widgets to the report, one per page.

5. Click Add New in the left pane. The following widgets are available:
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6. Select the check-box for one or more Widgets and click Add. Each page can have only one widget. The
pages can be rearranged by drag and drop in the left pane.



7. For each page, select the page properties in the right pane. They differ based on widget and options that
you have chosen.
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8. You can also select the Table columns for each page.

The following options are available based on the page type:

l Title—Title for the report.

l Description—Detailed information about the report criteria.



l Duration— Time interval. For example, Last Day or Last 7 Days.

l Chart/Graph Style— Type of graph. For example, Horizontal Bar or Pie Chart

l Data Limit—Volume of data to be filtered. For example, Top 5 or Top 10.

l Sort By—Column name in the tabular format. For example, Count, or Total Usage.

9. Click Save.

Generate Reports Based on Templates
To add a new report, follow the steps below:

1. Navigate to Monitor and Manage > System or Site > Reports X > Scheduled tab.

2. Click Add New Graphical Report.
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3. Complete the following details:

l Name—Enter a name for the report.

l Description—Enter a detailed description for the report.

l Template— Select the PDF template from the drop-down list. If there is no template listed, click Add New
to create a new PDF template.

l Recipients — Add email addresses of the recipients or requesters to whom the report is applicable.

l Schedule— Select a schedule to generate the report from the following options:

l Now— Generate the report immediately after you click Add.

l Daily—Generate the report at the following interval:

l Start Date—Select the date.

l Start Time—Select the time.

l End—Stop generating this report:

l After— Enter the number of instances. The maximum is 100 instances.

l By—Select the date when the report generations should be completely stopped.

l Weekly—Generates the report at the following interval.

l Monthly—Generates the report at the following interval.

4. Click Schedule. Adds the report to the list of Scheduled Reports.



Provisioning
The Provisioning chapter includes both Device Software Update and Configuration. It is separated into the
following topics:

l Software Update

l Fixed Wireless Configuration

l Wireless LAN Configuration

l Switch Groups Configuration

l 60 GHz cnWave Configuration

l NSE 3000 Configuration

l Configuring Advanced Features

Software Update

The Software Update tab displays the device update details. This section includes the following:

l Overview

l Create Software Update Job

l Viewing Running Jobs in header

Software Update Overview
The Software Update feature allows users to deploy the latest software images to devices. Software updates
can be started at any level in the Device Tree. Updates are created as Jobs and placed into the Jobs Queue.
When the update is ready to run, it can be started. The process flow of Software Update is shown below:

Figure 233 Software Update Overview

When a Job completes, it is placed in the completed Jobs table. Jobs are available for one week before they are

deleted.
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Create Software Update Job
Device Selection
Navigate the Device Tree to an appropriate level for the devices to be updated. For example, selecting a Fixed
Wireless AP will filter the devices to include the AP and its children.

Device Type
Software Updates are executed on one type of device at a time.

Software Update Dashboard
Once the device type is chosen, the UI displays the most recent software release version for that device type. It
also displays a breakdown of the different software versions currently installed on the devices.

NOTE:

Enterprise Wi-Fi shown below contains device types on the Software Update page:

l Enterprise Wi-Fi (E-Series)

l Enterprise Wi-Fi (XE/XV-Series)

l Enterprise Wi-Fi (Xirrus-Series)

Figure 234 Software Update: Enterprise Wi-Fi

NOTE:

Update both partitions option is available at System/Network/Site/Device levels. It is only
available for the devices that support it.

Perform sequential updates within a site option is available at System/Network/Site level
except the Device level.

If the Update both partition option is enabled/ disabled, the device level of the Software Update will be
displayed as follows:

l Enable: The selected target image will be upgraded in both active and inactive portions of the device.

l Disable: The selected target image will be upgraded in only active portion of the device.



Figure 235 Software Update: Device level

If Perform sequential updates within a site is enabled, the image upgrade will happen only on one device at a
time.

Figure 236 Software Update: cnMatrix

Disable Auto Reboot option disables reboot after applying the new software image. The user must manually
reboot the device to complete the software update.

Figure 237 Software Update: cnRanger
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Figure 238 Software Update: 60 GHz cnWave

Figure 239 Software Update: PTP 700

NOTE:

Ensure that your PTP 45700 devices run software version 04-02 or higher before proceeding
with the upgrade.

Software Update
The software version on the devices can be automatically updated to the preferred version when the device
first contacts cnMaestro.

Enable the automatic update of device software as follows:

1. Navigate to Administration > Jobs > Software Update page.

2. Select the Manual or Auto page for updating the device software feature.

3. Choose the software version depending on the device type.

4. Click Start.



Figure 240 Manual update

NOTE:

A Manual Update can be aborted at any point of time by clicking the Abort.

Figure 241 Auto update

NOTE:

Auto update can't be manually aborted.

You need to download the new image version released from the Support Site. For more details refer to
Managing Device Software Images.

Device Table
Select the devices to upgrade in the Devices Table.

NOTE:
l You can upgrade a device only when status is Up. If you try to upgrade a device when it is

Down, you will receive a message the selected device is down.
l If the device is under the Auto Software Upgrade, the manual software update is not

possible.

The following parameters are visible (though some are only available for certain device types).
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Parameter Description

Current Version The version of the active software image running on the device.

Devices The names of available devices in a system. The list is pre-filtered based upon the
node selected in the Device Tree.

Selected SMs If the AP is selected, the corresponding SMs will also be selected.

Status The status of a particular device in a system. Devices that are not connected cannot
updated.

Table 59: Parameters in Device Table

Retry Software Update
The Retry Software Update option is available in every Software Update tab; it is enabled by default.

Figure 242 Retry Software Update

When you select Schedule to update, the following options are available as shown below:

Figure 243 Retry Software Update: Schedule

If the Software Update Job was Skipped for a device because it was offline, an icon ( ) appears next to the

Active Software version of the device. This indicates the software update for the device will be done with the
Target device version in the Job, whenever it reconnects to cnMaestro.

If the software update job was skipped while upgrading with the same version as the device active version, the
icon will not be displayed, and the device will not update when it reconnects.



NOTE:
The device which undergoes Retry Software Update, does not create a new Job.

Options

Stop Updates on Critical Error

If one of the updates fails, do not start any additional updates and instead pause the update job. All existing,
concurrent updates will be allowed to proceed until completion. The administrator will be able to continue the
update where it left off if desired.

Sector Upgrade Order

The recommended update order for devices within a sector will be pre-configured according to the
recommendations for the device. It can be changed if desired.

NOTE:
Device update occurs sector-by-sector. One sector needs to complete before a second sector
is started.

Parallel Upgrades

Specify how many device upgrades to perform in parallel to complete the upgrade faster. However if the job is
configured to halt on an error, all concurrent sessions will still be allowed to complete.

Upgrade Steps
To upgrade an ePMP (Sectors) device, perform the following steps:

1. Navigate to System/Network/Tower/Device level. and select the device.

2. To update the device, navigate to Manage > Software Update.

3. Select the following ePMP (Sectors) from the Device Type drop-down:

a. 60 GHz cnWave

b. cnMatrix

c. cnPilot Enterprise (ePMP Hotspot)

d. cnPilot Home (R-Series)

e. cnRanger

f. cnReach

g. cnVision

h. cnWave 5G Fixed

i. Enterprise Wi-Fi (E-Series)

j. Enterprise Wi-Fi (XV-Series)

k. ePMP (Sectors)

l. ePMP 1000 Hotspot

m. Machfu

n. NSE

o. PMP (Sectors)

p. PTP 650/670/700
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q. PTP 820/850

4. Select the software image to update from the Version drop-down.

5. Select checkbox for the devices to update.

6. Select Job Options.

7. Click Add Software Job.

Software Update Jobs and Parameters
The Software Update Jobs table lists all currently running, queued, and completed jobs. The jobs can be
triggered immediately, or they can be run later.

( Administration > Jobs > Software Update tab.)

The following table displays the list of parameters in the Software Update Jobs tab:

Parameter Description

Action Use the Start or Delete button to manage the upgrade process. After the upgrade has
started, the Pause button will stop new upgrades from the beginning. If the upgrade
process fails or the upgrade has been paused, you can restart the process by clicking
the Resume button.

Created By The user who has created this job.

Created On Date and time the job is created.

Details Count of devices and date and time the upgrade process is initiated.

ID Identification number of the active job.

Image Type Displays Device for Device Firmware Upgrade.

Occurrence Displays Now and Scheduled depending upon the job options selected during
Software Update Job.

Parallel Number of devices to start in parallel.

Sector Priority For cnVision, ePMP/PMP, the priority of AP/SM to start.

Status Status of update.

Stop on Error Stop the job on an error in any device update.

Target Target software version to upgrade.

By selecting the Show More icon, you can view the following parameters:

Device Device for which the upgrade is initiated.

Message The message that is displayed after the update.

Table 60: Parameters in Software Update Jobs



Parameter Description

Original Version The current software image version of the device.

Result The upgrade status of the device.

Status Status of the device.

Table 60: Parameters in Software Update Jobs

The user can filter the jobs based on the running status. The user can also filter the devices in a particular job
based on the parameters mentioned in the above table.

Abort Software Job
Abort operation will skip devices that are waiting for an update to begin. Devices already being updated may
continue, but cnMaestro will stop tracking their progress. Aborting a Software Job puts the device into a
"Completed" state that cannot be manually restarted by the user. The "pending" devices will not begin their
updates.

Figure 244 Abort Software Job

NOTE:

1. Devices which are already updated display as Completed with a message Update
Complete along with the status as Completed.

2. Devices that are ongoing display as Aborted with a message Manually Aborted with the
status as Aborted.

3. Devices that have not yet started display as Skipped with a message Job was aborted
with the status as Skipped.

4. Software update jobs can be scheduled in parallel irrespective of other running jobs in
cnMaestro X accounts.

5. Only Configuration or Software Update Job operation can be performed on the device,
as the job locks the device.

Viewing Running Jobs in header

Click the icon in the top right corner of the UI. This navigates to the Software Update tab > Jobs page of

the Software Update section. For more information, see Software Update
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FixedWireless Configuration

This chapter provides the following information:

l Overview

l Configuration Templates

l Configuration Variables

l Configuration Update at Onboarding

Overview
Template configuration is supported for ePMP, PMP, cnWave 5G Fixed devices. Templates are textual
representations of device settings that contain a full or partial configuration. When a template is applied to a
device, the only parameters changed are those in the template.

The process flow of the basic template configuration is shown below:

Figure 245 Basic Template Configuration Flow

Configuration Templates
Templates can be pushed to a device manually through a configuration job. This is accomplished in the
configuration management page. Templates can also be applied prior to onboarding, in which they would be
provisioned in the On-boarding Queue.

Some sample templates are listed below. The ellipses (…) represents additional content that has been excised
from the example to limit the size of the text. Each device type has its own template syntax, which can be
examined by viewing the device configuration.

Sample ePMP Template
The ePMP template uses the exported ePMP configuration format, which is JSON-encoded.



Figure 246 Sample ePMP Template

Configuration Variables
Administrators can embed variables into templates that will be replaced when the template is applied to a
device. This allows one to leverage a shared, generic template, but to tailor it to individual devices when it is
pushed. Template variables are added to a configuration file by replacing an existing parameter with a
customer-defined string of the format ${VARIABLE}. An example configuration line with a single variable
replacement is shown below:

“networkLanIPAddr”: ${IP ADDRESS}

The above variable is named IP_ADDRESS. When the template is pushed to a device, this variable will be
replaced with a value specific to the device. This value needs to be set for the device prior to the template
application, else the configuration will not be pushed. Default values can also be specified for variables, as
shown below:

“networkLanIPAddr”: ${IP ADDRESS="10.1.1.254"},

The default value is "10.1.1.254". In this case, if the variable is not set for a device, the default value is used.

Variable Usage
The Templates and Variables are merged to create the final configuration that is pushed to the device. The
figure below explains the usage of variables for configuration:

Figure 247 Variable Usage

Macros
Macros can be used in templates similar to variables except that they automatically embed values provided by
the device itself.

l %{ESN} will be replaced with the MAC address of the device
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l %{MSN} will be replaced with the Serial Number of the device

Variable Caching
Variables set for a particular device will be cached, so they can be reused later. This means the next time a
template is applied that leverages a variable with the same name as used previously that value will be pre-
populated with the previous value. It is therefore beneficial to define a uniform variable naming and usage
scheme for variables across different templates.

Device Type-Specific Configurations
The format and values of a configuration template are unique to the different device types. Templates that work
with device type do not work with others, and all templates need to be mapped to a specific device type upon
creation.

Device Mode restrictions
Some devices, such as ePMP execute in AP and SM modes. The ePMP templates can be configured to only
apply to devices that support a selected mode.

Variable validation
All variables for a selected template must be mapped to a value in order to create a configuration job. If any
variables are not mapped, an error will be generated. Variables with default settings do not cause an error if
they are unset.

Sample Templates
A number of sample templates are provided for each device type. These are not meant to be applied directly,
but rather serve as an example of the configuration data format accepted by the device. Refer to the device
documentation for complete information.

Template file creation
The typical process for creating your own configuration templates is below:

1. On a test device configure the parameters to the devices. This can be done directly on the device UI .

2. Export the device configuration using cnMaestro.

l Navigate to Configuration > Templates, select the device in the left-hand tree and click the View Device
Configuration link. This can also be done via the device GUI, typically in the Administration or Operations
section where there will be an Export for configuration.

3. View the configuration file in a text editor like Notepad++ and search for the values entered in step 1. You
can also search for the parameter name to find the correct lines.

4. Copy and paste the relevant lines into a new file.

5. Optionally replace values with replacement variable text. This will allow you to set the value per device.

6. Once you have this partial template, it can be copied into the template creation text field and saved.

Template
To create a configuration template:

1. Navigate to Configuration > Templates in the main menu.



The following template is for BTS:

The following template is for CPE:
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2. Click Add Template button.



3. Choose a Device Type, Name, and Description for the template. For ePMP, PMP, cnWave 5G Fixed, cnReach,
cnMatrix, and Machfu templates, you should select a Device Type as well.

4. Either upload your template into the UI or paste the template text into the text area.

NOTE:

No default templates available for R-series. User needs to create a new template.

5. After clicking Save, the template will be available in the selection menu on the configuration and onboarding
pages, as long as the device type and model match the device selected.

6. By selecting the Custom option under the Template type filter All Default templates will be hidden.

NOTE:

When you navigate to the Template page default template type filter will be custom. User
needs to select All or Default to view other templates.

BTS and CPE Configuration
To configure BTS, navigate to Monitor and Manage > BTS > Configuration.

To configure CPE, navigate to Monitor and Manage > BTS > CPE > Configuration.
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Configuration Template for PTP 820/850
To create a configuration template of PTP 820/850 device, perform the following steps:

1. Navigate to Configuration > Templates in the main menu.

2. In the Add Template drop-down, select PTP 820/850.

The Basic template page appears.

3. In the Basic page, enter Name and Description and click Save.



By default, NTP Configuration, Time Services, SNMP, and Security pages are disabled. Click slider icon next to
the fields to enable the pages and configure the template.

NTP Configuration
1. In the NTP Configuration, click Add New.

Create window appears.

2. Select Admin Status from drop-down.

3. Select Version from drop-down.

4. Enter Server IP Address.

5. Click Save.

NTP configuration is added to the table. You can perform the following actions for configurations added in the
table.

1. Click edit icon to edit the configuration

2. Click delete icon to delete the configuration.

Time Services

1. Enter the values for the following fields:

l Offset from GMT

l Daylight Saving Start Time

356 | Fixed Wireless Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide



357 | Fixed Wireless Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide

l Daylight Saving End Time

2. Click Save.

SNMP
1. Enter the details for V2 Users, add V3 Users and Trap Managers, and select Trap Version.

2. Click Save.

Security
1. Select the values for General Access Control.

2. Select Protocol Control.



3. Click Save.

Configuration Update

Device Selection
Navigate to the Configuration Update tab, and then navigate the Device Tree to the appropriate level for device
selection. For example, selecting a Fixed Wireless AP will enable selection of the AP and all its SMs.

Device Type
Configuration jobs are created for a single device type. The type includes the specific hardware (ePMP, PMP) as
well as the mode of the device (cnVision, PMP or PTP mode for ePMP for example).

Device Table
Select the devices to upgrade in the Devices Table. The following parameters are visible in the table:

Parameter Description

Devices The names of available devices in a system. The list is pre-filtered based upon the
node selected in the Device Tree.

Network/Tower The network and the tower on which the device is located.

Status The status of a particular device in a system. Devices that are “Down” can not have
images pushed to them.

Table 61: Device Table parameters

NOTE:
l You can only push configuration to a device when its status is Up.
l The user should validate the configuration before pushing it to the device from

cnMaestro.
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Options

Stop all Configuration on a Critical Error

If one of the configuration updates fails, then do not start any additional updates and instead pause the update
job. All existing, concurrent updates will be allowed to proceed until completion. The administrator will be able
to continue the update where it left off.

Parallel Upgrades

Define how many configuration updates to perform in parallel.

Update Ordering

Allows you to specify update ordering within a Fixed Wireless sector. Options are SMs first and then AP or
AP first and then SMs.

Abort Configuration

Abort operation will skip devices that are waiting for update to begin. Devices already being updated may
continue but cnMaestro will stop tracking their progress. Aborting a Configuration Job puts the device into a
complete state that cannot be manually restarted by the user. The pending devices will not begin their updates.

Figure 248 Abort Configuration

NOTE:

1. Devices which are already updated display as Completed with a message Update Complete
along with the status as Completed.

2. Devices which are ongoing display as Aborted with a message Manually Aborted with the status
as Aborted.

3. Devices which have not yet started display as Skipped with a message Job was Aborted with the
status as Skipped.

Configuration Update Steps
To update the configuration of an ePMP (Sectors) device, perform the following steps:

1. Navigate to Manage > Configuration > Device Details in the Main Menu.

2. Navigate to System > Network in the Device Tree. From the list of available networks, select a network in
which the device belongs.

3. Select ePMP (Sectors) from the Device Type drop-down.

4. Select the configuration template to upgrade from the Template drop-down.

5. Select the device(s) to upgrade.

6. Click the gear icon to view or edit variables that are required for selected devices.

7. Click Apply Configuration.



NOTE:
l The Configuration Upgrade cannot proceed until all required variables (those without

default parameters) are entered. If you attempt to create a configuration job without
setting required variables, the gear icon will turn red for any devices not meeting this
requirement.

l To save and download the existing Device Configuration as Template, click View Device
Configuration link.

Configuration Jobs
Navigate to Administration > Jobs > Configuration Update tab.

Jobs are presented with various Status values: Running, Queued, Skipped, and Completed. They can be
triggered to execute immediately or run later. The list of parameters in the Jobs tab is shown below:

NOTE:

cnMaestro X account user can run any number of Jobs in parallel.

The following table displays the list of parameters in the Jobs tab:

Parameter Description

Action Use the Start or Delete button to manage the upgrade process. After the upgrade has
started, the Pause button will stop new upgrades from the beginning. If the upgrade
process fails or the upgrade has been paused, you can restart the process by clicking
the Resume button.

Created By The user who has created this job.

Created On Date and time on which the job is created.

Details Count of devices and date and time the upgrade process is initiated.

ID Identification number of the active job.

Parallel Number of devices to start in parallel.

Table 62: Configuration Update parameters
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Parameter Description

Sector Priority For ePMP/PMP, cnRanger, cnVision Hub/Client, the priority of AP/BBU/SM to start.

Status Status of update.

Stop on Error Stop the job, if any device in middle finds any error.

Target Target software version to upgrade.

By selecting the Show More icon, you can view the following parameters:

Device Device for which the upgrade is initiated.

Message The message displayed after the update.

Result The upgrade status of the device.

Status Status of the device.

Mode SM or AP mode selected.

Network Type of Network.

Tower Name of the Tower.

Table 62: Configuration Update parameters

Configuration Update at Onboarding
Administrators can apply the configuration to devices during the onboarding process: Prior to approving the
device in the Onboarding Queue, the configuration template and variables can be specified. These will then be
pushed to the device during onboarding. For more details on onboarding, see Device Onboarding.

Wi-Fi Configuration

Wi-Fi configuration is handled through AP Groups or Templates, which Fixed Wireless devices, such as ePMP
and PMP, exclusively use Templates. This section will focus exclusively on AP Groups.

This chapter provides details on the following sections:

l cnPilot Home and Enterprise Wi-Fi

l Factory Reset

l Association ACL

l Access Control Policies

l Custom ApplicationsX

cnPilot Home and Enterprise Wi-Fi
There are four types of Wi-Fi hardware:

1. Enterprise Wi-Fi (E, XE, and XV-Series)

2. cnPilot Enterprise (ePMP 1000 Hotspot devices)

3. cnPilot Home (cnPilot R-series devices)



4. Enterprise Wi-Fi (Xirrus-Series)

These four hardware types map to the following AP group types:

1. Enterprise Wi-Fi (E-Series,XE/XV-Series)

2. Enterprise Wi-Fi (Xirrus-Series)

3. cnPilot Home (R-Series)

4. RV22 Home Mesh

Multiple AP Group types are needed, because the features available across the groups are different.

Note:

Wi-Fi devices can alternately be configured using a template mechanism, in which a subset of
configuration is pushed to the device manually through a user-defined template of
parameters. See the section on Templates for more information. Template configuration and
AP Group configuration cannot be used simultaneously.

Configure cnPilot using Wi-Fi Profiles
Wi-Fi devices are configured by creating an AP Group, mapping it to shared WLANs, and assigning it to devices
through the Configuration tab. Once assigned, the configuration is pushed manually or automatically (if Auto
Sync is enabled).

Note:

Xirrus devices embed WLAN configuration directly into the AP Group Full Configuration tab
and do not support separate WLAN profiles.

Auto Synchronization

AP Groups can automatically synchronize device configuration whenever the AP Group or associated WLANs
are updated. This is done by enabling Auto Sync in the AP Group Configuration page.

Manual Synchronization

When a device is mapped to an AP Group without Auto Sync turned on, the device is placed in an
Unsynchronized state until it is manually synchronized. Manual synchronization can be done as follows:

l Navigate to device Configuration page > Sync Now or

l Navigate to Administration > Sync Configuration > Sync Configuration. page.

Create an AP Group

Note:

l This example demonstrates how to create an Enterprise Wi-Fi (E-Series, XV-Series) AP
Group. A similar process can be followed for the cnPilot Home (R-Series) AP Group.

l The Enterprise Wi-Fi (Xirrus-Series) AP Group is different than the others. It embeds a full
configuration template of CLI commands that needs to be updated manually. The Xirrus
AP Group will support Auto Synchronization when the embedded template is changed,
which makes it different than applying the configuration through the standalone Template
mechanism.

To create an AP Group, perform the following steps:
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1. Navigate to Configuration > Wi-Fi Profiles > AP Groups page.

2. Click New and select Enterprise Wi-Fi (E-Series, XV-Series) Type.

Note:

l The special characters can be used to create AP Group and WLAN Password (Eg: a-zA-Z_
-*&%#@!<>.() []^~`$1234567890). The user can also rename them if required.

l By default password will not be configured. User has to configure the password for AP
Groups.

Basic

In the Basic page, configure the following details such as:

1. Select Type from one of the following:

l cnPilot Home (R-Series)

l Enterprise Wi-Fi (E, XE, XV, and Xirrus-Series)

2. Enter the mandatory fields based on device type.

l Name

l Country

l Description

l WLAN

3. Click Add WLAN and select WLAN from the list.

4. Click Save.

Figure 249 Basic: cnPilot Home (R-Series)



Figure 250 Basic: Enterprise Wi-Fi (E, XE, and XV-Series)

Figure 251 Basic: Enterprise Wi-Fi (Xirrus-Series)

The Xirrus AP Group embeds a Full Configuration of CLI commands.
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Figure 252 Full Configuration: Enterprise Wi-Fi (Xirrus-Series)

Management

The Management page allows to configure the Administrator Access, Time Settings, Event Logging and SNMP.

Note:

The AP uses the AES algorithm for encryption and SNMPv3 password configuration
parameter is used for encryption and authentication.

Figure 253 Management: Enterprise Wi-Fi (E-Series, XV-Series and XE-Series)

Radio

The Radio page allows the user to enable or disable the Software Defined Radio operations. It allows to
configure Software Defined Radios, Basic, Enhanced Roaming, Off Channel Scan, Auto-RF, and External
Antennas.



Figure 254 Radio: Enterprise Wi-Fi (E-Series, XE-Series, XV-Series)

Note:

l The software defined radio creation and channel listing are populated based on the
country-specific restrictions, device type, and release version.

Software Defined Radios

The Software Defined Radios (SDR) allows you to configure radio parameters for XV3-8, XE3-4, and XE5-8
device models. By default these device models are configured for radio bands as shown in Figure 254. The
other radio bands for which the devices can be configured are as shown in Table 63.
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Table 63: Supported Radio bands for Enterprise Wi-Fi Series (E-Series, XV-Series and XE-Series)

Models Radios
Supported
Radio Bands

Channel Specification

Channel width Default
Channel

width

Supported channel list

XV3-8 Radio 1 2.4 GHz 20/40 20 1 to 13

Radio 2 5 GHz (8x8 -
single radio)

or 5 GHz
(Split 4x4
dual radio)

20 / 40 / 80 40 100 to
165 in
Split
4x4
dual
radio

36 to 165 in
8x8 - single

radio

Radio 3 20 / 40 / 80 40 36 to
64 in
Split
4x4
dual
radio

XE3-4 Radio 1 2.4 GHz 20/40 20 1 to 13

Radio 2 5 GHz 20 / 40 / 80 40 36 to 64

Radio 3 5 GHz 20 / 40 / 80 /
160

40 100 to 165

6 GHz 160 Any 6 GHz channel

XE3-4TN Radio 1 2.4 GHz 20/40 20 1 to 13

Radio 2 5 GHz 20 / 40 / 80 40 36 to 64

Radio 3 5 GHz 20 / 40 / 80 /
160

40 100 to 165

6 GHz 160 Any 6 GHz channel

XE5-8 Radio 1 2.4 GHz 20/40 20 1 to 13

Radio 2 5 GHz or 6
GHz

20 / 40 / 80 /
160

20*/80**

Refer to Table 64 for
Supported Channel
list in 5 GHz and 6 GHz

Radio 3 5 GHz or 6
GHz

20 / 40 / 80 /
160

20*/80**

Radio 4 5 GHz (8x8 -
single radio)

or 5 GHz
(Split 4x4
dual radio)

20 / 40 / 80 20

Radio 5 20 / 40 / 80

* 5 GHz **6 GHz



NOTE:

l Split 4x4 is applicable only for 8x8 spatial streams supported devices. (Supported device
models are XV3-8 and XE5-8).

l Dual 5 GHz Radio (Only supported for XV3-8 and XE5-8 Access Points) Splits 8x8 5 GHz
radio into two 4x4 5 GHz radios.

Table 64: Supported Channel list 5 GHz or 6 GHz in XE5-8

Radio Index Radio 1 Radio 2 Radio 3 Radio 4 Radio 5

8x8 mode of operation: Radio 4 & 5 as single radio with 8x8

Radio 2 Radio 3 Radio 4 & 5

5 GHz 5 GHz 5 GHz NA 100 to 128 149 to 165 36 to 64

6 GHz 5 GHz 5 GHz NA Any 6 GHz
channel

100 to 165 36 to 64

5 GHz 6 GHz 5 GHz NA 100 to 165 Any 6 GHz
channel

36 to 64

6 GHz 6 GHz 5 GHz NA * 1 to 93 ** 97 to
233 / 65 to

93

36 to 165

Split 4x4 mode of operation: Radio 4 and 5 as individual radio with 4x4

Radio 2 Radio 3 Radio 4 Radio 5

5 GHz 5 GHz 5 GHz 5 GHz NA 60 to 64 100 to 128 149 to
165

36 to 40

6 GHz 5 GHz 5 GHz 5 GHz NA Any 6 GHz
channel

100 to 128 149 to
165

36 to 64

5 GHz 6 GHz 5 GHz 5 GHz NA 100 to 128 Any 6 GHz
channel

149 to
165

36 to 64

6 GHz 6 GHz 5 GHz 5 GHz NA * 1 to 93 ** 97 to
233

100 to
165

36 to 64

Note: *FCC SKU 6GHz UNII-5 or 6 (1 - 93) EU SKU UNII-5 low (1 - 61)

**FCC SKU 6GHz UNII-7 or 8 (97 - 233) EU SKU UNII-5 High (65 - 93)

NOTE:

You can use no channels-distribution global configuration CLI command for all multi-
radio platforms, such as XV3-8, XE3-4, and XE5-8 APs. When configured on device, default
channel list can be overridden.

1. In the Radio tab, you can configure Software Defined Radios for the required Model as shown in Table 63.
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The Enterprise Wi-Fi (E-Series, XV-Series, and XE-Series) devices can be configured with radio features for
2.4 GHz, 5 GHz and 6 GHz radio bands.

2. Click the plus sign (+) next Basic, select Enable or Disable status of the radio.

3. Select the Auto value in the Channel drop-down.

4. In the Candidates Channel select All.

5. Select the parameter values from the drop-down for the following fields:.

l Channel Width

l Transmit Power

l Beacon Interval

l Minimum Unicast Rate

l Multicast Data Rate

l Mode



Figure 255 Radio page

6. Click the (+) plus sign next to Enhanced Roaming and configure Roam SNR Threshold.
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NOTE:

Enable Enhanced Roaming only in networks with sufficient signal strength throughout the
coverage area, otherwise clients could face connectivity issues.

7. Click the (+) plus sign next to Off Channel Scan and enable OCS.

8. Click the (+) plus sign next to Auto-RF and enable Auto-RF.

9. Select Dynamic Channel Change Options as required.

10. Click Save.

External Antennas

This feature allows users to customize the antenna models for each of the three radios in the XE3-4TN AP as
shown in Figure 256. This customization helps in achieving optimal wireless network performance customized
for specific deployment scenarios.

Figure 256 External Antennas for XE3-4TN APs

Network

The Network page allows to configure Ethernet Ports, VLANs, Routes for IPv4 and IPv6, DHCP Pool, Tunnels,
PPPoE , VLAN Pool, and WWAN.



Figure 257 Network: Enterprise Wi-Fi (E-Series, XV-Series and XE-Series)

Configuring 802.1X port-based authentication
802.1X authentication on Ethernet ports enhance the network security of the AP.
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The AP supports 802.1X port-based authentication with the following authentication modes:

l Single-host authentication—Only one client is allowed to access the network after successful 802.1X
port-based authentication. After successful authentication, the port VLAN is assigned based on RADIUS
assigned VLAN.

l Multi-host authentication—Authentication is enforced on all clients connecting to the wired port. After
the first client authenticates, the port VLAN is assigned based on RADIUS assigned VLAN. Any further
client connections to the port will be part of the initial Radius VLAN that was assigned.

Note

l By default, the 802.1X port-based authentication feature is enabled in the single-host
authentication mode.

l 802.1X port-based authentication does not support CoA messages.

802.1X port-based authentication also requires a RADIUS AAA server for authentication and accounting.

To configure 802.1X, complete the following steps:

1. Navigate to Configuration > Network > Ethernet Ports.

2. Expand the Port Control section and select the 802.1x Authentication check box.

The Host Mode field is enabled.

3. Select from the following authentication modes in the Host Mode drop-down list.

n Single Host

n Multi Host

4. Expand the RADIUS Server section and configure the RADIUS server parameters for 802.1X authentication.



Table 65: RADIUS Server parameters

Parameters Description Range Default

Authentication
Server

Specifies the authentication server details, such as:

l Host—IPv4 or IPv6 address or hostname of the
server

l Secret—Text string that is used to encrypt data in
RADIUS packets shared between the AP and the
sever. Format—Text string

l Port—Port number of the authentication server.
Default—1812

A maximum of three RADIUS authentication servers can be
configured.

- Disabled

Accounting
Server

Specifies the accounting server details, such as:

l Host—IPv4 or IPv6 address or hostname of the
server

l Secret—Text string that is used to encrypt data in
RADIUS packets shared between the AP and the
sever. Format—Text string

l Port—Port number of the accounting server.
Default—1813

A maximum of three RADIUS accounting servers can be
configured.

- Disabled

Timeout Time (in seconds) to wait for a response from the RADIUS
server.

1-30 3

Attempts Number of retry attempts for contacting the RADIUS
server.

1-3 1

Accounting
Mode

Specifies the accounting mode to be used. The following
modes are supported:

l Start-Stop—Accounting packets are transmitted by APs
to the AAA server when a wireless client is connected
and when the client disconnects.

l Start-Interim-Stop—Accounting packets are transmitted
by APs to the AAA server when a wireless client
connects, then at regular intervals (configured in the
Interim Update Interval field) and also when the client
disconnects.

l None—Disables the accounting mode. This is the default
mode.

- None
(Disabled)

Server Pool Mode Users can configure multiple Authorization and Accounting
servers. Based on a number of wireless stations, the user
can choose Failover mode.

- Failover
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Parameters Description Range Default

l Load Balance—AP equally distributes the requests
between the configured RADIUS servers,

l Failover—AP selects the RADIUS server that is
functional based on the order of configuration.

Interim update
interval

Time (in seconds) to wait for sending RADIUS interim
accounting update packets.

Note: This interval is applicable only when you select the
Start-Interim-Stop option in the Accounting Mode
parameter.

10-
65535

1800

Dynamic
Authorization

This option is required, where there is CoA request from
AAA/RADIUS server.

- Enabled

IPv6 Support
IPv6 enables the next generation of large-scale IP networks by supporting addresses that are 128 bits long.

NOTE:

l In the current release, IPv6 functionality is supported only for cnPilot Enterprise devices.

l IPv6 functionality is supported on cnPilot from System Release 4.0.

Configuring IPv6

To configure IPv6, perform the following:

1. Navigate to Configuration Wi-Fi Profiles > AP Groups tab.

2. Select Network tab and click Edit VLAN.



3. Click the (+) plus sign next to IPv6 option.

4. Select Mode from drop-down list. By default, the IPv6 Mode is Disabled. The different IPv6 modes are Static,
Stateless DHCPv6, Stateful DHCPv6, and Auto Configuration.

If Static is selected, provide the following details:

l IPv6 Address: Enter IPv6 address.

376 | Wi-Fi Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide



377 | Wi-Fi Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide

l Prefix Length: Enter IPv6 prefix. For example: 2001:1111:2222:3333::/64.

5. Enable Request Option All to use the IPv6 Gateway, DNS, DHCPv6 options received on this interface.

By default the priority of IPv6 Gateway Source Precedence is Static and then Auto-config/DHCPv6.

To create a new static Route,

1. Navigate to IPv6 Multiple Route Entries section.

2. Click Add New.

3. Enter Destination IP/Prefix and Gateway.

4. Click Save.

To set the preference of IPv4 and IPv6:

1. Navigate to Routes tab.

2. Select the IPv6 Preference checkbox.

Security

The Security page allows to configure DoS Protection and Rogue AP.



Map WLANs to AP Groups
WLANs are added in the AP Group configuration. Ensure the WLANs are ordered correctly if Mesh mode is
used. When a WLAN uses Mesh Client mode it must always be the first WLAN in the AP Group, and only one
Mesh Client WLAN is allowed per AP Group.

The ordering when using Mesh mode is as follows:

1. Client (maximum of one Mesh Client is selected)

2. Base (maximum of two Mesh Base is selected)

3. Recovery (maximum of one Mesh Recovery is selected)

4. WLANs with Mesh Mode Off (total WLAN limit including Mesh WLANs)

NOTE:

Maximum of 16 WLAN policies are supported for E-Series and XV-Series devices and 8
WLAN policies are supported for ePMP 1000 Hotspot. Only one WLAN is available for
cnPilot Home.

Lock device Configuration
Locking automatically restores the configuration of devices if it is changed outside of cnMaestro. When this
feature is enabled, external configuration changes are automatically reverted by reapplying the AP Group
configuration. The configuration is pushed only if the device is in Sync status.

To enable this feature, perform the following steps:

1. Navigate to Configuration > Advanced Features page.

2. Select the Lock cnPilot/cnMatrix device Configuration checkbox.

3. Click Save.

When a configuration change is made on the device using UI or CLI, cnMaestro detects the change and the
device is marked Not In Sync. In this scenario, an Auto-Sync job is triggered to automatically revert the
changes.

The Auto-Sync job can be viewed in Administration > Jobs > Configuration Update page.

Retry Configure
When the user applies an AP Group to the device, and the Job is skipped because the device is Offline, the
reason for the skip will be displayed as Device was offline in the Jobs page. When device comes up and
connects to cnMaestro, an Auto-Sync job pushes the AP Group to the device. (It will not apply the AP Group if
Auto-Sync is disabled in the AP Group).

378 | Wi-Fi Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide



379 | Wi-Fi Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide

NOTE:

The Config Update (Auto-Sync) will happen only when the Auto-Sync option is enabled in
the AP Groups page. If the device was Skipped/Failed for any reason other than the Device
was offline, the device will not be updated.

The default password admin of cnPilot R-Series should be changed before upgrading to the build 4.6-RX.

After upgrading to 4.6-RX, the default password admin is invalid and needs to be reset through the WAN.

NOTE:

Default User Name: admin can be used after the upgrade.

Apply AP Group to Device
A Configuration Job can be created as follows:

1. Navigate to Monitor and Manage > System > Configuration.

2. Select Device Type and set of devices along with AP groups to which they will be mapped.



This can be done in three steps:

1. Select the AP Group.

2. Select Device Type from the drop-down:

l cnPilot Home (R-Series)

l cnPilot Enterprise (ePMP Hotspot)

l Enterprise Wi-Fi (E-Series, XV-Series)

l Enterprise Wi-Fi (Xirrus-Series)

3. Click Apply Configuration.

AP Group and WLAN Import/Export
The AP Groups and WLANs are created for cnPilot Home and Enterprise devices. The configurations that are
created for each WLAN and AP Groups in a server can be exported and imported to a different server.
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Export AP Groups and WLANs

To export AP Group or WLANs, perform the following steps:

1. Navigate to Configuration > Wi-Fi Profiles page.

2. Select AP Group or WLAN tab.

3. Click Export icon in the row of the AP Group or WLANs to export.

NOTE:

l The AP Groups and WLANs should be exported separately as the associated WLANs are
not included while exporting an AP Group.

l The AP Groups and WLANs will be exported with proper name and timestamp.

Import AP Groups and WLANs

To import AP Group and WLANs, perform the following steps:

1. Navigate to Configuration > Wi-Fi Profiles page.

2. Select AP Group or WLAN tab.

3. Click Import.

Import AP Group window appears.



4. Enter the Name.

5. Select the Scope from drop-down.

6. Select the Configuration file in JSON format.

7. Click Import.

NOTE:

l To import an AP Group, ensure all associated WLANs in the AP Group are already
imported. If the WLAN associated with the AP Group is unavailable, an error message will
be displayed during import.

l If the name is not provided for WLAN or AP Group while importing, it will take the name
of the imported file.

l If the name provided for the AP Group/WLAN is already in use, an error message The
specified policy name already exists will be displayed.

Create a WLAN
To create a WLAN, perform the following steps:

1. Navigate to Configuration > Wi-Fi Profiles > WLAN tab,or WLAN page in the Wireless LAN View.

2. In WLAN tab select New.

As with AP Groups, WLANs are separated into cnPilot Home and Enterprise Wi-Fi. Enterprise Wi-Fi WLANs are
able to configure WLAN, RADIUS, Guest Access, Usage Limits, Scheduled Access, and Access parameters.
cnPilot Home WLANs can configure SSID, Scheduled Access, and Access parameters.

Note:

The special characters can be used to create AP Group and WLAN names (Eg: a-zA-Z_-
*&%#@!<>.() []^~`$1234567890). The user can also rename them if required.

To create a WLAN, perform the following steps:

1. Navigate to Configuration > Wi-Fi Profiles in the left-side menu.

2. Select WLANs tab and then click New.

3. Enter Type, Name, and WLAN parameters.

4. Ensure WPA2 PSK is enabled in Security drop-down.
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5. Click Save.

Note:

In 6 GHz Band, Open option is not supported in Security.

Creating an ePSK WLAN
To create an ePSK WLAN, perform the following steps:

1. Navigate to Configuration > Wi-Fi Profiles or WLAN page in the Wireless LAN View.

2. Select WLANs tab and click Add.

As with AP Groups, WLANs are separated into cnPilot Home and Enterprise Wi-Fi types. Enterprise Wi-Fi
WLANs are able to configure WLAN, RADIUS, Guest Access, Usage Limits, Scheduled Access, and Access
parameters. cnPilot Home WLANs can configure SSID, Scheduled Access, and Access parameters.

Note:

l The special characters can be used to create AP Group and WLAN names (Eg: a-zA-Z_-
*&%#@!<>.() []^~`$1234567890). The user can also rename them if required.

l By default, password will not be configured. User has to configure the password for
WLAN.

To create WLAN policy, perform the following steps:

1. Navigate to Configuration > Wi-Fi Profiles.

2. Select WLAN tab and click Add.

3. Select Enterprise Wi-Fi from the Type drop-down list and enter details in the Basic Information section.

4. In the Basic Settings section, ensure the WPA2 Pre-Shared Keys option is selected in the Security drop-
down list.



5. Click Save.

6. In ePSK > select type of Passphrase Strength (Easy, Strong, or Number).

7. Click Add New.

The Add ePSK window is displayed.

8. Select Mode type as one of the following:

l Single: In the Single mode, only the User Name is mandatory and rest of the entries are optional. There is
only one entry in this mode.
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NOTE:

Passphrase is optional and it will be automatically generated based on the selected
Passphrase Strength.

l In the Bulk mode, the Count and User Name Prefix are mandatory. There are multiple entries in this
mode.



9. To automatically expire ePSK details after a specific duration. The following options are available:

l None—ePSK details never expire. Select None to never expire the ePSK credentials.

l Date and Time— ePSK expires after the specified date and time (in dd/mm/yyyy hh:mm AM/PM format)

Supported minimum time is 12 A.M. on the next day and the maximum is five years.

l Duration— ePSK expires after the specified (in hours, days, months, or years) in the Expiry by drop-down.

Supported minimum duration is one hour and the maximum is five years. No decimal values are
supported, for example, 1.5 hours.

NOTE:

l The configured expiry time appears in the Expiration Date column on the WLANs >
<WLAN name> page.

l The Status column on the WLANs > <WLAN name> page displays the status of the
ePSK details—Active, Expired, or None. None is displayed only when older ePSK keys
are imported to cnMaestro.

l Expired ePSK details are deleted from the AP only when the next configuration sync
functionality is initiated or when there is a configuration change in the AP.

Creating a Personal Wi-Fi ePSK X

In Multiple Dwelling Units (MDU), personal Wi-Fi allows a user to connect all the personal devices to a unique
SSID associated with a VLAN. For example, a user can connect multiple devices to a single personal Wi-Fi

To configure personal Wi-Fi on the AP, complete the following steps:

1. Add and enable the SSID details (to be used as personal Wi-Fi) in the WLANs tab, under Manage and
Operation > Networks > <network name> > Configuration > Device Configuration > Advanced Settings
section.

a. Select the Enable SSID checkbox.

b. In the Passphrase field, configure the passphrase.

c. Configure the VLAN with which the SSID must be associated.

2. Enable personal Wi-Fi on the ePSK page for the WLAN profile by selecting the Base Personal SSID
checkbox.
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By default, this feature is disabled. Once enabled, the Enable checkbox (under WLANs > WLAN > Basic
Settings > SSID) is cleared. Also, the local and RADIUS ePSKs are disabled.

Import ePSK

1. Click Import.

2. Select Import.csv file.

Alternatively, one can import a CSV file containing a list of ePSK entries. A sample file format is available
from the Import dialog.

3. Click Download Sample File, to view sample ePSK Excel sheet.

Export ePSK

1. Click Export.

2. Select export.csv file.



Editing ePSK

To edit an ePSK, select the required ePSK and click the edit ( ) icon in the row.

You can edit only the passphrase and the expiry duration information.

Deleting ePSK

To delete an ePSK, select the required ePSK and click Delete. You can also click the delete ( ) icon in the row.

To delete multiple ePSK entries, select the checkboxes corresponding to the ePSK entries and click Delete.

NOTE:

l ePSK feature is supported on cnPilot from System Release 3.11.1
onwards.

Access Control

The Access Control page allows user to enable or assign access control policies and configure User Group
Policy and Device Policy. It offers visibility into the configured rules, ensuring efficient and secure network
management.
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Figure 258 Access Control page

NOTE:

If an Access Control Policy is assigned at the AP group level, it does not appear under User
Group or Device Group policies.

Enable Access Control Policy

Users have the provision to enable or disable access control policies under Access Control tab as shown in
Figure 259.

Figure 259 Enabling Access Control Policy

Note:

NOTE:

User can select the available access control policies listed in Wi-Fi profiles in Access Control
Policy drop-down list. User can review the configured rules associated with these policies by
clicking View Rule icon as shown in Figure 259. This provides a comprehensive view of the
policies and rules within the network.

User Group Policy

User Group Policy enables users to categorize into specific roles with customized access permissions and
restrictions, facilitating fine-tuned control over network access.



Adding a new User Group Policy

To add a new User Group Policy, perform the following steps:

1. Navigate to Configuration > Access Control page.

2. Click Add New in the top right corner of the User Group Policy as shown in Figure 260.

Figure 260 User Group Policy

3. Complete the details in the Add User Group pop-up window as shown in Figure 261.

Figure 261 Add User Group

NOTE:

l The user needs to assign an Access Control Policy or VLAN to create a User Group.

l Users can add a maximum of 64 User Groups and Device Policies each.

l Users can only select Access Control Policies (ACPs) with NON-MAC filters from the
Access Control Policy drop-down menu.

l Mapping an Access Control Policy (ACP) to a User Group Policy (UGP) enables its use
for the AP group, and vice versa. However, the same ACP cannot be shared between
UGP and AP group; you can apply it to only either UGP or AP group.
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Device Policy

Device Policy allows users to apply specific rules and access control policies based on the type and
characteristics of devices, offering customized control over device behavior within the network.

Adding a new Device Policy

To add a new Device Policy, perform the following steps:

1. Navigate to Configuration > Access Control page.

2. Click Add New in the top right corner of the Device Policy as shown in Figure 262.

Figure 262 Device Policy

3. Complete the details in the Add Device Policy pop-up window as shown in Figure 263.

Figure 263 Add Device Policy

Services

The Services tab allows to configure the LDAP, NAT Logging, DHCP Option 82, Speed Test, RTLS (Real-Time
Location System) such as Wi-Fi API, Bluetooth API, Stanley-AeroScout, and Bonjour.



NOTE:

Stanley-AeroScout is supported only for cnMaestro X features.

Stanley-AeroScout

Stanley-AeroScout delivers an accurate and reliable location data for assets and customers with the STANLEY
Healthcare Wi-Fi tags. It is an integral component of STANLEY Healthcare's Stanley-AeroScout RTLS solutions.
The Stanley-AeroScout determines a location using signal strength measurements (RSSI) which are collected
by the Cambium Wi-Fi Access Points. These Wi-Fi Access Points can simultaneously serve location sensors and
provides network access. Stanley-AeroScout utilizes a location engine to determine the position of Wi-Fi tags.
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Pre-Defined Overrides
Some device configuration is specific to an individual device and not easily shared through an AP Group. This
includes IP Address, Radio Channel settings, and WLAN details such as Enabling/Disabling SSID and
Passphrase. These items can be configured in the Device Configuration page, which can be selected by
choosing Manage > Configuration in the menu, and then selecting the device in the tree to update.

You can then choose/change different values from AP Group to be overridden. The icon to the left of a field
must be selected first to override that parameter. After specifying override parameters, select Apply
Configuration on the bottom right to save your changes to the server and create a job to push the new values to
the device. This option is also applicable for Onboarding process queue.

Advanced Settings
By default, Enterprise Wi-Fi devices have Auto-set from device enabled. This option reads several network
related configuration fields from the device and uses those as override values to prevent overwriting values that
would disconnect the device.

Modify the Advanced Settings section on the Access Point level configuration page as below:

l Add option to override Dual 5 GHz Radio setting for XV3-8 APs below the Placement field.

l If the Dual 5 GHz Radio feature is Enabled, then show the settings to override/configure the 3rd 5 GHz radio.

l If the Dual 5 GHz Radio option is enabled, then allow channel range > = 100 for Radio 2 and 36 – 64 for Radio
3.



NOTE:

XE3-4TN features a radio antenna override option.
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User-Defined Overrides
User-Defined Overrides can be entered into the end of an AP Group configuration. They will be appended to the
AP Groups before the configuration is applied to the device. This allows setting configuration parameters which
are not supported by GUI; this is an advanced operation that should rarely be used. The format of the
commands is same as with the device CLI.

For example, if a new version of the software had a feature unsupported in cnMaestro, it could can be pushed to
the device using CLI commands through the User-Defined Override mechanism.

This can be explained with the following example, in which country-code and hostname are appended to the
end of the configuration and will override any settings in the UI.

country-code IN

hostname Wi-Fi_Device

User-Defined Variables
Override configuration also supports a programmatic concept called User-Defined Variables (which are also
used with templates). User-Defined Variables can be embedded into the User-Defined Override text area. They
require a value to be set for each device mapped to the AP Group before the configuration can be applied. This
is either through a default value, or an explicit setting in the device configuration.

The syntax for User-Defined Variables is shown in the following example: the VariableName maps to an
identifier set by each Device. If the value is not set, the optional DefaultValue will be used.

Parametername ${VariableName=DefaultValue}



NOTE:
You can also configure User-Defined Variables in the Onboarding process queue page. They
are mapped individually to each device.

Other Examples

Enterprise Wi-Fi (E-Series and XV-Series) and cnPilot Enterprise (ePMP hotspot)

country-code ${countryname=US} // country name with US as default value

hostname ${hostname=ePMP_1000_Hostpot}

cnPilot Home R-Series

Parametername ${variableName=someDefaultValue}

Example

CountryCode=${countryName=IE}

RTDEV_CountryCode=${5GHz_CountryName=IE}

wan_ipaddr=${wan_ip=10.110.68.10}

Macros can be used in Advanced Configuration similar to User-Defined Overrides, except they automatically
take values provided by the device itself.

l %{ESN} will be replaced with the MAC address of devices.

l %{MSN} will be replaced with the Serial Number of devices.

Bulk Overrides
Bulk Overrides allow the user to edit the multiple configurations shared through an AP Group for one or more
devices.

NOTE:

Bulk Edit option under Configuration > Devices Overrides is supported only for cnMaestro X.

The user can override for the following configurations in cnPilot (R-Series):

l Management

l Radios

l Wi-Fi Configuration

Figure 264 Bulk Override: cnPilot (R-Series)
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The user can override for the following configurations in Enterprise Wi-Fi (E-Series, XV-Series):

l Location

l Management VLAN

l Radios

l WLANs

l User-Defined Variables

Figure 265 Bulk Override: Enterprise Wi-Fi (E-Series, XE-Series, XV-Series)

NOTE:

Configuration tab will be available from other container levels like Network/Site and also
from AP group level.

To configure Bulk Overrides for the devices, perform the following steps:

1. Navigate to Manage > System > Configuration.

2. Select the Device Type from the drop-down.

3. Select Device from the list and click Configure.

3. Click the plus (+) next to Device Override(s), to override the list of devices.

4. In the Device Override table, reconfigure tabs and perform the following actions:

l Bulk Edit

l Export



l Import

5. Select the device(s) from the Device Override table to configure.

6. Click Bulk Edit.

A pop-up window appears for the fields to reconfigure.

7. Click Save.

You can export, as described:

l Export page as CSV

l Export all as CSV

After modifying the field values, the CSV file can be imported.

8. Click Import, to import the file.

9. Select the file to import in CSV file format.

10. Click Apply.

Location
1. In the Location tab, select the devices from the list.

2. Click Bulk Edit.
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.

3. Edit Location window appears, edit the configuration details and click Save.

Management VLAN
1. In the Management VLAN tab, select the VLAN of the device from the list.

2. Click Bulk Edit.



3. Edit Management VLAN window appears, edit the changes and click Save.

Radios
In the Radio tab, select the radios from the device list, to perform Import and Export actions.

NOTE:

Bulk Edit tab is removed from Radio configuration from 3.1.1 release.

WLANs
1. In the WLANs tab, select the WLAN of the devices from the list.

400 | Wi-Fi Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide



401 | Wi-Fi Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide

2. Click Bulk Edit.

3. Edit WLANs window appears, edit the configuration details and click Save.

User-Defined Variables
1. In the User-Defined Variables tab, select the devices from the list.

2. Click Bulk Edit. Edit WLANs window appears, edit the configuration details and click Save.



NOTE:

For Bulk overrides to enable in User-Defined Overrides tab, user has to define overrides in
User-Defined Overrides section of AP groups. For more details, refer to User-Defined
Overrides

3. Click Apply Configuration to start immediately, or click Schedule Configuration to schedule later.

The user can override for the following configurations in Enterprises Wi-Fi ( Xirrus-Series):

l User-Defined Variables

Figure 266 Bulk Override: Enterprises Wi-Fi (Xirrus-Series)

1. In the User-Defined Variables tab, select the devices from the list.

2. Click Bulk Edit. Edit WLANs window appears, edit the configuration details and click Save.
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3. Click Apply Configuration to start immediately, or click Schedule Configuration to schedule later.

Synchronize (Sync) Configuration
AP Groups can be configured to synchronize automatically or manually when they are updated. The setting is
available in the AP Group configuration page.

1. Enterprise Wi-Fi AP Groups by default synchronize automatically (so any change of AP Group or WLAN,
followed by a Save, will immediately push configuration to the devices without manual intervention).

2. cnPilot Home AP Groups by default synchronize manually. Updates to them (or the WLANs to which they
map) need manual synchronization to push configuration to the devices.

Manual Synchronization

Manual configuration synchronization allows the user to synchronize any devices with a single action rather
than updating each device separately.

Navigate to Administration > Sync Configuration.

Sync Configuration only displays devices currently Out-of-Sync with a mapped AP Group.

Sync Configuration has the following fields:

l AP Group (AP Group to which device is mapped)

l Device (Hostname)

l Device Type

l Network (Network in which device is present)

l Status (Up/Down)

l Site (Site under which device is present)

l Sync Status (Sync status will tell whether job is completed or failed )

Steps to Sync Configuration:

1. Click the Sync Configuration inthe top right of the Configuration > WLAN and AP Groups or Manage >
Configuration > Device Details or Jobs tab.

2. Select devices to synchronize.

3. Click Sync Now.



NOTE:

l Sync Configuration can only be used if an AP Group is already mapped to the device.

l Software Update Jobs can be scheduled in parallel irrespective of other running Jobs in
cnMaestro X. Configuration and Software Update jobs execute sequentially if mapped to
the same device.

Configuration Job Status
After applying the configuration, the Configuration Job status is viewed at:

l Navigate to Monitor and Manage > Configuration > View Update Jobs (for Access and Backhaul devices)
or

l Administration > Jobs (for Wireless LAN devices).

When the configuration is pushed from the Sync Configuration page, a Configuration job will be created in the
background.

NOTE:

l Configuration jobs skip offline devices. With manual synchronization, they need to be
synchronized by the administrator.

l For more information on Wi-Fi AP configuration, refer to the following URLs:

l Unique per-Device values in Profiles Using User-Defined Overrides

l AP Groups and Overrides for Wi-Fi Devices.

l Migrating from Templates to Profiles

l cnMaestro X can run any number of Jobs in parallel.

Factory Reset
A factory reset erases all the data on the device. Factory reset is supported for two device models: Enterprise
Wi-Fi higher than 3.10-R6 version and cnMatrix higher than 4.0 version.

To factory reset the device perform as follows:

1. Navigate to the Configuration page of the device.

2. Select Factory Reset.
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3. Click Factory Reset.

It displays Please confirm factory reset message as shown below:

4. Click Yes, Factory reset option.

If the Factory Reset is successful, the following message is displayed on the Notifications tab.

When Factory Reset is performed, cnMaestro deletes the existing device cookie and displays message to
Approve in the homepage. When the device connects back you have to re-approve the device as shown below:



When Factory Reset is applied to an offline device, it displays an error as shown below:

Association ACL
This section describes how cnMaestro replies to AP's request to allow or disallow client associations. This
feature allows you to configure a MAC Association list that is used to allow/deny client associations.

Overview
When a client tries to connect to an AP, the following occurs:

1. The AP sends MAC authentication request along with the MAC Address of client and the Customer ID (CID) to
the Controller. This is optional and occurs only if MAC ACL is configured for the WLAN on the AP and the policy
for the MAC ACL is cnMaestro.

2. Controller checks and responds with an action to Allow or Deny the request.

3. AP allows or denies the client’s request based on the response of the Controller.

Configuring Association ACL
To configure the Access Control List (ACL) in cnMaestro:

1. Navigate to Configuration > Wi-Fi Profiles > Association ACL tab.

2. Click Add.
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3. Select Allow.

4. Enter the MAC and Description.

5. Click Save.

It displays the Success message.

5. To configure MAC authentication as cnMaestro:

The Association ACL is shared among all Enterprise WLANs, but it must be explicitly mapped to each
Enterprise Wireless LAN that uses it (at Access Control > MAC Authentication).



NOTE:

l If MAC is not configured under the policy (to Allow or Deny), the default action will be
applied.

l You can perform the following actions by selecting the respective icons in the table:

l Edit

l Delete

l Export

l Import Association ACL, by selecting Import.csv file.

Access Control Policies
This feature allows you to configure policies that define who can connect to the network, and how or when they
are allowed to connect and access a specific device. The policies are a set of conditions, constraints, and
settings.

The policies can be configured on both AP Group level and WLAN level, AP Group policies have more priority
than WLAN Access Control policies.

On both AP group policy and WLAN policy, we can have L2, L3 and L3 Rules. The configuration rules are
processed in following priority: MAC Filters followed by IP and Application Filters.

Configuring Access Control Policies for AP Groups and WLANs
To configure the Access Control Policies:

1. Navigate to Configuration > Wi-Fi Profiles > Access Control Policies tab.

2. Click Add. WLAN Policy or Add. AP Group Policy in the top right corner of the corresponding lists.
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3. Enter a Name for the policy.

4. Select the Scope from the drop-down list.

5. For AP Groups, Enable Air Cleaner.

6. Click Add New in the top right corner of the MAC Filtering Rules list and complete the details in the Add
MAC Filtering Rule pop-up window.

7. Click Add New in the top right corner of the IP and Applications Filtering Rules list and complete the details
in the Add IP and Application Filtering Rule pop-up window.

NOTE:

Application Filtering Rule is an X Feature.



8. After adding all the required rules, Click Add in the bottom left corner of the window.

9. Navigate to WLAN > Access Control or AP Group > Access Control tab and link this policy.

NOTE:

l AP Group Access Control Policies are applied at the device level.

l WLAN Access Control policies have less priority than AP Group Access Control policies.

Custom ApplicationsX

Custom applications allow you to configure applications with a specific IP address or a domain name, and apply
filter rules, such as enable or disable traffic from these applications. By default, these applications are applied
on the devices along with the AP group configuration.
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After creating the custom application, when you click Apply, cnMaestro creates a job for devices in the
AP group that has auto sync enabled. Devices in AP groups that do not have auto sync enabled, are marked as
Not in Sync, and users must manually apply the configuration on to the devices.

To disable cnMaestro from applying the custom application configuration on the devices, clear the Enable
Custom Application check box from the AP Groups > Services tab > Application VisibilityX section.

To add a new custom application, complete the following steps:

1. Navigate to Configuration > Wi-Fi Profiles > Custom ApplicationsX.

2. Click Add New on the Custom ApplicationsX page.

The Add Custom Application window is displayed.

Configure the following parameters:



Parameter Description

Name Specifies the name for the custom application.
Supports a maximum of 20 characters.

Scope Specifies the availability of the custom application across managed accounts.
The following values are supported:
l Base Infrastructure—Custom application is available only for the global account. It

is not shared with other managed accounts.
l Shared—Custom application is shared across all managed accounts. It can be

mapped to devices in the managed account, but it cannot be modified. To modify
the configuration, it must be copied into the managed account and then updated.

l Managed Account—Custom application is available only for that specific
managed account.

Note: Once the scope has been configured on a custom application, it cannot be
modified.

FQDN/IP Address Specifies the IPv4 address or the domain name of the custom application.

Category Specifies the category to which the application must belong.
Select the appropriate category from the drop-down list.

Productivity Index Indicates how appropriate an application is useful for business purposes. The higher
the rating number, the more business-oriented an application is.

Risk Index Indicates how likely an application is to pose a threat to the security of your network.
The higher the rating number, the riskier of an application is.

Enable Select the check box to enable this custom application.

Table 66: Custom Application Parameters

3. Click Add New.

4. To apply this configuration on the AP, click Apply.

cnMatrix Switches

cnMatrix switches simplifies the network deployment and operation. cnMaestro provides management,
configuration and control, and security services for cnMatrix with deployment options such as Policy-Based
Automation (PBA) to simplify core operations and improve network security. Central to cnMaestro's
orchestration of cnMatrix devices is the concept of Switch Groups.

Switch Group Configuration
A Switch Group represents a virtual stack of switches, independent of their locations or networks. The Switch
Group functionality enables users to manage multiple switches with the same configuration.

Configuration is common to all switches belonging to a Switch Group:

l Configuration changes are synchronized and applied for all the switches in a Switch Group.

l A subset of configuration attributes can be overruled for an individual switch.

l Switch Ports across all physical switches are associated with a Switch Group and can be simultaneously bulk
edited.

From the Switch Groups tab, the administrator can navigate to the Switches and the Switch Ports tabs for
configuration. The Dashboard tab is used to monitor the health condition of the virtual stack.

The process for creating a new switch group configuration is as follows:

1. Navigate to Configuration > Switch Groups.
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2. Click New Switch Group.

NOTE:

To Edit the Configuration of existing Switch group, click Edit icon, navigates to Switch Group
Configuration page.

3. Configure the following tab parameters to create a Switch groups:

l Basic

l Management

l Network

l Security

l User-Defined Overrides

NOTE:

l Toggle the Show Advanced button to view the advanced options of the Switch
Groups.

l Click Save on individual tab parameters or click once after entering all the four tab
parameters.



Basic
The Basic tab provides options to the user to configure the device name as well as other standard values used
to identify a switch.

1. Navigate to Configuration > Switch Groups > Basic.

2. On the Basic page enter device identification data such as:

l Name

l Contact

l Description

Note:

l The special characters should be used to create Switch Groups names (Eg: a-zA-Z_-
*&%#@!<>.() []^~`$1234567890). The user can also rename them if required.

l By default password will not be configured. User has to configure the password for
Switch Group.

l By default Auto Sync for automatically push configuration is enabled.

3. Click Save.

Management
1. Navigate to Management page.

2. Enable the Daylight Saving Time and enter the details.

Note:

cnMatrix Switches supports SNMP configuration from release 3.0.4.
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3. Click Add New to add Administrator Access, enter the details and click Add.

4. Password should match the special characters as shown below:

5. Click Save.



Network
The Network page allows the user to configure VLANs, PBA, IP Route, and Spanning Tree details.

Note:

From release 3.0.4 cnMatrix Switches supports MSTP Mode and Path Cost Method in
Spanning Tree.

1. Navigate to Switch Groups > Network, enter the details of VLANs, Policy Based Automation, MAC List File
Server Settings, IP route, and Spanning Tree.

Note: Use Site Name for localization, MAC List File Server Settings, and MAC Lists are cnMaestro X features.

2. To Add a new VLANs click Add New.

a. Enter the VLAN ID.

b. Enter the VLAN Name.

c. Enable the IGMP Snooping.

d. Enable the DHCP Snooping.

e. Enable the ARP Inspection.

f. Enable the Voice VLAN.

g. Click Add.
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3. To Add a new IP Route click Add New.

a. Enter the Destination Network.

b. Enter the Subnet Mask.

c. Enable the Next Hop.

d. Enable the Distance.

e. Click Add.

4. Enable Spanning Tree.

a. Select the Mode RSTP from the drop-down.

l Select Path Cost Method Long or Short.

l Select Priority.

b. Select the Mode PVRST from the drop-down.

l Select Path Cost Method Long or Short.

l Select Priority.



c. Select the Mode MSTP from the drop-down.

l Select Path Cost Method Long or Short.

l Enter the Region Name and Revision.

l User can edit Priority by clicking edit icon.

l Select the Priority and click Update.
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5. Click Save.

Security
In Security page user can configure RADIUS and Access Control List (ACL) details.

To configure Security:

1. Navigate to Switch Groups > Configuration > Security tab

2. Enter Server Address.

3. Enter RADIUS Key.

4. In AAA Authorization Server select None or RADIUS from the drop-down.

5. Enter RADIUS Dynamic Authorization.

6. In IP ACL, click Add New.



l Enter ACL Name.

l Select the appropriate Protocol from the drop-down.

l Enter Source IP/Mask.

l Enter Destination IP/Mask.

l Click Add.

7. Click Save.

User-Defined Overrides

Note:

The minimum device software version supported for this feature is 4.0.

User-Defined Overrides allows you to apply configuration in cnMatrix switches. If there are conflicts, the below
settings will take precedence. The format used is the same as a configuration file exported from the device via
its web UI or the "View Device Configuration" link in the device level configuration page.

Import Switch Group

1. Click Import Switch Group. A dialogue box appears.

2. Select the Scope from drop-down.

3. Select import.json and import the file.

4. Click Import.

Delete Switch Group

To delete Switch Group from the list click Delete icon of the specific device row.
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Retry Configure
When the user tries to apply any Switch Group on the device and if the job was skipped for the device as it was
offline, the reason for the skip will be displayed as " Device was offline", in the Jobs page. In this case, when
device comes Up and connects to cnMaestro, then cnMaestro will create an Auto-sync job for that device and
pushes the Switch Group. (It will not apply to the switch group if the "Auto-Sync" was disabled in the switch
group).

NOTE:

The config update (auto-sync) will happen only when the Auto-Sync option was enabled in
the Switch Groups page. If the device was skipped/failed because of any other reason other
than the "Device was offline", then the device will not be updated.

Create a Configuration Job
Configuration job can be created from System/Network/Tower/Site/Device Configuration page. Select a
device type and a set of devices along with switch groups to which they will be mapped. This can be done in
three steps:

1. Select the Switch Group that needs to be pushed from drop-down.

2. Select the list of Switch Group Device.

3. Click Apply Configuration

Synchronize (Sync) Configuration
Switch Groups can be configured to synchronize automatically or manually when they are updated. The setting
is found in the Switch Group configuration.



Switches by default synchronize automatically (so any change of switch group, followed by a Save, will
immediately push configuration to the devices without manual intervention).

Manual Synchronization
Manual configuration synchronization allows the user to synchronize any devices with a single action rather
than updating each device separately. The page is located at Administration > Sync Configuration.

Sync Configuration has the following fields:

l Device (Hostname)

l Type

l Status (Online/Offline)

l Network (Network in which device is present)

l Site (Site under which device is present)

l AP Group/Switch Group (AP Group/Switch Group to which device is mapped)

l Sync Status (Sync status will tell whether job is completed or failed )

Steps to Sync Configuration:

Perform the following steps for Sync Configuration:

1. Navigate to System > Configuration > Sync Configuration.

2. Select the devices to synchronize and click Sync Configuration.

3. Click the Sync Now.
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User can also synchronize devices from Application >Sync Configuration.

NOTE:

Sync configuration can only be used if a Switch Group is already mapped to the device.

Policy Based Automation (PBA)
Cambium Networks PBA feature fully automates commonly performed operations, improving network security
while eliminating potential configuration errors. It allows the user to automatically configure switch port
settings based on the device connected to the port. These dynamic PBA settings remain in-use for the duration
of the device connection and are automatically cleared when the device disconnects from the switch.

PBA configuration is common to all switches within a Switch Group.

NOTE:

Dynamic PBA updates are indicated by asterisk * on the Switch Dashboard and on the Switch
Ports pages.

Configure the PBA as follows:

1. Navigate to Switch Groups > Configuration > Network > Policy Based Automation.

2. Navigate to Rules tab.

3. Click Add New to set the rules.

4. Click Add.

5. Navigate to Actions tab.



6. Click Add New to set the actions.

7. Click Add.

8. Navigate to Policies.

9. Click Add New to set the policies.
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In cnMatrix dashboard page, user can navigate to the following pages using Action drop-down menu in Port
Status

l Port Configuration

l Port Statistics

l Topology

l Remote CLI

l Port Operations
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Switches
The Switches page is accessed by selecting the Switch Groups > Switches tab lists all of the physical switches
assigned to the Switch Group. The Switch Dashboard and switch override configurations settings are accessible
through this page.

Switch overrides allows certain attributes for each switch to be configured individually.

NOTE:

For configuration, a switch must belong to a Switch Group.

Configure the Switch Group as follows:

l Navigate to Switch Groups > select the switch from the list and click Switches page to view and edit the
onboarded switches.

The Switches details view displays following fields by default:

l Device, Health, Onboarding Status, Serial Number, IP Address, Switch Group, Type, Site, and Action tab.

Action column can be used to edit or delete any device of the Switches.

User can click on top bar to include additional fields in Switches Detail view.

Export Switches

Perform the following steps to export the Switch table:

1. Click Export. A dialogue box appears.

2. Select Export page as CSV/PDF/all as CSV and export the file.



Action

Action column can be used to edit or delete any device of the Switches.

1. Click Action. A dialogue box appears.

2. Select Configuration to edit the device details or click Edit icon .

3. Select Software Upgrade to update the device software or click .

4. Click to delete the selected device from the list.

Switch Configuration
To edit or configure the switches, click the Edit or Configuration from the Action drop-down.

Navigates to the Device Configuration page.

1. Enter the Device Details, Set the service location and Device Configuration.
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2. Click Apply Configuration.

Device Configuration
Device Configuration allows you to configure the Configuration Method as Switch Group/Template.

Switch Group Configuration Method

Enable the Switch Group and select a device from the Switch Group drop-down.

To Edit or Create a Switch Group. Refer to the Switch Groups Configuration.

Navigate to the Advanced Settings and configure the following parameters:

VLAN Interface

VLAN Interface allows the user to edit/Add the VLAN details such as VLAN ID, DHCP Client, IP Address, and
Subnet Mask.

l Click Advanced Settings in Configuration page and navigate to VLAN Interface tab.

#Switch


l Click Edit Icon or Add New.

l Enter the required details and click Add

Switch Group Configuration Method

Spanning Tree

Certain configuration parameters are different for each Switch, and these are highlighted within cnMaestro as
Overrides.

Configure the spanning tree to override as follows:

l Click Advanced Settings in Configuration page and navigate to General tab.

l Click Enable Spanning Tree Overrides.

l Select the Spanning Tree parameters.

NOTE:

If Spanning Tree is disabled the overrides feature will be disabled on the Switch
configuration.

IP Routes
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IP Routes allows the user to configure the Default Gateway and IP Routes to override the Switch Group.

l Configure the IP Route as follows:

l Enable the IP Routes Override and enter the Default Gateway.

l Click Add New.

l Enter the parameters such as Destination Network, Subnet Mask, Next Hop, and Distance.

l Click Add.

Default gateway IP will override the all IPs of the Switch Groups.

General

General tabs allows to configure PBA Localization settings to override the Switch Group settings.

To configure the PBA Localization perform as follows:

l ClickAdvanced Settings in Configuration page and navigate to General tab.



l Enable PBA localization overrides.

l Select Use Site Name or Custom.

l Enter PBA Uplink Ports.

Switch Ports
The Switch Ports table displays the list of Ports and the Port Channel assigned to the specific switch. The Switch
Ports table allows administrators to configure the port settings by port ID for all ports within the Switch Group.
By default, a port ID identifies the switch (by switch name) and port number.

For example: Gi0/1

It supports bulk editing of Switch Port settings across all physical switches.

To view the Switch Ports, navigate to Configuration > Switch Groups > Switch Ports.

Ports
The Ports table supports creating port channels, editing port configuration and configuring port parameters.
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Navigate to Switch Ports > Configuration tab, configure the following parameters:

l General

l Physical

l Network

l Security

General Tab

The Ports General details view displays following fields by default:

l Port, Tags, Description, Interface, Administrative State, Operational State, PoE Capable, and Edit.

l Click on Apply Configuration whenever you are sure to apply the modified configuration, preferably after
all the port details are updated.

User can click on top bar to include additional fields in Ports General Detail view.



Click Edit icon or Port device in the list to edit the Ports Configuration General tab details.

Navigate to Switch Groups > Switches > Port Configuration.

Enter the Tags and Description details and Click Save.

NOTE:

After modifying the port or channel details, you can apply the configuration to the device
by clicking the Apply Configuration button at the bottom of the Switch Ports page.
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Physical Tab

The Ports Physical details view displays following fields by default:

l Port, Tags, Operational State, PoE State, PoE Priority, Speed, Duplex, MTU, and Edit.

User can click on top bar to include additional fields in Ports Physical Detail view.

Click Edit icon or Port device in the list to edit the Ports Configuration Physical tab details.



Enter the Port Management and PoE details and click Save.

Network Tab

The Ports Network details view displays following fields by default:

l Port, Tags, Type, VLANs, Native VLAN, Channel ID, PBA Policy, PBA State, STP State STP Priority, and
Edit.

l User can click on top bar to include additional fields in Ports Network Detail view.
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Click Edit icon or Port device in the list to edit the Ports Configuration Network tab details.



Note: LLDP Actions > Expiration Rest option is a Pro feature.

Enter VLANs, STP, Policy Based Automation, and Storm Control details and click Save.

Security Tab

The Ports Security details view displays following fields by default:

l Port, Tags, QoS Trust, User Priority, Dot1x port-control, Protected Port, DHCP Snooping Trust, ACL Name,
and Edit.

User can click on top bar to include additional fields in Ports Security Detail view.
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Click Edit icon or Port device in the list to edit the Ports Configuration Security tab details.

Enter 802.1xPort Control, DHCP Snooping Trusted State, QoS, Protected Port, Access Control List details and
click Save.

Port Channel
l To create a Port Channel, select a Port from the list under the specific parameters and click Create Port

Channel.

l Create Port Channel window Pops-up, enter details.

l Click Create.



The Port Channel details view displays following fields by default:

l Channel ID, Switch, Tags, Description, VLANs, Native VLAN, Type, Administrative State, Mode, Ports, STP
State, and STP Priority.

User can click on top bar to include additional fields in Port Channel Detail view.

Statistics
The Statistics page displays the latest data and statistics of each Port. Port statistics match the Client statistics
and generate the Client View.

To view the Switch Ports Statics navigate to Configuration > Switch Groups > Switch Ports > Statistics.

User can click on top bar to include additional fields in Statistics Detail view.
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Device Details
Details page provide the information about the switches Overview, Topology, and Port Statistics.

Details Overview
To view the details of the overview page, navigate to the Details > Overview tab.



Topology
To view the details of the Topology page, navigate to the Details > Topology tab.

Port Statistics
To view the details of the Port Statistics page, navigate to the Details > Port Statistics tab.
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60 GHz cnWave Network Configuration

cnWave 60 GHz operates with Cambium Networks cnMaestro management system. cnMaestro simplifies
device management by offering full network visibility and zero-touch provisioning. Using cnMaestro, user can
view network status and perform a full suite of wireless network management functions in real time including
optimizing system availability, maximizing throughput, and meeting the emerging needs of business and
residential customers.

Managing E2E Network
The Monitor and Manage tab displays the monitoring panel of 60 GHz cnWave for cnMaestro. This section
includes the following:

l Dashboard

l Notifications

l Configuration

l Links

l Statistics

l Software Update

l Report

l Tools

Dashboard
Dashboard pages are customized for each device type and aggregation level (such as E2E Network, Node, and
Site). The dashboard section displays the Nodes, Links, Wireless Throughput of PoP(s), Wired Throughput of
PoP(s), Alarms, E2E Controller Details, Top Active Alarms, Map, Top Links by MCS, Top Links by RSSI, Top Links
by SNR, Top Node(s) Top PoP(s), Top DN(s), and Top CN(s).



NOTE:

Backup CN links are not shown as Offline links in links widget.

Auto Manage IPv6 Routes (E2E Controller↔Node)

The External E2E Network. dashboard page displays the Auto Manage IPv6 Routes (E2E Controller ↔ Node)
tab, if you enable Auto Manage Routes in the Tools > Settings page of External E2E Network.

This feature automates IPv6 routes for DNs and CNs based on status of the topology and PoP nodes. It is
applicable only if PoP nodes and E2E Controller are in the same Network or containing the same prefix length.
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NOTE:

Auto Manage IPv6 Routes is not applicable for Onboard E2E Controller.

E2E Controller Details

E2E Controller Details displays the details such as Version, Management Address, IPv6 Address, IPv6 Gateway,
Sites, Nodes, (PoP/DN/CN), Deployment, Layer 2 Bridge, Country, Prefix Allocation, Topology Sync, and
System Clock

l If Onboard E2E controller is enabled in device and managed by cnMaestro, it displays deployment as
Running Onboard.



l If External E2E controller is managed by cnMaestro, it displays deployment as External.

Dashboard Maps

In the dashboard map, when user hovers on particular PoP, DN or CN it pops-up the device details. When user
hovers on particular link it pops up the link details.
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l Dotted line displays the Backup CN link between the DN and CN..

l Continuous line display the wireless link between PoP, DN, or CN..



l Continuous line with Wired tag displays the wired link between PoP, DN, or CN.

l Continuous line with gray color displays the Disabled Ignition link.
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Notifications
Notifications are same as shown above for other devices, refer to Notification for more details.

Configuration
Configure the following after onboarding the External or Onboard E2E Controller:

l Basic

l Management

l Radio

l Security

l Advanced

l E2E Controller

NOTE:
Once user selects the Auto-assign IPv6 Addresses while configuring E2E Controller and PoP
node. Use the same IPv6 during the prefix allocation.

Basic Configuration

1. Navigate to Configuration > Basic to configure basic settings of E2E Controller.



NOTE:
l Prefix allocation automatically gets updated, when E2E Controller is managed by

cnMaestro.
l Prefix Length of 48 is supported in Seed Prefix configuration.

2. In the Prefix Allocation, select Centralized or Deterministic to allocate the loopback IPv6 address for the
devices.

3. Enter the Seed Prefix and Prefix Length.

4. Enabling Layer 2 Bridge is optional.

Enabling this option will enable Layer 2 network bridging (via automatically created tunnels) connected
across all nodes and facilitates bridging of IPv4 traffic across the wireless networks. It also enables the
configuration of VLAN Management and Ports on all PoP, DN, and CN Nodes.

In Layer 2 Bridge, select the check box to enable Layer2 Network Bridging, choose Tunnel Concentrator as
Best PoP or Static.

l If user selects Tunnel Concentrator as Static, enter an external switch/router IPv6 address.

NOTE:

IPv6 Layer3 CPE Address can be enabled when E2E Controller is running 1.1 verison and
Layer 2 Bridge is disabled.

5. Select the IPv6 Layer3 CPE Address as SLAAC or DHCPv6 Relay.

If user selects IPv6 Layer3 CPE Address as DHCPv6 Relay, user can configure the DHCPv6 server address. The
CPE device sends a DHCP request.The CN device uses the Address and Prefix from the corresponding DHCP
pool and DHCPv6 server assigns address to the CPE device.
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NOTE:

l By default Country is Other, user can
configure it.

l Enter the Hostnames or IP address of NTP
server.

6. Select the Country from the drop-down.

7. Enter the DNS Server.

8. Enter NTP Server.

9. Select the Time Zone from the drop-down.

NOTE:

By default Wireless Scans will be disabled.

10. Click Save.

Management

Management configuration allows user to configure and manage the credentials of the administrator and it
allows enable SNMP.

1. Navigate to Configuration > Management to set the Device GUI Passwords and to enable the SNMP.

2. Click Save.



Radio

The Radio page manages the Radio related settings.

l Wireless Scans

l Enabled/Disabled—Enable or disable scheduled beam adjustment.

l Scan Interval—Specify an interval between wireless scans, in seconds.

l CN Channel Rescan

l Enabled/Disabled—Enable or disable CN channel rescan.

NOTE:

You can enable CN channel rescan only when Fast Acquisition is set to either
Disabled or Compatibility Mode.

l CN Channel Rescan timeout—Specify a timeout interval for a CN that does not have a wireless link
to reinitiate channel scanning, in seconds.

l Fast Acquisition

NOTE:

Fast acquisition is supported only on 60 GHz cnWave devices running System
Release version 1.3 or later.
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l Mode

l Disabled—On link acquisition, performs IBF scan on 61 fixed beams. This is the default
option.

l Compatibility Mode—On link acquisition, tries the last known (if present) beam index. If
unsuccessful, tries normal IBF scan.

l Static Mode—On link acquisition, tries the last known (if present) beam index. If
unsuccessful, the association fails.

l Asymmetric TDD

l Duty Cycle—Select a duty cycle from the drop-down list. For example:

l 60% Downlink / 40% Uplink—Set 60% of physical bandwidth for downloading and 40% of
the physical bandwidth for uploading.

l Other Settings

l Enable post acquisition beam refinement—Select to enable.

Security

Security page allows the user to enable the wireless security PSK or 802.1x. The disabled option connects as
unsecure devices.

To Enable PSK :

1. Navigate to Configuration > Security tab.

2. Select PSK in Wireless Security.

3. Enter the Passphrase.

NOTE:

If Passphrase field is blank, default psk key is used.

4. Click Save.

To Enable 802.1x



1. Navigate to Configuration > Security.

2. Select 802.1x in Wireless Security.

3. Enter the Radius server IP.

4. Enter the Radius Server port.

5. Enter the Radius Server Shared Secret.

6. Click Save.

Advanced

Advanced tab allows the advanced user to edit the settings of the Table and JSON format of the E2E Controller.

It also allows to optimize the network using the following options:

l Optimize Control Superframe Allocation

l Optimize DPA Zone Allocation

l Clear Node Auto Configuration

Table

In the Table advanced user can view and edit Field Name and Value. The field names are sorted in alphabetical
order.

To add a field:

1. Navigate to Configuration > Advanced.

2. Click Add New.

3. Enter the Field Name and Value.
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4. Click Save.

JSON

JSON allows Advanced user to download or view and edit in json format.

To view or edit the JSON file:

1. Navigate to Configuration > Advanced > JSON.

NOTE:

Enabling the Device Logs is supported only for External E2E Controller devices and it allows
the Support team to view the logs.

2. Enable Device Logs and click Update.

E2E Controller

E2E Controller allows the advanced user to set the Table and download the JSON file.

Table

In E2E Controller Table user can Edit or add Field Name and Value.

To Add Field:

1. Navigate to Configuration > E2E Controller.

2. Click Add New.



3. Enter the Field Name and Value.

4. Click Save.

JSON

JSON allows Advanced user to download or view and edit in JSON format.

To view or edit the JSON file:

1. Navigate to Configuration > E2E Controller > JSON.

Links
Links provide the details about the link established between the nodes and also provides the option to create a
new Wireless, Wired and Backup CN link.

l List

l Statistics

l Events

List

The List page provides details of General: Name, A-Node, Z-Node, A-Node MAC, Z-Node MAC, Alive, Link Time,
Type, Ignition Attempts, Distance, Azimuth, Backup CN Link, and Ignition Status for each link of all the devices
in the E2E Network in a page format.

To add a link, perform the following steps:

1. Navigate to the E2E Network tree menu click ( ) icon and click Add Link from the drop-down or navigate

to Network > Links > List > Add New.
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2. Add Link window pops-up.

3. Select Link Type Wireless or Wired.

Figure 267 Wireless link

Figure 268 Wired link

NOTE:

In Wired Link Type, add Sector is disabled.



4. Select the Node from the drop-down in A-Node.

5. Select the Sector of the node from the drop-down in A-Node Sector.
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6. Select the Node from the drop-down in Z-Node.

7. Select the Sector of the node from the drop-down in Z-Node Sector.



8. Enable the Backup CN Link.

l If the link between PoP or DN and CN gets disconnected. This Backup CN link provides the backup
connectivity from DN or PoP to particular CN.
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9. If user selects Disable Ignition option, wireless link creates with disable ignition. User need to manual select
Enable Ignition from link options.

10. Click Save.

11. Once the link is successful it displays the Alive status as Yes.

Available link options are:

l Send Assoc

l Send Dissoc

l Enable Ignition

l Disable Ignition

l Clear Fast Acquisition Beams

Delete Links

In the Links tab you can delete the E2E Controller Network Links.

To delete the links:

1. Navigate to Links > List.

2. In the List table select one or more links to delete. User can also delete individual link, by selecting delete ( )

icon in the table.

3. Click Delete.

Import List

In Links tab you can import the E2E Controller Network Links.

To import the links:

1. Navigate to Links > List.

2. Select Import.



3. Import Links pops-up.

4. Click Download Template to download the sample template in .CSV format.

5. Select the file and click Import.

Export List

In Links tab you can export the E2E Controller Network Links.

To export the links:

1. Navigate to Links > List > select Export.

2. It exports .csv file format as shown below.

Statistics

Statistics pages provides details of Basic: Name, Direction, A-Node, Z-Node, Alive, Link Time, Type, Distance,
Azimuth, Rx Golay, Tx Golay Detailed Statistics: A-Node Sector MAC, Z-Node Sector MAC, RSSI, Rx Airtime%,
Rx Beam Azimuth Angle, Rx Beam Elevation Angle, Rx SNR, Rx MCS, Rx PER, Rx Scan Beams, Rx Throughput,
Tx Airtime%, Tx Beam Azimuth Angle, Tx Beam Elevation Angle, Tx Power Index, EIRP, Tx MCS, Tx PER, Tx Scan
Beams, Rx Errors, Rx Frames, Tx Errors, Tx Frames, Tx Throughput, Rx Time, Tx Time and Link Fade Margin
each link of all the devices in the E2E Network in a page format.
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You can Apply Filter(s) for Name, A-Node, Z-Node, A-Node Sector MAC, Z-Node Sector MAC, and Alive. The
Auto Refresh option allows to refresh data automatically as per Refresh Interval, which is configured for five
minutes. By default, Refresh Interval is 10 seconds. This option gets disabled after five minutes. Then you must
click Enable Auto Refresh and specify the refresh intervals to enable this option. To Enable Auto Refresh,
perform the following steps:

1. Click Enable Auto Refresh.

2. Select Refresh Interval from the drop-down.

l 10 seconds

l 30 seconds

l 60 seconds

3. Click Start to start Auto Refresh.

4. Click the info icon to view Refresh Interval and Remaining Time.

Export Statistics

To export the Statistics:

1. Navigate to Links > Statistics > select Export.



2. It exports .csv file format as shown below.

Events

Events provide the details of link availability, hourly link availability in percentage, link availability in different
time lines, and distance of the link.

Figure 269 Links > Events

Field Description

Link Name Name of the link.

Alive Status of the link (Yes or No).

Availability
Chart

Displays the link availability based on time range selected from the drop-down.When you
hover the mouse on the Availability Chart, the link availability is shown as described:

1. If you select time range as Last 1 Hour, then link availability for every 5 minutes is
displayed.

Table 67: Events fields
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Field Description

2. If you select time range other than Last 1 Hour, then link availability for every 1 hour is
displayed.

l Hover on the link to see the hourly availability as shown in Figure 271.

l Clicking on percentage link availability displays pop-up window as shown in Figure 272

l Link availability is presented in different colors in the chart as shown in Figure 270

Availability
Percentage

Availability of link is shown in percentage in the Availability column as shown in Figure 271.

Distance Distance of the link in meters.

Table 67: Events fields

Figure 270 Link Availability in Percentage

Availability percentage per link is calculated including the duration when E2E Controller was Offline in
cnMaestro.



Figure 271 Link Availability

Figure 272 Link Status

Events details are available for Last 1 hour, Last 6 hours, Last 12 hours, Last 24 Hours, Last 2 days, Last 4 days,
and Last 7 days.

NOTE:

Event details for Custom Range and Last 30 days is available only for cnMaestro X users.

Statistics
The E2E Network provides the following statistics:

l Nodes
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l BGP

Statistics

Nodes provide a tabular aggregation of data, including General information on the nodes monitored, as well as
Wireless, Network, and Traffic metrics. Node Statistics pages provide details of General: Device, Serial Number,
IPv6 Address, MAC, Mode, Model, Status, Status Time, Site, Zone, PoP Node, Software Version. GPS: Sync Mode,
Fix Type, Satellites Tracked, Latitude, Longitude, Height. Network: Radio Channel, Main Aux SFP, Sector
Throughput (Tx), Sector Throughput (Rx),Ethernet Throughput (Tx), and Ethernet Throughput (Rx) each
device in E2E Network, generally in a page format.

Figure 273 Nodes Statistics

BGP

NOTE:

BGP statistics displays only if BGP option is enabled in Routing in PoP configuration.

BGP provides the details of Advertised Routes, Received Routes, and Peer details.



Figure 274 BGP Statistics

Software Update
The Software Update tab allows to update with the latest device software.

To update the software:

1. Select the Network and navigate to the Software Update tab.

2. In Software Update tab select the desired Versions from drop-down in Versions tab.

3. Select the Device.

4. In Job Options, do the following:

l Select Batch Size

l Enter Upgrade Timeout.

l Enter Download Retry Limit.

l Enter Download Timeout.

l Select the Download Protocol as HTTPS or Torrent.

l Enable the Skip Failures or Skip PoP Failures.

5. Click Add Software Job to device.
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NOTE:
Onboard E2E controller will support only one synced image. If user needs to sync another
image, select the image from Versions drop down and click Sync Selected Image.

The Software Update is performed on the devices managed by External E2E Controller and Onboard E2E
Controller as follows:

External E2E Controller

1. In the Networks, select External E2E Controller and check the Software Version.

2. From External E2E Controller menu options, select Update Software.

Software Update page appears.

3. In Versions drop-down select the version and the devices in the network for software upgrade.

Device software update version check for External E2E Controller is described in Table 68.



Table 68: Device Software Update: External E2E Controller

Version Example

If Software Version of the device is less than the
Software Version of the External E2E Controller
then Software Upgrade is successful.

External E2E Controller software version: 1.2.1

When Device Software Version is selected as 1.2.1 or
lower then Device Software is upgraded successfully.

If Software Version of the Device is selected
higher than the External E2E Controller version
then Software Upgrade fails.

E2E External Controller Software Version :1.2.1

When Device Software Version is selected as 1.2.2 or
higher then Device Software upgrade fails.

Error message:

Device version should not be higher than External E2E
Controller version 1.2.1

Onboard E2E Controller

1. In the Networks, select Onboard E2E Network and check the software version.

2. From Onboard E2E Network menu options, select Update Software.

Software Update page appears.

Device software update version check for Onboard E2E Controller is described in Table 69.
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Table 69: Device Software Upgrade: Onboard E2E Controller

Software Upgrade Example

If software version of Onboard PoP device is lower
and upgraded to higher version then Software
Upgrade is successful.

If the Onboard PoP device is running with 1.2, and
selected software version is 1.2.1 or higher then
Onboard PoP device is upgraded successfully.

If software version of all devices including Onboard
PoP are lower and upgraded to higher version then
Software Upgrade is successful.

If all the devices including the Onboard PoP are
running with 1.2, and selected software version is 1.2.1
or higher then all the devices including PoP device are
upgraded successfully.

If software version of all devices are higher and
downgraded to lower version except Onboard PoP
then Software Upgrade are successful.

If all the devices are running with 1.2.2, and selected
software version is 1.2 then all the devices expect PoP
device are upgraded successfully.

If software version of all devices including PoP are
higher and downgraded to lower version then
Software Upgrade are successful.

If all the devices including PoP are running with 1.2.2,
and selected software version is 1.2 then all the
devices are upgraded successfully.

If software version of all devices including Onboard
PoP are higher and downgraded to lower version
then Software Upgrade should fail if one or more
nodes running with higher version in list.

If all the devices including the Onboard PoP are
running with 1.2.2, and selected software version is
1.2.1 then Software Upgrade should fail.

If software version of Onboard PoP device is higher
and upgraded to lower version then Software
Upgrade for PoP fails, only when other devices
software version are higher.

If the Onboard PoP device is running with 1.2.2, and
selected software version is 1.2.1 or lower then
Software Upgrade of Onboard PoP device fails, only
when the other devices software version is 1.2.2.

If software version of all devices are lower and
upgraded to higher version except Onboard PoP
then Software Upgrade should fail.

If all the devices including Onboard PoP are running
with 1.2.2, and selected software version is 2.0
excluding PoP node, then Software Upgrade for all
the devices should fail except PoP node.

If software version of all devices including PoP is
running with same version, and when you select all
nodes to upgrade, then PoP fails to upgrade. You
need to manually upgrade the PoP node.

If all the devices including PoP are running with
software version 1.1 and selected software version is
1.2. If PoP failed to upgrade, then you need to
manually upgrade the PoP.

4. From the Versions drop-down, select the version and the devices in the network for software upgrade.

The Software Upgrade scenario for Onboard E2E Controller is explained in Table 69.

View Update Jobs

After adding the new Software Images, click View Update Jobs.



1. Navigate to the Administration > Jobs > Software Update.

2. Click Show More to view the Job Details.

Reports
Reports page provides details on how to schedule and generate different types of data reports such as Devices,
Active Alarms, Alarm History, and Events. For further details refer to Reports.

Map
Map shows how devices are connected in a E2E network, the state of the devices, and links in the E2E network.
To view the map, perform the following:

l Navigate to E2E Network > select Map icon in the left pane of the homepage to view E2E Network and 60

GHz cnWave devices and links as shown in Figure 275.
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Figure 275 Viewing E2E Network

NOTE:
Gray color lines are un-managed links and gray color nodes are un-managed nodes.

The following fields provides visual representation of the nodes and links:

l Device Overlay

l Link Overlay

l Options

l Details

l Device Auto Refresh



Field Description

Device
Overlay

1. Select the Mode type as Status to view the following:

l Status: The device status is Online or Offline.
l Type: The device types are PoP, CN, or DN in the E2E Network.

2. Select the Mode type as Channel and Polarity to view the following:

l Channel: The seven channels are represented in different color codes. Auto channel is

indicated as and Overridden channel is indicated as .
l Polarity: The polarity is represented as odd, even, hybrid odd, and hybrid even. Underlined

values indicate they have been Overridden in the node configuration.

3. Select the Mode type as Sector to view the following:

Sector: The two sectors are represented in two different color codes.

Table 70: Map fields in E2E Network
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Field Description

V5000 Sectors is shown below:

Link
Overlay

1. Select the Mode type as Status to view the following:

l Status: The link status is Online or Offline.

By default Ignition Disabled is checked, which appears in light gray.

Table 70: Map fields in E2E Network



Field Description

2. Select the Mode type as Golay to view codes.

l Golay: Golay is represented in color codes, as shown below:

3. Select the Mode type as SNR to view link qualities.

l SNR: SNR shows various SNR link qualities and is represented in different colors.

Table 70: Map fields in E2E Network
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Field Description

4. Select the Mode type as MCS to view link range.

l MCS: MCS shows the link status, and various link ranges represented in different colors.

5. Select the Mode type as RSSI to view link qualities.

l RSSI: RSSI shows various RSSI link qualities represented in different colors.

Table 70: Map fields in E2E Network



Field Description

6. Select the Mode type as Link Fade Margin to view link fade margins.

l Link Fade Margin: calculates link fade margins between two devices. For details on
overview and calculation, refer to the example described in Figure 276.

Note: Link Fade Margin is applicable only when E2E Controller and Device version are 1.2.2.

l Airtime%
l Throughput (Mbps)

Options Toggle to view Show Names and Show Prefix Zones, as described:

l Show Name: shows the name of the nodes available in the E2E Network.

Table 70: Map fields in E2E Network
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Field Description

l Show Prefix Zones: shows the prefix zone of each PoP that is communicating with each
other.

Details Details: displays the basic details of E2E Network when E2E Network is selected from the tree.

Table 70: Map fields in E2E Network



Field Description

1. Click ellipsis ( ) icon in the Details section to view E2E Network Dashboard.

2. When a device is selected from the map, the device details are displayed. Click ellipsis ( )

icon next to the device to view the device Dashboard and Topology Scan. For more details
on how to troubleshoot a node using Topology Scan refer Topology Scan.

Table 70: Map fields in E2E Network
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Field Description

l Node Throughput Test and Current Best Routes are added in the Troubleshooting
section.

3. When a link is selected from the map, link details are displayed. Click ellipsis ( ) icon next

to link to view the Actions details for the links.

l Link Throughput Test is added in the Troubleshooting section.

Device Auto Refresh: allows to refresh data automatically in the E2E Network.

1. Select the devices in the map and add it to the watch list for Device Auto Refresh.

2. Click the ( ) play icon to start Auto Refresh.

Table 70: Map fields in E2E Network



Field Description

Note: A maximum of 10 devices can be added to Device Auto Refresh.

3. Click ( ) to remove devices from Auto Refresh.

Table 70: Map fields in E2E Network

NOTE:
l Channel and Polarity mode type are available for cnMaestro X users only.
l Airtime%, Golay, SNR, RSSI, MCS, Link Fade Margin, and Throughput (Mbps) are

cnMaestro X features.

A new Link Fade Margin (LFM) statistics has been added to the displayed Link Statistics tab in 60 GHz cnWave
1.2.2 software version release. This statistic is shown in units of dB, and it is meant to provide operators with a
quick way to assess any additional system gain a RF link has available in order to help ride out potential RF link
fades due to weather (most typical) or other temporary RF link impairments. The rough calculation for LFM is
comprised of the RSSI received from a remote transmitter and assessing how much more TX power is available
(from the remote transmitter) and how far away the RSSI value is from an established receiver sensitively floor
of -72 dBm. The LFM allows operators quicky assess if/where you may have some marginal RF links that need
to be addressed in some way. Typical options would be changing an existing node out for a V3K (to get more
margin) or possibly dropping in an intermediate DN node such that their RF paths are shorter, typically
resulting in a much larger LFM.

Figure 276 Link Fade Margin
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Troubleshooting

l Topology Scan

l Node Throughput Test

l Current Best Routes

l Link Throughput Test

Topology Scan

Topology Scan X allows you to discover your entire network and create comprehensive, detailed network
topology maps. This tool will only detect nodes operating in responder mode. It will not detect CNs with a
wireless link already established. Offline nodes with a configured channel override will not be detected on a
different channel.

NOTE:

Topology Scan will cause a momentary throughput reduction in nearby links.

1. Select a Node from the Map.

2. Click ellipsis ( ) icon next to the device to select the Troubleshooting > Topology Scan.

Topology Scan preview window is displayed towards the left pane.

3. Click Start Topology Scan. Topology Scan begins as shown in the following figure.



4. Click Configure SNR Limit ( ) next to Topology Scan header to add new value or reset the existing value.

By default SNR value is 5 dB.

5. Click ( ) refresh icon to scan again.

The results are based on Link Quality by SNR and the results are shown in the left pane. MAC Address of the
links and the Link Quality is displayed.

After topology scan, map displays available nodes and links in the network by Link Quality color codes. Only
links available with GPS coordinates are shown in the map. You can add site, node, and link to the topology by
clicking the plus sign In Topology.

6. Add Node to Topology window pops up.
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7. Enter the node and link details and click Save.

Node Throughput Test X

To run a node throughput test, do the following:

1. Select a device except the POP Node from the Map.

2. Click ellipsis ( ) icon next to the device name in the right pane, and select Troubleshooting >Node

Throughput Test X



3. Enter the Duration between 5 to 300 seconds.

4. Select the Hop by hop throughput test check box to view the throughput for each hop separately.
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5. Click Start.



Current Best Routes X

To find the current best routes, do the following:

1. Select two nodes from the Map.

2. Click ellipsis ( ) icon next to the device, and select Troubleshooting >Current Best Routes X

3. Click Start.
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Link Throughput Test X

To run a link throughput test, do the following:

1. Select a Link from the Map.

2. Click ellipsis ( ) icon next to the link, and select the Troubleshooting >Link Throughput Test X



3. Enter the Duration between 5 to 300 seconds.

4. Click Start.

NOTE:

Show Prefix Zones is enabled only if Prefix Allocation is set to Deterministic.

Tools
The Tools page allows the user to perform the following actions:

l Operations

l Diagnostics

l Debug

l Remote Command
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l Services

l Settings

Operations

External E2E Controller deployment

If the device is deployed through External E2E Controller it displays the operations page as follows:

l Restart E2E Controller performs the Restart.

l A System Backup and Restore the entire state of a E2E Controller server as a file and file can be used to
transfer data between two E2E Controller instances. It can be saved in local hard drive through the UI and
restored into a new E2E Controller instance to re-create.

l The Software Upgrade is to upgrade E2E controller and can be done through E2E controller package.

Onboard E2E Controller deployment

If the device is running Onboard E2E Controller it displays the operations page as follows:

l Operations page allows the user to Restart E2E Controller and perform the System Backup. It also stores the
entire state of a E2E Controller server as a file and file can be used to transfer data between two E2E
Controller instances. It can be saved in local hard drive through the UI and restored into a new E2E
Controller instance to re-create the application state.



Onboard E2E to External E2E Migration

When you onboard an E2E Controller to External E2E Controller with or without sites, consider the following
prerequisites:

l Applicable only on external E2E Controller running with 1.2.2 version or later.

l IPv6 reachability and routing configuration are pre-requisites.

l External E2E Controller should have higher version than Onboard E2E.

l PoP Devices IPv6 addresses must be connecting between each other.

When you onboard an E2E Controller to External E2E Controller with sites, consider the following prerequisites:

l Multiple Multi-PoP Networks must not be connected to same wired switch.

l Selected Onboard Network and External E2E Controller networks for migration should not have same
site and device names.

Post Migration Steps:

l Multi-PoP / Relay Port should be updated with the interface as in PoP interface configuration if not
already done, to allow the connection between PoPs.

l If the existing E2E Network if configured with BGP, migrated PoP BGP Configuration must be updated in
cnMaestro and then in POP GUI

l If the PoPs are not on the same L2 network:

l Controller configuration about broadcast should be set to true.

l If External E2E Controller and PoP devices are not connected/routed through a network router

l It is recommended to set Deterministic prefix algorithm

l Routes to each PoP with respective Seed Prefix should be added manually in E2E
Controller.

Perform the following steps to migrate Onboard E2E Controller to External E2E Controller:

1. Select Onboard E2E Network > Tools > Operations.

2. Click Start Migration.

The Onboard E2E Controller to External E2E Migration window appears.
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3. Select a new external E2E Controller network from the drop-down.

4. Enter IPv6 Address.

5. Enter IPv6 Gateway Address of PoP node, which is optional.

6. Select the checkbox next to Yes, I have downloaded latest E2E Controller backup.

7. Click Start Migration.

A successful message on migration process is displayed.

The Onboard E2E Controller network is migrated with all the sites and nodes into External E2E Controller, as
shown below:



Fallback to Onboard E2E Network

The fallback process is applicable only for External E2E networks where Onboard to External E2E Network
migrated. Perform the following steps to fallback to Onboard E2E Network after the migration from Onboard to
External E2E Network.

1. Change the Controller IPv6 in the PoP from cnMaestro in External E2E Controller.

2. Go to PoP GUI and when the status displays as not connected, Enable Onboard E2E Controller.

3. Disconnect the External E2E controller from cnMaestro.

4. Delete the devices and sites in cnMaestro when the External Controller is offline, as they will conflict with
Onboard E2E network devices when connected to cnMaestro.

5. In cnMaestro, approve the Onboard E2E network and restore the backup taken before the Migration.

6. Verify the Network and devices status in PoP device GUI and cnMaestro.

Diagnostics

Diagnostics page allows the user to gather Technical Support Dump and can be downloaded and sent to
cambium support team.

All the events information of E2E controller can be viewed under E2E Events. In E2E Events tab user can view
the Event ID, Time, Device, Level, Source and Reason of the E2E Network.
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Figure 277 Diagnostics

Debug

In Debug tab, you can view and download the Node logs by executing the following log:

l bridging

l e2e_minion

l openr

l pop_config (available for PoP device)

l exabgp (available for PoP device)

l cnAgent (available for Onboard PoP device)

l e2e_controller (available for Onboard PoP device)

To view the logs:

1. Navigate to Tools > Debug.

2. Select a node name from the Select Node drop-down.

3. Select the required log name from the Select Log drop-down.

4. Click Show Logs.

The output for the selected criteria appears as shown:



l Click download ( ) icon to download the generated output.

l Click clear ( ) icon to clear the output.

Remote Command

In Remote Command tab, user can view or download command logs by executing the following command:

l Show Interfaces

l Show Routes

l Show OpenR Adjacencies

l Show OpenR Prefixes

l Show SFP Power Details (applicable for V5000 and V3000)

l Show IPv4 Neighbors

l Show IPv6 Neighbors

l Show Wired Interface State Changes

l Ping

To execute the command:

1. Navigate to Tools > Remote Command.

2. Select a node name from the Select Node drop-down.

3. Select the required command from the Command drop-down.

4. Click Execute.

The output for the selected criteria appears as shown:
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5. Click the download ( ) icon to download the generated output.

6. Click the clear ( ) icon to clear the generated output.

To execute Ping command, perform the following steps:

1. Select the Ping command from drop-down.

2. Select Node or type of IP address (IPv4 or IPv6).

3. Select the following options:

l Destination Node

l Number of packets minimum 1 to maximum 10 (-c)

l Buffer Size minimum 1 to maximum 65507 (-s)

4. Click Start Ping.

Output is displayed, as shown in Figure 278.

Figure 278 Remote Command: Ping

Services

In Services page user can view the services running in E2E Controller.



Figure 279 Services

Settings

NOTE:

E2E Settings are not applicable for Onboard E2E Controller deployment.

External E2E Controller deployment

External E2E Network displays the Settings page as follows:

Remote SSH Management allows the user to enable and disable Remote SSH Management.

In Network Configuration user can configure the E2E Controller IPv6 Address and IPv6 Routes.

To change E2E Controller IPv6 Address, perform the following:

1. Navigate to Tools > Settings > Network Configuration tab.
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2. Click Generate to automatically generate IPv6 address or manually change the IPv6 Address of E2E
Controller.

3. Click Save.

To configure IPv6 Routes, perform the following:

You can also enable the Auto Manage Routes. This automates IPv6 Routes to DNs and CNs based on the
topology and PoP nodes status. It is applicable only if PoP nodes and E2E Controller are in same Network/Prefix
length.

If IPv6 routes is enabled as Auto Manage Routes, Type field displays as Auto.

To Enable Auto Managed Routes:

1. Navigate to Tools > Settings > Network Configuration tab.

2. Enable Auto Manage Routes.

3. Click Save.

To retain auto-managed routes, even after auto-managed routes is disabled, complete the following steps:

1. Navigate to Tools > Settings > Network Configuration tab.

2. Enable Retain Auto-Managed Routes.

3. Click Save.

4. Please wait pops-up.

Once the Auto Manage Routes is disabled, IPv6 routes can be managed through static routes and in type it
displays as Static.



5. Click Save.

To add new static IPv6 Routes:

1. Click Add New.

2. Enter Destination and Gateway.

3. Click Save.

The user can configure the NTP Settings to configure the time configuration of the server with hostname or IP
address.

To configure the NTP server:

1. Navigate to Tools > Settings > NTP Settings tab.

2. Enable the NTP Settings.

3. Enter Host Name or IP Address. It displays Current System Time and Status of the server.

500 | 60 GHz cnWave Network Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide



501 | 60 GHz cnWave Network Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide

Site Configuration
Sites are located within the networks and wireless access points attached to it.

To Add a Site

1. Navigate to Network and click icon.

2. Select Add Site from the drop-down.

3. Enter the Name, Altitude, and Accuracy.

4. Once the address is entered in the Map, Latitude and Longitude gets fetched automatically. You can also
enter the details Manually.



5. Click Save. When the Site is configured it gets added under the E2E Network.

To edit the Site perform the following:

1. Navigate to Network > Site > Configuration.

2. Edit the details and click Save.
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Site Dashboard
Dashboard pages are customized for each device type and aggregation level. The Site dashboard section
displays the Nodes, Links, Wireless Throughput, Wired Throughput, Alarms, Top Active Alarms, Top Links by
MCS, Top Links by RSSI, Top Links by SNR, Top Node(s), Top PoP(s), Top DN(s), and Top CN(s).

Figure 280 Site Dashboard



Node Configuration
Node can be configured through the Site Menu option by clicking the icon in Network or Site tree menu or

through Network > Site > Nodes and click Add.

NOTE:

From 3.1.1 release V2000 device (beta version) is supported.

To Add a Node:

1. Navigate to the Network > Site > Nodes.

Add Node window pops-up.

2. Click Add new.
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Click to add site.

Adding the Node allows the user to create the different Nodes as shown below:

l PoP Node

l DN

l CN

PoP Node configuration
To add a PoP Node:

1. Navigate to the Network > Site > Nodes.

2. Click Add New.

3. Add Node window pops-up.



4. Enter the PoP Name, select the Mode DN.

5. Enable PoP Node.

NOTE:
Once the PoP Node is enabled user needs to select the Routing and Interface details.

6. Enter the Serial Number .

7. Enter the Azimuth and Elevation.

8. In the PoP Configuration select BGP or Static Routing.

9. In Interface select Aux or Main or SFP or Disabled.
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10. Enter the IPv6 and Gateway Addresses.

NOTE:

Generate IPv6 provides Seed Prefix in CIDR format from which subnet prefixes are allocated
to all DNs and CNs (e.g. fdce:b00c:cafe:ba00::/56)

11. In IPv4 Management, enter the IPv4 Address, Subnet Mask and Gateway Address.

12. Click Save.

NOTE:

Once the PoP Node is configured, PoP(s) Onboarding Config.json file gets downloaded
automatically, which can be used to import and configure in the PoP Node UI.

Once the PoP node is configured it gets listed under the Site.



DN/CN Node configuration
To add DN/CN node:

1. Navigate to the Network > Site > Nodes.

2. Click Add New.

3. Add Node window pops-up.
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4. Enter the Node Name, select the Mode DN or CN.

5. Enter the Serial Number.

6. Enter the Azimuth and Elevation.



7. In IPv4 Management enter the IPv4 Address, Subnet Mask and Gateway Address.

8. Click Save.

9. Once the DN/CN node is configured, it gets listed under the Site.
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Replace Node

Replace Node allows to replace the existing faulty nodes with new nodes along with the configuration and links
of existing faulty nodes.

NOTE:

New node should be replaced with same model as existing node.

To replace Node:

1. Navigate to Node tree menu and select the node.

2. Click icon and Select Replace Node from the drop-down.

3. Replace Node window pops-up.

4. Enter the New Serial number.

5. Click Save.

PoP Node
Once the PoP node is configured it displays the monitoring panel of the PoP node.



Dashboard
Dashboard pages can be customized for each device type and aggregation level. The PoP node dashboard
section displays the Status, Links, Channels, Throughput, Sector Throughput (Sector 1 and Sector 2), Ethernet
Throughput (Main, Aux, SFP), Alarms, Top Active Alarms, Link MCS, Device Info, Sectors, and Ethernet.

NOTE:

l Sector Throughput (sector1) for V3000, V2000 and V1000.

l Sector Throughput (sector1 and sector2) for V5000.

l Ethernet Throughput graph with Main for V1000.

l Ethernet Throughput graph with Main, Aux, SFP for V5000 and
V3000.

l Ethernet Throughput graph with Main and Aux for V2000.

Figure 281 PoP Node Dashboard

Configuration

Basic

It displays the basic details of PoP node such as Name, Description, MAC Address, Azimuth, and Elevation. It
also allows to edit the name of the node.
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Figure 282 Basic

Radio

It allows the user to configure the EIRP, Adaptive Modulation, Sectors (channels, Polarity and Link(s) Golay),
and GPS.

NOTE:

Antenna and PTP deployment Range options is available only for v3000.



Figure 283 Radio

For V3000, MCS 13 is supported as seen the following UI:
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Network

Network tab allows the user for the PoP configuration, E2E Controller Configuration, BGP Configuration, IPv6
Layer 3 CPE, IPv4 Management, OOB, Other Settings (Multi-PoP or Relay Port, Enable Aux port power),
PTP External Failover, Ethernet Ports, and 1G SFP.

NOTE:

When Layer 2 Bridge is enabled in E2E Controller, Layer 2 Bridge option will be available in
PoP Network Configuration



Figure 284 Networks

Configure the Network as shown below:

1. Navigate to the Configuration > Network.

2. In PoP Configuration:

l Select the appropriate option in Routing and Interface.

l Enter the IPv6 Address.

l Enter IPv6 Gateway Address its optional.

3. In E2E Controller Configuration, enter the IPv6 Address.

4. In BGP Configuration add IPv6 Address.

516 | 60 GHz cnWave Network Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide



517 | 60 GHz cnWave Network Configuration Cambium cnMaestro Cloud 5.0.1 | User Guide

5. In IPv6 Layer 3 CPE

l Select IPv6 CPE interface as Aux, Main, or SFP.

l Enter IPv6 CPE Prefix.

6. In IPv4 Management:

l Enter IPv4 Address.

l Enter Subnet Mask.

l Enter Gateway IP Address.

7. In Ethernet Ports enable the appropriate option Main or Aux or SFP.

8. In Layer 2 bridge enable the appropriate options such as:

l Disable Broadcast Broadcast packets (except DHCP Offer and DHCP Ack) in the downlink
direction including client to client packets will be dropped.

l Disable Downlink Multicast Flood - Multicast packets in the downlink direction including client
to client packets will be dropped

l Disable Unknown Unicast Flood

l Disable IPv6

l Monitor PoP Interface Layer 2 tunnels will failover to next best PoP when the backhaul
interface of this PoP is down.

NOTE:

The configuration is applicable only when static routing is used and IPv4 gateway is
configured..

l Insert DHCP Option 82



9. In Other Settings enable Enable Aux port power and Multi-PoP / Relay Port.

10. In OOB Interface enable the appropriate option Main or Aux or SFP.

l Enter IPv4 Address.

l Enter Subnet Mask.

11. Click Save.

NOTE:

Once the configuration is updated successfully in cnMaestro, the same parameters needs to
be entered in the UI of the PoP Node GUI.

VLAN

NOTE:

From Software Update Version 1.1 of all nodes, supports configuration of the
VLAN Management and Ports.

Virtual Local Area Networks (VLANs) is a broadcast domain in a Layer 2 network. A broadcast domain is the set
of all devices that will receive broadcast frames originating from any device within the set and traffic will be
tagged when transporting over wireless.
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NOTE:

Only PoP node Management VLAN can be configured, if Layer 2 Bridge is not enabled in
E2E Network > Configuration > Basic page.

Node running version 1.0.1:

l When Layer2 bridge is disabled, Only PoP node Management VLAN ID can be
configured.

l When Layer2 bridge is enabled, all nodes Management VLAN ID can be configured.

Node running version 1.1:

l When Layer2 bridge is disabled, Only PoP node Management VLAN ID, Priority with
Outer Tag can be configured.

l When Layer2 bridge is enabled, all node management VLAN and ports can be
configured.

To add a Management VLAN:

1. Navigate to Configuration > VLAN.

2. Click Enabled.

3. Enter the VLAN ID and VLAN Priority.

4. Enable Add Outer Tag.



5. Enter S-VLAN ID.

6. Enter S-VLAN Priority.

7. Enter QinQ EtherType.

8. Click Save.

If Layer 2 Bridge is enabled in 60 GHz cnWave Network > Configuration > Basic page. User can configure
Management VLAN and Ports of PoP node, DN and CN.

NOTE:

VLAN settings are not applicable if Relay Port, SFP Port, or Aux Port is enabled on Network
page.
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To add a VLAN:

1. Navigate to Configuration > VLAN.

2. Click Enabled.



3. Enter the VLAN ID and VLAN Priority.

4. Enable Add Outer Tag.
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5. Enter S-VLAN ID.

6. Enter S-VLAN Priority.

7. Enter QinQ EtherType.

NOTE:

VLAN settings configuration of Main Port, SFP Port, or Aux Port is similar.

8. Select Port Q or QinQ types.

a. If user selects Q type perform as follows:

n Select Untagged Packets Allow or Drop.

n Enter Native VLAN ID.

n Enter Native VLAN Priority.

n Enter Allowed VLANs.

n To add new VLAN Remarking.

n Click Add New



l Enter Ingress VLAN and Remark VLAN.

l Click Save.

n To add new VLAN Priority Override.

n Click Add New.

l Enter Ingress VLAN and Remark VLAN.

l Click Save.

n Click Save.

b. If user selects QinQ type perform as follows:
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n In Untagged Packets select Allow or Drop.

n In Single Tagged Packets select Allow or Drop.

n Enter Native C-VLAN ID.

n Enter Native C-VLAN Priority.

n Enter Native S-VLAN ID.

n Enter Native S-VLAN Priority.

n Enter Allowed VLANs.

n Enter QinQ EtherType.

n To add new VLAN Remarking.

n Click Add New



l Enter Ingress VLAN and Remark VLAN.

l Click Save.

n To add new VLAN Priority Override.

n Click Add New.

l Enter Ingress VLAN and Remark VLAN.

l Click Save.

n Click Save.

Security

Security tab allows to reset the identity and password of the Radius user.
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Figure 285 Security

Advanced

Advanced tab allows the advanced user to edit the settings of the Table and JSON format of the PoP Nodes.

Table

In the Table user can view and edit Field Name and Value. You can sort field name in alphabetical order.

To add a field:

1. Navigate to Configuration > Advanced.

2. Click Add New.

3. Enter the Field Name and Value.

4. Click Save.



JSON

JSON allows advanced user to download or view the JSON format.

To download the file:

1. Navigate to Configuration > Advanced > JSON.

2. Click Show Full Configuration.

View Device Existing Configuration window pops up.

3. Click Download.
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Links
Links provide the details about the links between nodes, statistics and events of the links in the E2E Network.

List

List provide the details about the links of the nodes and also provides the option to create a new link. User can
delete the links in bulk by selecting the particular links. It also allows to export or import link details.

Figure 286 List

For more details to add a link and delete a link in the network refer List section.

NOTE:

By default A Node is selected as node, when adding new link in the network.

Export List

Export list allow the user to export the PoP links list.

To export the links :

1. Navigate to Links > List > select Export.

2. It exports .csv file format as shown below.

Import List

Import list allow the user to import the PoP links list.

1. Navigate to Links> List > select Import.



Import Links window appears.

2. Click Download Template to download the .CSV format file.

3. Select the file and click Import.

Statistics

Links Statistics pages provides details of Basic: Name, Direction, A-Node, Z-Node Alive Link Time Type Distance
Azimuth, Rx Golay, Tx Golay Detailed Statistics: A-Node Sector MAC, Z-Node Sector MAC, RSSI, Rx Airtime%,
Rx Beam Azimuth Angle, Rx Beam Elevation Angle, Rx SNR, Rx MCS, Rx PER, Rx Scan Beams, Rx Throughput,
Tx Airtime%, Tx Beam Azimuth Angle, Tx Beam Elevation Angle, Tx Power Index, EIRP, Tx MCS, Tx PER, Tx Scan
Beams, Rx Errors, Rx Frames, Tx Errors, Tx Frames, Tx Throughput, Rx Time, Tx Time, and Link Fade Margin
links created with PoP node, generally in a page format.

Export Statistics

Export list allow the user to export the PoP links Statistics.
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To export the Statistics :

1. Navigate to Links > Statistics > select Export.

2. It exports .csv file format as shown below.

Events

Events provide the details of link availability, hourly link availability in percentage, link availability in different
time lines, and distance of the link.

Figure 287 Link Events

Field Description

Link Name Name of the link.

Alive Status of the link (Yes or No).

Availability
Chart

Displays the link availability based on time range selected from the drop-down.When you
hover the mouse on the Availability Chart, the link availability is shown as described:

1. If you select time range as Last 1 Hour, then link availability for every 5 minutes is
displayed.

2. If you select time range other than Last 1 Hour, then link availability for every 1 hour is
displayed.

Table 71: Link > Events fields



Field Description

l Hover on the link to see the hourly availability as shown in Figure 271.

l Clicking on percentage link availability displays pop-up window as shown in Figure 272

l Link availability is presented in different colors in the chart as shown in Figure 270

Availability
Percentage

Availability of link is shown in percentage in the Availability column, as shown in Figure 271.

Distance Distance of the link in meters.

Table 71: Link > Events fields

Figure 288 Link Availability in Percentage

Availability percentage per link is calculated, including the duration, when E2E Controller goes Offline in
cnMaestro.

Figure 289 Link Availability
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Figure 290 Link Status

Events details are available for Last 1 hour, Last 6 hours, Last 12 hours, Last 24 Hours, Last 2 days, Last 4 days,
and Last 7 days.

NOTE:

Event details for Custom Range and Last 30 days are available only for cnMaestro X users.

Details
Details page provides the following device information:

l Overview

l Network

Overview

Overview page provides the device details and it also details of the last 3 software update history.



Figure 291 Details Overview Page

Network

Network page provides the Ethernet details of Main, Aux, and SFP.

Figure 292 Details Network Page

Tools
In Tools page, you can view the Status, Debug, details and Remote Command results of the device.

Status

In Status tab you can view the status of the device:

l Critical alarms

l Download Tech Support File

l Online or Offline

l Restart minion

l Reboot the device.
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Debug

In Debug tab user view or download the PoP logs by executing the following log commands:

l Bridging

l pop-config

l e2e_minion

l openr

l exabgp

l cnAgent (available for Onboard PoP device)

To view the logs:

1. Navigate to Tools > Debug.

2. Select the required log name from the Select Log drop-down list box.

l Click the download icon to download the generated output.

l Click the clear icon to clear the generated output.



Remote Command

In Remote command tab user view or download Command logs by executing the following commands:

l Show Interfaces

l Show Routes

l Show OpenR Adjacencies

l Show OpenR Prefixes

l Show SFP Power Details (applicable for V5000 and V3000)

l Show IPv4 neighbors

l Show IPv6 neighbors

l Show Wired Device State Changes

l Ping

To Execute the command:

1. Navigate to Tools > Remote Command.

2. Select the required command from the Command drop-down list box.

3. Click Execute.

The output for the selected critera appears as shown:

l Click the download icon to download the generated output.

l Click the clear icon to clear the generated output.

DN/CN Node
To create a new site, refer to Site.

To create a node, refer to DN/CN.

Dashboard
Dashboard pages are customized for each device type and aggregation level. The DN/CN node dashboard
section displays the Status, Links, Channels, Throughput, Sector Throughput (Sector 1 and Sector 2), Ethernet
Throughput (Main, Aux, SFP), Alarms, Top Active Alarms, Link MCS, Device Info, Sectors, and Ethernet.
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Figure 293 DN/CN Node Dashboard

Configuration
Configuration page allows the user to configure the following details of CN/DN:

l Basic

l Radio

l Network

l VLAN

l Security

l Advanced

Basic

It allows to configure and reset the basic details of DN/CN node such as Name, Description, MAC Address,
Azimuth, and Elevation. It also allows to edit the name of the node.



Figure 294 Basic

Radio

NOTE:

GPS option is not enabled for v1000.

It allows the you to configure the EIRP, Adaptive Modulation, Sectors (channels, Polarity and Link(s) Golay), and
GPS.

Figure 295 Radio
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Network

Network tab allows the user to edit the Layer 3 CPE, IPv4 Management, Ethernet Ports, PTP External Failover,
and Other Settings.

Figure 296 Network

VLAN

VLAN configuration of CN/DN is same as PoP Node VLAN as shown above.

NOTE:

Enable Layer 2 Bridge in 60 GHz cnWave > Configuration > Basic page to configure the
CN/DN VLAN.

Security

Security tab allows to reset the identity and password of the Radius user.

Figure 297 Security



Advanced

Advanced tab allows the advanced user to set Field Name and Value.

1. Navigate to Configuration > Advanced.

2. Click Add New.

3. Enter the Field Name and Value.

4. Click Save.

JSON

JSON allows Adavanced user to view the JSON format.
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To download the file, perform the following steps:

1. Navigate to Configuration > Advanced > JSON.



2. Click Show Full Configuration.

3. View Device Existing Configuration pops up.

4. Click Download.
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Links
Links provide the details about links of the node and also provides the option to create a new link. User can
delete the links in bulk by selecting the particular devices.

List

List provide the details about the links of the node and also provides the option to create a new link. User can
delete the links in bulk by selecting the particular link.

Figure 298 List

Statistics

Links Statistics pages provides details of Basic: Name, Direction, A-Node, Z-Node Alive Link Time Type Distance
Azimuth, Rx Golay, Tx Golay Detailed Statistics: A-Node Sector MAC, Z-Node Sector MAC, RSSI, Rx Airtime%,
Rx Beam Azimuth Angle, Rx Beam Elevation Angle, Rx SNR, Rx MCS, Rx PER, Rx Scan Beams, Rx Throughput,
Tx Beam Azimuth Angle, Tx Power Index, EIRP, Tx MCS, Tx PER, Tx Scan Beams, Rx Errors, Rx Frames, Tx
Errors, Tx Frames, Rx Time, Tx Airtime%, Tx Beam Azimuth Angle, Tx Beam Elevation Angle, Tx Throughput, Tx
Time, and Link Fade Margin links created with DN/CN node, in a page format.

Events

Events provide the details of link availability, hourly link availability in percentage, link availability in different
time lines, and distance of the link.

Figure 299 Events



Field Description

Link Name Name of the link.

Alive Status of the link (Yes or No).

Availability
Chart

Displays the link availability based on time range selected from the drop-down.When you
hover the mouse on the Availability Chart, the link availability is shown as described:

1. If you select time range as Last 1 Hour, then link availability for every 5 minutes is
displayed.

2. If you select time range other than Last 1 Hour, then link availability for every 1 hour is
displayed.

l Hover on the link to see the hourly availability as shown in Figure 271.

l Clicking on percentage link availability displays pop-up window as shown in Figure 272

l Link availability is presented in different colors in the chart as shown in Figure 270

Availability
Percentage

l Clicking on percentage for the complete timeline link availability displays pop-up
window as shown in Figure 301.

l Availability of link is shown in percentage in the Availability column as shown in Figure
271.

Distance Distance of the link in meters.

Table 72: Events fields

Figure 300 Link Availability in Percentage
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Figure 301 Link Availability details

Availability percentage per link is calculated including the duration when E2E Controller was Offline in
cnMaestro.



Figure 302 Link Availability

Figure 303 Link Status

Events details are available for Last 1 hour, Last 6 hours, Last 12 hours, Last 24 Hours, Last 2 days, Last 4 days,
and Last 7 days.

NOTE:

Event details for Custom Range and Last 30 days is available only for cnMaestro X users.

Tools
In Tools page you can view the Status and Debug details of the device.

Status

In Status tab you can view the status of the device:

l Critical alarms

l Download Tech Support File

l Online or Offline

l Reboot the device.
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l Restart Minion

l Factory reset

Debug

In Debug tab, you can view or download the DN or CN logs by executing the following log commands:

l Bridging

l e2e_minion

l openr

To view the logs:

1. Navigate to Tools > Debug.

2. Select the required log name from the Select Log drop-down list box.

The output for the selected critera appears as shown:

l Click the download icon to download the generated output.

l Click the clear icon to clear the generated output.



Remote Command

In Remote command tab, you can view and download Command logs by executing the following commands:

l Show Interfaces

l Show Routes

l Show OpenR Adjacencies

l Show OpenR Prefixes

l Show SFP Power Details (applicable for V5000 an V3000)

l Show IPv4 neighbors

l Show IPv6 neighbors

l Show Wired Device State Changes

l Ping

To Execute the command:

1. Navigate to Tools > Remote Command.

2. Select the required command from the Command drop-down.

3. Click Execute.

The output for the selected critera appears as shown:

l Click the download icon to download the generated output.

l Click the clear icon to clear the generated output.

Managing NSE 3000 using cnMaestro

NSE 3000 is managed using the cloud-hosted cnMaestro (a management solution from Cambium Networks).

This section covers the following topics:

l Claiming an NSE device associated with a site

l Configuring NSE 3000

l Configuring WAN in the device UI
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Claiming an NSE device associated with a site
A device manufacturer serial number (MSN) is required to claim an NSE device. You can find the device MSN at
the bottom of the device as shown in Figure 304.

Figure 304 MSN of the NSE device



To claim an NSE device that is associated with a site, complete the following steps:

1. From the home page, navigate to Monitor and Manage.

The System page appears, as shown in Figure 305.

Figure 305 The System page

2. On the left panel, in the Networks section, expand the site panel.

3. Click the actions icon and select Claim Device(s).

The Claim Devices window appears, as shown in Figure 306.
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Figure 306 The Claim Devices window

4. From the NSE Group drop-down list, select the required group.

NOTE:

The selected NSE group is automatically pushed to the device while onboarding.

5. In the Enter field, enter the MSN of the NSE device.

6. Click Claim Devices.

The NSE device that is associated with a site is claimed successfully.



Configuring NSE 3000
To configure NSE 3000 devices, create configuration profiles called NSE Groups.

To create and configure a new NSE 3000 group, navigate to Configuration > NSE Groups and click Add.

Figure 307 Creating NSE groups

For a new NSE group, you must configure parameters using the following tabs:

l Basic

l Management

l Network

l Groups

l WAN

l Firewall

l DNS

l Threat Protection

l VPN

l User-Defined Overrides

Basic
Using the Basic tab, you can configure basic group information, such as group name and group scope. You have
the option to enable automatic synchronization of the configuration changes for devices associated with the
NSE group.

To configure parameters on the Basic Information page, complete the following steps:

1. Navigate to Configuration > NSE Groups and click Add.

The Basic Information page appears, as shown in Figure 308.
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Figure 308 The Basic Information page

2. Configure the parameters, as described in Table 73.

Table 73: Parameters on the Basic Information page

Parameter Description

Name Name for the NSE group.

This parameter allows a maximum of 64 characters.

This is a mandatory parameter.

Scope Scope determines the availability of the NSE group across different tenant
accounts.

By default, the following options are supported:

l Shared - Configured NSE group will be available to other tenant
accounts.

l Basic Infrastructure - Configured NSE group will be available only to the
Basic Infrastructure user. Other tenant accounts will not have access to
the NSE group.

Auto Sync Specifies whether the configuration changes made to the NSE group are
automatically applied to all devices associated with the group.

By default, auto sync is enabled.

3. Click Save.

Management
Using the Management tab, you can configure the profile-related parameters such as time settings and event
logging.

To configure parameters on the Management page, complete the following steps:



1. On the NSE Groups > Add New page, select the Management tab.

The Management page appears, as shown in Figure 309.

Figure 309 The Management page

2. Configure the parameters, as described in Table 74.

Table 74: Parameters on the Management page

Parameter Description

On the Management page, there are Management, Time Settings, and Event Logging sections.

Management

Admin
Password

The password used to authenticate the NSE 3000 users who access through
SSH or web.

This parameter allows a maximum of 32 characters.

This is a mandatory parameter.

Note: Click the edit icon to reset the password.

Time Settings

Time Zone The time zone based on the installation location of the device.

Select an appropriate time zone from the drop-down list to ensure that the
device clock is synchronized with the wall clock time.
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Parameter Description

NTP Server 1 The IPv4 address or domain name of the primary Network Time Protocol
(NTP) server.

NTP Server 2 The IPv4 address or domain name of the secondary or a backup NTP server.

Event Logging

Syslog Server 1 The IPv4 address or the domain name of the syslog server 1.

Port The port number of the syslog server 1 to which the syslog messages are
sent.

Supported values: 1 to 65535.

Syslog Server
2

The IPv4 address or the domain name of the syslog server 2.

Port The port number of the syslog server 2 to which the syslog messages are
sent.

Supported values: 1 to 65535.

Syslog
Severity

The logs with the selected severity level that must be forwarded to the
server.

The following options are supported:

l Emergency (Level 0)

l Alert (Level 1)

l Critical (Level 2)

l Error (Level 3)

l Warning (Level 4)

l Notice (Level 5)

l Info (Level 6)

l Debug (Level 7)

3. Click Save.

Network
Using the Network tab, you can configure LAN ports, VLANs, and static routes.

To configure parameters on the Network page, complete the following steps:

1. On the NSE Groups > Add New page, select the Network tab.

The Network page appears, as shown in Figure 310.



Figure 310 The Network page

2. Configure the parameters, as described in Table 75.

Table 75: Parameters on the Network page

Parameter Description

On the Network page, there are LAN Ports, VLANs, and Static Routes sections.

LAN Ports

Click the edit icon to modify the configuration of the corresponding LAN port as shown in

Figure 311, and click Update to apply the changes.

Name Name of the LAN port.

This parameter cannot be modified.

Mode The VLAN mode of the port.

The following options are supported:

l Access Single VLAN: An access port which places all traffic on its
configured VLAN and only passes untagged traffic.

l Trunk Multiple VLANs: A trunk port which allows the selected port
to accept or pass 802.1Q tagged traffic.

Description A brief description of the LAN port.

VLAN This parameter is applicable only when the Mode parameter is set to
Access Single VLAN.

By default, VLAN value is 1.

VLAN value can be in the range: 1 to 4094

This is a mandatory parameter.
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Native VLAN Indicates that the traffic on the native VLAN is untagged. This parameter
is applicable only when the Mode parameter is set to Trunk Multiple
VLANs.

The Native VLAN value can be in the range: 1 to 4094

This is a mandatory parameter.

Tag the native
VLAN

This parameter is applicable only when the Mode parameter is set to
Trunk Multiple VLANs. When Tag the native VLAN parameter is enabled,
the native VLAN traffic is tagged with 802.1Q.

Allowed VLANs This parameter is applicable only when the Mode parameter is set to
Trunk Multiple VLANs.

This parameter supports a range or comma-separated list of VLANs.
Example: 1-3 or 4, 10, 22

Link Speed
Advertisement

Indicates the port speed that must be configured for advertisement.

Default: Auto

The following options are supported:

l Auto

l 10 Mbps

l 100 Mbps

l 1000 Mbps

Port Duplex Specifies the mode of port communication. The following options are
supported:

l Full Duplex

l Half Duplex

Port Speed Specifies the port speed.

Default: Auto

The following options are supported:

l Auto

l 10 Mbps

l 100 Mbps

l 1000 Mbps

Shutdown Enables or disables the port.

By default, this parameter is disabled.

VLANs



Parameter Description

Note: You can configure up to 16 VLANs.

To add a new VLAN, click Add New. The Add New VLAN window appears, as shown in Figure
312.

To edit an existing VLAN configuration, click the edit icon and modify the parameters in the

Edit VLAN window. Finally, click Update to apply the changes.

VLAN ID Indicates the VLAN ID.

The VLAN ID value can be in the range: 1 to 4094

This is a mandatory parameter.

Description Displays the user-configured description for the VLAN.

IP Address IPv4 address that is assigned to the VLAN.

This is a mandatory parameter.

Subnet Mask Subnet mask that is assigned to the VLAN.

This is a mandatory parameter.

Management
Access

Indicates whether the management access is enabled or disabled.

By default, this parameter is enabled.

Enable Rate Limit Indicates whether the rate limit is enabled or disabled.

By default, this parameter is disabled.

When you select the Enable Rate Limit check box, the Rate Limit
parameter appears.

Rate Limit Specifies the rate of requests sent or received. This parameter appears
only when you enable the Enable Rate Limit parameter.

This parameter supports only integer values.

This is a mandatory parameter.

DHCP mode The following options are supported:

l None

l DHCP Server - When you select this option, the DHCP server-
related parameters appear.

l DHCP Relay - When you select this option, the Relay Server IP
address parameter appears.

DHCP Server

In addition to the below parameters, you must also configure the parameters in the DHCP
Options and MAC Binding List sections, as shown in Figure 313.
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Start IP address Starting IPv4 address in the range.

This is a mandatory parameter.

End IP address Ending IPv4 address in the range.

This is a mandatory parameter.

Primary DNS The primary DNS server for clients on the network.

If the DNS server option is enabled on the NSE, the IPv4 address
configured for the VLAN can be provided as the DNS server for the
network.

Secondary DNS The secondary DNS server for clients on the network.

Domain The DNS search domain for the network.

Lease Time The DHCP lease expiry time for the DHCP pool (in Days, Hours, and
Minutes).

This is a mandatory parameter.

DHCP Options

NSE allows configuration of standard and custom DHCP options.

To add a new DHCP option, click Add New. The Add New DHCP Option window appears, as
shown in Figure 314.

To edit an existing DHCP option, click the edit icon and modify the parameters in the Edit

DHCP Option window. Finally, click Update to apply the changes.

Option The following DHCP options are supported:

l Log server(7)

l Domain name(15)

l NTP server(42)

l Vendor specific information(43)

l Vendor class identifier(60)

l TFTP server name(66)

l Boot file name(67)

l Proxy auto config(252)

l Custom

This is a mandatory parameter.

Code A value for the code.

This parameter allows a maximum value of 254.
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This is a mandatory parameter.

Type The following options are supported:

l Text

l IP Address

l Integer

This is a mandatory parameter.

Value A value in ASCII.

This is a mandatory parameter.

MAC Binding List

For every DHCP pool configured, the user can bind the client MAC address with an IPv4
address from the network. This enables the client to obtain the same IPv4 address whenever
they connect to the NSE device.

Following parameters are required to create the binding list:

l MAC address of the client

l IPv4 address from the configured pool

When you set MAC and IP address fields and click Add, the binding of MAC and IP address is
added.

Note: Upto 200 MAC to IP address bindings are supported per DHCP pool.

Note: When you bind, the binding IP address should be outside the DHCP pool range.

To add a new MAC binding, click Add New. The Add New MAC Binding window appears, as
shown in Figure 315.

To edit an existing MAC binding, click the edit icon and modify the parameters in the Edit

MAC Binding window. Finally, click Update to apply the changes.

MAC The MAC address of the client.

This is a mandatory parameter.

IP Address The IPv4 address that must be assigned to the client.

This is a mandatory parameter.

Description Displays the user-configured description.

Import Imports the MAC bindings.

Note: The CSV file that you import must be in the three-column format,
for example, MAC, IP address, and Description.

To import MAC bindings, click Import. The Import MAC Bindings window
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appears, as shown in Figure 316.

Replace existing
list

Indicates whether the imported bindings will overwrite the existing list or
append to the list.

l If enabled, the imported bindings will overwrite the existing list

l If disabled, the imported bindings will append to the existing list.

By default, this parameter is enabled.

Export Exports the configured bindings list.

The following options are supported:

l Export all as CSV

l Export page as CSV

To export MAC bindings, click Export. The export options appear, as
shown in Figure 317.

DHCP Relay Indicates whether the DHCP relay unicasts the DHCP request to an
external DHCP server.

This is a mandatory parameter.

Relay Server IP
address

IPv4 address of the external DHCP server.

This is a mandatory parameter.

Static Routes

To add a new route, click Add New. The Add New Route window appears, as shown in Figure
318.

To edit an existing route, click the edit icon and modify the parameters in the Edit Route

window. Finally, click Update to apply the changes.

Destination
Network

The IPv4 address of the destination network.

This is a mandatory parameter.

Prefix Length The prefix length for the network address.

This parameter supports integer values and a maximum value of 32.

This is a mandatory parameter.



Parameter Description

Next Hop The next hop IPv4 address for the route.

This is a mandatory parameter.

Exit Interface The exit interface through which the next hop is reachable.

The following options are supported:

l WAN-1

l WAN-2

l VLAN-1

l VLAN-10

l VLAN-20

l VLAN-30

This is a mandatory parameter.

Metric The metric for the route.
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Figure 311 The Edit Port window

Figure 312 The Add New VLAN window



Figure 313 DHCP Options and MAC Binding List
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Figure 314 The Add New DHCP Option window

Figure 315 The Add New MAC Binding window



Figure 316 The Import option in MAC Binding List

Figure 317 The Export option in MAC Binding List
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Figure 318 The Add New Route window

3. Click Save.

Groups
Using the Groups tab, you can configure user groups, IP groups, and application groups.

To view the Groups page, complete the following steps:

1. On the NSE Groups > Add New page, select the Groups tab.

The Groups page appears, as shown in Figure 319.

Figure 319 The Groups page

2. Configure the parameters, as described in Table 76.



Table 76: Parameters on the Groups page

Parameter Description

On the Groups page, there are User Groups, IP Groups, and Application Groups sections.

User Groups

User groups are used to group locally configured networks and these groups can be used to associate with
policies, especially application rules or DNS rules.

To add a new user group, click Add New. The Add User Group window appears, as shown in Figure 320.

To edit a user group, click the edit icon and modify the parameters in the Edit User Group window.

Finally, click Update to apply the changes.

Name Name for the user group.

This is a mandatory parameter.

Description Description for the user group.

IP Addresses/Source
Subnets

IPv4 addresses or source subnets for the user group.

This is a mandatory parameter.

IP Groups

IP groups are used to group networks originating from the WAN, and can be used to attach port forwarding
rules.

To add a new IP group, click Add New. The Add IP Group window appears, as shown in Figure 321.

To edit an IP group, click the edit icon and modify the parameters in the Edit IP Group window. Finally,

click Update to apply the changes.

Name Name for the IP group.

Description Description for the IP group.

IP Addresses/IP
Ranges/Source
Subnets

IPv4 addresses, IP ranges, or source subnets for the IP group.

This is a mandatory parameter.

Application Groups

Application groups are used to group applications by using application names or categories, which can then
be attached to a policy for permitting or denying access.

To add a new application group, click Add New. The Add New Application Group window appears, as shown
in Figure 322.

To edit an application group, click the edit icon and modify the parameters in the Edit Application Group

window. Finally, click Update to apply the changes.

Name Name for the application group.
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Description Description for the application group.

Applications

To add applications to the application group, select the required application(s) from the drop-down list and
click Add New. The selected applications are added in the Name list.

Application Name Applications for the new application group.

Categories

To include categories for the new application group, select the required categories.

Categories Categories for the new application group.

Figure 320 The Add User Group window

Figure 321 The Add IP Group window



Figure 322 The Add New Application Group window

3. Click Save.

WAN
Using the WAN tab, you can configure the settings related to the WAN interface.

To configure parameters on the WAN page, complete the following steps:

1. On the NSE Groups > Add New page, select the WAN tab.

The WAN page appears, as shown in Figure 323.
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Figure 323 The WAN page

2. Configure the parameters, as described in Table 77.

Table 77: Parameters on the WAN page

Parameter Description

On the WAN page, there are WAN Configurations, Load Balancing, and Flow Preferences
sections.

WAN Configurations

In this section, you can configure the parameters in Connection Health, Dynamic DNS, Link
Capacity, Traffic Shaping, Failover Policy, and WAN Speed Test subsections.

The same parameters appear in both WAN-1 and WAN-2 tabs.

IP Address Assignment Determines the mode of IP address assignment for the WAN
interface.

The following options are supported:

l Dynamic: Dynamically learn the IP address and DNS from the
DHCP server.

l Static: Manually configure the IP address, gateway, and DNS
server IP provided by the service provider.

l PPPoE: When you configure PPPoE, you must provide the
username and password of the service provider. While the
account name and service name are not mandatory
configurations, they may be required if the service provider
enforces it. By default, the MTU is set to 1492 and the TCP
MSS clamping is enabled. If required, you can also tag the
packet on the WAN link to send.

Enable 802.1q VLAN When this parameter is enabled, 802.1Q tag is inserted with



Parameter Description

tagging of frames configured VLAN ID for all the packets going out of the WAN
interface.

By default, this parameter is disabled.

VLAN ID This parameter is applicable only when Enable 802.1q VLAN tagging
of frames check box is selected.

VLAN ID range: 1 and 4094.

This is a mandatory parameter.

When the 802.1Q header is configured, all transmitted frames are
expected to include the 802.1Q header with the same VLAN ID.

Following parameters appear when you select Static from the IP Address Assignment drop-
down list.

IP Address The IPv4 address of the WAN interface.

This is a mandatory parameter.

Subnet Mask The subnet mask for the IPv4 address of the WAN interface.

This is a mandatory parameter.

Default Gateway The IPv4 address of the default gateway for the WAN interface.

Primary DNS The IPv4 address of primary upstream DNS server on this interface.

This is a mandatory parameter.

Secondary DNS The IPv4 address of secondary upstream DNS server on this
interface.

Following parameters appear when you select PPPoE from the IP Address Assignment drop-
down list.

Account Controller
Name

Name of the account controller.

This parameter allows a maximum of 32 characters.

This parameter is optional.

Service Name Indicates the service name of the Account Controller.

This parameter allows a maximum of 32 characters.

The service name configuration is optional.

User User name for PPPoE authentication.

This is a mandatory parameter.

Password Password for PPPoE authentication.
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This parameter is optional.

MTU MTU for PPPoE interface.

MTU ranges from 500 to 1492 bytes.

Default: 1492 bytes.

TCP MSS Clamping Indicates whether TCP MSS Clamping is enabled or disabled.

By default, this parameter is enabled.

Additional IP
Addresses

WAN IP addresses that are available for source NAT.

Enable Source NAT Indicates whether the source NAT is enabled or disabled.

When enabled, NSE device will replace the source IP address of the
traffic routed from LAN to WAN with the WAN interface IP address.

By default, this parameter is enabled.

Source NAT Rules

Allows user to configure source NAT rules. User can choose the WAN IP addresses from the
Additional IP Address for source NAT. User can configure WAN IP address(es) of their choice
for source NAT. By default, all the LAN users' traffic will be source NATed to the configured
WAN IP address(es). When LAN pool is configured, the traffic from the specified LAN networks
will be source NATed to the configured WAN IP address(es).

Note: Source NAT Rules supports up to 16 rules per WAN.

To add a new source NAT, click Add New. The Add New Source NAT Rule window appears, as
shown in Figure 324.

Precedence The precedence value for the source NAT rule.

The precedence value can be between 1 and 150.

This is a mandatory parameter.

LAN Pool The following options are supported:

l All

l IP Group

l IP Address / Source Subnet

WAN Pool The following options are supported:

l Single IP Address

l Multiple IP Addresses

IP Address IPv4 address for the WAN pool.
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Applicable only when Single IP Address option is selected.

Start IP Starting IP address in the range.

This parameter is applicable only when Multiple IP Addresses option
is selected.

This is a mandatory parameter.

End IP Ending IP address in the range.

This parameter is applicable only when Multiple IP Addresses option
is selected.

This is a mandatory parameter.

IP Group Select the IP group for the source NAT. IP groups are the ones that
you configure in the Groups > IP Groups section.

This parameter is applicable only when IP Group option is selected.

This is a mandatory parameter.

IP Address / Source
Subnet

This parameter is applicable only when IP Address / Source Subnet
option is selected.

This is a mandatory parameter.

Connection Health

This section is configured to monitor the WAN connection health.

Click the edit icon to modify the Monitor Host configuration, as shown in Figure 325. Finally,

click Update to apply the changes.

To add a new monitor host, click Add New. The Add New Monitor Host window appears, as
shown in Figure 326.

Monitor Host The hosts used to monitor and collect network traffic data.

Default: 8.8.8.8

This is a mandatory parameter.

Number of Host
Failures

The number of monitor hosts that fail to declare the link down.

Default value: 1

The maximum number of monitor hosts that can be configured to
fail is 5.

Failure Detect Time The time period (in seconds) during which the device waits for the
response from the monitored host before declaring the link down.

Default: 5. Range: 5 to 60
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Interval The time interval (in seconds) used by the device to check and reach
the monitor hosts.

Default: 2. Range: 2 to 10

Timeout The time period (in seconds) the device waits for a response from
the monitor host after which the connection is timed out.

Default: 2. Range: 1 to 10

Dynamic DNS

Enable Dynamic DNS Indicates whether the dynamic DNS for the interface is enabled or
disabled.

By default, this parameter is disabled.

Following parameters appear when Enable Dynamic DNS check box is selected.

DNS Provider The following options are supported:

l Cloudflare: Requires secret/access token and zone
configuration.

In the Cloudflare account, navigate to Profile > API Tokens to
create a token.

Following is the recommended setting:

l Permissions: Zone, DNS, Edit

l ZoneResource: Include, Specific Zone, <zone name>

l Godaddy: Requires API key, secret/access token, and zone
configuration.

In the Godaddy account, create an API key at
https://developer.godaddy.com/keys

l Hetzner: Requires secret/access token and zone
configuration.

In the Hetzner account, navigate to Profile > API Tokens and
create an access token.

l Namecheap: Requires password and zone configuration.

1. In the Namecheap account, navigate to Domains >
Free DNS to manage external domains.

2. Before you update/create a record, a new record of
type A must exist. To create a record, navigate to the
dashboard, and then navigate to Products > Advanced
DNS. Add a new record of type A. On the same page,
enable Dynamic DNS and note the password.

l Noip: Requires server name, username, and password



Parameter Description

configuration.

l Route53: Requires API key, secret/access token, and zone
configuration.

1. In the Route 53 account, navigate to route53 > Hosted
Zones > Create Hosted Zone to create a zone. Use type
Public hosted zone. Note the name servers in hosted
zone details and the hosted zone ID.

2. Navigate to IAM > Users > Create user. Select attach
policies directly. Create a policy.

The following is an example of a policy:

{

"Version": "2012-10-17",

"Statement": [

{

"Sid": "",

"Effect": "Allow",

"Action": [

"route53:ListResourceRecordSets",

"route53:GetChange",

"route53:ChangeResourceRecordSets"

],

"Resource": [

"arn:aws:route53:::hostedzone/<ZONE_ID>",

"arn:aws:route53:::change/*"

]

},

{

"Sid": "",

"Effect": "Allow",

"Action": [

"route53:ListHostedZonesByName",

"route53:ListHostedZones"

],

"Resource": "*"

}
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]

}

3. Replace ZONE_ID in the policy with the previously
noted zone id. Select the new policy for the previously
created user.

4. To create access key, navigate to users, select the user,
Security Credentials > Create Access Key.

l Porkbun: Requires API key, secret/access token, and zone
configuration.

In the Porkbun account, navigate to Account > API Access to
create a token. Additionally, the domain configuration much
be changed to enable API access.

l Dyn: Oracle Dyn requires server name, username, and
password configuration.

l DynDNS2 compliant: Requires server name, username, and
password configuration.

By default, Noip option is selected.

DNS Hostname Indicates the DNS host name.

Link Capacity

Uplink The WAN uplink capacity in Mbps.

Default: 1000. Range: 1 to 1000

This is a mandatory parameter.

Downlink The WAN downlink capacity in Mbps.

Default: 1000. Range: 1 to 1000

This is a mandatory parameter.

Traffic Shaping

Note: Traffic Shaping supports up to 16 rules per WAN.

To add a new traffic shaping rule, click Add New, the Add New Traffic Shaping Rule window
appears, as shown in Figure 327.

Enable Traffic Shaping Indicates whether traffic shaping is enabled or disabled.

By default, this parameter is disabled.

Precedence The precedence value for the traffic shaping rule.

The precedence value can be between 1 and 150.
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This is a mandatory parameter.

Description Displays a user-configured description for the traffic shaping rule.

Uplink Bandwidth Indicates the uplink bandwidth in Mbps.

Range: 1 to 1000

This is a mandatory parameter.

Downlink Bandwidth Indicates the downlink bandwidth in Mbps

Range: 1 to 1000

This is a mandatory parameter.

DSCP Differentiated Services Code Point (DSCP) can range from 0 to 63,
with 0 being the lowest priority and 63 being the highest priority.

Type Indicates the type of filter rule.

The following options are supported:

l IP Based – Allows you to configure Protocol parameter as
TCP, UDP, or any.

l Application Based – Allows you to configure Deep Packet
Inspection (DPI) Type parameter as Application or Category.

Deep Packet Inspection
(DPI) Type

This parameter is applicable only when Type parameter is
Application Based.

The following options are supported:

l Application – Specific type of application within a category.

l Category – All applications belonging to a category (For
example, Social Messaging).

This is a mandatory parameter.

DPI Application This parameter is applicable only when Deep Packet Inspection
(DPI) Type parameter is set to Application.

This is a mandatory parameter.

DPI Category This parameter is applicable only when Deep Packet Inspection
(DPI) Type parameter is set to Category.

This is a mandatory parameter.

Protocol This parameter is applicable only when Type parameter is IP Based.

The following options are supported:

l TCP – Match TCP traffic.
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l UDP – Match UDP traffic.

l any – Match any of the above protocol traffic.

Source IP Address The source IPv4 address for the shaping rule.

This is a mandatory parameter.

Mask The subnet mask for the shaping rule.

This is a mandatory parameter.

Port Displays the source port from which IPv4 address messaging is sent.

This is a mandatory parameter.

Destination IP Address The destination IPv4 address for the shaping rule.

This is a mandatory parameter.

Mask The subnet mask for the shaping rule.

This is a mandatory parameter.

Port Displays the destination port to which IPv4 address messaging is
sent.

This is a mandatory parameter.

Failover Policy

Note: Failover Policy supports up to 32 rules per WAN.

To add a new failover policy, click Add New. The Add New Failover Policy window appears, as
shown in Figure 328.

Enable Failover Policy Indicates whether failover policy is enabled or disabled.

By default, this parameter is disabled.

Precedence The precedence value for the failover policy.

The precedence value can be between 1 and 150.

This is a mandatory parameter.

Description A description for the policy.

Action By default, this parameter is disabled.

Type The type of failover rule.

The following options are supported:

l IP Based – Allows you to configure the Protocol parameter as
TCP, UDP, or any.
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l Application Based – Allows you to configure Deep Packet
Inspection (DPI) Type parameter as Application, Category, or
Application Group.

Protocol This parameter is applicable only when Type parameter is IP Based.

The following options are supported:

l TCP – Match TCP traffic.

l UDP – Match UDP traffic.

l any – Match any of the above protocol traffic.

Source IP Address The source IPv4 address for the failover rule.

This is a mandatory parameter.

Mask The subnet mask for the failover rule.

This is a mandatory parameter.

Port The source port for the failover rule.

This is a mandatory parameter.

Destination IP Address The destination IPv4 address for the failover rule.

This is a mandatory parameter.

Mask The subnet mask for the failover rule.

This is a mandatory parameter.

Port Displays the destination port for the failover rule.

This is a mandatory parameter.

Deep Packet Inspection
(DPI) Type

This parameter is applicable only when Type parameter is
Application Based.

The following options are supported:

l Application – Specific type of application within a category.

l Category – All applications belonging to a category (For
example, Social Messaging).

l Application Group - All applications belonging to a group.

This is a mandatory parameter.

Apply to This parameter is applicable only when Type parameter is
Application Based.

The following options are supported:
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l All

l User Group

l IP Address / Source Subnet

User Group This parameter is applicable when User Group option is selected.

This is a mandatory parameter.

IP Address / Source
Subnet

This parameter is applicable when IP Address / Source Subnet
option is selected.

This is a mandatory parameter.

WAN Speed Test

Enable WAN Speed
Test

Enable or disable the WAN speed test.

By default, this parameter is disabled.

Figure 324 The Add New Source NAT Rule window

Figure 325 The Edit Monitor Host window



Figure 326 The Add New Monitor Host window

Figure 327 The Add New Traffic Shaping Rule window
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Figure 328 The Add New Failover Policy window

3. Expand the Load Balancing section and configure the parameters, as described in Table 78.

Table 78: Parameters on the Load Balancing section

Parameter Description

Load Balancing

WAN-1 Mode Determines the load balancing mode of device.

By default, the WAN-1 Mode parameter is set to Shared.

The following options are supported:

l Shared – Enables the WAN link to actively forward a percentage of user
traffic. The percentage of user traffic on this link is set via the Traffic
Share Percentage parameter.

l Backup – The WAN link forwards user traffic only when all of the Shared
WAN interfaces are down.

l Disabled – Disables the WAN link from participating in WAN link load
sharing, and failover procedures.

Traffic Share Percentage For the Shared mode, the traffic share percentage must be between 5 and 100.

This is a mandatory parameter.

WAN-2 Mode Determines the load balancing adjust mode of device.

By default, the WAN-2 Mode parameter is set to Backup.

The following options are supported:
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l Shared – Enables the WAN link to actively forward a percentage of user
traffic. The percentage of user traffic on this link is set via the Traffic
Share Percentage parameter.

l Backup – The WAN link forwards user traffic only when all of the Shared
WAN interfaces are down.

l Disabled – Disables the WAN link from participating in WAN link load
sharing, and failover procedures.

Traffic Share Percentage For the Shared mode, the traffic share percentage between 5 and 100.

This is a mandatory parameter.

4. Expand the Flow Preferences section and configure the parameters, as described in Table 79.

Table 79: Parameters on the Flow Preferences section

Parameter Description

Flow Preferences

Flow preferences support up to 30 rules for both WANs combined.

To add a new flow preference, click Add New. The Add New Flow Preference window appears, as shown in
Figure 329.

WAN Interface The following options are supported:

l WAN-1

l WAN-2

Description Provide a description for the flow preference.

Policy The flow preference policy.

The following options are supported:

l Flexible – Allow traffic to failover if the preferred WAN link goes
down.

l Strict – Traffic is dropped in strict mode, if the preferred WAN link
goes down.

Type The flow preference type.

The following options are supported:

l IP Based – Allows you to configure Protocol parameter as TCP,
UDP, or any.

l Application Based – Allows you to configure Deep Packet
Inspection (DPI) Type parameter as Application or Category.

Protocol This parameter is applicable only when Type parameter is IP Based.
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Parameter Description

The following options are supported:

l TCP – Match TCP preference.

l UDP – Match UDP preference.

l Any – Match any of the above preferences.

Source IP Address The source IPv4 address for the flow preference.

This is a mandatory parameter.

Mask The subnet mask for the flow preference.

This is a mandatory parameter.

Port The source port for the flow preference.

This is a mandatory parameter.

Destination IP Address The destination IPv4 address for the flow preference.

This is a mandatory parameter.

Mask The subnet mask for the flow preference.

This is a mandatory parameter.

Port The destination port for the flow preference.

This is a mandatory parameter.

Deep Packet Inspection
(DPI) Type

This parameter is applicable only when Type parameter is Application
Based.

The following options are supported:

l Application – Specific type of application within a category.

l Category – All applications belonging to a category (For example,
Social Messaging).

This is a mandatory parameter.

DPI Application This parameter is applicable only when Deep Packet Inspection (DPI)
Type parameter is set to Application.

This is a mandatory parameter.

DPI Category This parameter is applicable only when Deep Packet Inspection (DPI)
Type parameter is set to Category.

This is a mandatory parameter.



Figure 329 The Add New Flow Preference window

5. Click Save.

Firewall
NSE 3000 firewall allows the user to configure the IP-based and application-based outbound rules, GEO IP
filters, port forward rules, one-to-one NAT mappings, and one-to-many NAT mappings. All inbound connections
are denied by default. You can configure port forwarding or NAT rules to allow inbound traffic. Outbound traffic
is allowed by default. Using application-based outbound rules, users can create rules to block websites without
specifying IP addresses or port ranges. Application-based rules allow the user to block a specific type of
application within a category or all applications belonging to a category (For example, social messaging).

NOTE:

Up to 150 outbound firewall rules are supported for an NSE Group including combinations of
IP-based and application-based rules.

To configure parameters on the Firewall page, complete the following steps:

1. On the NSE Groups > Add New page, select the Firewall tab.

The Firewall page appears, as shown in Figure 330.
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Figure 330 The Firewall page

2. Configure the parameters, as described in Table 80.

Table 80: Parameters on the Firewall page

Parameter Description

On the Firewall page, there are Outbound Filter Rules, Denial of Service (DoS) Protection, GEO
IP WAN to LAN Filters, GEO IP LAN to WAN Filters, Port Forward Rules, NAT One-to-One, NAT
One-to-Many, and Device Access sections.

Outbound Filter Rules

To add a new outbound filter rule, click Add New. The Add New Filter Rule window appears, as
shown in Figure 331.

Precedence The precedence value for the filter rule.

The precedence value can be between 1 and 150.

This is a mandatory parameter.

Description Displays a user-configured description for the filter



Parameter Description

rule.

Action Determines the action of filter.

The following options are supported:

l Permit - Allow traffic matching this filter rule.

l Deny - Drop traffic matching this filter rule.

Type The type of filter rule.

The following options are supported:

l IP Based – Configure Protocol parameter as
TCP, UDP, ICMP or any.

l Application Based – Configure Deep Packet
Inspection (DPI) Type parameter as
Application, Category, or Application Group

Protocol This parameter is applicable only when Type
parameter is IP Based.

The following options are supported:

l TCP: Match TCP traffic.

l UDP: Match UDP traffic.

l ICMP: Match ICMP traffic.

l any: Match any of the above protocol traffic.

Source IP Address The source IPv4 address for the filter rule.

This is a mandatory parameter.

Mask The source subnet mask for the filter rule.

This is a mandatory parameter.

Port This parameter is applicable only when Protocol
parameter is TCP or UDP.

Supported values: 1 to 65535 or any

This is a mandatory parameter.

Destination IP Address The destination IPv4 address for the filter rule.

This is a mandatory parameter.

Mask The destination subnet mask for the filter rule.

This is a mandatory parameter.
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Parameter Description

Port This parameter is applicable only when Protocol
parameter is TCP or UDP.

Supported values: 1 to 65535 or any

This is a mandatory parameter.

Deep Packet Inspection (DPI) Type This parameter is applicable only when Type
parameter is Application Based.

The following options are supported:

l Application – Specific type of application
within a category.

l Category – All applications belonging to a
category (For example, Social Messaging).

This is a mandatory parameter.

DPI Application This parameter is applicable only when DPI Type
parameter is set to Application.

This is a mandatory parameter.

DPI Category This parameter is applicable only when DPI Type
parameter is set to Category.

This is a mandatory parameter.

Apply to This parameter is applicable only when Type
parameter is Application Based.

The following options are supported:

l All

l User Group

l IP Address / Source Subnet

User Group This parameter is applicable when User Group option
is selected.

This is a mandatory parameter.

IP Address / Source Subnet This parameter is applicable when IP Address /
Source Subnet option is selected.

This is a mandatory parameter.

Denial of Service (DoS) Protection

IP Spoof Enable or disable the IP spoof attack protection.

By default, this parameter is disabled.



Parameter Description

Smurf Attack Enable or disable the smurf attack protection.

By default, this parameter is disabled.

IP Spoof Log Enable or disable IP spoof log messages.

By default, this parameter is disabled.

ICMP Fragment Enable or disable the fragmented ping attack.

By default, this parameter is disabled.

GEO IP WAN to LAN Filters

GEO IP WAN to LAN filters allows users to configure rules to permit/deny traffic based on the
source country of inbound traffic.

Mode Specifies the mode for GEO IP WAN to LAN filters.

The following options are supported:

l Allow Only (Deny by default) – Allow traffic
coming from the countries that are configured.
The traffic coming from the countries which
are not part of the configured countries will be
dropped.

l Deny Only (Allow by default) – Block traffic
coming from the countries that are configured.
The traffic coming from countries that are not
part of the configured countries will be
allowed.

l None – Disables the feature. Traffic is allowed
from all the countries.

Countries The source countries from which the traffic
originates.

Exceptions

Exceptions allow users to configure source IP address ranges that are allowed in the inbound
traffic.

To add a new exception, click Add New. The Add New Exception window appears, as shown in
Figure 332.

Start IP Starting IPv4 address in the range.

This is a mandatory parameter.

End IP Ending IPv4 address in the range.

This is a mandatory parameter.
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Parameter Description

GEO IP LAN to WAN Filters

GEO IP LAN to WAN Filters allows users to configure rules to permit/deny traffic based on the
destination country of outbound traffic.

Mode Specifies the mode for GEO IP LAN to WAN filters.

The following options are supported:

l Allow Only (Deny by default): Allow traffic
destined to the countries matching the
configured countries. The traffic destined for
the countries which are not part of the
configured countries will be dropped.

l Deny Only (Allow by default): Block traffic
destined to the countries matching the
configured countries. The traffic destined for
the countries which are not part of the
configured countries will be allowed

l None: Disables the feature. Traffic is allowed in
all countries.

Countries The destination countries to which the traffic is
destined.

Exceptions

Exceptions allow users to configure destination IPv4 address ranges that are allowed in the
outbound traffic.

To add a new exception, click Add New. The Add New Exception window appears, as shown in
Figure 332.

Start IP Starting IPv4 address in the range.

This is a mandatory parameter.

End IP Ending IPv4 address in the range.

This is a mandatory parameter.

Port Forward Rules

Port Forward Rules allow users to forward traffic destined to the WAN Interface IP address of
NSE 3000 on a specific TCP or UDP port to any of the LAN IP address. Port Forward Rules
provides remote access to internal resources.

To add a new port forward rule, click Add New. The Add New Port Forward Rule window
appears, as shown in Figure 333.

WAN The interface to forward inbound traffic to the
internal host.



Parameter Description

The following options are supported:

l WAN-1

l WAN-2

Description Displays the user-configured description for the port
forward rule.

LAN IP Address The IPv4 address to which traffic will be forwarded.

This is a mandatory parameter.

LAN Port The LAN port to which the traffic will be forwarded.

Supported values: 1 to 65535.

This is a mandatory parameter.

Protocol The protocol of forwarded traffic.

The following options are supported:

l TCP

l UDP

Port The destination port of the incoming traffic on the
WAN interface.

Supported values: 1 to 65535.

This is a mandatory parameter.

Apply To The following options are supported:

l All

l IP Group

l IP Address / Source Subnet

IP Group This parameter is applicable only when IP Group
option is selected.

IP Address / Source Subnet This parameter is applicable only when IP Address /
Source Subnet option is selected.

This is a mandatory parameter.

NAT One-to-One

NAT One-to-One allows users to map an IP address on the WAN side to a LAN IP address. The
IP address on the WAN side should be different from any of the WAN interface (WAN-1/WAN-
2) IP addresses. NAT One-to-One rules provide remote access to any of the LAN resources.

To add a new NAT one-to-one, click Add New. The Add New NAT One-to-One window
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Parameter Description

appears, as shown in Figure 334.

WAN The following options are supported:

l WAN-1

l WAN-2

Public IP Address The public IPv4 address on the WAN side that is used
to access the LAN resource.

The public IPv4 address is different from the IPv4
address of the WAN (WAN-1/WAN-2) interfaces.

This is a mandatory parameter.

LAN IP Address The LAN IPv4 address of the server which is hosting
the resource.

This is a mandatory parameter.

Protocol The protocol of the incoming traffic.

The following options are supported:

l TCP

l UDP

NAT One-to-Many

NAT One-to-Many provides remote access to internal resources. It maps a public IP address to
multiple LAN IPs and ports.

To add a new NAT one-to-many, click Add New, the Add New NAT One-to-Many window
appears, as shown in Figure 335.

WAN The following options are supported:

l WAN-1

l WAN-2

Public IP Address The public IPv4 address on the WAN side that is used
to access the LAN resource.

The public IPv4 address is different from the IPv4
address of the WAN (WAN-1/WAN-2) interfaces.

This is a mandatory parameter.

LAN IP Address The LAN IPv4 address of the server which is hosting
the resource.

This is a mandatory parameter.



Parameter Description

LAN Port The LAN Port which is hosting the resource.

This is a mandatory parameter.

Protocol The protocol of the incoming traffic.

The following options are supported:

l TCP

l UDP

Port The destination port of the incoming traffic on the
WAN interface.

This is a mandatory parameter.

Device Access

Respond to ICMP pings from WAN This parameter is disabled by default.

When enabled, this service is enabled for all the
sources, unless specific IP addresses or IP groups are
configured in the IP Group and IP Address / Source
Subnet parameters.

IP Group Specifies the IP group for this service.

IP Address / Source Subnet Specifies the IPv4 address or source subnet for this
service.
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Figure 331 The Add New Filter Rule window

Figure 332 The Add New Exception window



Figure 333 The Add New Port Forward Rule window
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Figure 334 The Add New NAT One-to-One window

Figure 335 The Add New NAT One-to-Many window

3. Click Save.



DNS
NSE 3000 supports DNS-based filters. DNS-based filters allow users to block certain category of websites.
From the blocked list, users can still allow certain websites by adding them to the exception list. For example, if
user blocks social-media category then all the social websites will be blocked including linkedin.com since
linkedin.com belongs to social-media category. Adding linkedin.com to the Exception to filters list will allow
access to linkedin.com while blocking other social-media websites.

To configure parameters on the DNS page, complete the following steps:

1. On the NSE Groups > Add New page, select the DNS tab.

The DNS page appears, as shown in Figure 336.
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Figure 336 The DNS page

2. Configure the parameters, as described in Table 81.



Table 81: Parameters on the DNS page

Parameter Description

On the DNS page, there are DNS, Policies, and Hosts sections.

DNS

Enable Built-in DNS Server Indicates whether the on-board DNS server is enabled or
disabled.

By default, this parameter is enabled.

Block external DNS servers Blocks the client to reach to any external DNS servers.

By default, this parameter is enabled.

Block external DNS exceptions Allows the clients added in the exceptions list to reach to
any external DNS servers.

Log to Syslog Specifies whether the DNS queries received from the
client is logged to an external syslog server.

Learn DNS servers from DHCP Dynamically learns the DNS server IP on WAN.

By default, this parameter is enabled.

When you disable this parameter, the Primary DNS and
Secondary DNS parameters are displayed.

Primary DNS The IPv4 address of the primary upstream DNS server.

Secondary DNS The IPv4 address of the secondary upstream DNS server.

Local DNS Entries

To add a new local host, click Add New. The Add New Local Host window appears, as shown in Figure 337.

Domain A domain name for the local host.

This is a mandatory parameter.

IP address The IPv4 address of the local host.

This is a mandatory parameter.

Conditional Forwarding Rules

To add a new forwarding rule, click Add New. The Add New Forwarding Rule window appears, as shown in
Figure 338.

Domain A domain name for the forwarding rule.

This is a mandatory parameter.

IP address The IPv4 address of the server to which the DNS query is
forwarded.
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Parameter Description

DNS Filter Mode Specifies the mode for DNS filtering. The following
options are supported:

l Disabled: Disables DNS filter. By default, this option
is selected.

l Learning: Builds local cache for domain categories
but does not filter requests.

l Filtering: Filters requests based on configuration.

Policies

To add a new policy, click Add New. The Add New Policy window appears, as shown in Figure 339.

Name Name for the policy.

This is a mandatory parameter.

Description Description about the policy.

Deny categories Categories to deny in the following sections:

l Productivity

l Privacy

l Sensitive

l Misc

l IT Resources

l Security

Expand the sections and select individual categories. To
select all categories in a section, select the check box
provided for the section.

Safe Search Mode The following options are supported:

l Disabled: Disables safe search mode. By default,
this option is enabled.

l Moderate: Enable moderate safe search mode.

l Restricted: Enable restricted safe search mode.

Allow Exceptions (List of Domain Names) Enter the exempted domain names separated by a
comma (,).

Apply to The following options are supported:

l All: Apply to all user groups. By default, this option
is selected.

l User Group: Apply to selected user groups.



Parameter Description

User Group This parameter is applicable only when User Group option
is selected for Apply to parameter.

This is a mandatory parameter.

Hosts

Hosts section contains two tabs - Safe Search Moderate Hosts and Safe Search Restricted Hosts

The following parameters appear in both the tabs and can be configured as required.

A list of hosts are already added by default. You can modify these hosts by clicking the edit icon or you

can add new hosts by clicking Add New in the respective tabs as shown in Figure 340 and Figure 341.

Domain Name The domain name for the safe search host

This is a mandatory parameter.

IP address The IPv4 address of the safe search host.

This is a mandatory parameter.

Figure 337 The Add New Local Host window

Figure 338 The Add New Forwarding Rule window
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Figure 339 The Add New Policy window

Figure 340 The Add New Safe Search Moderate Host

Figure 341 The Add New Safe Search Restricted Host

3. Click Save.

Threat Protection
Using the Threat Protection tab, you can configure the Intrusion Detection and Prevention system (IDS/IPS)
parameters.



NSE 3000 supports IDS/IPS engine. IPS engine uses a series of rules that help define a malicious network
activity. IPS engine supports rules from snort and emerging threats. The solution supports both community and
licensed rules. The IPS engine uses these rules to find packets that match against them and generates alerts for
users.

To configure parameters on the Threat Protection page, complete the following steps:

1. On the NSE Groups > Add New page, select the Threat Protection tab.

The Threat Protection page appears, as shown in Figure 342.

Figure 342 The Threat Protection page

2. Configure the parameters, as described in Table 82.

Table 82: Parameters on the Threat Protection page

Parameter Description

IDS/IPS

Enable
IDS/IPS

Indicates whether IDS/IPS is enabled or disabled.

By default, this parameter is disabled.

Mode Specifies the IDS/IPS mode.
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Parameter Description

The following options are supported:

l Detection – Detects malicious activity and generates alerts for users.

l Prevention – Detects malicious activity, generates alerts for users, and
takes action to prevent attacks.

Rule Type Specifies the IDS/IPS rule type.

The following options are supported:

l snort-community – The community rule set is a GPLv2 Talos certified
rule set that is distributed free of charge and without any license
restrictions. The rules are updated every Tuesday and Thursday.

l snort-vrt – The Snort Subscriber rule set is developed by Talos research
team and is governed by license agreement. The rule set is updated on
Tuesday and Thursday. The snort-vrt rule set requires an oinkcode to
download and activate rules.

l emerging-threats open – Consists of signatures contributed from the
community. The emerging-threats open rule sets are distributed free of
charge.

l emerging-threats pro – Consists of signatures created as a result of
Proofpoint research. The rule sets are governed by license agreement.
The emerging-threats pro rule set requires an oinkcode to download
and activate the rules.

Rules Specifies the IDS/IPS rule policy. This parameter is applicable when Rule Type
is snort-vrt or snort-community.

The following options are supported:

l Connectivity – Policy designed to favor device performance over the
security controls in the policy.

l Balanced – This policy is the default policy that is recommended for
initial deployments. The policy attempts to balance security needs and
performance characteristics.

l Security – This policy is designed for customer base that is extremely
concerned about organizational security. This policy is deployed in
networks that have higher security requirements.

Oink Code This parameter is applicable when Rule Type is snort-vrt or emergency-
threats pro.

Category Categories to select from the Category section. This parameter is applicable
when Rule Type is snort-vrt or emergency- threats pro.

Rule Updates



Parameter Description

Auto Update Indicates whether the IDS/IPS rules must be automatically updated or not.

By default, this parameter is disabled.

When Auto Update is enabled, NSE 3000 will periodically download and
activate the IDS/IPS rules.

Auto Update
Interval

Time interval for the periodic updates of IDS/IPS rules.

The following options are supported:

l 12 Hrs – Auto updates the rules every 12 hours.

l 24 Hrs – Auto updates the rules every 24 hours.

IDS/IPS
bypass list

List of allowed IPv4 addresses or range of allowed IPv4 addresses.

IDS/IPS operating in prevention mode blocks traffic from a host on detecting
malicious traffic from the host.

When an IPv4 address is part of allowed IP addresses, IDS/IPS will not block
traffic from the host even when malicious traffic is detected.

3. Click Save.

VPN
NSE 3000 provides an on-board VPN server that allows remote users to establish a connection using the native
VPN client supported in most of the operating systems. The VPN server uses the L2TP/IPsec protocol with the
IPsec encryption and hashing algorithms. The VPN server maintains a pool of IP addresses and leases the IP
addresses from this pool for remote users.

NSE 3000 also provides an on-board RADIUS server that allows authentication and accounting of enterprise
and remote users. The RADIUS server maintains user profiles in a central database.

Using the VPN tab, you can configure DNS server, VPN server, and RADIUS server parameters.

To configure parameters on the VPN page, complete the following steps:

1. On the NSE Groups > Add New page, select the VPN tab.

The VPN page appears, as shown in Figure 343.
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Figure 343 The VPN page

2. Configure the parameters, as described in Table 83.



Table 83: Parameters on the VPN page

Parameter Description

On the VPN page, there are Site-to-Site VPN, Client VPN, Users, RADIUS Clients, and VPN
sections.

Site-to-Site VPN

IPsec tunnel is a VPN technology that provides a secure, encrypted connection between two
devices or networks over the internet or another public network. It uses IPsec protocols to
encrypt the traffic between two endpoints, making it difficult for anyone to intercept the
communication.

IPsec site-to-site tunnel is used to connect two remote sites for secure communications. NSE
allows setting up tunnels both in responder mode and initiator mode. Both, IKEv1 and IKEv2 are
supported in the configuration. The default version is IKEv2.

Pre-shared key is the authentication method supported by the device. Each site can have its
own pre-shared key. The site is identified by an identifier (string or the IP address of the site).
Each site has to be configured with a local and remote site for the tunnel to establish.

To view the IPsec tunnel stats, navigate to the NSE Group > Network > VPN Sites tab, as shown
in Figure 345.

To add a new site-to-site VPN, click Add New. The Add New Site-to-Site VPN window appears,
as shown in Figure 344.

Enable Site-to-Site VPN Indicates whether site-to-site VPN is enabled or
disabled.

By default, this parameter is disabled.

Following parameters appear when you select Enable Site-to-Site VPN check box.

Name A name for the new site-to-site VPN.

This is a mandatory parameter.

IKE version The Internet Key Exchange (IKE) version for the site-
to-site VPN. The following options are supported:

l IKE v1

l IKE v2

Role Specifies the role for the tunnels. The following
options are supported:

l Initiator

l Responder

Default role: Responder

Dead peer detection interval The interval (in seconds) for detecting dead peers.
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Range: 30 - 600 seconds. Default: 120 seconds

This is a mandatory parameter.

Remote ID The remote ID.

The value of 192.168.50.10 is pre-configured and is not
modifiable.

This is a mandatory parameter.

Local ID The local ID.

This is a mandatory parameter.

Local Subnets The comma-separated list of local subnets.

This is a mandatory parameter.

Remote Subnets The comma-separated list of remote subnets.

This is a mandatory parameter.

Remote PSK The remote PSK.

This is a mandatory parameter.

Local PSK The local PSK.

This is a mandatory parameter.

The following parameters are common for both IKE Phase 1 and IKE Phase 2.

Encryption The following options are supported:

l aes128

l aes192

l aes256

l aes128-gcm16

l aes192-gcm16

l aes256-gcm16

l 3des

Integrity The following options are supported:

l md5

l sha1

l sha256

DH Group The following options are supported:



Parameter Description

l 1

l 2

l 5

l 14

l 15

Key Lifetime The duration (in hours) for the pre-shared key.

Range: 1 to 24

Client VPN: This section contains the following tabs:

l WireGuard: A VPN protocol that is highly secure. It is simpler and more efficient than
traditional IPSec.

l IPSec IKEV2

l L2TP over IPSec

WireGuard: A VPN protocol that is highly secure. It is simpler and more efficient than traditional
IPSec.

Enable WireGuard Indicates whether WireGuard is enabled or disabled.

By default, this parameter is disabled.

Following parameters appear when you select Enable WireGuard check box.

Port Indicates the WireGuard listen port number.

Default: 51820

This is a mandatory parameter.

Client Pool Indicates the WireGuard interface IP for the device
and the client IPs to be assigned for the WireGuard
clients.

This is a mandatory parameter.

Keep Alive Periodic keep alive packets sent for the configured
duration.

Default: 5 seconds

This is a mandatory parameter.

Enable Split Tunnel Indicates whether the split tunnel is enabled or
disabled.

By default, this parameter is disabled.

Note: When you enable split tunnel, only the traffic
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destined to tunnelled subnets is allowed. You can
override the Enable Split Tunnel parameter at the user
level.

Tunnelled Subnets Specifies the list of local subnets in NSE that should
be allowed access from the WireGuard clients.

Note: The same Tunnelled Subnets field is auto-
populated in the Add New User window. You can edit
this field at the user level.

IPSec IKEV2

Enable IPSec IKEV2 Indicates whether IPSec IKEV2 is enabled or disabled.

By default, this parameter is disabled.

Following parameters appear when you select Enable IPSec IKEV2 check box.

Client IP Pool Range Start Starting IPv4 address in the range.

This is a mandatory parameter.

Client IP Pool Range End Ending IPv4 address in the range.

This is a mandatory parameter.

L2TP over IPSec

Enable L2TP over IPSec Indicates whether L2TP over IPSec is enabled or
disabled.

By default, this parameter is disabled.

Following parameters appear when you select Enable L2TP over IPSec check box.

Client IP Pool Range Start Starting IPv4 address in the range.

This is a mandatory parameter.

Client IP Pool Range End Ending IPv4 address in the range.

This is a mandatory parameter.

IPsec Shared Secret Enter a pre-shared key string for the IPsec protocol.
The shared secret is used between the VPN Client and
Server for device authentication.

This is a mandatory parameter.

Enable 2FA Indicates whether two-factor authentication (2FA) is
enabled or disabled.

By default, this parameter is disabled.



Parameter Description

VPN Two-Factor Authentication

1. When you enable two-factor authentication (2FA), scan the QR code to add a 16-digit
key to a particular user's Google Authenticator app.

2. An email is also sent to the configured email address with the QR code and the 16-digit
key.

3. The two-factor authentication gets enabled for the user when the user tries to connect
to the NSE device using the remote VPN client from the WAN side. Users on the LAN
side do not require two-factor authentication.

Users: This section is common for all the three protocols - WireGuard, IPSec IKEV2, and L2TP
over IPSec.

To add a new user, click Add New. The Add New User window appears, as shown in Figure 346.

Email ID Email ID of the user.
User is either an enterprise user or a remote user.

This is a mandatory parameter.

Password Password for the user.

This is a mandatory parameter.

Enable WireGuard Indicates whether WireGuard is enabled or disabled.

By default, this parameter is disabled.

Following parameters appear when Enable WireGuard check box is selected in the Add New
User window.

Enable Split Tunnel Indicates whether split tunnel is enabled or disabled.
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Parameter Description

By default, this parameter is enabled.

Tunnelled Subnets Specifies the list of local subnets in NSE that should
be allowed access from the WireGuard clients.

Device Indicates the NSE device.

When you select an NSE device, the device's public
key is populated in the [Peer] section of the
WireGuard client configuration file.

This is a mandatory parameter.

WAN Interface WAN Interface of the NSE device.

When you select a WAN interface, the NSE's WAN IP
is populated as the endpoint IP in the [Peer] section of
the WireGuard client configuration file.

The following WAN Interface options are supported:

l WAN-1

l WAN-2

Clients: In this section, you have an option to add a new WireGuard client.

To add a new WireGuard client, click Add New. The Add New WireGuard Client window
appears, as shown in Figure 347.

Name Name for the new WireGuard client.

This is a mandatory parameter.

Auto generate key pair Generates a public and private key pair for the client.
By default, this parameter is enabled.

When this option is enabled, the Client Public Key
field is auto-populated with the public key generated
for that client.

When this option is disabled, you need to provide the
WireGuard client public key generated on the
WireGuard client device.

Client Public Key Public key of the client.

This is a mandatory parameter.

IP Address Auto-generated IP address of the WireGuard client.

Note: You have options to download QR code and configuration file in the Add New WireGuard
Client window, as shown in Figure 347.



Parameter Description

RADIUS Clients

To add a new RADIUS client, click Add New. The Add New RADIUS Client window appears, as
shown in Figure 348.

Name Name of the RADIUS client.

This is a mandatory parameter.

Secret The shared secret of the RADIUS client. This is the
shared secret (password) that the NAS needs to
communicate with the RADIUS server.

This is a mandatory parameter.

Address The IPv4 address or network address of the RADIUS
client.

This is a mandatory parameter.

Prefix Length The client network prefix length.

This is a mandatory parameter.

VPN

VPN Server Interface The following options are supported:

l WAN-1 - The first WAN interface on your
server.

l WAN-2 - The second WAN interface on your
server.

l All - Applies to all WAN interfaces.
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Figure 344 The Add New Site-to-Site VPN window

Figure 345 The VPN Sites page



Figure 346 The Add New User window
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Figure 347 The Add New WireGuard client window

Figure 348 The Add New RADIUS Client window

3. Click Save.

User-Defined Overrides
Using the User-Defined Overrides tab, you can configure the user-defined overrides.

To configure parameters on the User-Defined Overrides page, complete the following steps:

1. On the NSE Groups > Add New page, select the User-Defined Overrides tab.

The User-Defined Overrides page appears, as shown in Figure 349.



Figure 349 The User-Defined Overrides page

2. In the text box, enter the configuration that you want to apply to the device.

3. Click Save.

Configuring WAN in the device UI
In the WAN page, you can configure the device’s IPv4 address based on the IP mode.

NOTE:

If PPPoE is used as the WAN connection mode as shown in Figure 350, make sure to
configure the PPPoE username and password. Once you have configured the PPPoE user
name and password, you can proceed to configure the NSE group by providing the same
username and password and then attaching the default NSE group to the device.

Figure 350 PPPoE as WAN connection mode

To view and configure the WAN settings, complete the following steps in the device UI:

1. From the main NSE 3000 dashboard page, click WAN tab from the left panel.

The WAN page appears, as shown in Figure 351.
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NOTE:

By default, WAN-1 page appears. You can configure WAN on WAN-1 or WAN-2.

Figure 351 The WAN page

2. Configure the parameters, as described in Table 84.

Table 84: Parameters on the WAN page

Parameter Description

IP Mode Determines the network that must be configured to use IPv4
addresses.

The following options are supported:

l Dynamic

l Static

l PPPoE

By default, the Dynamic mode is selected.

VLAN ID The VLAN ID can range from 1 to 4094.

The VLAN configuration is optional.

When the 802.1Q header is configured, all transmitted
frames are expected to include the 802.1Q header with the
same VLAN ID.

Following parameters appear only when you select the mode as Static from the IP Mode drop-
down list, as shown in Figure 352.

IP Address The 32-bit binary number that identifies a network element
by both network and host.

Subnet Mask The subnet mask for the destination IP/network for the
route.

Gateway The gateway for the destination IP/network for the route.

DNS



Parameter Description

Primary DNS The IPv4 address of primary upstream DNS server.

Secondary DNS The IPv4 address of secondary upstream DNS server.

Following parameters appear only when you select the mode parameter as PPPoE from the IP
Mode drop-down list, as shown in Figure 353.

Account Name The name of Access Controller.

This parameter allows a maximum of 32 characters.

This parameter is optional.

Service Name Service name of Access Controller.

This parameter allows a maximum of 32 characters.

This parameter is optional.

User Name A user name for PPPoE authentication.

This parameter is mandatory.

Password A password for PPPoE authentication.

This parameter is optional.

MTU MTU for PPPoE interface in bytes.

Default: 1492. Range: 500 to 1492

TCP MSS Clamping Indicates whether TCP MSS Clamping is enabled or disabled.

By default, this parameter is disabled.

Figure 352 Static mode
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Figure 353 PPPoE mode

3. Click Save.



Configuring Advanced Features
To configure advanced features, navigate to Configuration > Advanced Features page.

Lock Device Configuration
To lock NSE, cnMatrix, and Wi-Fi Device Configuration, select the check box. Once you enable this check box,
you cannot update the device-level configuration using the device UI or any other method. Only the
configuration pushed from cnMaestro for NSE, Switch and Wi-Fi AP groups will be retained on the device.

Strict Device Password Policy
To enable strict password policy for Switch Groups or Enterprise AP Groups, select the Enable Strict Device
Password Policy check box.

If you enable this option:

l The device administrator passwords are stored as one-way hashes for all NSE Groups, Switch Groups,
and Enterprise AP Groups (XE/XV-series).

l The administrator password has to be updated for all NSE Groups, Switch Groups, and Enterprise
AP Groups under Configuration > NSE Group > Management page, Configuration > Switch Group >
Management page, and Configuration > Wi-Fi Profiles > AP Group > Management page respectively for
this setting to take effect.

l The configuration cannot be pushed to cnPilot E-series device.

l Device software versions must be at or above 1.3 for NSE, 4.6.1 for cnMatrix, and 6.5.3 for Enterprise Wi-
Fi XE/XV-Series to support the strict password policy. cnMaestro will not push any configuration to
devices not meeting these requirements, including all cnPilot E-Series devices when the strict policy is
enabled.

If you disable this option:

l The password has to be updated for all NSE Groups, Switch Groups, and Enterprise AP Groups under
Configuration > Switch Group > Management page for this setting to take effect.
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Managing Home Mesh Router

The Home Mesh Router is engineered to provide superior Wi-Fi performance and mesh networking capabilities.
It incorporates the advanced 802.11ax technology, ensuring it is fully compatible with a wide range of consumer
devices while offering low latency and high throughput. These routers are specifically designed for
comprehensive home coverage, supporting simultaneous operation on both 2.4 GHz and 5 GHz bands. This
enables extended range, enhanced efficiency, and reduced interference compared to previous generations of
Wi-Fi technology. Additionally, the routers are configured to work in tandem, creating a seamless mesh
network that covers the entire home, effectively eliminating areas with weak or no Wi-Fi signal.

The Home Mesh Routers can be configured using cnMaestro Cloud and the cnMaestro Subscriber application.

For information on supported platforms, see Home Mesh Router User Guide.

The basic architecture of the Home Mesh Router is as shown below.

The cnMaestro Subscriber application allows home customers to manage RV22 devices using their mobile
phones. In the graphic above, the Subscriber is demarcated by the SM CPE. Alternatively, it could be mapped to
a PON ONU, or to no explicit backhaul at all. In the latter case, the Subscriber would be attached to a new
cnMaestro Home Site.

The workflow for creating and onboarding Subscribers, so customers can use the mobile application, has a
cnMaestro (blue) and a customer (purple) component, as shown below.

A Subscriber is configured in cnMaestro Cloud, and an invite is sent to the customer’s email address, which will
enable home Wi-Fi management using the mobile application. The customer must download the cnMaestro
Subscriber application from the Apple App store or Google Play Store. The “Site” in the application, which maps
to the Subscriber, can be customized and branded.

Feature Details

Onboarding Supported using Cambium ID or Serial Number (MSN).

Dashboard Dashboards tailored for Home Site and RV22 Home Mesh.

Configuration Available through RV22 Home Mesh AP Groups.

Details Overview and network information display.



Feature Details

Notifications Alarms, AP Events, and Wi-Fi Events aggregated at System, Managed Account, Network,
Site, and Device levels.

Performance WAN Throughput, Wireless Throughput (downlink/uplink), Clients by Band, Noise Floor,
Interference, and Airtime (2.4/5 GHz) performance graphs.

Statistics System, Managed Service, and Network statistics available.

Software
Update

Software update provided at System, Managed Account, Network, Site, and Device
levels.

Maps Location of Home Sites and Devices.

Clients Both Wired and Wireless Clients supported at Site and Device levels.

Tools Status, Debug, Network Connectivity, Wi-Fi Analyzer, Speed Test, and Packet Capture
tools available.

Reports Data Reports downloaded from the System, Managed Service, Network, and Site levels.

This topic contains the following sections:

l Configuring Home Mesh Router

l Viewing router system information and network traffic status

l Viewing, editing, and blocking connected clients

l Monitoring and troubleshooting the Home Mesh Router

Configuring Home Mesh Router
Before shipping the Home Mesh Routers to the subscribers, they must be configured with AP groups, Wi-Fi
profiles, and associated with the corresponding subscriber.

Configuring the routers involves the following steps:

1. Configuring WLAN profiles (SSIDs)

2. Configuring AP Groups

3. Onboarding the Home Mesh Router to cnMaestro

a. cnMaestro Subscriber application branding

b. Adding a Subscriber Service Profile

c. Adding a subscriber

d. Claiming the Home Mesh Router

Configuring WLAN Profiles (SSIDs)
WLANs allow you to configure home and guest access SSIDs for the Home Mesh Router. This WLAN profile is
associated with an AP group that contains configuration applied on the Home Mesh Routers. These SSIDs act as
default SSIDs on all routers associated with the AP group.

To configure a WLAN profile, complete the following steps:
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1. Sign in to cnMaestro.

The home page appears.

2. Navigate to Configuration > Wi-Fi Profiles.

The AP Groups page under Wi-Fi Profiles appears, by default.

3. Click the WLANs tab.

The WLANs page appears.

4. Click Add.

The WLANs > Add New window appears.

In the WLANs > Add New window, configure the WLAN parameters as described in Table 85.



Table 85: WLAN parameters

Parameter Description

Basic Information

Type Type of device for which the WLAN profile is configured.

Select RV22 Home Mesh from the drop-down list.

Name Name of the WLAN profile.

Description Brief description for the WLAN profile.

SSIDs—Home Access

Configure the default SSID that is used to connect devices wirelessly. Only one home SSID can be
configured.

SSID Unique name of the SSID for this WLAN.

Supports a maximum of 32 characters.

You must either configure the default SSID or enter a customized SSID.

The default SSID: RV22_<last 6 digits of device MAC>. For example, RV22_
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Parameter Description

123456.

Security Security method used for encryption.

The following security methods are supported:

l Open

l WPA Pre-Shared Key (AES, CCM)

l WPA2 Pre-Shared Keys (AES, CCM)

l WPA2 Pre-shared Keys (TKIP, AES)

l WPA Pre-Shared Key (TKIP, AES)

Password Security passphrase or key used to connect to this SSID.

You must either configure the default password or enter a customized password.

Default password: password

SSIDs—Guest Access

Configure the guest SSID to allow any guest devices to access the wireless network.

Enable Guest
Access

Determines whether the guest access is enabled.

Select the check box to enable guesst access.

SSID Unique name of the guest SSID for this WLAN.

Supports a maximum of 32 characters.

Password Security passphrase or key used to connect to this guest SSID.

Band Steering Determines whether the band steering is enabled for the wireless clients.

When enabled, APs steer wireless clients to connect to the 5 GHz band.

5. Click Save.

Configuring AP Groups
AP groups apply the same configuration to multiple Home Mesh Routers. AP groups contain configuration, such
as administrator password, event logging, radio settings, WAN mappings, and DNS mode.

The following are part of the AP group:

l Basic

l Management

l Administrator Access

l Time Settings



l Event Logging

l SNMP

l Radio

l Network

l WAN Configuration

l LAN Configuration

l Security

l DoS Protection

l Access Control List (ACL)

To configure an AP group, complete the following steps:

1. Sign in to cnMaestro.

The home page appears.

2. Navigate to Configuration > Wi-Fi Profiles.

The AP Groups page under Wi-Fi Profiles appears, by default.
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3. Click Add.

The Add New window appears with multiple tabs. By default, the Basic tab is selected.

4. In the Add New window > Basic tab, select RV22 Home Mesh in the Type drop-down list and configure
the parameters described in Table 86.



Table 86: Basic parameters

Parameter Description

Type Type of device for which the AP group is configured.

Select RV22 Home Mesh from the drop-down list.

Name Hostname of the device.

Supports a maximum of 64 characters.

Auto sync Specifies whether configuration is applied to the router automatically after
saving.

Select the check box to enable auto sync of configuration.

Country Country from where the device is operated.

To be set by the administrator only.

The allowed operating channels and the respective transmit power levels
depend on the country of operation. The list of countries supported depends on
the SKU of the device (FCC and ROW).

Note: Radios remain disabled unless this parameter is configured.

LED When enabled, turns on the device LEDs during operation.

Description Brief description for the AP group.

WLAN WLAN profile to be associated with this AP group.

WLAN profile contains SSID details of the wireless network.

Select the WLAN from the drop-down list. If no WLAN is configured, create one

by clicking the add ( ) icon. For more information, See Configuring WLAN

profiles (SSIDs).

5. Click the Management tab on the left pane and configure the parameters described in Table 87.
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Table 87: Management parameters

Parameter Description

Administrator Access-related parameters

Admin Password Password required for authentication of the router.

Disable Hardware
Reset Button

Determines whether the reset button on the router is required to prevent a
factory reset operation of the router.

Select the check box to prevent the user from performing the factory reset
operation.

Time Settings-related parameters

Time Zone Time zone of the location where the router is installed.

Select an appropriate time zone from the drop-down list.

NTP Server 1 Hostname or IPv4 address of the Network Time Protocol (NTP) server.

NTP Server 2 Hostname or IPv4 address of a second NTP server.

Event Logging-related parameters



Parameter Description

Syslog Server Hostname, IPv4, or IPv6 address of the Syslog server and the respective port
number.

Default port number: 514

Syslog Severity The severity level of event that must be forwarded to the server. The supported
severity levels (0-7) are based on RFC standards.

SNMP-related parameters

Enable Determines whether SNMPv2c or SNMPv3 support on the router is enabled.

Select the check box to enable SNMP support.

Trap Receiver IP IPv4 address of the SNMP server to receive the SNMP traps.

This parameter is appicable to both SNMP v2c and v3 versions.

Version Specifies the SNMP version configured for the router.

The following options are available:

l v2c

l v3

SNMPv2c-related parameters

SNMPv2c RO
community

The SNMP v2c read-only community string used as a password when obtaining
information from the router.

SNMPv2c RW
community

The SNMP v2c read-write community string as a password when writing
information to the router.

SNMPv3-related parameters

SNMPv3
Username

Username for the SNMPv3 server.

Supports a maximum of 32 characters.

Enable
Authentication

Indicates whether authentication is enabled for SNMP communication.

Select the check box to enable authentication.

Authentication
Protocol

Specifies the authentication protocol.

The following options are available:

l MD5

l SHA

Cambium uses SHA-1 authentication protocol.

By default, the SHA option is selected.
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Parameter Description

Authentication
Password

Password used for authentication.

Supports 8 to 32 characters.

Enable Encryption Indicates whether encryption is enabled for SNMP communication.

Select the check box to enable encryption.

Encryption Type Specifies the encryption type.

The following options are available:

l AES

l DES

By default, the AES option is selected.

Encryption
Password

Password used for encryption.

Supports 8 to 32 characters.

6. Click the Radio tab on the left pane and configure the preferred radios (2.4 GHz or 5 GHz or both).

By default, both the radios are enabled. You can disable only the 2.4 GHz radio.

Configure the parameters (described in Table 88), which are similar across 2.4 and 5 GHz radios.



Table 88: Radio parameters

Parameter Description

Enable Enables the operation of radio.

Channel This parameter cannot be modified.

This is configured as Auto, by default.

Auto Channel Frequency
Coordination

Enable to prevent router from self-interference with upline wireless
network infrastructure.

Channel Width Select the following channel widths for the operation:

l For 2.4 GHz—20 MHz and 40 MHz channel width are
supported.

Default: 20 MHz

l For 5 GHz—20 MHz, 40 MHz, 80 MHz, and 160 MHz channel
width are supported.

Default: 80 MHz

Transmit Power Transmit power of the router in percentage (%).

The following options are available:

l Auto

l 20

l 40

l 60

l 80

l 100

7. Click the Network tab on the left pane and configure the WAN mode and IP address assignment
parameters.
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i. The AP Mode is pre-configured as Router and cannot be modified.

ii. In the WAN Configuration section, select the required WAN mode and configure the
corresponding parameters.

This mode selects the mode of IP address assignment for the WAN interface. The following WAN
modes are supported:

l DHCP—This mode is selected by default.

No additional parameter configuration is required.

l PPPoE—Configure the PPPoE parameters as described in Table 89.



Parameter Description

PPPoE-related parameters

Service Name Name of the PPPoE service name.

Supports a maximum of 32 characters.

Username Username of the PPPoE service required for authentication.

Password Password of the PPPoE service required for authentication.

Passthrough Indicates whether the clients must directly establish connection
with the service provider.

Select the check box to enable passthrough.

Table 89: WAN Mode:  PPPoE parameters
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Parameter Description

PPP Connection
Trigger

Indicates the connection method for the router for keeping the
connection intact.

The following options are supported:

l Auto Connect

l On Demand

Idle Timeout This parameter is mandatory when you select On Demand type
of PPP Connection Trigger.

Specifies the duration (in seconds) after which PPPoE keep-alive
packets must be sent to keep the connection intact.

Default: 300

MTU Maximum size (in bytes) of each packet sent in a single
transmission between connected devices.

Default: 1492

Table 89: WAN Mode:  PPPoE parameters

l Static—Configure the Static parameters as described in Table 90.



Parameter Description

Static-related parameters

IP Address IPv4 address assigned to the router.

Subnet Mask Subnet mask assigned to the router's IPv4 address.

Gateway IPv4 address of the gateway used for communication.

Primary DNS IPv4 address of the primary DNS server.

Secondary DNS IPv4 address of the secondary DNS server.

MTU Maximum size (in bytes) of each packet sent in a single
transmission between connected devices.

Default: 1492

Table 90: WAN Mode:  Static parameters

Note

If you select PPPoE or Static mode, you must preconfigure the settings in the
router before shipping the routers to customers. Complete the following steps
before shipping the Home Mesh Router to the customers:

i. Onboard the Home Mesh Router using the standard WAN mode as
DHCP.

ii. After the Home Mesh Router is onboarded, set the WAN mode to PPPoE
or Static.

iii. Configure the username and password credentials.

The configuration and the credentials are applied on the Home Mesh
Router.

iv. Disconnect the Home Mesh Router and ship it to the customer.

When the customer connects the router to the PPPoE authenticated
network, the Home Mesh Router uses the PPPoE credentials to
authenticate.

iii. In the LAN Configuration section, configure the mode of IP address assignment for connecting
devices to Auto or Manual.

If you select Manual mode of assignment, configure the following parameters:
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Parameter Description

IPv4-related parameters

Local IP Address Local IPv4 address assigned to the router.

Local Subnet Subnet mask assigned to the router's IPv4 address.

Address Range
Start

Starting IPv4 address in the address pool.

Address Range End Ending IPv4 address in the address pool.

Domain Name The domain name.

DNS Mode DNS mode used for IP address resolution.

Following are the supported options:

l Auto

l Manual

l Proxy

Table 91: LAN Configuration parameters for Manual mode

8. Click the Security tab on the left pane and configure protection against different types of attacks, such as
Smurf attack and ICMP fragment.

Select the check box corresponding to the DoS protection options.



Parameter Description

IP Spoof Enable protection agains IP spoof attacks.

When enabled, the router checks whether the spoofed IP address is reachable
before accepting.

Smurf Attack Enable protection agains Smurf attacks.

When enabled, the router does not respond to the broadcast ICMP.

IP Spoof Log Enable logging of IP spoof addresses.

When enabled, the router logs the unroutable source IP address.

ICMP Fragment Enable protection against ICMP fragmented ping attack.

When enabled, the router drops the fragmented ICMP packets.

Table 92: Security parameters: DoS Protection

9. Click Add New in the ACL section and configure the parameters as described in Table 92.
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Parameter Description

Precedence Specifies the priority of the rule configured.

Select the precedence from the drop-down list.

Policy Indicates the action to be taken for the policy.

The following are the supported actions:

l Accept

l Drop

l Reject

Direction Direction to which the policy must be applied.

Table 93: Security parameters: Access Control List (ACL)



Parameter Description

The following are the supported options:

l WAN to LAN

l LAN to WAN

l WAN to Router

l Router to WAN

Type Type of traffic to which the policy must be applied.

The following are the supported options:

l IP

l IPv6

l MAC

l Protocol

l Protocolv6

Additional parameters are enabled when you selct the type.

Source IP/Mask

Destination IP/Mask

This field is applicable when you select the Type as IP, IPv6, Protocol, or
Protocolv6.

Specifies the source IPv4 or IPv6 address and the destination IPv4 or IPv6
address for the policy.

You can configure Any if there is no specific IP address to apply the policy to
any source IP address.

Source MAC/Mask

Destination
MAC/Mask

This field is applicable when you select the Type as MAC.

Specifies the source MAC address and the destination MAC address for the
policy.

You can configure Any if there is no specific MAC address to apply the policy
to any source IP address.

Protocol Type of protocol for which the policy must be applied.

The following are the supported options:

l TCP

l UDP

l ICMP

l Any

Additional parameters are enabled when you selct the protocol.

Table 93: Security parameters: Access Control List (ACL)
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Parameter Description

Source Port This field is applicable when you select the Protocol as TCP, UDP, or Any.

Specifies the source port number for the policy.

Destination Port This field is applicable when you select the Protocol as TCP, UDP, or Any.

Specifies the source port number for the policy.

Description Description for the rule.

Table 93: Security parameters: Access Control List (ACL)

10. Click Save.

The AP group is successfully created with the configured parameters.

Onboarding the Home Mesh Router to cnMaestro
After creating a WLAN profile and an AP group, you must now create a subscriber profile and associate it with
the subscriber. Finally, you must onboard the router(s) to the corresponding subscriber.

Adding a subscriber and onboarding the router involves the following steps:

1. cnMaestro Subscriber application branding

2. Adding a home site

3. Adding a Subscriber Service Profile

4. Adding a subscriber

5. Claiming the Home Mesh Router

cnMaestro Subscriber application branding
Customize the cnMaestro Subscriber mobile application with your company name, brand logo, and other
details, such as support contact information and hours. This branding can be associated with individual
subscriber service profiles.

To add brand details to the cnMaestro Subscriber application, complete the following steps:

1. Navigate to the Manage Service Providers > Managed Subscribers > Subscriber Service Profiles tab.

The Subscriber Service Profiles page appears.



2. Click Subscriber App Branding.

3. Click the add ( ) icon.

The Subscriber App Branding window appears. Configure the following parameters as described in Table
94.

Table 94: Subscriber App Branding parameters

Parameter Description

Name Name of the application branding.

Logo Brand logo displayed in the cnMaestro Subscriber application.

Maximum size of the image supported is 1 MB.

Only JPEG, JPG, PNG, and SVG file formats are supported.

Support Email address for customer support team displayed in the application.
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Parameter Description

Email

Support
Phone
Number

Phone number for customer support team displayed in the application.

Support
Hours

Contact hours for the customer support team.

l Select the Weekdays check box and configure the week days on when the
customer support team is available. You can also configure the time using the
time picker tool.

l Select the Weekends check box and configure the weekend days on when the
customer support team is available. You can also configure the time using the
time picker tool.

You can preview your branding updates by scrolling through the images in the preview window on the
right.

4. Click Save.

Adding a home site
A home site is required to associate the subscriber’s device with the device configuration.

To create a home site, complete the following steps:

1. Click Monitor and Manage ( ).

2. In the Networks tab, search for the network and hover over the network name.

3. Click the actions ( ) icon and select Add Site.

The Sites > Add New page appears.



4. Select the Home option in the Type field.

5. Enter the location details in the Longitude and Latitude fields.

You can also search for the location in the map to fill in the details.

6. Click Add.

Managing subscribers (end-customer)
To enable a subscriber to manage the router using the Android or iOS application, you must add a subscriber
profile in cnMaestro and send an invitation to the subscriber.

This pocess involves the following actions:

1. Adding a subscriber service profile

2. Adding a subscriber

3. Claiming the Home Mesh Router

Adding a Subscriber Service Profile
To add a subscriber service profile, complete the following steps:

1. Navigate to the Manage Service Providers > Managed Subscribers > Subscriber Service Profiles tab.

The Subscriber Service Profiles page appears.
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2. Click Add New.

The Add Subscriber Service Profile window appears.

3. Select the Home Mesh Router configuration to which you want to associate with the subscriber service
profile and configure the parameters as described in Table 95.



Table 95: Subscriber Service Profile parameters

Parameter Description

Name Name of the subscriber service profile.

Description Brief description for the subscriber service profile.

Download (Mbps) Download speed (in Mbps) configured for the profile.

Subscribers that are onboarded to this profile will be restricted to this download
speed.

Upload (Mbps) Upload speed (in Mbps) configured for the profile.

Subscribers that are onboarded to this profile will be restricted to this upload
speed.

Type Displays the device type as RV22 Home Mesh.

This field cannot be modified.

Device
Configuration

Specifies the Wi-Fi AP group (created for Home Mesh Router) that must be
associated with the service profile.

Select the group from the drop-down list.

Subscriber App
Branding

Specifies the cnMaestro Subscriber application branding that must be used in
this profile.

All routers sent to subscribers in this service profile contain the selected
branding logo and information.

Select the required branding from the drop-down list.

If no branding is present, create one by clicking the add ( ) icon. See

cnMaestro Subscriber application branding for more information.

4. Click Save.

Adding a subscriber
5. Click the Subscribers tab on the Managed Subscribers page.

6. Click Add New.
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The Add Subscriber window appears.

7. In the Add Subscriber window, configure the details of the subscriber in the Basic Information section, as
described in Table 96.

Table 96: Subscriber > Basic tab parameters

Parameter Description

Full Name Name of the subscriber.

Email ID Email address of the subscriber.

Phone Number Phone number of the subscriber.

Customer ID Unique ID for the subscriber.

Address Address of the subscriber where the routers will be installed.

8. Click Next.

The Service Configuration tab is displayed.



9. Select the subscriber service profile to be associated with this subscriber from the Service Profile drop-
down list.

10. Click Save.

A new tab, Devices appears, where you can link (or claim) the Home Mesh Router to the subscriber. See
Claiming the Home Mesh Router.

The cnMaestro Subscriber application invitation email is sent to the subscriber with the link to join the
account.

After the email is sent, you must follow the steps, as described in Logging in to the cnMaestro Subscriber
application, to accept the invitation and join the account to manage the routers in the cnMaestro
Subscriber application.

11. Click Devices.

12. Select one of the following options in the Deployment Type field:

l Fiber—Select the Optical Network Unit (ONU) device that you want to associate with the
subscriber's router by searching in the ONU search box.
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l Fixed Wireless—Select the Subscriber Module (SM) device that you want to associate with the
subscriber's router by searching in the SM search box.

l Home Site—Select the home site that you want to associate with the subscriber's router by
searching in the Home Site search box. To add a home site, see Adding a home site.

13. Before linking the Home Mesh Router to the subscriber, click Save.

Claiming the Home Mesh Router
After adding a subscriber profile and a subscriber, you must now associate the Home Mesh Router to the
subscriber by claiming the router in cnMaestro.

To claim the router, complete the following steps:

1. Navigate to the Manage Service Providers > Managed Subscribers > Subscribers tab.

2. In the list of subscribers, select the subscriber name for which you want to associate the Home Mesh
Router.

3. Click the Devices tab.

4. In the Add Devices to Subscriber section, click Add New.

The Link Subscriber window appears.

5. In the Link Subscriber window, link the Home Mesh Router to the subscriber by using any of the following
methods:

l To claim a new router that is not onboarded to cnMaestro, select the Claim new and assign option
and enter the serial number of the device to be claimed.

You can claim multiple routers by adding multiple serial numbers separated by commas.



l To claim a router that is already onboarded to cnMaestro, select the Search for inventory and
assign option.

Enter the details of the router you want to claim.

6. Click Assign.

The assigned router appears in the Add Devices to Subscriber section.

Note

Click the unlink ( ) icon to unlink the router from the subscriber.

Setting up the Home Mesh Router
Home Mesh Routers can be deployed in one of the following modes:

l Setting up the Home Mesh Router—Standalone mode

l Setting up the Home Mesh Router—Wireless Mesh Mode

l Setting up the Home Mesh Router—Wired Mesh Mode
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Setting up the Home Mesh Router—Standalone mode
In standalone mode of deployment, there is only one Home Mesh Router deployed. A sample scenario is shown
in the following figure:

A sample cnMaestro dashboard for the standalone mode of deployment is shown in the following figure:

Setting up the Home Mesh Router—Wireless Mesh Mode
To configure a wireless mesh, onboard the routers to a site—Claim all the routers, which you want to be part of
the mesh, on cnMaestro in the subscriber workflow. See Claiming the Home Mesh Router. Connect the mesh
base router to the internet and wirelessly connect the node routers. The AP group mapped to the subscriber is
applied to all the routers to sync the configuration.

Following are some of the wireless mesh configuration scenarios and the corresponding dashboards and
hierarchy in cnMaestro:

l Wireless mesh: 1-1 deployment

l Wireless mesh: 1-1-1 deployment

l Wireless mesh: 1-2 deployment

l Wireless and wired mixed mesh 1-2 deployment

Wireless mesh: 1-1 deployment

In this deployment, the base router is connected to one node router, thereby creating a wireless 1-1 mesh
deployment.



Figure 354 Wireless mesh: 1-1 deployment

Figure 355 displays a sample cnMaestro dashboard for the wireless mesh 1-1 deployment.

Figure 355 Sample dashboard for wireless mesh: 1-1 deployment

Figure 356 displays a sample cnMaestro status page for the wireless mesh 1-1 deployment.

Figure 356 Sample status page for wireless mesh: 1-1 deployment

Wireless mesh: 1-1-1 deployment

In this deployment, the base router is connected wirelessly to only one of the node routers, which is inturn
connected to another node router, thereby creating a wireless 1-1-1 mesh deployment.
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Figure 357 Wireless mesh: 1-1-1 deployment

Figure 358 displays a sample cnMaestro dashboard for the wireless mesh 1-1-1 deployment.

Figure 358 Sample dashboard for wireless mesh: 1-1-1 deployment

Figure 359 displays a sample cnMaestro status page for the wireless mesh 1-1-1 deployment.

Figure 359 Sample status page for wireless mesh: 1-1-1 deployment



Wireless mesh: 1-2 deployment

In this deployment, the base router is connected to two node routers simultaneously, thereby creating a
wireless 1-2 mesh deployment.

Figure 360 Wireless mesh: 1-2 deployment

Figure 361 displays a sample cnMaestro dashboard for the wireless mesh 1-2 deployment.

Figure 361 Sample dashboard for wireless mesh: 1-2 deployment

Figure 362 and Figure 363 display sample status pages for the node routers in a wireless mesh 1-2 deployment.

In the following status samples, the RV22-Base-Pantry router is connected to both RV22-Mesh-Shelf and RV22-
Mesh-Cabin routers, forming a 1-2 multi-mesh topology.
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l Network toplogy for the RV22-Mesh-Cabin router

Figure 362 Sample status page for RV22-Mesh-Cabin node router in a wireless mesh: 1-2 deployment

l Network toplogy for the RV22-Mesh-Shelf router

Figure 363 Sample status page for RV22-Mesh-Shelf node router in a wireless mesh: 1-2 deployment

Wireless and wired mixed mesh 1-2 deployment
In this deployment, the base router is connected to one node router wirelessly and simultaneously to another by
a wired connection, thereby creating a mixed 1-2 mesh deployment.



Figure 364 Wireless and wired mixed mesh: 1-2 deployment

Figure 362 and Figure 363 display sample status pages for the node routers in a mixed mesh 1-2 deployment.

In the following status samples, one RV22 base router is connected to one RV22 node router wirelessly and
simultaneously to another RV22 node router by a wired connection.

l Network toplogy for the wireless RV22 node router

Figure 365 Sample status page for the wireless RV22 node router in a mixed mesh: 1-2 deployment

l Network toplogy for the wired RV22 node router
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Figure 366 Sample status page for the wired RV22 node router in a mixed mesh: 1-2 deployment

Setting up the Home Mesh Router—Wired Mesh Mode
To configure a wired mesh, onboard the routers to a site—Claim the routers, which you want to be part of the
mesh, on cnMaestro in the subscriber workflow. See Claiming the Home Mesh Router. Connect the mesh base
router to the internet and connect the node routers to the base router using Ethernet cables. The AP group
mapped to the subscriber is applied to all the routers to sync the configuration.

No configuration changes are required for RV22 routers to work in both wired and wireless mesh modes. Use
any LAN port on the mesh base and any LAN port on the mesh node routers to establish a wired mesh
connection. When a mesh node router detects an RV22 neighbor on its LAN port, it automatically establishes a
wired mesh link using the LAN ports.

Note

You must not use the WAN port on the mesh node router to establish a wired mesh.

Following are some of the wired mesh configurations supported:

l Wired mesh: 1-1 deployment

l Wired mesh: 1-1-1 deployment

l Wired mesh: 1-2 deployment

Wired mesh: 1-1 deployment

In this deployment, the base router is connected to one node router using an Ethernet cable (between any
LAN ports on both routers), thereby creating a wired 1-1 mesh deployment.

Figure 367 Wired mesh: 1-1 deployment



Wired mesh: 1-1-1 deployment

In this deployment, the base router is connected to only one of the node routers, which is inturn connected to
another node router, by a wired connection (between any LAN ports on the routers), thereby creating a wired 1-
1-1 mesh deployment.

Figure 368 Wired mesh: 1-1-1 deployment

Figure 369 displays a sample cnMaestro status page for the wired mesh 1-1-1 deployment.

Figure 369 Sample status page for wired mesh: 1-1-1 deployment

Wired mesh: 1-2 deployment

In this deployment, the base router is connected to two node routers simultaneously by a wired connection,
thereby creating a wired 1-2 mesh deployment.
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Figure 370 Wired mesh: 1-2 deployment

Figure 371 and Figure 372 display sample status pages for the node routers in a wired mesh 1-2 deployment.

In the following status samples, the Reg-MB-Base router is connected to both Reg-MC-1 and Reg-MC-2 routers
using Ethernet cables, forming a wired 1-2 multi-mesh topology.

l Network toplogy for the Reg-MC-1 router

Figure 371 Sample status page for Reg-MC-1 node router in a wired mesh: 1-2 deployment

l Network toplogy for the Reg-MC-2 router

Figure 372 Sample status page for Reg-MC-2 node router in a wired mesh: 1-2 deployment

Viewing router system information and network traffic status
When the customer configures the Home Mesh Router and connects to the internet, you can check the
connection of the router in cnMaestro. You can also check the details of the clients that are connected.



To view router system information and the connection status, navigate to Monitor and Manage > <Home-Mesh-
Router-name> > Details tab.

The Details page displays information in the following tabs:

l Overview

This page displays information in the following sections:

l System—Displays information, such as router name, MAC address, health of the router (online,
offline), software version, and location.

l Radio—Displays radio details, such as the running bands, RF quality, count of clients connected to
each radio, and the average throughput.

l Configuration Update—Displays the history of configuration updates to the router.

l Software Update—Displays the currently running software version and a history of software
updates that were performed and the status.

l Network Info

This page displays information in the following sections:

l WAN—Displays collective statistics about total number of transmitted and received data packets,
data bytes, packets dropped, maximum and average speeds

l IPv4 Routes—Displays the IPv4 routes configured for the router.

l DNS Server(s)—Displays the details of the DNS servers.

l LAN—Displays details of the LAN interfaces, their status, total number of transmitted and received
data packets and size (in bytes), packet errors and drops.
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l DHCP Server—Displays details of the DHCP servers, start and end IP address in the range used for
allocation, and the lease time.

Viewing, editing, and blocking connected clients
cnMaestro allows you to view details of clients (both wired and wireless) connected to the router and edit the
name of clients. You can also block certain clients that you do not want to be connected to your wireless
networks.

This topic contains the following sections:

l Viewing connected clients

l Editing client host name

l Blocking clients

Viewing connected clients
To view the list of connected clients, both wired and wireless, navigate to Monitor and Manage > <Home-Mesh-
Router-name> > Clients tab.

The Details page displays information in the following tabs:

l Wireless Clients

This page displays information about the wireless clients connected to the router, such as the host name,
MAC address, IPv4 addess assigned, the router it is connected to, and the status of connection with the
router (online, offline).



l Wired Clients

This page displays information about the wired clients connected to the router, such as the host name,
MAC address, IPv4 addess assigned, port number to which it is connected, the manufacturer of device
connected, last connected duration, and the download and upload data size (in MB).

Editing a client's host name
To edit the host name of a connected client, click the edit client name ( ) icon corresponding to the client.

Enter the name in the Host Name field and click Save.

Blocking clients
To block a connected client, click the block ( ) icon corresponding to the client.

Monitoring and troubleshooting the Home Mesh Router
You can monitor and perform troubleshooting tasks on the Home Mesh Router using cnMaestro. This topic
covers the following sections

l Monitoring the Home Mesh Router

l Troubleshooting the Home Mesh Router
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l Upgrading the Home Mesh Router firmware

Monitoring the Home Mesh Router
When the device is onboarded to cnMaestro, based on the deploymnet type, the router is displayed under the
site that it is configured.

cUsing the following pages in cnMaestro, monitor and view details of the router and the deployment.

l Home Site Dashboard

l Notifications

l Software Update

l Performance

Home Site Dashboard
To view the site dashboard, access the Dashboard page under Monitor and Manage > <Home-site-name>
> Dashboard.



Notifications
The Notifications page displays current alarms, previous alarms, Wi-Fi-related events, and other device-related
events.

cnMaestro displays the following types of notifications:

l Alarms

l Alarms History

l Events

l Wi-Fi Events
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Alarms
The Alarms page displays the number of critical, major, and minor events observed for the Home Mesh
Router.You can also view the details of the events, such as severity level, name of the event, time and action
taken.

To view the alarms raised, access the Alarms page under Monitor and Manage > <Home-site-name>
> Notifications > Alarms.

Alarms History
The Alarms History page displays the number of critical, major, and minor events observed in the previous
week.

To view the alarms history displayed as a graphical representation, access the Alarms History page under
Monitor and Manage > <Home-site-name> > Notifications > Alarms History.

Events
The Events page displays Home Mesh Router-related events, such as its status, if there was a bandwidth
change, when the DHCP server IP was assigned to the connected clients.



To view the events, access the Events page under Monitor and Manage > <Home-site-name> > Notifications >
Events.

Wi-Fi Events
The Wi-Fi Events page displays client-related events, such as when the client connected to the network, when it
was disconnected, and authentication events.

To view the Wi-Fi events, access the Wi-Fi Events page under Monitor and Manage > <Home-site-name>
> Notifications > Wi-Fi Events.

Software Update
To upgrade the router firmware, go to the Software Update page. See Upgrading the Home Mesh Router
firmware for more information.
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Performance
To view the performace of the router, access the Wi-Fi Events page under Monitor and Manage > <Home-Mesh-
Router-name> > Performance.

The page displays the following graphical information:

Table 97: Performance page graphs—Base and Node routers

Parameter Description
Router (Base /
Node / Both)

Stacked WAN
Throughput

Hourly throughput for both downlink and uplink in the WAN
interface for each band of the mesh base router.

Base only

Stacked
Throughput by
Band (Downlink)

Downlink speed in each band. Both

Stacked
Throughput by
Band (Uplink)

Uplink speed in each band. Both

Stacked Clients by
Band

Count of number of clients connected in each band. Both

Noise Floor Amount of background noise (in dBm) or interference created
by devices in the same frequency.

Both

Interference Interefence (in dBm) caused by other wireless signals and
devices interrupting the router's Wi-Fi signal.

Both



Parameter Description
Router (Base /
Node / Both)

Airtime 2.4 GHz Capacity utilization (in %) of the 2.4 GHz band for effective
transmission.

Both

Airtime 5 GHz Capacity utilization (in %) of the 5 GHz band for effective
transmission.

Both

Available Memory Amount of router memory (in %) available for use. Both

CPU Router CPU utilization in percentage (%). Both

SNR Minimum, average, and maximum SNR values (in dB) for the
mesh node router.

Node only

RSSI Received Signal Strength Indicator (RSSI) value (in dBm) for
the mesh node router.

Node only

Data Rate Minimum, average, and maximum data rates (in Mbps or Gbps)
provided by the mesh node router to the client devices.

Node only

Following are sample performance graphs for base and node routers:
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l Performance of the base router in a mesh deployment

l Performance of the node router in a mesh deployment



Troubleshooting the Home Mesh Router
cnMaestro provides the following troubleshooting options for the router:

l Status

n Downloading tech support file

l Debug
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l Network Connectivity

l Wi-Fi Analyzer

l Speed Test

l Packet Capture

Status
The Status page displays the status of link between the Home Mesh Router base and client devices.

To view the status of the link between the Home Mesh base and client devices, access the Status page under
Monitor and Manage > <Home-Mesh-Router-name> > Tools.

Downloading tech support file

To download the tech support file, click the Download Tech Support File ( ) icon on the Status page.

Debug
The Debug page displays log information of the Home Mesh Router. To view the debug information, complete
the following steps:

1. Navigate to the Monitor and Manage > <Home-Mesh-Router-name> > Tools > Debug tab.



2. Click Start Logs.

The log information is displayed in the Output window.

Network Connectivity
The Network Connectivity page provides network connectivity information of the Home Mesh Routers.

cnMaestro supports the following tests to provide connectivity information for the Home Mesh Routers:

l Ping

l DNS Lookup

l Traceroute

To test network connectivity of the router, complete the following steps:

1. Navigate to the Monitor and Manage > <Home-Mesh-Router-name> > Tools > Network Connectivity tab.

2. Select the required test type from the Test Type drop-down list and configure the corresponding
parameters required for the test.

3. Click Start Test.

cnMaestro initiates the test and displays the result in the <Test Type> Result window.
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Wi-Fi Analyzer
The Wi-Fi Analyzer page displays radio traffic and signal information for the selected band. It displays the
interference and noise measured for the selected band.

To view the Wi-Fi Analyzer details, complete the following steps:

1. Navigate to the Monitor and Manage > <Home-Mesh-Router-name> > Tools > Wi-Fi Analyzer tab.

2. Select the required band (2.4 or 5 GHz).

3. Click Start Scan.

cnMaestro analyzes the band and displays the result in a table.



Speed Test
The Speed Test page displays the internet speed provided by the Home Mesh Router.

To know the speed of the router, complete the following steps:

1. Navigate to the Monitor and Manage > <Home-Mesh-Router-name> > Tools > Speed Test tab.

2. Configure the required values for testing the speed.

3. Click Start Speed Test.

cnMaestro checks the speed and displays both download and upload speeds in megabits per second
(Mbps).

The speed test option is also available on the Subscriber page in the Home Wi-Fi Devices Setting Override
section.
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To avail this speed test option, complete the following steps:

1. Navigate to the Manage Service Providers > Managed Subscribers > Subscribers tab.

2. From the list of subscribers, click the subscriber name for which you want to configure the speed test.

The Edit <Susbcriber-name> window is displayed.

3. Click the Service Configuration tab.

4. In the Home Wi-Fi Devices Setting Override section, click the Speed Test tab.

5. To schedule the speed test at a particular duration, select the Schedule Background Testing check box.

6. Select the start and end time for performing the speed test on the router.

Packet Capture
The Packet Capture page allows the user to capture all packets on a specified interface.



To capture packet data, complete the following steps:

1. Navigate to the Monitor and Manage > <Home-Mesh-Router-name> > Tools > Packet Capture tab.

2. Select the required interface, and provide the source and destination IP address or MAC address.

3. Provide the number of packets that must be captured.

4. Click Start Capture.

cnMaestro displays the information in the Ouput window.

5. To download the PCAP file, click the download ( ) icon.

Upgrading the Home Mesh Router firmware
To upgrade the firmware of Home Mesh routers present in a home site, complete the following steps:

1. Navigate to Monitor and Manage > <Home-site-name> > Software Update.

The Software Update page appears.

2. Select RV22 Home Mesh from the Device Type drop-down list.

3. Select the software version from the Versions drop-down list.

4. In the list of devices table, select the check boxes corresponding to the devices for which you want to
upgrade the firmware.

You can also select one router to upgrade the firmware of only that router.

5. Select the Now option in the Update field to upgrade the firmware immediately.

To schedule the upgrade job, select the Schedule option and configure the required date and time.

6. Click Add Software Job to <number of devices> device(s).

The upgrade is scheduled to run at the specified date and time.

To view the status of the update jobs, click View Update Jobs.
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Analytics
This chapter covers the following topics:

l Site Analytics

l Client Analytics

Analyzing Connection Failures of Wi-Fi Clients and
Poor Performance of Wi-Fi Networks

The Wi-Fi Analytics feature provides deep visibility into the health of Wi-Fi client connections, including root
cause analysis of failures and possible remediations. It also provides analytics on aggregated data that can help
to improve client connectivity in the Wi-Fi network.

NOTE:

This feature is currently available as a free trial to all cnMaestro X customers, but will require
a separate paid subscription in the future.

This section covers the following topics:

l Overview

l Use cases

l Resolve connectivity issues

l Address poor performance of applications

l Identify OS, SSID, and AP specific issues

l Accessing the Analytics XA page

l Setting filters to view the connection data

l Viewing the connection events

l Dashboard page

l Analytics XA page

l Connection tab

l Disconnection tab

l Viewing a client or host-specific connection or disconnection event

l Viewing an event-based connection or disconnection event

l Viewing an AP-specific information

Overview
The Analytics XA feature analyzes the Wi-Fi client connection events and helps to troubleshoot common
network connectivity and performance issues such as the following:
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l Connectivity—Association, authentication, and network connectivity failures.

l Poor Performance—Low RSSI, low data rate, high retry rate, and high latency in AAA, DHCP, DNS, and
applications.

You can use this feature to detect and analyze common network problems that occur in your wireless networks.

NOTE:

Analytics XA is supported only for XV and XE devices.

The Analytics XA page reports the following data for the Wi-Fi clients:

l Statistics of successful connections per connection type such as new, reconnection, and roaming.

l Statistics of failed connections and disconnections, such as reason codes for association, EAP/EAPOL
handshake, DHCP, DNS, and Captive Portal failures.

Figure 373 The Analytics XA page

Use cases
Following are some of the use cases, to identify the connectivity issue and analyze the root cause:



Resolve connectivity issues
The Analytics XA page provides visual analytics of client connection failures in each phase such as baseline
performance and key metrics in the form of graphs and tables with multiple data filters. You can easily identify
the root cause based upon the phase of the Wi-Fi connection lifecycle.

l Association—Accessing the AP may fail if the client has low RSSI; if the request for capabilities is not
supported by the AP; or if the AP is already handling the maximum number of clients.

In such cases, you can use the Lifecycle Analysis widget on the Analytics XA page. This widget displays the
statistics of 802.11 authentication/association failures in percentage. In addition, you can use the Events
page to analyze the reason, cause, impact, and the recommended action.

l Authentication—Authentication may fail when 802.1X/EAP key is incorrect; the RADIUS server cannot be
reached; or the WPA2-PSK or WPA3-SAE key derivation is invalid.

In such cases, the Lifecycle Analysis widget displays the RADIUS authentication failure count in percentage.

l Network connection—When a client is successfully authenticated, it must be assigned an IP address by the
DHCP server and provided networking information such as for DNS and Gateway. When the DHCP server
fails, connectivity to the network cannot be established.

In such cases, the Lifecycle Analysis widget can help identify that the DHCP server failure, and the Events
page can analyze the reason and cause.

l Aggressive roaming—Time sensitive applications such as voice and video require uninterrupted
connectivity. To ensure this, Wi-Fi clients monitor the RSSI from local APs and probe better APs when the
connection degrades. The RSSI threshold at which a client moves from the current AP to another AP may be
different for each client and is vendor specific. Some clients may have aggressive roaming where they move
frequently across APs. This can result in increased contention in the network and longer delay for other
clients connecting or transmitting data. The client drill down presents the association, authentication, and
network connectivity events generated due to aggressive roaming.

You can use the Lifecycle page to analyze the RSSI ranges, roam quality, and lifecycle eventsts.

l DHCP, AAA, or DNS latency—Each of the association, authentication, and network connectivity stages might
add latency to the total connection time.

The Lifecycle Analysis widget and the Events page display statistics for the DHCP, AAA, and DNS latencies.

Address poor performance of applications
Wi-Fi clients may use a wide range of advanced video coding (AVC) applications such as Google Meet,
Microsoft Teams, Zoom, Skype, YouTube, and multiple e-commerce applications such as Flipkart and Amazon.
In such scenarios, clients may experience poor network performance or network disconnection due to low RSSI
or bad roam quality.

You can view the Session Timeline section in the Lifecycle page to analyze the RSSI ranges, and events such as
success, failed, connected, disconnected, and roam quality. This analysis helps you to understand the cause and
take recommended actions.

Identify OS, SSID, and AP-specific issues
Apart from run-time metrics, the Connection Health widget provides filters to identify performance issues with
a specific vendor, operating system, and associated AP and SSID.

Accessing the Analytics XA page
To access the Analytics XA page:
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1. On the left navigation pane, select the Monitor and Manage ( ) icon.

2. Select either a System, MSP, or Network, and then a Site node in the tree.

NOTE:

The Analytics XA page is available only at site and client levels.

The Dashboard tab displays the default Wi-Fi connection statistics.

3. Select the Analytics XA tab.

Setting filters to view the connection data
After accessing the Analytics XA page, you may change the default threshold for failed connections and set the
period to view the connection events such as 1 hour or 24 hours, or 7 days.



To set failure threshold and period:

1. Navigate to the Connection tab

2. Click Settings located inside the Connection Health widget.

3. Enter the Failure Threshold.

The default value is 10% and higher. To reset the threshold, click Reset to system default.

4. Select the Generate alarms when threshold is exceeded check box to generate a System Alarm whenever
the threshold is surpassed.

5. Select the Impact Level Filter as

l High (recommended) or

l High and Medium or

l High, Medium, and Low

6. To apply the configuration changes, click Update.

7. To view the connection or disconnection events for a specific period, select the Settings filter as

l Last 1 Hour or

l Last 24 hours (Resolution 1 hour) or

l Last 7 days (Resolution 1 hour) or

l Date: To view the connection or disconnection data for a specific date. The Date filter supports
today's date and dates of the last seven days.

Based on the failure threshold, failure Impact filter, and the period, the Dashboard and Analytics XA

pages display the Wi-Fi client’s connection data. Whenever the failure percentage exceeds the
configured failure threshold, the Analytics XA page automatically generates alerts.
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NOTE:

Consider the following key points specific to impact level failures:

l High impact failure—Occurs when a client is unable to establish a connection with an
access point or transmit data over a connection. These failures are typically
permanent until the underlying problem is resolved. High impact failures include
incorrect pre-shared key (PSK); the VLAN not being configured or present on the
switch; and AP software issues.

l Medium impact failure—Occurs when a client is intermittently unable to connect to a
network,and the time to connect is relatively short (sub-seconds). These failures may
not be noticed by end users. They are caused by transient issues such as the moving
client or when an access point locks the necessary information during the initial
connection attempt. Medium impact failure events include fast transition (FT);
authentication failure; missed packets during the four-way handshake; DHCP request
process; or momentary interference from other wireless devices.

l Low impact failure—Occurs when a client is unable to connect to a network, without
causing any noticeable impact for end users. These failures may arise due to specific
wireless LAN features or configurations, such as band steering. These failures are
expected, based upon the Wireless LAN protocols, and do not impact the user
experience. In some cases, adjusting WLAN configuration can resolve such failure
issues.

Viewing the connection events
You can view and analyze the Wi-Fi connection events using the following UI pages:

l Dashboard page

l Analytics XA page

Dashboard page
The site Dashboard page displays the following widgets:

l Client Connection Health—Displays overall statistics for connection events through a gauge/dial chart.
Based on the impact level filter set on the Analytics XA > Settings page, this widget displays the
statistics for failed connections.



The default Impact filter for a Site is High. The resolution of this chart is 1 hour, which means every 1 hour
this chart is updated. This chart displays the data based on the threshold and the impact level filter you
set.

l Number and percentage of successful connections.

l Number and percentage of impact level failures for failed connections.

NOTE:

The Client Connection Health widget score is calculated, as follows.

Score = (Failures * 100)/(Failures+Success) %

Depending on the selection of the impact level filter on the Analytics XA > Settings
page, the failure count is calculated as follows:

l High Impact—Includes high impact failures only.

l High and Medium Impact—Includes medium and high impact failures.

l High, Medium, and Low Impact—Includes all failures: high, medium, and low
impact.

l Wi-Fi Client Analytics—Indicates the percentage of failed connections at each step in the client lifecycle.

The phase-wise chart displays the current status by highlighting the phase in:

l Red—If the failure percentage exceeds the configured failure threshold configured in Analytics
XA> Settings page,

l Orange—If the failure percentage falls within the range of 80-100% of the configured failure
threshold,

l Green —If the failure percentage is below 80% of the configured failure threshold.

The Wi-Fi Client Analytics widget displays the connection state of clients to the Internet in the following
phases:

l Duration in each phase indicates the average time taken by the clients in the respective phase.

l Association—Indicates the percentage of failed connections during the association phase.

l Authentication—Indicates the percentage of failed client authentications such as EAP, RADIUS,
and authentication key derivation (EAPOL) failures.

l DHCP—Indicates the percentage of failed DHCP request/responses from/to the client.

l DNS—Indicates the percentage of failed DNS request/responses from/to the client.

l Captive Portal—Indicates the percentage of failed captive portal accesses.
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NOTE:

A captive portal is a web page launched in a browser that enables access to a
public network. For example, business centers, airports, hotel lobbies, coffee
shops, and other public venues use captive portals to offer free Wi-Fi hotspots
for internet users.

Analytics XA page

After accessing the Analytics X page and setting the failure threshold percentage, failure impact filter, and
duration, you can analyze the connection events using the following tabs:

l Connection—Provides statistics for the connection events.

l Disconnection—Provides statistics for the disconnection events.

Connection tab
Following widgets on the Connection tab show connection failure events for the configured duration:

l Connection Health—Displays statistics of the failed connections in a bar chart, based on the threshold
you set and the impact level failures in percentage.

The Connection Health bar chart represents the following data:

l Percentage of failed connections in a specific period for each Failure impact.

l Percentage of average failures highlighted by a grey line.

l Percentage of high, medium, and low impacted connections in different colors.

l Orange line indicates the Failure threshold percentage configured.

When you click on a bar in the chart, the chart displays the connection statistics for the selected date and
time.



When you select a bar on the Connection Health chart, the following widgets display data for the
selected failed connection event for the selected duration:

l Top Failures Across Phases

l Lifecycle Analysis

l Top Affected APs

l Top Affected Devices

l Top Affected OSes

NOTE:

Click the icon, located on the top right corner of the Analytics XA page, to refresh

the page.

l Top Failures Across Phases—Displays statistics of top failed connections in a pie chart, indicating failure
reasons across phases in percentage.

When you select any top failure slice on the pie chart, the following widgets display data for the selected
top failure:

l Lifecycle Analysis

l Top Affected APs

l Top Affected Devices

l Top Affected OSes
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l Lifecycle Analysis—Displays statistics for failed connections that help you analyze the life cycle of an
event. By default, the phase with highest failure percentage is selected and highlighted.

.

This Lifecycle Analysis widget displays data through the following formats:

l Phase-wise chart—Displays the phase-wise chart that indicates the percentage of failed Wi-Fi
client connections. When you click on a phase, the line graph below the phase-wise chart displays
the corresponding data.

l Line graph—Displays the count of failed connections based on the date and time.

l Filters to view the required failed connection in detail—Displays a detailed table to view failed
connection events.

To use filters and view the details of a failed connection, perform the following steps:

1. Inside the Lifecycle Analysis widget, click Apply Filter(s) located below the line graph
section.



2. To search for and view data of the required client's connection event, enter one or more of
the following values:

Filter
name

Description

Host Name The name of the host for which you want to view the failed connection
details.

MAC
Address

The MAC address of the device for which you want to view the failed
connection details.

Device
Type

Type of device used for the connection.

Device OS The operating system (OS) running on the device.

3. Click Apply Filter(s) to apply the changes.

A table below the line graph displays the count of failures for the searched criteria, as
shown in the following figure:

NOTE:

You can also click the icon in the table to quickly search for Mac

address, device type, device OS, and failure count.

When you click on a host name, the site-specific Clients page appears, displaying the
connection data for the selected host.
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l Top Affected APs—Displays the name of top affected APs and the statistics for the failed connection. To
view the statistics of top affected APs in percentage or count, click the icon next to the Top Affected
APs widget title.

Placing the cursor on any colored bar, displays the failure type and count specific to the failed
connection. If you click on any AP name, the site-specific Wi-Fi dashboard appears with the AP or device
information.

l Top Affected Device Types—Displays the name of top affected device types and the statistics for the
failed connection in count or percentage.

l Top Affected OS: Displays the name of top affected OS and the statistics for the failed connection in
count or percentage.

l Connection Events : Last 1 Hour—A table with filters displays the details of successful or failed connection
events that occurred in the last one hour.

NOTE:

Failure events per AP, Device type, and OS are displayed only when an hourly bar is
selected.

To use filters and view the connection details for the last one hour, perform the following steps:

1. Inside the Connection Events : Last 1 Hour widget, click Apply Filters.

2. To search and view data for the last one hour, enter one or more of the following details:



Filter
name

Description

MAC
Address

The MAC address of the device with connection events.

Success Select whether you want to view successful or failed connection events.

l Success

l Failed

Reason Select the required reason type from the drop-down list such as MAC-ACL, MAC-
AUTH, QoS failure, Passpoint failure, Capability mismatch, L2 Auth failure,
Association failure, Roaming failure, SAE failure, Cipher failure, or TDLS failure.

Impact Select the required impact type from the list:

l Low

l Medium

l High

Host Name The name of the host for which you want to view the connection state.

Device
Type

The type of device used for the connection.

Device OS The operating system (OS) running on the device.

3. Click Apply Filter(s) to apply the changes.

The table displays the connection event details with date, time, and AP names for the searched
criteria.

NOTE:

You can also click the icon in the table to quickly search for status, reason, impact level,

AP name, host name, device type, and device OS.

l When you click on any date and time, the Events page displays connection state data for the selected
date and time.

l When you click on any AP name, the site-specific Wi-Fi dashboard displays the AP or device information.
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l When you click on a host name, the site-specific Clients page displays the connection data for the
selected host.

Disconnection tab
On accessing the Analytics XA page, click on the Disconnection tab and set the time filter by choosing the
required time period as last 1 hour, last 24 hours, last 7 days, or a custom date. The Disconnection tab displays
the data for the selected time period.

The following widgets on the Disconnection page support root cause analysis:

l Disconnection—Displays the count of clients and APs initiated during the time period.

When you click on a bar in the chart, the chart displays the count of Clients and APs initiated at the
specific date and time.

When you select any bar on the Disconnection chart, the following widgets display data for the selected
disconnection event:

l Top Reasons

l Top Reporting APs

l Analytics

l Top Reporting Device Models

l Top Reporting Device Types

l Top Reporting OSes



NOTE:

Click the icon, located on the top right corner of the Analytics XA page, to refresh

the page.

l Top Reasons—Displays statistics of top failure reasons such as state machine issues, roam, QoS failures,
and timeout failures.

When you select any top failure slice on the pie chart, the following widgets display data for the selected
top failure:

l Top Reporting APs

l Analytics

l Top Reporting Device Models

l Top Reporting Device Types

l Top Reporting OSes

NOTE:

Click the icon, located on the top right corner of the Analytics XA page, to

refresh the page.

l Analytics—Displays statistics for disconnections to help analyze failure events in detail.
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This Lifecycle Analysis widget displays data in the following formats:

l Line graph: Displays the count of disconnections, including the date, time, and failure reasons in
different colors.

l Filters to view the required disconnection in detail: A table with filters displays detailed
information of a disconnection event.

To use filters and view the details of a disconnection event, perform the following steps:

1. Inside the Analysis widget, click Apply Filters located below the line graph section.

2. To search for and view data of the required client's disconnection state, enter one or more
of the following:

Filter name Description

Host Name The name of the host for which you want to view the disconnection
details.

MAC
Address

The MAC address of the device for which you want to view the
disconnection details.

Device
Type

Type of device used for the connection.

Device OS The operating system (OS) running on the device.

3. Click Apply Filter(s) to apply the changes.



A table below the line graph section displays the count of disconnections for the searched
criteria, as shown in the following figure:

NOTE:

You can also click the icon in the table to quickly search for MAC

address, device type, device OS, and disconnection count.

When you click on a host name, the site-specific Clients page displays the disconnection
state data for the selected host.

l Top Reporting APs—Displays the names of top APs and the count of disconnections in different colors
based on the disconnection types.

When you place your cursor on any color, you can view the reason type and count specific to the
disconnection type.

l Top Reporting Device Types—Displays the names of the top devices and the count of disconnections in
different colors based on the disconnection reasons. When you place your cursor on any color, you can
view the reason type and count specific to the disconnection events.

l Top Reporting OS—Displays the names of top OS and the count of disconnections. Different colors are
used to highlight the disconnection reasons. When you place your cursor on any color, you can view the
reason type and count specific to disconnection.

l Disconnect Events: Last 1 Hour—A table with filters displays the data of disconnection events that
occurred in the last one hour.

To use filters and view the disconnection state details for the last one hour, perform the following steps:

1. Inside the Disconnection Events : Last 1 Hour widget, click Apply Filters.

2. To search for and view data of the disconnection events, enter one or more of the following:
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Filter
name

Description

MAC
Address

The MAC address of the device for which you want to view the disconnection
events.

Reason Select the type of reason from drop-down list such as Unknown-disc-O, QoS
failure, Radius failures, TDLS failures, timeout failures, state machine issues, AP
Resource failures, AP assisted roaming, and roam.

Host Name The name of the host for which you want to view the disconnection state.

Device
Type

Type of device used for the connection.

Device OS The operating system (OS) running on the device

3. Click Apply Filter(s) to apply the changes.

The table displays the disconnection state with date, time, and AP names for the searched criteria.

NOTE:

You can also click the icon in the table to quickly search for MAC address, reason, AP

name device type, device OS, and disconnection count.

l When you click on any date and time, the Events page displays the disconnection state data for the
selected date and time.

l When you click on any AP name, the site-specific Wi-Fi dashboard displays the AP or device information.

l When you click on a host name, the site-specific Clients page displays the disconnection state data for
the selected host.

Viewing a client or host-specific connection or disconnection event
You can analyze client or host-specific connection or disconnection events in detail and take appropriate
actions.

To view client or host-specific information, perform the following steps:

1. Click on a host name to view the connection or disconnection state in detail.

You can locate the host names in the following widgets:



l Lifecycle Analytics on the Connection page—host names are available in a table below the line
graph section.

l Connection Events: Last 1 Hour on the Connection page.

l Analytics on the Disconnection page.

l Disconnect Events: Last 1 Hour on the Disconnection page.

When you click the required host name, the site-specific Clients page displays detailed information for
the selected host. The following figure is an example of the site-specific Clients page:

This site-specific Clients page contains the following tabs:

l Dashboard—Provides a summary of the client connection or disconnection events such as Client
history or lifecycle events.

By default, the Dashboard tab is visible when the site-specific Clients page appears. Based on the
period options such as Last 24 Hours or Last 7 Days from the Time Range filter on the Dashboard
page, the site-specific Dashboard page displays the Wi-Fi client information in the following
widgets:

l Connection

l Reassociations

l Total Bytes

l Top Application

l Client Details

l Client History

l AP/Radio Details

l Lifecycle Events
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l Connection Success Rate

l Top Failures Across Phases

l RSSI

l SNR

l Top Applications

l Data Rate

l Top Categories

l Applications—Provides detailed information of top applications used for the connection.

Based on the time period you select from the Time Range filter on the Applications page, the
Applications page displays the application information for the Wi-Fi client in the following
widgets:

l Total Bytes

l Top Application

l Top Category

l Application / Category History

Click the icon (for example, next to Application History) to view the history of category
details.

l Performance—Provides detailed information of RSSI, SNR, date rate, usage in uplink and downlink,
and the application usage.



Based on the time period you select from the Time Range filter on the Performance page, the
Performance page displays the network performance for the Wi-Fi client in the following widgets:

l RSSI

l SNR

l Data Rate

l Usage

l Application Usage

You can click the icon (Data point selector) to filter and view the required options specific to
performance in the widgets.

l Lifecycle—Provides detailed information of the client's connection or disconnection events.
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Based on the date and impact levels you select from the date and Impact filters, the Lifecycle
page displays the session timeline and the lifecycle events of the Wi-Fi client for the selected date.

In the Session Timeline section, you can find the AP names, band used, and the radio index. In
addition, different indicators mark RSSI, the connection event as failed or success, the
disconnection event, roam quality as bad or good, and short association.

For example, in the following UI page, the RSSI ranges and bad and good roam quality are
highlighted using different colors.

l Placing the cursor on the icon, displays date and time of the succeeded event.

l Placing the cursor on the icon, displays reason and cause for the failed event.

l Clicking or icon in the Session Timeline section, displays the Events page with detailed
information for the selected event.

l
Clicking the disconnect ( ) icon, displays details about the event and disconnection

reason.

l The short association ( ) icon denotes that the client connected and disconnected within

a minute.

l
The edit ( ) icon denotes that the client connection failed in DHCP, DNS or Captive

portal phase in the first connection attempt but succeeded later.

NOTE:

A client connection is considered failed in DHCP, DNS, or CP, if the client fails
to complete the phase within 45-60 secs.



The Lifecycle Events section provides detailed information of the client's connection and
disconnection events such as timestamp, connection type, connection status, AP name, IPv4
address, radio ID, impact of the event, band used, RSSI, session duration, total bytes, wireless
mode used, VLAN used, and WLAN details.

You can also use the filters to view and analyze the required event information. To view the
required lifecycle event using filters, perform the following steps:

a. In the Lifecycle Events section, click Apply Filter(s).

b. Enter one or more of the following details:

Filter name Description

Timestamp Time period for which you want to view the data:

l Between

l After

l Before

Type Type of event for which you want to view the data:

l Roam

l Connect

l Disconnect

Status State of the event:

l Success

l Failed

AP Name Name of the AP that is used in the event.

IPv4 Address The IPv4 address used for the connection.

Radio ID ID of the radio used in the event.

Impact Impact level of the event.

l Low

l Medium

l High

Band The bandwidth used for the connection.

Mode The standard wireless mode used for the connection. For example:
802.1ac

VLAN The VLAN ID used for the connection.

WLAN The WLAN ID used for the connection.
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NOTE:

You can also click the icon in the Lifecycle Events table to quickly

search for type, status, AP name, IPv4 address, radio ID, impact, band,
RSSI, VLAN, and WLAN.

c. Click Apply Filter(s).

The table in the Lifecycle Events section is updated with the required information for the
client or host.

You can also drill-down an event to view what went wrong during the connection or the
reason for the disconnection event.

2. Analyze the data for the required client or host and take actions.

Viewing an event-based connection or disconnection event
After viewing the lifecycle events for a specific client or host, you can drill-down an event to analyze what
caused a failed connection or a disconnection.

To view an event-based connection or disconnection state, perform the following steps:

1. Click Date and Time or Timestamp to view the connection or disconnection event in detail.

You can locate a date or timestamp in the following widgets:

l Timestamp in the Lifecycle Events widget available on both the Connection page and the
Disconnection page)

l Date and Time in the Connection Events: Last 1 hour widget on the Connection page

l Date and Time in the Disconnect Events: Last 1 hour widget on the Disconnection page

When you click on Timestamp or Date and Time, the Events screen displays the detailed event
information.

The Events page provides phase-wise information with complete event details such as reason, impact,
cause, and resolution. These event-based details help with troubleshooting.



2. To view an event for a specific date, you can select the required date from the date drop-down list.

Similarly, you can use < or > to view time-based events for a client. You can also select the time-based
events from the drop-down list.

3. Click the icon to close the Events page.

Viewing an AP-specific information
You can view an AP-specific information for the required client or event and analyze the connection or
disconnection data. This analysis helps identify device details used for the connection.

To view AP-specific information, perform the following steps:

1. Click the AP Name to view the data.

You can locate an AP name in the following widgets:

l Top Affected APs on the Connection page

l Connection Events—Last 1 Hour on the Connection page

l Top Reporting APs on the Disconnection page

l Disconnect Events—Last 1 Hour on the Disconnection page

l Lifecycle Events on both the Connection and Disconnection pages

When you click on the required AP name, the site-specific Wi-Fi dashboard dispalys the AP or device
information.
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For more information on the AP (or device) specific dashboard, refer to the Wireless LAN Dashboards
section of cnMaestro Cloud User Guide.

2. Analyze the AP data and take appropriate actions.



Managed Services
This section includes the following topics:

l Managed Accounts

Managed Accounts

This section includes the following topics:

l Overview

n Managed Accounts

n Accounts

n Managed Account Service

n Account Service Users (Administrators)

l Configuring Managed Account Services

n Enable Managed Accounts

n Creating Managed Account Services

n Creating Account

n Validating Account Users

l Managed Account Administration

n Overview

n System Dashboard

n Account Administration

n Device Management

n Swap 60 GHz cnWave Accounts

n Disabling the Managed Accounts feature

Overview
Managed Accounts allow the cnMaestro owner to partition their installation into independent accounts with
their own administrators and configuration. This feature is for MSPs who want to provision a full cnMaestro
account for their customers, while still maintaining control over the global deployment.

Managed Accounts
The Managed Accounts feature combines Accounts with Account Services.

Accounts
Managed Accounts group cnMaestro devices and configuration objects (such as AP Groups, WLANs, and Sites)
into administration domains within a single cnMaestro deployment . Accounts are independent, and the devices
added to them are configured using the objects in the Account.
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Figure 374 Accounts

Access Points
Access Points exist in the global Company Account, or they can be added to a single Managed Account. Access
Points in a Managed Account are configured using the Wi-Fi Profiles in that Managed Account.

Figure 375 Access Points

Managed Account Service
A Managed Account Service creates a branded version of the cnMaestro UI. Each Account Service can be
mapped to multiple Accounts.



Figure 376 Account Service

Each Managed Account Service adds the following support to an Account:

Support Details

Administrator
Database

Each Account Service has its own independent database of users who can be shared
across multiple Accounts.

Custom Login URL The path of the login URL used by the Account Service Administration can be
tailored to the Account Service. The path must be unique across all cnMaestro.

Branded UI The Account UI is customized for the Account Service through graphics, colors, and
text.

Account Service
Users

List of all the users mapped to the Managed Account Service. They may be mapped
to zero or more associated Accounts.

Account UI
The Account UI can be customized to represent the service brand. A sample Account UI is shown below:

Figure 377 Account UI - Sample 1
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Figure 378 Account UI - Sample 2

Account Service Users (Administrators)
Account Service Users are assigned to Accounts. They access similar features as the Global cnMaestro
Administrators, except they are only allowed to manage the subset of devices and objects (AP Groups, WLAN,
Sites, etc.).

Account Service Users (Administrators) Roles
Account Service Users can be assigned one of three roles as shown below for each account:

l Administrator

l Monitor

l Operator

The authorizations for each Role are listed in the table below:

Feature Description Administrator Operator Monitor

AAA Services

(Global cnMaestro
administrator only)

Add AAA services None None None

Administration
Settings

(Global cnMaestro
administrator only)

Change global
application
configuration,
Onboarding
settings like
password change

None None None

API Management

(Global cnMaestro
administrator only)

Create API clients None None None

Application Create Networks, All View View

Table 98: Tenant Administrator Roles



Feature Description Administrator Operator Monitor

Operations 1 Towers, and Sites

Application
Operations 2

Tech Dump,
import/export
server data,
change Account
Type (Enterprise
or Access and
Backhaul)

None None None

Association ACL Configure MAC list
on the controller

All View None

Auto-provisioning

(Global cnMaestro
administrator only)

Support for global
auto-provisioning
rules

None None None

Audit logs Logs user action of
different features

All All All

Device Operations Reboot device, link
test, connectivity
test

All All None

Device Override Per-device
configuration
changes

All All View

Global
Configuration

Apply
Configuration
through Templates
and AP Group

All View View

Guest Access Portal Guest Access All View View

(Sessions)

Monitoring Access Device
Statistics Data

All All View

Notifications View Alarms and
Events

All All View

Onboarding Approve Device
Onboards

All All View

Reporting Generate reports All All All

Software Images

(Global cnMaestro

Download device
software images

All None None

Table 98: Tenant Administrator Roles
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Feature Description Administrator Operator Monitor

administrator only)

Software Upgrade Upgrade device All All View

System Operations Reboot VM,
change log level,
system upgrade,
system monitoring

None

(Except System
Monitoring)

None

(Except System
Monitoring)

None

(Except System
Monitoring)

User Management Manage users,
roles, and sessions

All None None

Table 98: Tenant Administrator Roles

Configuring Managed Account Services
This section provides the following details on configuration of Account Services in cnMaestro:

l Enable Managed Accounts

l Creating Managed Account Services

l Creating Account

l Validating Account Users

Enable Managed Accounts
By default, Account Services is disabled in the cnMaestro UI.

To enable Account Services:

1. Navigate to Managed Services > Managed Accounts.

2. Click the Enable Managed Accounts.

Figure 379 Enabling Managed Accounts

Note:

Account Services provide independent administration domains for Devices, WLANs, Sites,
and AP Groups. They organize large deployments and form the basis for multi-tenanted
Account Services.

Additions in the cnMaestro UI when Managed Accounts is Enabled
l Once Managed Accounts is enabled, Accounts and Account Services tabs appear in the cnMaestro UI.



Figure 380 Accounts and Account Services tabs

l The Header adds a select box that allows the Global Administrator to enter the context of Account selected.

Figure 381 Managed Accounts Component in Header

l The System Dashboard adds a Health component for Top Managed Accounts.

Figure 382 Dashboard > Top Managed Accounts

l Global tabs in the UI are updated with a Managed Account column.

Figure 383 Managed Account Column
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Creating Managed Account Services
The user can create an Account Service and map it to an Account. The Account Service supports an
independent user database and a customized user interface. There is a default Account Service, so creating a
new one is optional.

To create an Account Service:

1. Navigate to Managed Services > Managed Accounts > Account Services tab.

Figure 384 Account Services Tab

2. Click New Account Service.

The Add Account Service window is displayed.



Figure 385 Add Account Service Window

3. Enter the following details:

Parameter Description

Name Name of the service. This name is visible to Account Administrators.

A maximum of 64 characters are supported for the name.

Login Path Account Administrators log into cnMaestro using a standard URL with an additional Path
that defines the Account Service.

For example: https://<cnmaestro cloud URL>/msp/<branded_service_path>

Note:

l The Path name must be unique across all Account Service accounts
hosted of Cambium Cloud.

l A maximum of 16 characters are supported for the path name.

Table 99: Parameters in the Add Account Service Window

4. Click Add.
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Creating Account
To create an Account:

1. Navigate to Managed Accounts > Accounts tab.

Figure 386 Accounts Tab

2. Click New Account.

The Add Account window is displayed.

Figure 387 Add Account window

3. Enter the following details:

Parameter Description

Name Name of the Account. This is sent in the invitation email when users are invited to the
account.

Friendly Name The Friendly Name will be sent in the invitation email.

Status Determines whether the account is enabled or disabled. When an account is disabled,

Table 100: Parameters in the Add Account Window



Parameter Description

all Account Users (users) are logged out.

Account Service The Account Service used for branding and authentication.

Email The email address of the first Account User. You can add more users after the account
has been created.

Table 100: Parameters in the Add Account Window

4. Click Add.

Validating Account Users
Once an Account is created, the Account User is sent an email invitation. The email provides directions on how
to access the Account UI and set their password.

Figure 388 Sample Email Invitation
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Check Email for Invite
An email is sent inviting the Account User to view their new Managed Account. It has a link that must be clicked
to enable access.

Figure 389 Checking Account Administrator User Email

Create Account in Account Service
Clicking the link prompts the user to create a new Account or use an existing Account.

NOTE:
If a user already has an Account in the Account Service, they can use their existing email
login to accept the invite for the new Account. In the global cnMaestro UI, switching
between accounts is accomplished using the choice box in the UI header (upper right).

Login to the Accounts UI
Once the Account Administrator (User) is created, use the URL listed in the Login Path column to login.



Figure 390 A Sample Login URL

Managed Account Administration

Overview
Once Managed Accounts are enabled, there are three ways to administrator the Accounts.

l System View

l Account View

l Account Administrator (User) View

Important Points to Remember
Please note the following points for Account Services administration:
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NOTE:

l When a device is moved from one Account to other, it goes offline for one minute before
appearing online. Only active alarms are moved to the new account and other data is
retained in the old account.

l The Managed Accounts feature can be disabled only if all devices in Accounts are
deleted or moved to Base Infrastructure account.

l Administrators of Accounts do not have access to the settings page of the server to
change the account type.

l When Global Super Administrators trigger Configure/Software/Reports Jobs, the
Account users cannot view them.

l When Account Users trigger Configure/Software/Reports Jobs, they are reflected under
the Global Super Administrator view along with respective Job IDs enrolled in the
respective Accounts.

l The devices that have not started Software/Configure Jobs cannot be moved across
Accounts.

l The Global Super Administrator and the Account Administrator cannot trigger a
Software or Configure Job simultaneously on the same device.

l The Lock AP configuration can be enabled only by the Global Super Administrator. But
whenever a device configuration is changed outside of cnMaestro by either a Global
Super Administrator or an Accounts Administrator, the Auto Synchronization Job starts
automatically with the configuration job ID as in Accounts and reflects in both the Global
Super Administrator and Accounts Administrator accounts.

System View
At the System level, one can view APs, AP Groups, or Sites across all Managed Accounts in a single, unified
table. This allows one to review the status of all accounts in context to each another. The following figure
displays the AP table, and specifies which APs are mapped to Accounts.

Figure 391 System View

Account View
The Managed Accounts > Accounts page allows you to select individual Accounts, which launches the Account
View. This provides full status and configuration for all components of the Account, including Dashboard,
Notifications, Configuration, Software Update, Reports, Clients, etc.



Figure 392 Account View

Account Administrator (User) View
The Account Administrator View presents the branded Account UI, without having to explicitly log into it. It is
accessed through the Account drop-down in the UI header. Selecting a specific Account (rather than All)
updates the UI to the Account Administrator's view. From here, the Global Administrator can update the
configuration and monitor issues.
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Figure 393 Managed Account Administrator (User) View

System Dashboard
The System Dashboard integrates Accounts into the global health component. It ranks the top Accounts based
upon device count.



Figure 394 System Dashboard

Account Administration
AP Groups, WLANs, and Switch Groups have three types of accessibility scope as shown below:
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State Description

Base Infrastructure The object is only available for the global account.

Managed Account The object belongs to a Managed Account.

Shared The object is shared among all Managed Accounts. It can be mapped to devices in
the Account, but it cannot be modified. To change the configuration, it needs to be
copied into the Account and then updated.

Table 101:

NOTE:
Once the scope has been configured on an object, it cannot be changed.

Device Management
Devices are added at the global System level or within Managed Accounts. Devices added at the System level
can be moved into Accounts at a later time.

System Onboarding
Onboarding at the global System level supports both MSN and Cambium ID. In the example below, a
Management Account can be selected for all devices onboarded in the MSN batch.

Figure 395 System Onboarding

Device Onboarding
Onboarding devices through the Managed Account UI automatically places the devices in the Account.

NOTE:
cnMaestro supports onboarding through either MSN or Cambium ID. Within Accounts, only
MSN onboarding is supported.



Moving a Device Between Accounts
You can move a device from one Managed Account to another by using the Change option in the device
configuration page.

Figure 396 Moving a Device Between Accounts

In Enterprise view, the device can be moved between Accounts using the Managed Account ( ) icon in the

AP Groups > <AP-group-name> > Devices > List tab.

Figure 397 Moving a device between Accounts in Enterprise View

Account Deletion

NOTE:
All devices must be removed from the Account before deleting the account.

To delete a Managed Account, navigate to the Account Services page and click the delete icon.
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Figure 398 Account Deletion

Disabling the Managed Accounts feature
The Managed Accounts feature can be disabled within the system only after all the devices are deleted or
moved to the Global context. By disabling Account Services, the Account field will be disabled across all the
tables such as Clients, Notifications, Inventory, etc.

NOTE:
In the current release, only the global administrator of On-Premises account has control on the
following features:

l Association ACL

l Auto-Provisioning

l Scheduled Backup

l Server Settings

l SMTP Server

l SNMP Configuration

Network Services
This section includes the following topics:

l API Client

l RESTful API

l Guest Access

l RADIUS Proxy

l CBRS

l Organization

l LTE

l Managing Edge Controller

l cnArcher Summary

l Spectrum Analyzer
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API Client

Overview
The cnMaestro RESTful API allows customers to manage their deployment programmatically using their own
client applications. The API is supported over HTTPS, and messages are exchanged in JSON format. Modern
programming languages have rich support for RESTful interfaces.

NOTE:
cnMaestro currently provides monitoring data over the API (such as inventory, statistics,
events, and alarms).

API Clients
API Clients are external applications that access the RESTful API over HTTPS using OAuth 2.0 Authentication.
They require a Client ID and Client Secret for access, both of which are detailed later in this chapter. For more
information, refer to RESTful API Specification.

To add API Client:

1. Navigate to Network Services > API Clients.

2. Click Add API Client.

3. Enter Name.

4. Enter Description.

#RESTful_API_Specification
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5. Enter Expiration Time.

6. Enter Token Renewal Time.

7. Click Save.

Once the API Clients is added you can able to view or download credentials shown in the OAuth 2.0 Access
Credentials.

RESTful API Specification

Authentication
API Authentication uses OAuth2. The client retrieves an Access Token to start the session. It then sends API
requests until the Access Token times out, at which point the token can be regenerated.



Establish a Session
A session is created by sending the Client ID and Client Secret to the cnMaestro server. These are generated in
the cnMaestro UI and stored within the application. The Client ID defines the cnMaestro account and
application, and the Client Secret is a private string mapped to the specific application. The Client Secret should
be stored securely.

If the session is established successfully, an Access Token is returned along with an expiration string. The
Access Token is used to authenticate the session. The expiration is the interval, in seconds, in which the Access
Token remains valid. If the Access Token expires, a new session needs to be created.

API Access
The application sends the Access Token, in every API call. The token is sent in an Authentication header. Details
are provided later in this document.

Session Expiration
If a token expires, an expiration error message is returned to the client. The client can then generate a new
token using the Client ID and Client Secret. The token expires immediately if the Client API account is deleted.
The default expiration time for a token is 3600 seconds (1 hour). The session expiration is configurable in the UI.

Rate Limiter
The Rate Limiter API request helps in improving the availability of API based services by avoiding resource
starvation.

This API calculates the rate limit per customer based on various factors such as system configuration, number
of devices onboarded, Network, Towers, Sites, etc.

The API limits the number of NBI API calls to a single cnMaestro account per minute. Once the limit is reached,
the API receives a standard HTTP Response Status code such as 429 or 503.
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HTTP
Response
Status Code

Response
Headers

Explanation Action to be taken

429 RateLimit-
Limit: 10

Number of API calls
allowed for the
cnMaestro account
per minute

If the RateLimit-Remaining value is 0, then the client
application waits for the number of seconds to
Reset-RateLimit before sending the next subsequent
API requests

RateLimit-
Remaining: 0

Number of
remaining API calls
for the current
minute is zero

RateLimit-
Reset: 35

Number of seconds
remaining to reset
the rate limit

503 Retry-After Number of seconds
during which users
wait before retrying

If the value of Retry-After is greater than 0, then the
client application waits for the number of seconds to
Retry-After before sending the next subsequent API
requests

The following table below displays the approximate limit calculated by the system on a 4 vCPU, 8 GB RAM
Cloud instance.

Devices GET POST/Others

101 10 3

501 24 3

1001 47 5

2001 92 10

4001 163 17

Example of a Python client:



import sys

import requests

import json

import base64

import time

HOST = # host here

CLIENT_ID = # client id here

CLIENT_SECRET = # client secret here

TOKEN_URL = # token url here

# Retrieve access parameters (url, access_token, and expires_in).

def get_access_parameters(token_url, client_id, client_secret):

    """

    Authenticates to API.

    Parameters:

        `token_url` - Endpoint to authenticate to\n

        `client_id` – Auth client id\n

        `client_secret` – Auth client secret\n

    Returns:

        `(access_token, expiry)`

    """

    data = "%s:%s" % (client_id, client_secret)

    encoded_credentials = base64.b64encode(data.encode('ascii')).decode('ascii')

    headers = {

      "Authorization":"Basic %s" % encoded_credentials,

      "Content-Type":"application/x-www-form-urlencoded"

    }

    body = "grant_type=client_credentials"

    r = requests.post(token_url, body, headers=headers, verify=False)

    print ("Status Code: %s" % r.status_code)

    return r.json()['access_token'], r.json()['expires_in']

def call_api(method, host, path, access_token):

    """

    Makes HTTP call to an API with given method.
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    Parameters:

        `method` -

 method for the new Request object: GET, OPTIONS, HEAD, POST, PUT, PATCH, or DELETE\n

        `host` – host for the url\n

        `path` – path for the url\n

        `access_token` – a valid access token for header

    Returns:

        `(response_status_code, headers, body)`

    """

    api_url = "https://%s%s" % (host, path)

    headers = {

      "Authorization":"Bearer %s" % access_token,

    }

    response = requests.request(method=method, url=api_

url, headers=headers, verify=False)

    headers = response.headers

    body = response.json()

    response_status_code = int(response.status_code)

    return response_status_code, headers, body

def main():

    try:

        # Getting the access token using client id and client secret

        access_token, expires_in = get_access_parameters(TOKEN_URL, CLIENT_ID, CLIENT_

SECRET)

        # For the purpose of the example, let's send 100 requests back to back

        for i in range(100):

            # Calling the endpoint with GET method

            status_code, header, body = call_api

('GET', HOST, '/api/v2/devices/statistics', access_token)

            # identifying any client or server side error codes

            client_errors = (status_code - status_code%100) == 400

            server_errors = (status_code - status_code%100) == 500

            # handling error status code



            if client_errors or server_errors: # check for all 400 and 500 responses

                print("Failure: [%s]-[%s]" %(status_code, (json.dumps(body, indent=2))))

                # For 429, wait until `RateLimit-Reset` seconds 

                if (status_code == 429):

                    sleep_time = 10 # default wait time

                    # try block prevents any dict value exception

                    try:

                        # Reading the header

                        sleep_time = int(header["RateLimit-Reset"])

                    except: pass

                    # if sleep_time is not greater than 0, defaulting to 10 seconds

                    sleep_time = sleep_time if sleep_time > 0 else 10

                    print("Sleeping for %d seconds" % sleep_time)

                    # sleeping the main thread

                    time.sleep(sleep_time)

                if (status_code == 503):

                    sleep_time = 10 # default wait time

                    # try block prevents any dict value exception

                    try:

                        # Reading the header

                        sleep_time = int(header["Retry-After"])

                    except: pass

                    # if sleep_time is not greater than 0, defaulting to 10 seconds

                    sleep_time = sleep_time if sleep_time > 0 else 10

                    print("Sleeping for %d seconds" % sleep_time)

                    # sleeping the main thread

                    time.sleep(sleep_time)

            else:

                # process response

                print("Success: [%s]" %(json.dumps(body, indent=2)))

    except Exception as E:

        print("Failure: [%s]"%E)

        sys.exit()
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if __name__ == "__main__":

    main()

Swagger API

Introduction
The RESTful API documentation is supported through Swagger, which allows visualization and interaction with
the API resources.

To access Swagger, perform the following steps:

1. Navigate to Services > API Client grid.

2. Click Swagger API documentation.

Sample Swagger UI

Generating Client ID and Client Secret

cnMaestro User Interface
To create the Client Id and Client Secret in the cnMaestro UI, perform the following steps:

1. Navigate to Services > API Client.

Each client application should be added as an API Client.



2. Click Add APIClient to add a client.

Add API Client window pops up.

3. Enter Name and Description.

4. Click Save.

Download the Client Id and Client Secret
You can download and store the Client ID and Client Secret by clicking Download Credentials. The Client Id is
required to create an API session.
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API Session

Introduction
The cnMaestro API leverages the Client Credentials section of the OAuth 2.0 Authorization Framework (RFC
6749). An API session can be created using any modern programming language. The examples below highlight
how messages are encoded and responses returned.

Retrieve Access Token
Access Token Request (RFC 6749, section 4.4.2)

To generate a session, the client should retrieve an Access Token from cnMaestro. This is done by base64
encoding the Client_ID and Client_Secret downloaded from the cnMaestro UI and sending them to the
cnMaestro server. The Authorization header is created by base64 encoding these fields as defined below.

NOTE:

The fields are separated by a colon (:).

Authorization: Basic BASE64(<client_id>:<client_password>)

In the body of the POST the parameter grant_type must be set to client_credentials.

POST /api/v2/access/token HTTP/1.1
Host: server.example.com
Authorization: Basic czZCaGRSa3F0MzpnWDFmQmF0M2JW
Content-Type: application/x-www-form-urlencoded

grant_type=client_credentials

Alternatively, the credentials can be passed within the body of the POST without using the Authorization
header.

POST /api/v2/access/token HTTP/1.1
Host: server.example.com
Content-Type: application/x-www-form-urlencoded

grant_type=client_credentials&client_id=s6BhdRkqt3&client_secret=7Fjfp0ZBr1KtDRbnfVdmIw

Access Token Response (RFC 6749, section 4.4.3)

The response returned from cnMaestro includes the Access_Token that should be used in subsequent requests.
The expires_in field defines how many seconds the token is valid.

HTTP/1.1 200 OK
Content-Type: application/json;charset=UTF-8
Cache-Control: no-store
Pragma: no-cache
{
"access_token":"2YotnFZFEjr1zCsicMWpAA",
"token_type":"bearer",
"expires_in":3600

}

https://tools.ietf.org/html/rfc6749
https://tools.ietf.org/html/rfc6749


Sample 200 response body.

HTTP/1.1 200 OK
Content-Type: application/json;charset=UTF-8
Cache-Control: no-store
Pragma: no-cache
{
"access_token": "290eeaba71d3f4885405eac2fd18a4f3c300448d",
"expires_in": 3600,
"token_type": "bearer",
"redirect_uri": https://10.110.241.252

}

NOTE:

The returned redirect_uri should be used to generate the session.

Error Response (RFC 6749, section 5.2)

If there is an error, an HTTP 400 (Bad Request) error code is returned along with one of the following error
messages as shown below:

Table 102: Error Responce

Message Details

invalid_request Required parameter is missing from the request.

invalid_client Client authentication failed.

unauthorized_client The client is not authorized to use the grant type sent.

unsupported_grant_type The grant type is not supported.

An example error response is below:

HTTP/1.1 400 Bad Request
Content-Type: application/json;charset=UTF-8
Cache-Control: no-store
Pragma: no-cache
{

"error": "invalid_request"
}

Access Resources
When the Access_Token is retrieved, API requests are sent to cnMaestro server using the format below. The
Access_Token is sent within the HTTP Authorization header.

GET /api/v2/devices
Accept: application/json
Authorization: Bearer ACCESS_TOKEN
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API Details

HTTP Protocol

HTTP Response codes
Table 103 lists the response codes that are supported in cnMaestro and may be returned through the HTTP
protocol.

Table 103: HTTP Response codes returned

Code Description Use in cnMaestro

200 OK Standard response for successful HTTP requests.

400 Bad Request Status field in request validation related errors.

401 Unauthorized User tried to access a resource without authentication.

403 Forbidden An authenticated user tries to access a non-permitted
resource.

404 Not Found Server could not locate the requested resource.

405 Method Not Allowed A method (GET, PUT, POST) is not supported for the
resource.

413 Payload Too Large The request is larger than the server is willing to handle

422 Unprocessable Entity The server understands the request but cannot process it.

429 Too Many Requests The client has sent too many requests in a given interval.

431 Request Header Fields Too
Large

The header fields are too large to be processed.

500 Internal Server Error A server-side error happened during processing the request.

501 Not Implemented The request method is not recognized.

502 Bad Gateway Internal server error that may require a reboot.

503 Service Unavailable Internal server error that may require a reboot.

HTTP Response codes
Table 104 lists the HTTP request codes supported in cnMaestro.



Table 104: Request Headers

Header Details

Accept Set to application/json

Authorization Used in every API request to send the Access Token. Example: Authorization: Bearer
<Access-Token>

Content-Type Set to application/json

REST Protocol

Resource URLs
The format for cnMaestro path and parameters are the following:

Access a collection of resources:

/api/{version}/{resource}?{parameter}={value}&{parameter}={value}

Access a single resource:

/api/{version}/{resource}/{resource_id}?{parameter}={value}&{parameter}={value}

Access a sub-resource on a collection (this is also possible on single resources):

/api/{version}/{resource}/{sub-resource}?{parameter}={value}&{parameter}={value}

For example – read the statistics for MAC, Type, and IP on all devices:

/api/v2/devices/statistics?fields=mac,type,ip_wan

Version

The version is equal to v2 in this release.

Resource

Resources are the basic objects in the system. Examples include:

Table 105: Resource

Context Details

alarms Current active alarms.

alarms/history Historical alarms, including active alarms.

devices Devices, including ePMP, PMP, and WiFi.
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Context Details

events Historical events.

msp MSP managed services.

networks Configured networks.

sites Configured WiFi sites.

towers Configured Fixed Wireless towers.

Sub-Resources

Sub-Resources apply to top-level resources. They provide a different view of the resource data, or a filtered
collection based upon the resource. Examples include:

Table 106: Sub-Resources

Context Details

alarms Alarms mapped to the top-level resource.

alarms/history Historical alarms mapped to the top-level resource.

clients Wireless LAN clients mapped to the top-level resource.

devices Devices mapped to the top-level resource.

events Events mapped to the top-level resource.

mesh/peers Wireless LAN mesh peers mapped to the top-level resource.

operations Operations available to the top-level resource

performance Performance data for the top-level resource.

statistics Statistics for the top-level resource.

Responses

Successful Response

In a successful HTTP 200 response, data is returned using the following structure. The payload is presented in
JSON format.

The request URL is:

/api/v2/devices?fields=mac,type&limit=5



{
"paging": {
"offset": 0,
"limit": 5,
"total": 540

},
"data": [
{

"mac": "C1:00:0C:00:00:21",
"type": "wifi-home"

},
{

"mac": "C1:00:0C:00:00:18",
"type": "wifi-home"

},
{

"mac": "C1:00:0C:00:00:12",
"type": "wifi-home"

},
{

"mac": "C1:00:0C:00:00:15",
"type": "wifi-home"

},
{

"mac": "C1:00:0C:00:00:06",
"type": "wifi-home"

}
]

}

Error Response

Error Responses return a message and an error cause.

{
"error": {
"message": "Missing required property: stop_time \n Missing required property: start_

time",
"cause": "InvalidInputError"

}
}

Parameters
Most APIs can filter the data and limit the number of entries returned. The parameter options are listed below.
The specific fields and the appropriate values vary for each API.

Field selection
Field selection is supported through the optional Fields parameter, which can specify the data to return from
the server. If this parameter is missing, all available fields will be returned.

Table 107: Fields

Parameter Details

fields Define exactly what fields should be returned in a request. The names are provided as a
comma-separated list.
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Fields can limit which JSON parameters are returned as shown below:

Example: To retrieve name, type and location information for all devices.

Request:

/api/v2/devices?fields=mac,type

Response:

{
"paging": {
"total": 3,
"limit": 100,
"offset": 0

},
"data": [
{

"mac": "00:44:E6:34:89:48",
"type": "wifi-enterprise"

},
{

"mac": "00:44:16:E5:33:E4",
"type": "wifi-enterprise"

},
{

"mac": "00:44:26:46:32:22",
"type": "wifi-enterprise"

}
]

}

Filtering
A subset of fields support filtering. These are defined as query parameters for a particular resource, and they
are listed along with the API specification.

Table 108 describes the standard filtering parameters as shown below:

Table 108: Filtering

Field Details

network (Devices) Configured Network name.

severity (Alarms, Events) Alarm or Event severity (critical, major, minor, notice).

site (Devices) Configured Site name.

state (Alarms) Alarm state (active, cleared).

status (Devices) Device status (online, offline, onboarding).

tower (Devices) Configured Tower name.

type (Devices) Device type (60ghz-cnwave, cnreach, cnmatrix, epmp, pmp, wifi-enterprise, wifi-
home, wifi, ptp) (wifi includes wifi-home and wifi-enterprise).

Filters can be used simultaneously for Resources and Sub-Resources.



Example: Retrieve all WiFi devices that are online.

Request:

/api/v2/devices?type=wifi&status=online

Response:

{
"paging": {
"total": 1,
"limit": 100,
"offset": 0
},
"data": [

{
"ip": "233.187.212.38",
"location": {
"type": "Point",
"coordinates": [
77.55310127974755,
12.952351523837196

]
},
"mac": "C1:00:0C:00:00:24",
"msn": "SN-C1:00:0C:00:00:24",
"name": "Hattie",
"network": "Bangalore",
"product": "cnPilot R201",
"registration_date": "2017-05-23T21:28:37+05:30",
"status": "online",
"site": "Bangalore_Industrial",
"type": "wifi-home",
"hardware_version": "V1.1",
"software_version": "2.4.4",
"status_time": 1495560086

}
]

}

Time Filtering
Events, Alarms, and Performance data can be filtered by date and time using ISO 8601 format.

Example: January 12, 2015 UTC would be encoded as 2015-01-12.

Example: January 12, 2015 1:00 PM UTC would be encoded as 2015-01-12T13:00:00Z.

If the parameters that are described in the Table 109 are not specified, then the start or stop times will be open-
ended.

Table 109: Time Filtering

Parameter Details

start_time Inclusive start time of interval.

stop_time Inclusive stop time of interval.
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Sorting
Sorting is supported on a subset of fields within certain requests. Sort is used to specify sorting columns. The
sort order is ascending unless the path name is prefixed with a ‘-‘, in which case it would be descending.

Table 110: Sort

Parameter Details

sort Used to get the records in the order of the given attribute.

Example: To retrieve devices in sorted (ascending) order by name.

Request:

/api/v2/devices?sort=name

Example: To retrieve devices in sorted (descending) order by mac.

Request:

/api/v2/devices?sort=-mac

Pagination
The limit and offset query parameters are used to paginate responses.

Table 111: Pagination

Parameter Details

limit Maximum number of records to be returned from the server.

offset Starting index to retrieve the data.



Example: To retrieve the first 10 ePMP devices

Request:

/api/v2/devices?offset=3&limit=1

Response:

{
"paging": {
"total": 6,
"limit": 1,
"offset": 3

},
"data": [
{

"status": "online",
"product": "cnPilot E400",
"network": "Mumbai",
"software_version": "3.3-b14",
"registration_date": "2017-04-28T08:57:33+00:00",
"site": "Central",
"hardware_version": "Force 200",
"status_time": "3498",
"msn": "Z834275ABCDH",
"mac": "00:04:36:46:34:AA",
"location": { 
"type": "Point",
"coordinates": [
0,
0

]
},
"type": "wifi-enterprise",
"name": "E400-4634AA"

}
]

}

Internal Response limits
When clients try to access a resource type without pagination, the server will return the first 100 entries that
match the filter criteria. The response will always carry metadata to convey total count and current offset and
limit. Maximum number of results at any point is 100 even when the provided is more than 100.

Example: To retrieve all devices.

Request:

/api/v2/devices

Response:

{
data: {devices: [ {name: ‘ePMP_5566’, type:’ePMP’, location:’blr’} , {….}… ] },
paging:{ 
"limit":25,
"offset":50,
"total":100

}
}

The response returns the following values in the paging section:
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Table 112: Internal Response limits

Parameter Details

limit Current setting for the limit.

offset Starting index for the records returned in the response (begins at 0).

total Total number of records that can be retrieved.

Access API

Token (basic request)

POST

/api/v2/access/token

The access API generates token using the Client ID and Client Password created in the cnMaestro UI. The token
can be leveraged by API calls through the expiration time. Only one token is supported for each Client ID at any
given time.

Request
Table 113 describes about the header and its values as shown below:

Table 113: Headers

Header Value

Accept (optional) application/json.

Authorization Basic czZCaGRSa3F0MzpnWDFmQmF0M2JW.

Content-Type application/x-www-form-urlencoded.

The client_id and client_secret are encoded and sent in the Authorization header. The encoding is:

BASE64(client_id:client_secret)

Body

The body needs to have the grant_type.

grant_type=client_credentials

Response
The response returns credentials for API access.

Body



Name Details

access_token Access token to return with each API request.

expires_in Time in seconds that the API session will remain active.

token_type This will always be bearer.

{
"access_token":"2YotnFZFEjr1zCsicMWpAA",
"token_type":"bearer",
"expires_in":3600

}

Example

Request

curl https://10.110.134.12/api/v2/access/token \

-X POST -k \
-u 8YKCxq72qpjnYmXQ:pcX5BmdJ2f4QLM5RfgsS4jOtxAdTRF \
-d grant_type=client_credentials

Response

{"access_token":"d587538f445d30eb2d48e1b7f7a6c9657d32068e","token_type":"
bearer","expires_in":86400}

Token (alternate request)

POST

/api/v2/access/token

An alternative form is supported in which the client_ID and client_secret are sent in the body, rather than the
Authorization header.

Request
Headers

Header Value

Accept (optional) application/json

Content-Type application/x-www-form-urlencoded

Body

grant_type=client_credentials&client_id=s6BhdRkqt3&client_secret=7Fjfp0ZBr1KtDRbnfVdmIw
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Response
The response to both forms is the same.

Body

Name Details

access_token Access token to return with each API request.

expires_in Time in seconds that the API session will remain active.

token_type This will always be bearer.

{
"access_token":"2YotnFZFEjr1zCsicMWpAA",
"token_type":"bearer",
"expires_in":3600

}

Example

Request

curl https://10.110.134.12/api/v2/access/token \

-X POST -k \
-d grant_type=client_credentials \
-d client_id=8YKCxq72qpjnYmXQ \
-d client_secret=pcX5BmdJ2f4QLM5RfgsS4jOtxAdTRF

Response

{"access_token":"ee4e077cf457196eb4d27cf6f02686dc07763059","token_type":"
bearer","expires_in":86400}

Validate Token

GET

/api/v2/access/validate_token

Verify if an Access Token is valid and return the time remaining before it expires.

Request
HTTP Headers

Header Value

Accept (optional) application/json

Authorization Bearer <ACCESS_TOKEN>



Response
Body

Name Details

expires_in Time in seconds that the API session will remain active.

{
'expires_in': 86399

}

Example

Request

curl https://10.110.134.12/api/v2/access/validate_token \

-X GET -k \
-H "Authorization: Beareree4e077cf457196eb4d27cf6f02686dc07763059"

Response

{"expires_in":85643}

Selected APIs

Overview
cnMaestro APIs are defined within the Swagger specification, accessed here
https://docs.cloud.cambiumnetworks.com/api/5.0.0/index.html. This section only presents additional details
for the Device, Statistics and Performance APIs, which have unique responses based upon Device Type, and are
difficult to present within Swagger.

cnMaestro v2 API
Beginning with cnMaestro 3.0.0, the API version changes from v1 to v2. The v1 version will be supported through
3.1.0, but Cambium recommends updating existing API code to use v2. For most commands, swapping v1 in the
URL with v2 should be sufficient. However, the following APIs may need to be rewritten while moving to v2.

l AP Groups

l Devices

l Statistics

l Performance

l Mesh Peers

l Operations

There are Unique API responses such as:

l Device API Response (v2 Format)

l Statistics API Response (v2 Format)

l Performance API Response (v2 Format)
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Devices API Response (v2 Format)

Name Details
eP
MP

PM
P

W
i-
Fi

cnRea
ch

cnVisi
on

PT
P

PT
P
8xx

cnMat
rix

60
GHz
cnWa
ve

cnWa
ve 5G
Fixed

ap_group AP Group X

cbrs_state CBRS state X

cbrs_status CBRS status X

config.sync_
reason

Configuratio
n
synchroniza
tion reason

X X X X

X

X

X

X

config.sync_
status

Configuratio
n
synchroniza
tion status

X X X X

X

X

X

X

config.varia
bles

Device is
mapped to
configuratio
n variables

X X X X

X

X

X

X

config.versi
on

Current
configuratio
n version

X X X X

X

X

X

X

country Country X X X X

country_
code

Regulatory
band X

description Description X X X X X X X X

hardware_
version

Hardware
version X X X X

X
X

X
X

X

inactive_
software_
version

Inactive
software
version

X X X X

X

X

X

X X

ip IP address X X X X X X X X X X

ipv6 IPv6 X X X X X

last sync Last
Synchronize

X



Name Details
eP
MP

PM
P

W
i-
Fi

cnRea
ch

cnVisi
on

PT
P

PT
P
8xx

cnMat
rix

60
GHz
cnWa
ve

cnWa
ve 5G
Fixed

d

last_reboot_
reason

Reason for
the last
reboot (see
24.1)

X X X X

X

X X X

link_
symmetry

Link
symmetry X

location Location X X X X X X X X X X

mac MAC
address X X X X

X
X

X
X

X
X

managed_
account

Managed
account
name

X X X X

X

X

X

X

X

X

maximum_
range

Maximum
range (KM) X X

X
X

mode Mode type X X

msn Manufacture
r serial
number

X X X X

X

X

X

X

X

X

name Device
name X X X X

X
X

X
X

X
X

network Network X X X X X X X X X X

onboarding.
error_code

Error code
of the
device if it
fails to on-
board

X X X X

X

X

X

X

X

X

onboarding.
state

On-boarding
state of the
device.

X X X X
X

X
X

X
X

X

online Offline or
online X X X X

X
X

X
X

X
X

product Product X X X X X X X X X X
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Name Details
eP
MP

PM
P

W
i-
Fi

cnRea
ch

cnVisi
on

PT
P

PT
P
8xx

cnMat
rix

60
GHz
cnWa
ve

cnWa
ve 5G
Fixed

name

registratio
n_date

Registration
date X X X X

X
X

X
X

X
X

role X

site Site X X X

site_id Site unique
identifier X X

X

software_
version

Active
Software
version

X X X X

X

X

X

X X

status Status
(online,
offline,
onboardin
g).

X X X X

X

X

X

X

X

X

status_time Uptime/dow
ntime time
interval
(sec)

X X X X

X

X

X

X

X

X

temperature Temperatur
e

X

tower Tower X X X X X X X X

type Device type
(epmp, pmp,
wifi-home,
wifi-
enterprise,
cnreach,
ptp,
cnmatrix,
60ghz-
cnwave)

X X X X

X

X

X

X

X

X



Devices onboarding error codes

Error Codes Details

ERR_UNSUPPORTED_
DEVICE

Claiming {{type}} devices is not currently supported.

ERR_NON_ENTERPRISE_
WIFI_TYPE

Only cnPilot Enterprise (ePMP Hotspot), Enterprise Wi-Fi (E-Series and
XE/XV-Series) and cnMatrix devices are allowed into Enterprise account.

ERR_NON_WIFI_TYPE Cannot claim non Wi-Fi device under a Site.

ERR_UNSUPPORTED_TYPE Unsupported device type in current account view - {{view}}.

ERR_UNKNOWN_DEVICE Unknown Device.

ALREADY_CLAIMED Device already claimed.

LTE_CLAIMED cnRanger devices are not supported in production accounts.

ERR_INVALID_MSN Invalid Serial Number.

ERR_OWNER_DIFFERENT Device is claimed into another account.

ERR_INTERNAL System encountered an internal error; please try again later. If the problem
persists, contact support.

ERR_INVALID_MAC Invalid MAC.

ERR_DUPLICATE_KEY The device is already claimed.

UNPROCESSABLE Device state does not allow to cloud sync.

CBRS_ERROR_DEVICES MAC is already claimed. It cannot be claimed on CBRS.

SUBSCRIPTION_FAIL Device could not acquire slot.

SUBSCRIPTION_FAIL_
FEATURE_MISMATCH

Device is mapped to another onprem instance.

SUBSCRIPTION_FAIL_TOO_
MANY_ASSOCS

Device is mapped to another onprem instance.

Statistics API Response (v2 Format)
Statistics API Response v2 format are shown for the following devices:

l 60 GHz cnWave

l cnMatrix

l cnReach

l Fixed Wireless

l PTP

l PTP 820/850

l Wi-Fi

l cnWave 5G Fixed
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60 GHz cnWave

General

Name Details Mode

cpu CPU utilization All

last_sync Last synchronization (UTC Unix time milliseconds) All

mac MAC address All

IP IP address All

managed_account Managed account name All

memory Available memory All

mode Device mode All

name Device name All

network Network All

site Site name All

site_id Site ID All

status Status [online, offline, claimed, waiting, onboarding] All

status_time Uptime/downtime interval (seconds) All

sync_mode Radio Sync mode [RF, GPS, None] All

type Device type All

Networks

Name Details Mode

ipv6 IPv6 address All

Radios (Array format)

Name Details Mode

radios[].channel Channel All

radios[].id Radio Id All

radios[].mac Radio MAC All



Name Details Mode

radios[].rx_bps Receive bits per second All

radios[].sync_mode Radio Sync mode [RF, GPS, None] All

radios[].tx_bps Transmit bits per second All

Ethernet Ports (Array format)

Name Details Mode

ethports[].port Port name All

ethports[].rx_pkts Received packets All

ethports[].rx_errors Received packets errors All

ethports[].rx_pkts_drop Dropped received packets All

ethports[].speed Port speed and duplex All

ethports[].tx_pkts Transmitted packets All

ethports[].tx_errors Transmitted packets errors All

ethports[].tx_pkts_drop Dropped transmitted packets All

cnMatrix

General

Name Details

cpu CPU utilization

config_version Configuration version

last_sync Last synchronization (UTC Unix time milliseconds)

mac MAC address

managed_account Managed account name

memory Available memory

mode Device mode

name Device name

network Network
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Name Details

site Site name

site_id Site unique identifier

status Status [online, offline, claimed, waiting, onboarding]

status_time Uptime/downtime interval (seconds)

tower Tower name

type Device type

Networks

Name Details

ip IP address

cnReach

General

Name Details Mode

config_version Configuration version All

connected_sms Connected SM count All

last_sync Last synchronization (UTC Unix time milliseconds) All

mac MAC address All

managed_account Managed account name All

mode Device mode All

name Device name All

network Network All

status Status [online, offline, claimed, waiting, onboarding] All

status_time Uptime/downtime interval (seconds) All

tower Tower name All

type Device type All



Networks

Name Details Mode

ip IP address All

Radios (Array format)

Name Details Mode

radios[].device_id Device ID Radios

radios[].id Radio Id Radios

radios[].linked_with Linked with Radios

radios[].mac Radio MAC Radios

radios[].margin Margin Radios

radios[].mode Radio mode [ap, ep, rep] Radios

radios[].neighbors Radio neighbors Radios

radios[].network_
address

Network address Radios

radios[].noise Average noise (dB) Radios

radios[].power Transmit power Radios

radios[].rssi RSSI value (dB) Radios

radios[].rx_bytes Receive bytes Radios

radios[].software_
version

Current software version. Radios

radios[].temperature Radio temperature Radios

radios[].type Radio type [ptp, ptmp] Radios

radios[].tx_bytes Transmit bytes Radios
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Fixed Wireless (cnVision, ePMP and PMP)

General

Name Details cnVision ePMP PMP

ap_mac AP MAC SM SM SM

config_version Configuration version AP/SM AP/SM AP/SM

connected_sms Connected SM count AP AP AP

cpu CPU utilization AP/SM

distance SM distance (KM) SM SM SM

gain Antenna gain (dBi) AP/SM AP/SM AP/SM

gps_sync_state GPS synchronization state AP/SM AP/SM

last_sync Last synchronization (UTC Unix time
milliseconds)

AP/SM AP/SM AP/SM

mac MAC address AP/SM AP/SM AP/SM

managed_
account

Managed account name AP/SM AP/SM AP/SM

mode Device mode AP/SM AP/SM AP/SM

name Device name AP/SM AP/SM AP/SM

network Network AP/SM AP/SM AP/SM

reboots Reboot count AP/SM AP/SM

status Status [online, offline, claimed, waiting,
onboarding]

AP/SM AP/SM AP/SM

status_time Uptime/downtime interval (seconds) AP/SM AP/SM AP/SM

temperature Temperature AP/SM

tower Tower name AP AP AP

type Type AP/SM AP/SM AP/SM

vlan VLAN AP/SM



Networks

Name Details cnVision ePMP PMP

default_gateway Default gateway AP/SM AP/SM AP/SM

ip IP address AP/SM AP/SM AP/SM

ipv6 IPv6 address AP/SM AP/SM

ip_dns DNS AP/SM AP/SM AP/SM

ip_dns_secondary Secondary DNS AP/SM

ip_wan WAN IP AP/SM AP/SM

lan_mode_status LAN mode status [no-data, half, full] AP/SM AP/SM

lan_mtu MTU size SM SM

lan_speed_status LAN speed status AP/SM AP/SM

lan_status LAN status [down, up] AP/SM AP/SM AP/SM

netmask Network mask AP/SM AP/SM AP/SM

Radios

Name Details cnVision ePMP PMP

radio.auth_mode Authentication mode SM SM

radio.auth_type Authentication type ePMP [open,
wpa1, eap- ttls]

PMP [disabled, enabled]

AP/SM AP/SM AP/SM

radio.channel_width Channel width ePMP [5 MHz, 10 MHz,
20 MHz, 40 MHz]

PMP […]

AP/SM AP/SM AP/SM

radio.color_code Color code AP/SM

radio.dfs_status DFS status ePMP:

[not-applicable, channel- availability-
check, in-service, radar- signal-
detected, alternate-channel-
monitoring, not-in- service]

PMP: [Status String]

AP/SM AP/SM AP/SM
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Name Details cnVision ePMP PMP

radio.dl_err_drop_pkts Downlink error drop packets SM SM

radio.dl_err_drop_pkts_
percentage

Downlink error drop packets
percentage

SM SM

radio.frequency RF frequency AP/SM AP/SM AP/SM

radio.frame_period Frame period AP

radio.dl_frame_utilization Downlink frame utilization AP

radio.dl_lqi Downlink Link Quality Indicator SM

radio.dl_mcs Downlink MCS SM SM

radio.dl_modulation Downlink Modulation SM

radio.dl_pkts Downlink packet count AP/SM AP/SM AP/SM

radio.dl_pkts_loss Downlink packet loss AP/SM

radio.dl_retransmits Downlink Retransmission AP/SM AP/SM

radio.dl_retransmits_pct Downlink Retransmission percentage AP/SM AP/SM

radio.dl_rssi Downlink RSSI SM SM SM

radio.dl_rssi_imbalance Downlink RSSI imbalance AP

radio.dl_snr Downlink SNR (dB) SM SM

radio.dl_snr_h Downlink SNR (dB) horizontal SM

radio.dl_snr_v Downlink SNR (dB) vertical SM

radio.dl_throughput Downlink throughput AP/SM AP/SM AP/SM

radio.mac Wireless MAC AP/SM AP/SM

radio.mode Radio mode

[eptp-master, eptp- slave, tdd, tdd-
ptp, ap/sm]

AP/SM AP/SM

radio.sessions_dropped Session drops AP AP AP/SM

radio.software_key_
throughput

Software key – max throughput SM



Name Details cnVision ePMP PMP

radio.ssid SSID AP/SM AP/SM

radio.sync_source Synchronization source AP

radio.sync_state Synchronization state AP

radio.tdd_ratio TDD ratio ePMP [75/25, 50/50,
30/70, flexible]

PMP […]

AP AP AP

radio.tx_capacity SM transmit capacity SM SM

radio.tx_power Radio transmit power AP/SM AP/SM AP/SM

radio.tx_quality SM transmit quality SM SM

radio.ul_err_drop_pkts Uplink error drop packets SM SM

radio.ul_err_drop_pkts_
percentage

Uplink error drop packets
percentage

SM SM

radio.ul_frame_utilization Uplink frame utilization AP

radio.ul_mcs Uplink MCS AP/SM AP/SM

radio.ul_modulation Uplink Modulation example [2X
MIMO-B)]

SM

radio.ul_lqi Uplink Link Quality Indicator SM

radio.ul_pkts Uplink packet count AP/SM AP/SM AP/SM

radio.ul_pkts_loss Uplink packet loss AP/SM

radio.ul_retransmits Uplink Retransmission SM SM

radio.ul_retransmits_pct Uplink Retransmission percentage AP/SM AP/SM

radio.ul_rssi Uplink RSSI SM SM SM

radio.ul_snr Uplink SNR (dB) SM SM

radio.ul_snr_h Uplink SNR (dB) horizontal SM

radio.ul_snr_v Uplink SNR (dB) vertical SM

radio.ul_throughput Uplink throughput AP/SM AP/SM AP/SM

radio.wlan_status WLAN status [down, up] AP/SM AP/SM
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PTP 650/670/700

General

Name Details Mode

config_version Configuration version All

connected_sms Connected SM count Master

gain Antenna gain (dBi) All

last_sync Last synchronization (UTC Unix time milliseconds) All

mac MAC address All

managed_account Managed account name All

mode Device mode All

name Device name All

network Network All

status Status [online, offline, claimed, waiting, onboarding] All

status_time Uptime/downtime interval (seconds) All

temperature Temperature All

tower Tower name All

type Device type All

vlan VLAN All

Networks

Name Details Mode

default_gateway Default gateway All

ip IP address All

ip_dns DNS All

ip_dns_secondary Secondary DNS All

lan_status LAN status [down, up] All

netmask Network mask All



Ethernet Ports (Array format)

Name Details Mode

ethports[].port Port name All

ethports[].rx_frames Ports receive frames oversize All

ethports[].rx_util Ports receive bandwidth utiliization All

ethports[].speed Ports speed and duplex All

ethports[].tx_util Ports transmit bandwidth utiliization All

Radios

Name Details Mode

radio.byte_error_ratio Byte Error Ratio All

radio.channel_width Channel width

ePMP: [5 MHz, 10 MHz, 20 MHz, 40 MHz]

PMP: […]

All

radio.color_code Color code All

radio.rx_frequency Receive frequency All

radio.tx_frequency Transmit frequency All

radio.tx_power Radio transmit power All

PTP 820/850

General

Name Details Mode

ip IP address All

last_sync Last synchronized All

mac MAC address All

managed_account Managed account name All

mode Device mode All

name Device name All
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Name Details Mode

network Network All

status Status [online, offline, claimed, waiting, onboarding] All

status_time Uptime/downtime interval (seconds) All

temperature Temperature All

tower Uptime/downtime interval (seconds) All

type Device type All

Radio

Name Details Mode

radios[].defective_blocks Radio defective blocks All

radios[].id Radio Id All

radios[].radio_location Radio location All

radios[].rx_bps Receive bits/second All

radios[].rx_level Receive level All

radios[].rx_frequency Receive frequency All

radios[].tx_bps Transmit bits/second All

radios[].tx_level Transmit level All

radios[].tx_frequency Transmit frequency All

radios[].tx_mute_status Transmit mute status All

radios[].modem_mse Modem Mean Square Error (MSE) in dB All

radios[].modem_xpi Modem Cross-Polar Isolation (XPI) in dB All



Interfaces

Name Details Mode

interfaces[].admin_state Admin state All

interfaces[].auto_negotiation Auto Negotiation All

interfaces[].interaface_location Interface location All

interfaces[].mac MAC address All

interfaces[].media_type Media type All

interfaces[].operational_status Operational Status All

interfaces[].port_duplex Interface duplex type All

interfaces[].speed Interface speed All

Wi-Fi

NOTE:

Mode is Enterprise, Home, or All.

General

Name Details Mode

config_version Configuration version All

cpu CPU utilization All

mac MAC address All

managed_account Managed account name All

memory Available memory All

mode Device mode All

name Device name All

network Network All

parent_mac Parent MAC All
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Name Details Mode

site Site name All

site_id Site unique identifier All

status Status [online, offline, claimed, waiting, onboarding] All

status_time Uptime/downtime interval (seconds) All

type Device type All

Networks

Name Details Mode

ip IP address All

ipv6 IPv6 address All

ip_dns DNS All

ip_dns_secondary Secondary DNS All

ip_wan WAN IP All

lan_mode_status LAN mode status [no-data, half, full] Enterprise

lan_speed_status LAN speed status All

lan_status LAN status [down, up] Home

netmask Network mask All

Radios (Array format)

Name Details Mode

radios[].airtime Airtime All

radios[].band Radio band All

radios[].bssid Radio mac Enterprise

radios[].channel Channel All

radios[].id Radio Id All

radios[].multicast_rate Multicast rate Enterprise



Name Details Mode

radios[].noise_floor Noise floor Enterprise

radios[].num_clients Number of clients All

radios[].num_wlans Number of WLANs Enterprise

radios[].power Transmit power All

radios[].quality RF Quality description Enterprise

radios[].radio_state Radio state Enterprise

radios[].rx_bps Receive bits/second All

radios[].rx_bytes Receive bytes All

radios[].tx_bps Transmit bits/second All

radios[].tx_bytes Transmit bytes All

radios[].unicast_rates Unicast rates Enterprise

radios[].utilization Radio utilization Enterprise

cnWave 5G Fixed

General

Name Details Mode

cpu CPU utilization All

last_sync Last synchronization (UTC Unix time milliseconds) All

mac MAC address All

managed_account Managed account name All

ip IP Address All

mode Device mode All

name Device name All

network Network All

tower Tower name All
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Name Details Mode

status Status [online, offline, claimed, waiting, onboarding] All

status_time Uptime/downtime interval (seconds) All

config_version Current config version All

type Device type All

connected_cpe Number of CPEs connected to the BTS BTS

registered_cpe Number of CPEs registered with the BTS BTS

cpe_registration_state CPEs Registration State CPE

cpe_registration_count CPEs Registration Count CPE

cpe_imsi CPE Device Identity CPE

Boot

Name Details Mode

startup_count Startup Count for the device BTS

startup_reason Startup Reason for the device BTS

Shutdown (Array format)

Name Details Mode

shutdown[].date Shutdown Date BTS

shutdown[].detail Shutdown Detail BTS

shutdown[].index Shutdown Index BTS

shutdown[].reason Shutdown Reason BTS

Interface Config

Name Details Mode

sfp1_speed SFP1 Speed BTS

sfp2_speed SFP2 Speed BTS



Interfaces (Array format)

Name Details Mode

interfaces[].port_name Port name BTS

interfaces[].in_octets Received octets BTS

interfaces[].out_octets Transmitted octets BTS

interfaces[].in_ucast_pkts Received unicast packets BTS

interfaces[].out_ucast_pkts Transmitted unicast packets BTS

interfaces[].in_mcast_pkts Received multicast packets BTS

interfaces[].out_mcast_pkts Transmitted multicast packets BTS

interfaces[].in_bcast_pkts Received broadcast packets BTS

interfaces[].out_bcast_pkts Transmitted broadcast packets BTS

interfaces[].in_discards Received discarded packets BTS

interfaces[].out_discards Transmitted discarded packets BTS

interfaces[].in_errors Received errored packets BTS

interfaces[].out_errors Transmitted errored packets BTS

Radio

Name Details Mode

dl_throughput Received Throughput BTS

ul_throughput Transmitted Throughput BTS

frequency Frequency BTS

max_eirp Maximum EIRP BTS

polarization Polarization All

link_symmetry Link Symmetry BTS

bandwidth Bandwidth BTS

ul_target_rxPower Transmitted Target Power BTS

ul_tx_power_init Transmitted Initial Power BTS

ul_tx_power_cont Transmitted Control Power BTS
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Name Details Mode

ul_frame_util Transmitted Frame Utilization BTS

dl_frame_util Received Frame Utilization BTS

dl_mcs Downlink MCS CPE

ul_mcs Uplink MCS CPE

alignment_active Alignment Active Status CPE

cpe_range Range of CPE CPE

current_eirp Current Effective radiated power CPE

ul_backoff Uplink Backoff CPE

dl_backoff Downlink Backoff CPE

ul_sounding_state Uplink Sounding State CPE

dl_sounding_state Downlink Sounding State CPE

ul_channel_distortion Uplink Channel Distortion CPE

dl_channel_distortion Downlink Channel Distortion CPE

ul_evm Uplink EVM CPE

dl_evm Downlink EVM CPE

ul_rx_power Uplink Received Power CPE

dl_rx_power Downlink Received Power CPE

ul_spatial_freq Uplink Spatial Frequency CPE

dl_spatial_freq Downlink Spatial Frequency CPE

Wireless and Ethernet interfaces

Name Details Mode

in_octets Received octets CPE

out_octets Transmitted octets CPE

in_ucast_pkts Received unicast packets CPE

out_ucast_pkts Transmitted unicast packets CPE

in_mcast_pkts Received multicast packets CPE



Name Details Mode

out_mcast_pkts Transmitted multicast packets CPE

in_bcast_pkts Received broadcast packets CPE

out_bcast_pkts Transmitted broadcast packets CPE

in_discards Received discarded packets CPE

out_discards Transmitted discarded packets CPE

in_errors Received errored packets CPE

out_errors Transmitted errored packets CPE

Performance API Response (v2 Format)
Performance API Response v2 Format are shown for following devices:

l 60 GHz cnWave

l cnMatrix

l cnReach

l Fixed Wireless

l PTP 650/670/700

l PTP 820/850

l Wi-Fi

l cnWave 5G Fixed

60 GHz cnWave

General

Name Details Mode

mac MAC address All

managed_account Managed account name All

mode Device mode All

name Device name All

network Network All

online_duration Duration of device connection with server (seconds) All

site Site All
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Name Details Mode

timestamp Timestamp All

type Device type All

uptime Device online time (seconds) All

Radios (Array format)

Name Details Mode

radios[].id Radio ID All

radios[].rx_bps Receive bits per second All

radios[].tx_bps Transmit bits per second All

Ethernet Ports (Array format)

Name Details Mode

ethports[].max_rx Ports maximum receive bytes All

ethports[].max_tx Ports maximum transmit bytes All

ethports[].min_rx Ports minimum receive bytes All

ethports[].min_tx Ports minimum transmit bytes All

ethports[].port Port name All

ethports[].rx Ports receive bytes All

ethports[].tx Ports transmit bytes All

ethports[].rx_bps Ports receive bits per second All

ethports[].tx_bps Ports receive bits per second All

ethports[].min_rx_bps Ports minimum receive bits per second All

ethports[].min_tx_bps Ports minimum transmit bits per second All

ethports[].max_rx_bps Ports maximum receive bits per second All

ethports[].max_tx_bps Ports maximum transmit bits per second All



cnMatrix

General

Name Details

mac MAC address

managed_account Managed account name

mode Device mode

name Device name

network Network

site Site

timestamp Timestamp

tower Tower

type Device type

Switch

Name Details

switch.rx.broadcast_pkts Receive broadcast packets

switch.dl_kbits Downlink usage (in kbits on hour or minute basis)

switch.dl_throughput Downlink throughput (Kbps)

switch.ul_kbits Uplink (in Kbits on hour or minute basis)

switch.rx.multicast_pkts Receive multicast packets

switch.ul_throughput Uplink throughput (Kbps)

switch.rx.pkts_err Receive Packet error

switch.rx.unicast_pkts Receive unicast packets

switch.tx.broadcast_pkts Transmit broadcast packets

switch.tx.multicast_pkts Transmit multicast packets

switch.tx.pkts_err Transmit packet error

switch.tx.unicast_pkts Transmit unicast packets
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cnReach

General

Name Details Mode

mac MAC address All

managed_account Managed account name All

mode Device mode All

name Device name All

network Network All

online_duration Duration of device connection with server (seconds) All

sm_count Connected SM count All

timestamp Timestamp All

tower Tower All

type Device type All

uptime Device online time (seconds) All

Radios (Array format)

Name Details Mode

radios[].id Radio ID Radios

radios[].neighbors Radio neighbors Radios

radios[].noise Average noise Radios

radios[].power Transmit power Radios

radios[].rssi RSSI value Radios

radios[].rx_bytes Receive bytes Radios

radios[].throughput Total throughput Radios

radios[].tx_bytes Transmit bytes Radios



Fixed Wireless (cnVision, ePMP and PMP)

General

Name Details cnVision ePMP PMP

mac MAC address AP/SM AP/SM AP/SM

managed_account Managed
account name

AP/SM AP/SM AP/SM

mode Device mode AP/SM AP/SM AP/SM

name Device name AP/SM AP/SM AP/SM

network Network AP/SM AP/SM AP/SM

online_duration Duration of
device
connection
with server
(seconds)

AP/SM AP/SM AP/SM

sm_count Connected SM
count

AP AP AP

sm_drops Session drops AP/SM AP/SM AP

timestamp Timestamp AP/SM AP/SM AP/SM

tower Tower AP/SM AP/SM AP/SM

type Device type AP/SM AP/SM AP/SM

uptime Device online
time ( seconds)

AP/SM AP/SM AP/SM

Radios

Name Details cnVision ePMP PMP

radio.dl_frame_utilization Downlink frame
utilization

AP

radio.dl_kbits Downlink usage
(in Kbits on hour
or minute basis)

AP/SM AP/SM

radio.dl_mcs Downlink MCS SM SM
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Name Details cnVision ePMP PMP

radio.dl_modulation Downlink
modulation

SM

radio.dl_pkts Downlink packet
count

AP/SM AP/SM

radio.dl_pkts_loss Downlink packet
loss

AP/SM

radio.dl_retransmits_pct Downlink
retransmission
percentage

AP/SM AP/SM

radio.dl_rssi Downlink RSSI SM SM SM

radio.dl_rssi_imbalance Downlink RSSI
imbalance

SM

radio.dl_snr Downlink SNR SM SM

radio.dl_snr_h Downlink SNR
(dB) horizontal

SM

radio.dl_snr_v Downlink SNR
(dB) vertical

SM

radio.dl_throughput Downlink
Throughput
(Kbps)

AP/SM AP/SM AP/SM

radio.ul_frame_utilization Uplink frame
utilization

AP

radio.ul.kbits Uplink usage (in
Kbits on hour or
minute basis)

AP/SM AP/SM

radio.ul_mcs Uplink MCS SM SM

radio.ul_modulation Uplink
modulation

SM

radio.ul_pkts Uplink packet
count

AP/SM AP/SM

radio.ul_pkts_loss Uplink packet
loss

AP/SM



Name Details cnVision ePMP PMP

radio.ul_retransmits_pct Uplink
Retransmission
percentage

AP/SM AP/SM

radio.ul_rssi Uplink RSSI SM SM SM

radio.ul_snr Uplink SNR SM SM

radio.ul_snr_h Uplink SNR (dB)
horizontal

SM

radio.ul_snr_v Uplink SNR (dB)
vertical

SM

radio.ul_throughput Uplink
Throughput
(Kbps)

AP/SM AP/SM AP/SM

PTP 650/670/700

General

Name Details Mode

mac MAC address All

managed_account Managed account name All

mode Device mode All

name Device name All

network Network All

sm_count Connected SM count Master

timestamp Timestamp All

tower Tower All

type Device type All
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Ethernet Ports (Array format)

Name Details Mode

ethports[].max_rx Ports maximum receive bytes All

ethports[].max_tx Ports maximum transmit bytes All

ethports[].min_rx Ports minimum receive bytes All

ethports[].min_tx Ports minimum transmit bytes All

ethports[].pkt_error Ports packet error All

ethports[].port Port name All

ethports[].rx Ports receive bytes All

ethports[].tx Ports transmit bytes All

ethports[].rx_bps Ports receive bits per second All

ethports[].tx_bps Ports receive bits per second All

ethports[].min_rx_bps Ports minimum receive bits per second All

ethports[].min_tx_bps Ports minimum transmit bits per second All

ethports[].max_rx_bps Ports maximum receive bits per second All

ethports[].max_tx_bps Ports maximum transmit bits per second All

Ethernet

Name Details Mode

ethernet.link_loss Link loss All

ethernet.pcb_
temperature

PCB temperature All

ethernet.rx_channel_util Receive channel utilization All

ethernet.rx_capacity Receive capacity All

ethernet.ssr Signal strength ratio All

ethernet.rx_power Receive power All

ethernet.sfp_interface.tx SFP transmit bytes All



Name Details Mode

ethernet.rx_throughput Receive throughput All

ethernet.tx_channel_util Transmit channel utilization All

ethernet.tx_capacity Transmit capacity All

ethernet.tx_power Transmit power All

ethernet.tx_throughput Transmit throughput All

ethernet.vector_error Vector error All

PTP 820/850

General

Name Details Mode

mac MAC address All

managed_account Managed account name All

mode Device Mode All

name Device name All

network Network All

online_duration Duration online All

timestamp Timestamp All

tower Tower All

type Device type All

uptime Device online time ( seconds) All

Radio

Name Details Mode

radios[].id Radio ID All

radios[].max_rsl Radio Maximum Receiver Signal Level All

radios[].max_tsl Radio Maximum Transmission Signal Level All

radios[].min_rsl Radio Minimum Receiver Signal Level All
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Name Details Mode

radios[].min_tsl Radio Minimum Transmission Signal Level All

radios[].peak_
throughput

Radio Peak Throughput All

radios[].radio_location Radio Location All

radios[].throughput Radio Throughput All

radios[].modem_max_
mse

Modem maximum MSE in dB All

radios[].modem_min_
mse

Modem minimum MSE in dB All

radios[].modem_max_
xpi

Modem maximum XPI in dB All

radios[].modem_min_xpi Modem minimum XPI in dB All

radios[].modem_max_
mrmc_profile

Modem maximum MMRC All

radios[].modem_max_
mrmc_profile

Modem minimum MMRC All

Radio Groups

Name Details Mode

radios_groups[].id Radio Group ID All

radios_groups[].peak_
throughput

Radio Group peak throughput All

radios_groups[].radio_
location

Radio Group location All

radios_groups
[].throughput

Radio Group throughput All



Wi-Fi

General

Name Details Mode

mac MAC address All

managed_account Managed account name All

mode Device mode All

name Device name All

network Network All

online_duration Duration of device connection with server ( seconds) All

site Site All

timestamp Timestamp All

type Device type All

uptime Device online time ( seconds) All

Radios (Array format)

Name Details Mode

radios[].clients Number of clients All

radios[].id Radio ID All

radios[].rx_bps Receive bits/second All

radios[].throughput Total throughput All

radios[].tx_bps Transmit bits/second All

radios[].band Radio band (2.4 GHz/5 GHz) All

NOTE:

The specification for the equivalent v1 APIs is available in the Appendix.

l Statistics API Response (v1 Format)

l Performance API Response (v1 Format)
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cnWave 5G Fixed

General

Name Details Mode

mac MAC address All

managed_account Managed account name All

mode Device mode All

name Device name All

network Network All

online_duration Duration of device connection with server (seconds) All

timestamp Timestamp All

type Device type All

uptime Device online time (seconds) All

cpe_registered Registered CPEs count BTS

cpe_connected Connected CPEs count BTS

cpe_registrationCnt Number of times the CPE registered with the BTS CPE

Radio

Name Details Mode

ul_throughput Uplink Throughput BTS

dl_throughput Downlink Throughput BTS

cpe_ul_throughput Uplink Throughput CPE

cpe_dl_throughput Downlink Throughput CPE

cpe_ul_evm Uplink EVM CPE

cpe_dl_evm Downlink EVM CPE

cpe_ul_mcs Uplink MCS CPE

cpe_dl_mcs Downlink MCS CPE

cpe_ul_rxPower Uplink Rx Power CPE

cpe_dl_rxPower Downlink Rx Power CPE



Client API Response (v2 Format)
Client details API Response v2 Format are shown below:

Name Details Wi-Fi

ap_mac AP MAC

client_type Client type(Client | Guest Client)

download_quota Download quota (Note: only applicable for Guest Client)

download_quota_balance Download quota balance (Note: only applicable for Guest
Client)

ip IP address of client

mac Client MAC

managed_account Managed account name

manufacturer Manufacturer name

name Client name

radio.band Band(2.4 GHz/5 GHz)

radio.rssi RSSI

radio.rx_bytes Received bytes

radio.snr SNR

radio.ssid SSID

External Guest Access Login API
Integrates an external captive portal with the Cambium Networks AP while posting directly to cnMaestro. This
API provides the support for the external captive portal to make login requests.

POST /api/v2/ext-portals/login

Request:

curl -X

/api/v2/ext-portals/login" -H "accept: */*" -H "Authorization: Bearer
e88916f5b663c1ea966af835c8a0a19c20d17686" -H "Content-Type: application/json"-d

Body

"{\"ga_ap_mac\":\"11-22-33-44-55-66\",\"ga_cmac\":\"11-22-33-44-55-65\",\"ga_
Qv\":\"eUROBR86HBgAGDEEVgQAGw4UWRUCACYVMgFPMV5ZWVFfUVdGX1ZFJXxZR1dLBhMUMww\",\"ga_
user\":\"test-user\",\"ga_pass\":\"test-pass\"}"

Response:

{
“data”: {

“mType”: 3,
“msgId”:28,
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“status”:<integer values>,
“prefixQs”:<true/false>,
“expiry”:<integer values>,
“action”:<integer values>,
“cmac”:<client mac>,
“msg”:<Radius Returned Message>,
“extURL”:<external url string>
}

}

The status value description is provided in the table below.

Status Description

0 Login is successful.

1 Invalid login request, the client is not currently associated to the AP which is being requested for
login here.

2 RADIUS reject due to invalid username/password.

3 RADIUS timeout, AP didn’t received the RADIUS response.

4 Missing RADIUS server config on the WLAN config of the AP.

5 If LDAP configured on the AP for authentication then LDAP server responded back with reject.

6 LDAP timeout happened on the AP for the request.

7 Missing LDAP configuration on the WLAN configuration of the AP.

8 Logout is successful.

9 Logout failed due to missing session on the AP. Most likely client session is already deleted from
this AP.

The response parameter name and details is shown below.

Name Details

action 0: On success action redirects the user to AP onboard logout page.

1: On success redirects user to an external URL.

2: On success redirects user to its original URL.

cmac MAC address of the client.

expiry Displays the session time for the given guest session.



Name Details

msg Message is based on RADIUS attribute reply message (18) in the RADIUS Access Accept or
Reject message.

prefixQs True: Add query strings to landing URL on success.

False: Remove query strings from landing URL on success.

prefixQs and action values are driven based on WLAN configuration.

60 GHz cnWave RESTful API
cnMaestro supports configuration overrides for 60 GHz cnWave E2E Network, E2E Controller, and Node(s)
using the RESTful API.

E2E Network
To determine the configuration parameters available in an E2E Network, navigate to E2E Network >
Configuration > Advanced. Search for the desired Field, and review its Description, allowed Values, and
Override status. Use the RESTful API to override single or multiple fields.

GET /api/v2/cnwave60/networks/{network_id}/configuration

PUT /api/v2/cnwave60/networks/{network_id}/configuration

Field names are separated by dots. Each substring between the dots will be converted to objects and the last
substring will be the key and value.

Example

In case of field name radioParamsBase.fwParams.wsecEnable,payload will be:

{
"radioParamsBase": {
"fwParams": {

"wsecEnable": 1
}

}
}

WARNING:

Partial update is not allowed. Always send full configuration that needs to be pushed to E2E
Network.

784 | RESTful API Specification Cambium cnMaestro Cloud 5.0.1 | User Guide



785 | RESTful API Specification Cambium cnMaestro Cloud 5.0.1 | User Guide

Optimization

To determine the optimization parameters available in an E2E Network, navigate to E2E Network >
Configuration > Advanced.

GET /api/v2/cnwave60/networks/{network_id}/optimization/{optimization_type}

PUT /api/v2/cnwave60/networks/{network_id}/optimization/{optimization_type}

Available values :

controlSuperframeAllocation,

dpaZoneAllocation

clearNodeAutoConfig

Example

{
"clearUserConfig": true,
"nodes": [
"string"

],
"configPaths": "string"

}

Device (Node) Configuration
To update Device configuration, navigate to Node > Configuration > Advanced. Search for the Field, and review
its Description, allowed Values, and Overrides status. Use the RESTful API to override those fields.

GET /api/v2/cnwave60/networks/{mac}/configuration

PUT /api/v2/cnwave60/networks/{mac}/configuration

Field names are separated by dots. Each substring between the dots will be converted to objects and the last
substring will be the key and value.

Example

In case of field name linkParamsBase.fwParams.minTxPower, object to send in the API payload will be:

{
"linkParamsBase": {

"fwParams": {
"minTxPower": 6
"maxTxPower": 8

}
}



}

The below two APIs are introduced in Release 3.1.0 to update multiple device configurations overrides.

GET /api/v2/cnwave60/networks/{network_id}/devices/overrides

PUT /api/v2/cnwave60/networks/{network_id}/devices/overrides

WARNING:

Partial update is not allowed. Always send full configuration that needs to be pushed to 60
GHz cnWave Devices.

The example payload for PUT request is seen from cnMaestro UI.

Example
{
"device1_name": {
"radioParamsBase": {
"fwParams": {
"txPower": 6

}
}
},
"device2_name": {

"popParams": {
"POP_IFACE": "nic2"
}

}
}

NOTE:

You can download the full config of the node by clicking on the Show Full Configuration as
well and then get the JSON key and pass in RESTful API.

E2E Controller
To update E2E Controller configuration, navigate to E2E Network > Configuration > E2E Controller. Search for
the desired Field, and review its Description, allowed Values, and Override status. Use the RESTful API to
override those fields.
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GET /api/v2/cnwave60/networks/{network_id}/controller/configuration

PUT /api/v2/cnwave60/networks/{network_id}/controller/configuration

Field names are separated by dots. Each substring between the dots will be converted to objects and the last
substring will be the key and value.

Example

In case of field name prefixAllocParams.seedPrefix,payload will be:

{
"prefixAllocParams": {
"seedPrefix": "fd00:ceed:1992:1400::/56"
}

}

WARNING:

Partial update is not allowed. Always send full configuration that needs to be pushed to the
E2E Controller.

Guest Access

This section describes how to configure Guest Access using cnMaestro. This feature allows the clients to
connect to the internet through Free Tier, Vouchers, or Paid Access types.

The Guest Access feature creates a separate network for guests by providing Internet access to guest wireless
devices such as mobiles, tabs, and laptops.

NOTE:

The Guest Access feature is supported only on Enterprise Wi-Fi devices and ePMP 1000
Hotspot.

Configuration
l Create the Guest Access Portal in cnMaestro

l Map the device to cnMaestro



Creating the Guest Access Portal in cnMaestro
1. Basic Details

2. Access Portal

3. Design Page

4. Sessions

5. Guests

Procedure for Creating Guest Access
1. Navigate to Network Services > Guest Access Portal.

2. Click Add Portal. A maximum of four portals can be created per account.

3. Enter a name and brief description for the portal.

4. Click Save..

Basic Details
The Basic details page contains the Managed Account Type, Name, and Description.
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NOTE:

A name once created for the Portal cannot be changed.

Access Portal
The Access Portal tab has four different access types:

l Free

l Enterprise X access through one of the following options:

n Microsoft Azure

n Sponsored Guest

n Self Registration

n Google

l Paid X

l Vouchers

The parameters under each access method can be configured only after the corresponding access method is
enabled.

NOTE:

Microsoft Azure and Google-based access are not supported on devices running release 4.x..



Free Access Type Configuration

Free Access type contains configurable parameters such as:

l Session validity

l Renewable frequency

l Client rate limits

l Social login

You can select authentication using Google, Facebook, Twitter and Office 365, or all. You will need to enter the
App ID of your social login App. If you enable Facebook login you will also need to enter your Facebook App
secret.
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Parameter Description

Add Whitelist Options for configuring the IP address or the domain name.

Client Rate Limit Options for configuring downlink and uplink parameters in kbps to limit the data
transfer rate to or from the client. If a client rate limit parameter is blank, no limits
are applied.

Client Quota Limit The data quota limit feature has been added for RADIUS-based as well as
controller-based guest portals. For controller-based, it is either directional or total
data quota limit. Once the client logs inas a guest, the data quota limit is enforced
and the values are sent to the access point to which the client is connected. The
access point keeps track of the data limits and also sends client statistics to the
controller every thirty minutes. In case of multiple devices allowed for a given
policy, the data quota limits enforcement has some limitations and works with the
latency of thirty minutes during which the cumulative data quota limits of the
devices can be exceeded beyond the configured data quota limits.

The similar behavior is supported through RADIUS attributes for RADIUS-based
onboard guest access clients.

RADIUS_VENDOR_ID_CAMBIUM 9 (17713)
RADIUS_VENDOR_ATTR_CAMBIUM_WIFI_QUOTA_UP (151)
RADIUS_VENDOR_ATTR_CAMBIUM_WIFI_QUOTA_DOWN (152)
RADIUS_VENDOR_ATTR_CAMBIUM_WIFI_QUOTA_UP_GIGWORDS (153)
RADIUS_VENDOR_ATTR_CAMBIUM_WIFI_QUOTA_DOWN_GIGWORDS (154)
RADIUS_VENDOR_ATTR_CAMBIUM_WIFI_QUOTA_TOTAL (155)
RADIUS_VENDOR_ATTR_CAMBIUM_WIFI_QUOTA_TOTAL_GIGWORDS (156)

The gigwords attributes are used for supporting data quota limits above 4 GB when
required.

Renewable
Frequency

Once the session duration for the client expires, the client needs to wait for the
period specified by renewal frequency before logging in again.

Session Duration The duration for which the client is provided access.

SMS Authentication SMS OTP supports Twilio, SMS Country, and SMS Gupshup SMS gateway providers.
Any one of the gateway providers can be used to support the SMS OTP to be
delivered to the cell phone of the end user. Once OTP is received the client can
enter the OTP to get Internet access.

Social Login Consists of the following options:
l Domain URL: The redirected URL used by the client when trying to access the

Internet.
l Google: Consists of ID and Secret options to configure, which admin can create

from https://console.cloud.google.com/
l Facebook: Consists of ID and Secret options to configure, which admin can

create from https://developers.facebook.com/apps/
l Twitter: Consists of consumer key, consumer secret key, and callback URL.
l Office 365: Consists of Id and Replyback URL.

Table 114: Free Access Type Parameters

NOTE:

l Renewal frequency should be greater than session expiration.

l Client will get Social login options only when enabled in Access Control page in Portal.

l If Social login is enabled, it is mandatory in free access method for client to login through
Google/Facebook/Twitter/Office 365.

https://console.cloud.google.com/
https://developers.facebook.com/apps/


Enterprise Wi-Fi AccessX using Microsoft Azure Login, Sponsored Guest, Self Registration, or
Google

Note:

l Microsoft Azure and Google-based access are supported only on Enterprise Wi-Fi 6
APs running firmware version 6.5.1 and later.

l Microsoft Azure is supported on cnMaestro 4.1.0 and later versions.

l Google-based access is supported on cnMaestro 5.0.0 and later versions.

Microsoft Azure

Enterprise Microsoft Azure access page enables Microsoft Azure users to log in to access the Enterprise Wi-Fi.
To set up users to authenticate from Microsoft Azure, navigate to Network Services > Guest Access Portal >
Access > EnterpriseX > Microsoft Azure, complete the following parameters and click Save:
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Sponsored Guest

In this type of access, guests must provide their own email address and their sponsor's email address to request
Internet access.

To allow sponsored guests to access the Wi-Fi, navigate to Network Services > Guest Access Portal > Access >
EnterpriseX > Sponsored Guest complete the following parameters, and click Save:



Self Registration

Self registration enables guests to register themselves when connecting to the Wi-Fi network for the first time.
The Wi-Fi administrator can configure the self registration process to require a sponsor approval or not. The
sponsor approval can also be configured to be manual or automatic confirmation.

To configure self registration, navigate to Network Services > Guest Access Portal > Access > EnterpriseX > Self
Registration and configure the following parameters.
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Parameter Description

Enable Self
Registration

Select the check box to enable self registration feature and configure the following
parameters.

Sponsor Guest Settings
The guests must enter a sponsor email address when registering to connect to the wireless network. The
administrator can choose to configure whether the sponsor must manually approve each request or the
approval is automatic.

Require Sponsor Select the check box if you want the self registration to be approved by a sponsor.
The guests must enter the sponsor email address when registering for access to the
SSID.

Sponsor Type Specifies whether the sponsor approval for guest internet access must be
automatic or manual. The following options are available:
l Manual Confirmation—The sponsor receives an email for approving the guest's

access request. After approval, the guest receives an email confirmation along
with the password to connect to the wireless network.

l Automatic Confirmation—If the guest provides a configured sponsor's email
address, the password to access the network is automatically emailed to the
guest and the sponsor is also notified via email.

Sponsor Email List Configure the list of sponsor email addresses for approving access requests.

Receive password via text
By default, the guests receive the password to their email address. However, if you want the guests to
receive the password to their mobile devices as well, configure the following parameters.

Enable Select the check box to send the password to the guest's mobile device.

Table 115: Self Registration Parameters



Parameter Description

SMS Gateway
Provider

Select the SMS gateway to be used to send the OTP to the guest's mobile device.
The following gateways are supported (each of the gateways have their own
respective parameters that must be configured):
l Fast SMS
l Generic SMS API
l SMS Country
l SMS Gupshup
l SMSAPI
l Twilio
l Victory Link SMS

Each of the above gateways must be configured with their respective parameters.

Client-related parameters

Client Session—
Session Duration

Specifies the maximum duration (in minutes) that the guest can browse the internet
in a single session.
Supported range: 1-2628000 minutes

Client Rate Limit Specifies the download and upload speed limit (in Kbps) for the guests.
Configure the speed limit in the Downlink and Uplink fields.

Client Quota Limit

Quota Type Specifies the type of quota for configuring the data usage limit.
The following options are supported:
l None—No limit is configured for data usage. Guests can access unlimited data in

the configured session duration.
l Directional—Configure limits separately for downlink and uplink directions. The

Downlink and Uplink fields are enabled.
l Total—Configure the limit for both directions totally. The Total field is enabled.

Downlink Specifies the downlink data usage limit (in either MB or GB, selected from the drop-
down list).
This field is available only when you select Directional in the Quota Type field.

Uplink Specifies the uplink data usage limit (in either MB or GB, selected from the drop-
down list).
This field is available only when you select Directional in the Quota Type field.

Total Specifies total data usage limit for both the directions (in either MB or GB, selected
from the drop-down list).
This field is available only when you select Total in the Quota Type field.

Device Limit Specifies the number of devices that the guest can connect to the wireless network.
Default: 5.

Table 115: Self Registration Parameters

Google-based access

Google-based access enables users with a Google account to connect to the wireless network by synchronizing
the active directory. When enabled, if a guest who is part of the supported group tries to connect to the Wi-Fi
network, the AP provides access to the guest.
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Note:

To configure Google-based access, you must have a Google Workspace account.

To configure Google-based access, navigate to Network Services > Guest Access Portal > Access > EnterpriseX

> Google and configure the following parameters.

Parameter Description

Enable Google Login Select the check box to enable Google-based Wi-Fi access and configure the
following parameters.

Device Limit Specifies the number of devices that the guest can connect to the wireless
network.

Default: 5.

Google Login

Enable Directory
Synchronization

Select the check box to enable synchronization of Google Apps Domain
Directory.

This functions requires authorization. Click Follow these steps for information on
configuring your Google Apps Domain Directory.

Allowed Domains List of domains to be allowed for Google-based access. Enter the domain name in
the text box.

Client-related parameters

Table 116: Google Parameters



Parameter Description

Client Session—Session
Duration

Specifies the maximum duration (in minutes) that the guest can access internet in
a single session.

Supported range: 1-2628000 minutes

Client Rate Limit Specifies the download and upload speed limit (in Kbps) for the guests.

Configure the speed limit in the Downlink and Uplink fields.

Client Quota Limit

Quota Type Specifies the type of quota for configuring the data usage limit.

The following options are supported:

None—No limit is configured for data usage. Guests can access unlimited data in
the configured session duration.

Directional—Configure limits separately for downlink and uplink directions. The
Downlink and Uplink fields are enabled.

Total—Configure the limit for both directions totally. The Total field is enabled.

Downlink Specifies the downlink data usage limit (in either MB or GB, selected from the
drop-down list).

This field is available only when you select Directional in the Quota Type field.

Uplink Specifies the uplink data usage limit (in either MB or GB, selected from the drop-
down list).

This field is available only when you select Directional in the Quota Type field.

Total Specifies total data usage limit for both the directions (in either MB or GB,
selected from the drop-down list).

This field is available only when you select Total in the Quota Type field.

Table 116: Google Parameters

Designing the Guest Access Login Page and Email Templates

To design the guest login page for users to see when requesting access, navigate to Network Services > Guest
Access Portal > Design > Login Page, complete the following parameters, and click Save:
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To design the email template that should be used to send approval request to the sponsor (in Sponsored Guest
and Self Registration access types), navigate to Network Services > Guest Access Portal > Design > Email
Template > Sponsor, complete the following parameters, and click Save:



To design the email template that should be used to send approved access details to the guest, navigate to
Network Services > Guest Access Portal > Design > Email Template > Guest, complete the following
parameters, and click Save:

Paid AccessX

Paypal has been added as a payment gateway service where end users can purchase Internet connectivity
using a credit card or their existing PayPal accounts. For purchasing Internet plans, clients are directed to
PayPal portal where they purchase the plan and then they are automatically redirected to guest access portal
where the purchased voucher is displayed. The user should ensure to save this Voucher information if s/he
plans to use it on multiple devices.
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Table 117: Paid Access Type Parameters

Parameter Description

General Plan Name: The name of the plan.

Session Duration: The duration for which the client is allowed to access the network.

Client Rate Limit: The uplink and the downlink values in kbps to limit the data transfer rate to
or from the client. If a client rate limit parameter is blank, no limit s are applied.

Device Limit: The device limit allow that number of devices to be connected or select the
unlimited to connect any number of devices.

Voucher Access Type Configuration

Important Points to Remember

l Vouchers can only be generated after enabling Vouchers and creating at least one Voucher plan.

l A maximum of 50,000 Vouchers per portal can be created on cnMaestro.

Note:

User is allowed to add only 1000 vouchers at a time. In order to create 50,000 vouchers
user needs to add 50 times.

l A maximum of 1,000 Vouchers per portal can be created on cnMaestro Cloud
(https://cloud.cambiumnetworks.com/).

l Total number of generated Vouchers = Vouchers Unclaimed + Vouchers Claimed + Vouchers Expired.

l The admin can export all/valid/current page Voucher codes as PDF/CSV document.

Voucher contains options to add new plans and Vouchers. Based on user requirements, the plans can be
created with different validity and rate limits.

https://cloud.cambiumnetworks.com/


1. Create a plan

l Navigate to Network Services > Access Control Portal page and select Access Control tab.

l Enable Vouchers.

l Click Add New Plan button. The window with general and design parameters for the plan is displayed.

Parameter Description

Design l Color: There are options to modify colors for the title, message, code, and
background.

l Background Image: You can browse and select a background image for this
page.

l Title: The title of the voucher plan.

l Message: Detailed information about the plan.

l Access Code Message: 8 digit access code will be provided to use the voucher.

With all the above parameters, administrators can create their own design for the
card with text, color, and message to be displayed on card.

General l Name: The name of the plan.
l Session Duration: The duration for which the client is allowed network access.
l Voucher Expiry: The expiry time for the generated Vouchers. Once this time

lapses, the Vouchers cannot be used.
l Client Rate Limit: The uplink and the downlink values in kbps to limit the data

transfer rate to or from the client. If a client rate limit parameter is blank, no
limits are applied.

l Voucher Device Limit: Limit the devices to use the voucher.

Table 118: Voucher Access Type Parameters
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2. Once a plan is configured, Vouchers can be generated for it. Each Voucher is a unique, randomized
alphanumeric code.

Figure 399 Select a plan



Figure 400 Add Vouchers

3. Once the plan is created and the Vouchers are generated, the following page is displayed.

Figure 401 Sample Voucher Code

NOTE:
The modified values in the Access Portal page is reflected on the design page only when the
design page is saved after making the changes.

Design Page
The Design page refers to the page to which a wireless client is redirected when it connects to the guest portal.
Administrators can create their own Design page by modifying the default logo, background, and text to be
displayed in the Design page with different colors and fonts.

l If Free is selected in Access Portal, the client only sees free access related parameters.

l If Voucher is selected in Access Portal, the client only sees Voucher related parameters with a text box to
enter the Voucher code.

l If both Free and Voucher are selected, then the client sees both Free and Voucher related parameters.
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Parameter Description

Accept Terms
Message

Text to appear as the accept terms message.

Advanced Expand Advanced option. Browse and select the advanced fields.

Background Browse and select the image that needs to be displayed as the background.

l Recommended image resolution—1024 pixels × 800 pixels
l Maximum supported image file size—5 MB
l Supported file formats—JPEG, JPG, PNG, and GIF

Background
Placement

Choose the option from the drop-down for placing the background image in the
Design page.

Custom Fields Expand Custom Field option. The user can customize the fields in the Design page by
choosing the Custom Field option in the Guest Access Portal page and clicking Add
New button.

Enter Voucher
Code Message

Enter the text to appear in Voucher Code Message.

Free Label Enter the text that should appear on the Free Label.

Login Button Enter the text that should appear on the window to submit.

Login Failure
Message

Message to appear when any error occurs during login.

Login Success
Message

Message to appear after successful login.

Login Title Title of the login section.

Table 119: Design Page Parameters



Parameter Description

Logo Browse and select the logo that needs to be displayed on the Design page.

l Recommended image resolution—300 pixels × 50 pixels
l Maximum supported image file size—3 MB
l Supported file formats—JPEG, JPG, PNG, and GIF

Message Text to appear as the welcome text. You can choose the font style and size for the
welcome text.

On Success
Redirect to URL

Enter the URL to be redirected to the page like Google, Twitter, and Facebook, etc.

Opacity The transparency of background image.

Page Title Text to appear as the title of the page. You can choose the font style and size for the
title.

Please wait
Message

Text to appear in the waiting screen.

Repeat
Background

Enable the check box if you want the background image to be repeated.

Select Plans Label Enter the text to appear in the label to select plan.

Server Error
Message

Text to appear if there is an error while contacting server.

Terms and
Conditions Title

Text to appear as the title for the terms and the conditions.

Terms and
Conditions

Text to appear as the terms and conditions.

Terms Agree
Button

Text to appear in the terms agree button.

Terms Cancel
Button

Text to appear in the terms cancel button.

Text Design Choose the appropriate colors for the background, logo in the background, content
area, and for the text.

Voucher Code Enter the text to appear in Voucher Code, Voucher Label, Enter Voucher Code
Message, and Voucher Code Error Message.

Voucher Code
Error Message

Enter the text to appear in Voucher Code Error Message.

Table 119: Design Page Parameters
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Parameter Description

Voucher Label Enter the text to appear in Voucher Label.

Failure Enter the text to appear in Google Authentication Failure Message, Twitter
Authentication Failure Message, and Facebook Authentication Failure Message.

WIFI4EU WiFi4EU provides free, high-quality Internet access only across the European Union.

Table 119: Design Page Parameters

WIFI4EU

WiFi4EU provides the free, high-quality Internet access across the European Union. Administrator can enable
the WiFi4EU check-box to provide access to the free internet.

Table 120: WiFi4EU Parameters

Parameter Description

General l Network UUID: Universally Unique Identifier (UUID) that the EC attribute is generated
when the network installation is created in the Installation.

l Language: Allows to select the preferred language.
l Enable Self Test Mode: Allows the browsers background script verification.
l Show Logo: Displays the WiFi4EU logo provided by the European union.

Sessions

Sessions tab contains Client MAC address, Access Point MAC address, Access Type as Free (Google or
Facebook) or Voucher, WLAN-SSID of client connected AP, Remaining time and Disconnect option.

Administrator can check how many clients are connected, Access Type (Free/Voucher) of the client, and can
disconnect the clients.



Client Login Events table creates events of client login sessions. It maintains the login events for 7 days. This
table has Client MAC address, Portal Name, SSID, Access point MAC, Voucher code (if client connected with
Voucher), Access type (Google/Facebook/Voucher).

Admin can export the client login events as PDF / CSV.

Parameter Description

Access Point MAC address of the Access Point.

Access Type Access type as Free or Voucher.

Client MAC MAC address of the client.

Disconnect Displays if the client is disconnected from the network.

Remaining Time The time left for the client to access the Internet. It depends upon the session
duration configured in the Access Portal.

Voucher Displays the valid applied voucher.

WLAN SSID of the network.

Table 121: Sessions Parameters

NOTE:

For Free Access method, the client MAC address is displayed even after the free session
duration expires. Delete the MAC address of the client after the Renewable Frequency
completes.

Users table displays details of users accessing the network using Enterprise Google-based access.
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Parameter Description

Email Email address of the registered user.

Group Name of the group to which the user belongs.

Registered Devices MAC address of the registered devices.

Table 122: Users Table Parameters

GuestsX

The Guests page allows you to view details of self registered guests connecting to the wireless network.
However, to view this page, you must first enable and configure self registration under Network Services >
Guest Access Portal > Access Type > EnterpriseX > Self Registration.

You can also add new guest details on this page. These users can directly access the wireless network after
entering the required details in the access portal.

To add a new user, complete the following steps:

1. Click Add New on the Guests page.

The Add New User window is displayed.

2. Configure the name and email address of the guest in the Name and Email fields.

Add a description, if required, in the Notes field.

3. Click Add.

The details of the Enterprise self registered guests that are connected to the Wi-Fi network are displayed in
the table



Parameter Description

Name Name of the guest that was entered at registration.

Email Email address of the guest.

Status Displays the whether the guest is connected or offline.

Device Count Displays the number of devices that the guest has connected to the network.

Notes Displays the comments or description provided when adding the guest.

Activation Displays the date and time when the guest first connected to the network.

Expiration Displays the date and time when the guest disconnected from the network.
For currently connected guests, this field displays the date and time of session
expiration.

Table 123: Guests Table Details

Mapping the device to Guest Access Portal in cnMaestro
The administrator needs to configure the name of the Guest Access Portal in the device which redirects the
device to cnMaestro for client connectivity.

NOTE:

The client gets the fully configured Design page for login only if the Access Point is
onboarded to the server.

Configuration at device level
To configure the Guest Access at device level, perform the following:

1. Login to the device.

2. Navigate to Configuration > WLAN > Guest Access.
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3. Enable the Guest Access check box.

4. Choose the Portal Mode radio as cnMaestro.

5. In the Guest Portal Name text box, select the name of the portal that was created in cnMaestro and enter the
respective parameters.

Configuration at cnMaestro side
The administrator can push the configuration from cnMaestro through policy or advanced configuration.



Access Types
The following table describes the parameters described in cofiguring SMS authentication parameters:

To configure SMS Authentication on cnMaestro, perform the following:

1. Enable SMS Authentication feature.

2. In SMS Gateway provider, select your required gateway from the drop-down.

3. Enter the User Name.

4. Enter the Sender ID. This field is optional. This allows user to send SMS through the ID which he chooses.

5. Enter API Key.

6. Select your Account Type from the drop-down.

7. Enter the OTP Template. The OTP template should include “%code%. %code% replaces the OTP code in the
SMS.
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Guest Access using Social Login

Configuration
To achieve cnMaestro Guest Access using Social Logins like Google, Twitter, Facebook, and Office 365, perform
the following steps:

To create Guest Access profile on cnMaestro, do the following:

1. Login to cnMaestro and navigate to Network Services > Guest Access Portal > Add Portal.

2. Enter Portal Name, Description, enable logging for client login events.

3. Click Save.

4. Click Edit Guest Portal Details.

5. Navigate to Access tab and expand Social Login.



6. Select Google, Twitter, Facebook, Office 365 based on your requirement.

API Key Generation
Perform the following steps to create APIs for cnMaestro to integrate with Google, Twitter, Facebook, and
Office 365:

l Google

l Twitter
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l Facebook

l Office 365

Google

1. Login to Google Account and navigate to https://console.cloud.google.com/.

2. Click Select a Project and create a New Project.

3. Give a name to the Project and click CREATE..

4. Click Credentials under this project.

5. Under Credentials tab, create OAuth Client ID.

https://console.cloud.google.com/


6. Click Configure Consent Screen

7. Assign a name to the application, map to an email address, add cambiumbnetworks.com to the authorized
domain and click Save.
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8. Once clicked Save for above page it redirects to creation of OAuth Client ID.

9. Select Application type as Web Application, give a Name, add Guest Portal Hostname URL/IP which you will
get from cnMaestro UI and click Create.



10. Clicking Create on above page it redirects to the screen showing Client ID and Client Secret.

11. Copy the Client ID and paste it to the cnMaestro enabling Google under Social Logins and click Save.

Twitter

1. Login to Twitter Account and access https://developer.twitter.com/en/apps and click Create an app.

818 | Guest Access Cambium cnMaestro Cloud 5.0.1 | User Guide



819 | Guest Access Cambium cnMaestro Cloud 5.0.1 | User Guide

2. Click Keys and Tokens and copy Consumer API Key and Consumer API Secret Key..



3. Paste them to cnMaestro GUI for Twitter social login.

Facebook

1. Login to Facebook Account and access https://developers.facebook.com/apps/ and click Add a New app.

2. Enter App Display Name, Contact Email, and click on Create App ID.
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3. Select a Scenario as Integrate Facebook Login and click Confirm.

4. Navigate to Settings tab under Facebook Login and add Guest Portal Hostname from cnMaestro to Valid
OAuth Redirect URLs section and click Save Changes.



5. Navigate to Settings > Basic and copy App ID and App Secret.
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Office 365

1. Login to Office 365 Account and access https://apps.dev.microsoft.com/ and click Add an app.

2. Upon Adding your App name and clicking Create application, it redirectes to App page.

3. Copy Application ID and paste it to cnMaestro Guest Access page under Office 365.

4. Click Generate New Password.

5. Copy Reply URL from cnMaestro and paste it under Redirect URLs.

6. Add my.centrify.com to the Whitelist on the cnMaestro.



Sample Template
Sample of client login page is displayed below:
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Guest Access Portal Logout
To logout from cnMaestro Guest Access Portal perform as follows:

1. Navigate to Services > Guest Access Portal page and select the respective Guest Portal Name.

2. Select Access tab.

3. Select Enable Logout functionality for the guest client check box.

4. Click Save.

The users can access and use the Guest Access Portal at any time within the specified Renewal Frequency and
Session Duration provided.



SMS Authentication
The gateway provider sends a text SMS containing the OTP to the end user's phone number. Once OTP is
received the client can enter the OTP and get Internet access.

Twilio, SMS Country, and SMS Gupshup are the SMS gateway providers that support the SMS OTP. Also there is
a generic SMS gateway option, which provides flexibility to configure any preferred SMS gateway by cnMaestro
users. Configuring SMS Gateway through this generic SMS gateway does require a little more involvement to
review the integration specifications of the given SMS gateway. Please follow the guidelines as mentioned on
the Generic SMS Gateway configuration section.

Generic SMS Gateway configuration
SMS Service providers expose a SMS API which typically works over HTTP GET or HTTP POST requests. Most of
the SMS Gateways use username and password in the API requests to validate a given SMS send a request and
some use special authorization token in the HTTP Headers.

Apart from that many API have specific tokens that need to be passed into the request along with the
authentication part. To start off one has to first go through the SMS API document of the given SMS provider
and understand all components do that need to be provided in the HTTP request and then build the
corresponding cnMaestro configuration.

In general, all SMS API documents show example curl commands which can be used to create an SMS request
with the server. Curl examples demonstrate the required components in the request and help to find the right
configuration for the cnMaestro Guest Portal Generic SMS API.

The cnMaestro Generic SMS API configuration is split into multiple components which makes it easy to
configure the static and the dynamic parts of the SMS API request. It also provides a way to handle the SMS API
response and validate the API success or failure case. To handle the reply type, refer the Advanced options.

SMS Gateway provider name
Provide the SMS Gateway name which is used for reference purposes. This is not part of API request so please
provide a meaningful name to identify this SMS Gateway service provider.

HTTP Request type
Based on the SMS gateway provider and the API document information, identify the SMS API. The SMS API uses
HTTP GET or HTTP POST requests for communication with the SMS gateway server.

Example HTTP GET API request

https://smsapiserver.com/service/sms/send?user=xxx&password=yyyyy&message=”Your OTP is
ABCD”&mobileNumber=123456789&dnd=yes&sid=SenderID&v=1.1&messagType=N

Curl command to do HTTP GET request

Curl -v https://smsapiserver.com/service/sms/send?user=xxx&password=yyyyy&message=’Your OTP
is ABCD’&mobileNumber=123456789&dnd=yes&sid=SenderID&v=1.1&messagType=N

Example HTTP POST request

HTTP POST URL

https://smsapiserver.com/service/sms/send

HTTP POST Form Content

user=xxx&password=yyyyy&message=”Your OTP for Internet Access is
QW123”&mobileNumber=123456789&dnd=yes&sid=SenderID&v=1.1&messagType=N

Curl command to do HTTP POST request
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curl -v “https://smsapiserver.com/service/sms/send” -H "Content-Type: application/x-www-
form-urlencoded" -X POST \
--data-urlencode 'user=xxx' \
--data-urlencode 'passwd=yyyyy' \
--data-urlencode 'mobilenumber=1234567789' \
--data-urlencode 'message=Your OTP for Internet access is QW123' \
--data-urlencode 'sid=Sid' \
--data-urlencode 'v=1.1' \
--data-urlencode 'mtype=N' \
--data-urlencode 'dnd=yes' \
--data-urlencode 'DR=Y'

If the SMS Gateway is using an authorization token, then below example curl request shows how the
Authorization field is added into a HTTP header.

curl -v -H "Authorization: Bearer nZYIoU7QoUxfD03ct1CC2YvInqI7DmUAH6RYz01K1" \
"https://smsapiserver.com/service/sms/send?\
from=Test&\
to=123456789&\
message=’Your OTP for Internet access is QW123’&\
format=json"

All the SMS API have components as follows:

• Static components which are part of the request.

• Two dynamic components which are part of the mobile number, to which the SMS needs to be sent and the
message which contains the OTP.

Static components

API URL

Based on the above curl request example the URL configures as https://smsapiserver.com/service/sms/send
where the request needs to be sent.

API URL information

From the example curl request please find the static components of the URL. Based on our above example this
configures as user=xxx&password=yyyyy&dnd=yes&sid=SenderID&v=1.1&messagType=N.

Remove the message and mobile number query strings from that URL and configure the rest. This is what a
static component is for a given SMS API so identify what all options are required for the SMS API request and
add it in the format: key1=value1&key2=value2….

HTTP request header key

Based on the above example, If the SMS Gateway Provider API uses some HTTP header field like authorization
token, etc. The corresponding HTTP header field name will be configured as Authorization.

HTTP request header key value

Based on the above example, the SMS gateway API configuration settings expose some authorization token or
auth token and the provided HTTP header key value will be configured as Bearer
nZYIoU7QoUxfD03ct1CC2YvInqI7DmUAH6RYz01K1 in this configuration.

Dynamic components

Message parameter name

From the example curl request or the SMS gateway provider the parameter name used for the message key
component where the OTP is added. It could be something like message|text|msg or whatever custom
parameter name is used for sending the message component.

https://smsapiserver.com/service/sms/send


For example curl request, we have used “message” and this is what configures based on the example curl
request.

Mobile number parameter name

From the example curl request or the SMS gateway provider the parameter name used for the mobile number
key component where the OTP has to be sent. It could be something like To|mobile|mobile number or whatever
custom parameter name is used for sending the mobile number component.

In our example curl request, we have used mobile number and this is what configures based on the example curl
request.

Advanced options
If you care for adding functionality for parsing the SMS API response on the cnMaestro and find if the request
was successful or if the server returned an error. Then one can use this advanced configuration to let cnMaestro
parse the SMS API reply.

The usual HTTP response code is anyway handled by default and this advanced config parses the reply content
is configured. This should be configured by advanced users only and in case if there is any failure seen in SMS
functionality then disable this and report the issue to Cambium Networks support.

Reply type

The SMS gateway API sends back a response to let the client know about the request results, this result could
be in text format or in json/xml format. So based on the SMS API document select the reply type here as TEXT.

Success

Configure the text to match the success case as follows:

• Typically, servers may respond with a text message in reply like success or sent, then configure the exact
message which should be matched in the response.

• If a server response is like success, sent message to xxxxx, then configure just success which matches in
the reply.

Error

Configure the text which matches the failure case as follows:

• Typically, servers may respond with a text message in reply like Error or Failure, then configure the exact
message which should be matched in the response.

• If a server response is like ERROR, failed to send SMS to xxxxx, out of credit, then configure just ERROR
which matches in the reply to mark it as an error.

Reply Type JSON

JSON reply success key name

Please look for the SMS gateway provider API document in detail and find the JSON examples for the reply and
identify the key which contains the successful response status value.

cnMaestro guest portal generic SMS supports nested JSON too and one has to configure the complete path for
the given result key which contains the SMS message sent status. Example JSON replies are given below to be
configured for this configuration:

Example 1

{
"messages": {
"to": "123456789",
"status": {
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"id": 0,
"groupId": 0,
"groupName": "ACCEPTED",
"result": [
{
"status": "MESSAGE_ACCEPTED"
}
],
"description": "Message accepted"
},
"smsCount": 1,
"messageId": "2250be2d4219-3af1-78856-aabe-1362af1edfd2"
}
}

Success key name to be configured based on the above example messages.status.result[0].status.

Example 2

{
"count": 1,
"list": [
{
"id": "1460978572913968440",
"points": 0.16,
"number": "48500500500",
"date_sent": 1460978579,
"submitted_number": "48500500500",
"status": "QUEUE"
}
]
}

Success key name to be configured based on the above example list [0]. Status.

Example 3

{
“status”: “Sent”
}

Success key name to be configured based on the above example is status.

JSON reply success key value

The success status can be single or multiple values based on the SMS Gateway provider and SMS gateway can
respond back with a status as a message successfully sent or successfully queued, which is also a success case
that the queued message sents out shortly.

Based on our examples the status or the result field can be mapped to multiple values like as follows:

• Sent

• Queued

• Success

• Message Accepted

So in this configuration one can add multiple such values that should be matched for the success case for the
value as received for the JSON reply success key name field.

JSON reply failure key name

Look for the SMS Gateway Provider API document in detail and find the JSON examples for the reply and
identify the key which contains the Error/Failure response status value.



cnMaestro guest portal generic SMS supports nested JSON too and one has to configure the complete path for
the given result key which contains the SMS message sent failure field. Example JSON replies are given below
to be configured for this configuration:

Example

{
"invalid_numbers": [

{
"number": "456456456",
"submitted_number": "456456456",
"message": "Invalid phone number"
}

],
"error": 13,
"message": "No correct phone numbers"

}

JSON reply failure key name to be configured based on the above example is error.

JSON reply key value

The error/failure status can be single or multiple values based on the SMS Gateway provider and SMS gateway
can respond back with a status as a message sent error or multiple error codes for the corresponding error.

Based on our examples the error can be mapped to multiple values like 13|12|-1 etc. So in this configuration, one
can add multiple such values which should be matched for the failure case for the value as received for the
JSON reply failure key name field. reply type XML.

Reply type XML

XML reply success element

Look for the SMS gateway provider API document in detail and find the XML examples for the reply and identify
the elements which contain the successful response status value.

cnMaestro guest portal generic SMS supports nested XML too and one has to configure the complete path for
the given result element which contains the SMS message sent status. Example XML replies are given below to
be configured for this configuration:

Example 1

<items>
<item id="0001" type="result">
<status>Success</status>
</item>
</items>

Success Element Name to be configured based on the above example is items/item/status.

Example 2

<?xml version="1.0" encoding="utf-8"?>
<int xmlns="http://tempuri.org/">-11</int>

Success Element Name to be configured based on the above example.

XML reply success element value

The success status can be single or multiple values based on the SMS Gateway provider and SMS gateway can
respond back with a status as a message successfully sent or successfully queued, which is also a success case
that the queued message sents out shortly.

Based on our examples the status or the result field can be mapped to multiple values like as follows:

• Sent
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• Queued

• Success

• Message Accepted

So in this configuration one can add multiple such values that should be matched for the success case for the
value as received for the XML Reply Success Element field.

SMS message sent failure field. Example XML replies are given below to be configured for this configuration:

Example 1

<items>
<item id="0001" type="result">
<error>-12</status>
</item>
</items>

XML Reply Failure Key Name to be configured based on the above example is items/item/error.

Example 2

<items>
<item id="0001" type="result">
<status>Error</status>
</item>
</items>

XML Reply Failure Key Name to be configured based on the above example is items/item/status.

Example 3

<?xml version="1.0" encoding="utf-8"?>
<int xmlns="http://tempuri.org/">-11</int>

XML Reply Failure Key Name to be configured based on the above example is int.

XML reply failure element value

The error/failure status can be single or multiple values based on the SMS Gateway provider and SMS gateway
can respond back with a status as a message sent error or multiple error codes for the corresponding error.

Based on our examples the error can be mapped to multiple values like 13|12|-1 etc so in this configuration, one
can add multiple such values which should be matched for the failure case for the value as received for the XML
reply failure element field.



Sample configuration in the cnMaestro

Figure 402 : Guest Access Portal

RADIUS Proxy X

l RADIUS Proxy is not supported in cnMaestro Cloud.

l It is available only as a cnMaestro X feature.

Overview
cnMaestro can act as a proxy server to authenticate RADIUS requests for cnPilot Wi-Fi devices. In this scenario,
cnMaestro acts as a Network Access Server (NAS) for the RADIUS server.

The Access Point sends RADIUS packets to cnMaestro , and cnMaestro sends them to the RADIUS server.
cnMaestro can act as a proxy for either authentication or accounting messages, as show in Figure 403.
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Figure 403 RADIUS Proxy on cnMaestro On-Premises

Minimum version requirements are as follows:

l Minimum cnPilot AP release required: 3.3.

RADIUS Proxy Configuration
To configure RADIUS Proxy on cnMaestro , perform the following:

1. Navigate to Shared Settings > AP Groups and WLANs page.

2. Select Enterprise WLAN to edit, and then select AAA Servers.

3. Under AAA servers, select Proxy RADIUS through cnMaestro check box.

4. Configure Authentication Server details.

5. Configure Accounting Server details.

6. Configure NAS-Identifier.

Include NAS-Identifier attribute to use the RADIUS request packets and default the system
name.

7. Push the configuration from cnMaestro to AP.

Figure 404 RADIUS Proxy Configuration



Citizens Broadband Radio Service (CBRS)

This chapter details cnMaestro support for the Citizens Broadband Radio Service subscription which is required
to manage CBRS-compliant devices in the 3.6 GHz band (3550 MHz to 3700 MHz).

Enabling CBRS in Cloud
1. Login to a cnMaestro Cloud NMS account or Cloud Anchor account (if hosting on-premises).

2. Navigate to Services > CBRS page.

3. Select preferred Spectrum Access System (SAS) vendor.

4. Click I accept the CAMBIUM NETWORKS, LTD. "CBRS" TERMS OF SERVICES and I accept the CBRS Service
payment terms to activate Enable button.

5. Click Enable.

6. In the Billing Information window pop-up enter the following:

Business Contact

n First Name

n Last Name

n Email

n Phone

n Street Address

n Zip Code

n Country

n State

Technical Contact

Enable Same as Business Contact or enter a separate Technical Contact.

n First Name

n Last Name

n Email

SAS Portal Contact

Cambium Networks creates the SAS portal account on behalf of the operator.

n Click Save.
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7. The Account page displays:

n Token

n Status

n Total Devices

n SAS

n Contact Details

n Payment Details



a. Token:

Token used for authenticated communication with SAS through Cambium Domain Proxy. It gets
generated automatically once CBRS is enabled for the Cloud account.

b. Status:

l Displays the account status.

Pending Status Success Status

1. Account Creation: Displays as Account Created once the account is enabled. Refer to Step f
for entering contact information and enabling account.

2. Payment Method: Displays as Verified once the Payment Details are approved. Refer to
Step g Payment Details.
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3. SAS ID: Once the payment details are verified, the SAS ID is allocated automatically.

NOTE

It may take 1 day to get the SAS ID.

4. Effective:

n Grey: indicates the Pending Status.

n Green: indicates Success Status.

n Red: indicates the account has been Deactivated.

c. Total Devices: Displays the count of Total Devices registered with the SAS using the Token ID. Usage
History provides the list of devices registered with Month and Year.

NOTE

Initially the device counts will be 0 APs and 0 SMs.

d. SAS: Displays the SAS vendor preferred by the operator.

NOTE

Contact Cambium support to disable CBRS operation or to change SAS Vendor.

e. SAS: An operator needs to select which SAS vendor they prefer.

f. Contact Details:

For new CBRS account migrations, this information would have already been entered in Citizens
Broadband Radio Service (CBRS). Review and update if necessary, else refer to Payment Details.

Cambium Networks selectively communicates with both the Business Contact and the Technical Contact
with changes of interest: such as SAS administrator updates, CBRS initiative changes from the CBRS
Alliance and WInnForum, and announcements of new Cambium Network CBRS features and options.

Business Contact

Cambium Networks communicates with the Business Contact for all commercial aspects of the CBRS
Service such as invoicing, payment, change in terms, change in pricing, and other details. This page
requires:

l First Name

l Last Name

l Email

l Phone

l Street Address



l City

l Zip code/Postal Code

l State

l Country

Technical Contact

Cambium Networks communicate with the Technical Contact: such as software updates, release notes,
learning guides, technical issues, etc.

l First Name

l Last Name

l Email

SAS Portal Contact

Cambium Networks sets up the SAS portal account on behalf of the operator. Please select whether to
use the Business Contact, Technical Contact, or Other.

NOTE:

Google requires a Gmail address for registration.

l Click Update.

NOTE:

Clicking update the Account Page will overwrite the current entries.

g. Payment Details
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Select one of the payment methods below:

n Add Credit Card Details

n Add ACH Payment Method

Add Credit Card Detail

Enter the following and click Submit:

n 16 digit Credit Card Number.

n Expiration Date and Year on the card.

n CVV and Cardholder Name.

Add ACH Payment Method

Enter the following and click Submit:

n ABA/Routing Number.

n Bank Account Number.

n Select one of the following for Account Type:

n Checking

n Saving

n Business Checking

n Bank Name and Account Holder Name.



Management Tool
The Management Tool allows one to register CBRS devices to the SAS provider before physically connecting
CBRS-complaint devices to the network. The following Cambium CBRS-compliant devices operate in 3.6 GHz
band frequency, ranging from 3550 to 3700 MHz:

NOTE

The CBRS Multi-Grant feature is first supported in cnMaestro 3.0.2 and PMP 20.2.

l PMP 450b 3 GHz

l PMP 450m AP 3 GHz

l PMP 450i AP and SM 3 GHz

l PMP 450 AP and SM 3.6 GHz

l PTP 450i BHM and BSHS 3 GHz

l PTP 450 BHM and BHS 3.6 GHz

l LTE 3 GHz cnRanger 201 SM

l LTE 3 GHz cnRanger 210 RRH

The CBRS procedure can be performed by an authorized CPI (Certified Professional Installer). CPIs are required
to enter necessary credentials to update the CBRS parameters.

A CBRS sector view is shown below:

Generate Report
The Generate Report button allows one to download multiple device reports in a .CSV format.
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Relinquish Grant
The Relinquish Grant button relinquishes all grants of selected sector and places devices in the Registered state.
The device will start the Multi-Grant procedure if the Multi-Grant feature is enabled on the device.

NOTE

l Relinquish Grant can be performed only for the Config_Synced devices running in Single
Grant.

l PMP devices should be upgraded to release 20.2, which supports the Multi-Grant feature.

Relinquish grant creates a job in Action page, when relinquish of sector is initiated from Management Tool page.

Creating a Management Tool Sector
A sector can be created by two ways:

l Add AP/BHM/RRH: Add all parameters manually of an AP/BHM/RRH.

l Import Sector: Upload a file with details from all sector devices.

Add AP/BHM

1. Navigate to Services > CBRS > Management Tools and click Add AP/BHM/RRH.

2. Enter all parameters under the following categories when the user selects the Mode as AP/BHM:

l Common Parameters: Device Name, Mode, Device Type, MAC Address, and MSN.

l Location Related Parameters: Latitude, Longitude, Height, and Height Type, Horizontal Accuracy, and
Vertical Accuracy.

l Antenna Related Parameters: External Antenna Gain, Beamwidth, Azimuth, and Down Tilt.



l Co-Existence Related Parameters: Sector ID, Spectrum Reuse ID, and Include User ID.

NOTE

l Include User ID is applicable only for PMP devices, when SAS is Federated
Wireless.

l Select Yes or No to Include user ID.

l Add CPI Certificate: Certificate File, File Password, CPIR Name.
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l Click Add to add a sector.

Add RRH

1. Navigate to Services > CBRS > Management Tools and click Add AP/BHM/RRH.



2. Enter all parameters under the following categories when the user selects the Mode as RRH:

l Common Parameters: Device Name, Mode, Device Type, MAC Address, and MSN.

l Location Related Parameters: Latitude, Longitude, Height and Height Type, Horizontal Accuracy, and
Vertical Accuracy.

l Antenna Related Parameters: External Antenna Gain, Beamwidth, Azimuth, and Down Tilt.

l ECGI Related Parameters: PLMN ID, ECI (eNode ID + PCI), and ECGI.

l Co-Existence Related Parameters: Sector ID and Spectrum Reuse ID.

l Add CPI Certificate: Certificate File, File Password, CPIR Name.

3. Click Add to add a sector.

NOTE:
Refer to CBRS Device Parameters for additional details.

Import Management Tool Sector

To import a sector:

1. Navigate to Services > CBRS > Management Tool and click Import Sector button.
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2. Click Download Template if user does not have an Import Sector template. Users can download two
different template formats:

n PMP: Excel or ODS

n LTE: Excel or ODS

3. Click Import Excel to select Import Sector template file. File must be Microsoft Excel format (.xlsx) or
OpenDocument Spreadsheet (ods) format.

4. Enter CPI credentials:

a. Upload CPI Certificate File by clicking Import Certificate.

b. Enter CPI File Password.

c. Enter CPI Registered Name.

5. Enter the Sector ID.

6. Select Spectrum Reuse ID from the drop-down.

7. Select Include User ID.

l Selecting Yes to Include User ID prefixes the User ID to the Sector ID and Spectrum Reuse ID in the
registration message of the SAS.



NOTE

l Include User ID is applicable only for PMP devices, when SAS is selected as Federated Wireless.
l See the CBRS Consolidated Procedures Guide and the Cambium PMP Release 20.3 training

slides for more details on when to select Yes or No.

8. Click Import.

Import status is displayed as Success, Info, and Invalid.

9. Details of Success, Info, and Invalid section can be seen by clicking arrow ( ).

10. If the device is already claimed, it can be onboarded by clicking the onboard link.

Management Tool Sector Statistics

To view Sector Statistics:

1. Navigate to Services > CBRS > Management Tool.

2. Click View Sector Statistics under Status.

3. Sector Statistics window pops up.

NOTE:

Refer to the Live Status Update for additional details.
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Search Management Tool Sector

To search for a sector:

1. Navigate to Services > CBRS > Management Tool.

2. Select CBSD or MAC.

l For CBSD: Search by CBSD ID.

l For MAC: Search by MAC Address.

3. Enter text in search box to display filtered records.

NOTE:

l If an AP device is entered into Search, it displays both AP devices and the related SM
devices.

l If an SM devices is entered into Search, it displays only SM devices.

4. Filter AP or sectors can be cleared by clicking or Clear button.

Sector View

1. Click a sector from the Sector AP column to get the list of devices.

2. All devices of the sector are displayed.

Sector Details View

l The Sector Details view displays the following fields by default:



n Device Name, Device Type, Mode, Health, MSN, Latitude, Longitude, Sync Expiry Time, Height,
Registered, Sync State, Actions.

NOTE:

If the device is Config_Synced, the CBSD state of the device will be updated from the
device in real-time.

l SM can be added in the sector by manually entering all parameters using Add SM button or uploading a file
containing all SM details using Import SMs button.

l Action column can edit or delete any device in the sector. Edit and Delete buttons are available depending
upon the device state. Refer to Edit device and Delete device for more details.

l To include additional fields to be displayed in the Sector Details view, select required fields in the column
selector( ).

l User can use following button to control the CBRS procedure:

n Start and Stop: manage to start and stop CBRS procedure of a sector.

n Reinitialize: restarts the CBRS procedure and reinitializes the devices.
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n Deregister: deregisters the device (single or multiple).

n Spectrum Inquiry: checks the availability of frequencies.

n Delete: deletes the device (single or multiple).

n Unblock: clears the de-registered state on an LTE, allowing a registration or reregistration request.

n Export: exports the sector data in .xlsx format.

n Import: imports the SM in the sector.

n Relinquish Grant: relinquishes grants generated in Wide-Grant mode.

l Once the sector is authorized (AUTHORIZED state), button transfers grant details from the Management

Tool to real devices.

Add SM or BHS

1. Navigate to Services > CBRS > Management Tool > select a sector.

2. Click Add SM or BHS to add SM in a sector.



3. Enter all parameters under following categories:

a. Common: Device Name, Device Type, MAC Address, and MSN.

b. Location: Latitude, Longitude, Height and Height Type, Horizontal Accuracy, and Vertical Accuracy.

c. Antenna Parameters: Integrated Antenna Gain, Beam width, Azimuth, and Down Tilt.

d. Add Certificate: Certificate File, File Password, and CPIR Name.

4. Click Add to add an SM.

Import SMs

1. Navigate to Services > CBRS > Management Tool and select a sector.

2. Click Import button to import SMs into a sector.

3. Enable the ReImport Devices to overwrite the previous imported data and deregister all existing devices.
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4. Click Download Template if user does not have Import Sector template. Users can download two different
template formats:

n PMP: Excel or ODS

n LTE: Excel or ODS

5. Click Import Excel to select Import Sector template file. File must be Microsoft Excel format (.xlsx) or Open
Document Spreadsheet (ods) formats.

6. Enter the following CPI credentials:

l Upload CPI Certificate File by clicking Import Certificate button.

l Enter CPI File Password.

l Enter CPI Registered Name.

7. Click Import.

Import status will be shown under Success, Info, and Invalid sections.

8. Details of Success, Info and Invalid can be seen by clicking .

9. If the devices is already claimed, it can be onboarded by clicking the onboard link.

10. Once the user clicks Import, a job is scheduled.



Export Sector

1. Navigate to Services > CBRS > Management Tool and then select a sector.

2. Click Export button to export the sector (export as xlsx).

3. Once the user clicks Export, a job is scheduled.

4. Once the Job status is Completed, Download the Sector xlxs.

NOTE:

Download button is enabled only for two hours after the export job completes.

5. User can use the .xlxs file for importing back into the sector. To import, save the file as shown in the below
figure.

Edit Device

1. Navigate to Services > CBRS > Management Tool and select a sector.

2. Click Stop button if the CBRS procedure is running.

3. Click Edit button to edit device parameters.

4. Enter CPI credentials:

l Upload CPI Certificate File by clicking Import Certificate button.

l Enter CPI File Password.

l Enter CPI Registered Name.

5. After editing the device. The device should go to derigestered state.
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6. Click Save.

Delete Device

1. Navigate to Services > CBRS > Management Tool and select a sector.

2. Click Stop button if the CBRS procedure is running (the CBRS procedure is running if the START procedure
described below has been invoked, and if all devices in AUTHORIZED state).

3. Deleting SM:

l Select SM to deregister if it is not in UNREGISTERED state (Refer to the Live Status Update)

4. Once the SM selected click Delete and display popup All or Selected. click Selected:

n All :deletes the complete registered SM devices.

n Selected :deletes the selected single device.

5. Click Yes to confirm.



6. Once the user clicks Yes, a job will be scheduled.

7. Deleting AP:

l All SMs of the sector must be deregistered and deleted before deleting the AP. Refer to the Deregistration
procedure to deregister all SM devices.

l Select AP of the sector to delete.

l Click Delete.

NOTE:

If the procedure is started for the device and it is registered, then, while deleting the device,
Deregister checkbox should be selected otherwise the deletion fails.

Unblock Device

1. Navigate to Services > CBRS > Management Tool and select a sector.

2. If LTE device is Config Synced, and if device deregister flag is enabled, unblock removes the deregistartion
flag on the device.

3. Once the device is selected, click Unblock and choose All or Selected from the drop-down.

n All :unblock the complete registered devices.

n Selected :unblocks the selected single device.

4. Click Selected display the Please Confirm window.

5. Click Yes to confirm the action.

Start CBRS Procedure

The Start button starts the CBRS procedure for a sector.

1. Navigate to Services > CBRS > Management Tool and select a sector.

2. Click Start to start CBRS procedure of a sector.
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3. Once the user clicks start, the Spectrum Inquiry window pops up.

Note:

l Multi-Grant is enabled by default.
l Sorted By Ranking is applicable for users selecting Google or Federated Wireless SAS.
l User can enable or disable the multigrant only if the device version is less than 21, if

device version is 21 and above only multigrant is possible.

4. User can disable the Multi-Grant feature by disabling the checkbox This feature will enable multi grant on the
tool. For more details refer Multiple Grant.

5. Click Edit to edit Co-Existence Configuration and EIRP Computation.

n Spectrum Reuse ID Statistics displays the devices running on different sector, channels, and bandwidth
based on the Spectrum Reuse ID.

6. Once the Spectrum Inquiry is verified, click Save.

The Sector is created displays as shown below:

#Multiple_Grant


NOTE:

l If the device is already synced with the Management Tool, the CBRS Start and Stop
procedures are not applicable for all the synced devices.

l If user does not see the Start button, it means the CBRS procedure is already running.

l If all devices of the sector are in AUTHORIZED or HALT status and the user tries to start
the CBRS procedure, the Start button will go to Stop state (as CBRS procedure is
completed for all devices).

Multi-Grant

Multi-Grant feature divides selected channel bandwidth into multiple of 10 MHz channels. If the selected channel
bandwidth is 5 MHz or low/high frequency contains 5 MHz raster, the slice would be in 5 MHz channel. Each
slice will initiate a separate Grant procedure.

To enable Multiple Grant for a new sector:

1. Navigate to Services > CBRS > Management Tool and select a sector.

2. Click Start to start CBRS procedure of a sector.

3. Once the user clicks Start.

The Spectrum Inquiry window pops up as shown below.
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NOTE:
l Multi-Grant is enabled by default.
l Include User ID is applicable only for PMP devices, if user selects SAS is either Federated

Wireless.

4. Click Edit to edit Co-Existence Configuration and EIRP Computation.

l Spectrum Reuse ID Statistics displays the devices running on different sector, channels, and bandwidth
based on the Spectrum Reuse ID.

5. Accept the checkbox process of the Co-Existence parameters.

NOTE:

The Federated Wireless or Google SAS might need hours to fully process the Co-Existence
parameters in the Registration, (before they are properly reflected in the Spectrum Inquiry
Response). For more details see the CBRS Standalone Procedures Guide.

6. Once the Spectrum Inquiry is verified, click Save.

A Sector created with Multiple Grants will be displayed as shown below:



To view the Grant Status click the info icon .

Relinquish Grant

Relinquish Grant relinquishes all grants of selected sector. This will make devices enter the Registered state. The
device will start Multi-Grant procedure if Multi-Grant feature is enabled on it.

To Relinquish Grant Perform as follows:

1. Navigate to Services > CBRS > Management Tool and select a sector with Single Grant.

2. Once the SM is selected, click Relinquish Grant to display All or Selected. Click Selected.

n All: relinquish all the registered devices.

n Selected: relinquish the selected device.

3. Click Yes to confirm the action.
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NOTE:

Live update information may take upto several minutes to display the changes of reflected
relinquish status.

Once the user clicks Yes, Wider Grant gets converted to the Multiple Grants as shown below:

Stop CBRS Procedure

The Stop button stops the CBRS procedure for a sector.

1. Navigate to Services > CBRS > Management Tool and select a sector.

2. Click Stop button to stop CBRS procedure.

NOTE:

l If the device is already synced with the Management Tool, the CBRS Start and Stop
procedures are not applicable to the synced devices.

l If user does not see the Stop button, it means the CBRS procedure is already in
stopped state, Start and Stop are toggles.

l If all devices of the sector are in AUTHORIZED state, the CBRS procedure will
automatically stop.

Reinitialize CBRS Procedure

The Re-init button allows the user to start the CBRS procedure for a sector and reinitialize selected devices
(Reinitialize = Start of sector + Reinitialization of user selected devices). At least one device must be selected in
order to enable the Re-init button. Clicking Re-init reinitializes selected devices to UNREGISTERED (irrespective
of previous CBRS state).

1. Navigate to Services > CBRS > Management Tool and select a sector.

2. Click Stop if the CBRS procedure is already running.



3. Select one or more devices to be reinitialized.

NOTE:

You might notice some delay in enabling Re-init button after pressing Stop. It is due to a
delay in properly stopping the CBRS procedure.

4. Click Re-init to start the reinitialization procedure

5. Confirmation window pops up:

n Click Continue or

n Select Spectrum Inquiry to edit the EIRP values as shown in Start procedure.

NOTE:

l Synced devices cannot be reinitialized.

l Reinitialize modifies or corrects the parameters. For example, if a device is in HALT
state due to a parameter error, the user can stop the CBRS procedure and reinitialize
the device after modifying device parameters.

Deregistration

The deregistration procedure allows user to deregister the devices from the SAS server .

1. Navigate to Services > CBRS > Management Tool and select a sector.

2. Click Stop button if the CBRS procedure is already running.

3. Select one or many devices which need to be deregistered.

4. Click Deregister button to deregister selected devices.

5. Once the user clicks Deregister, a job will be scheduled.

6. If deregistration fails, the reasons will be indicated under .

Spectrum Inquiry

1. Navigate to Services > CBRS > Management Tool and select a Sector.

2. Click Spectrum Inquiry button.

3. Spectrum Inquiry status button is enabled once the device is registered (REGISTERED state) to the SAS.

l If the selected SAS is not Google, EIRP is unsupported, and Spectrum Inquiry is displayed as shown
below:
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l If the users is selected SAS is Google, it supports EIRP. Spectrum Inquiry displays as below:

l GAA: General Authorized Access

l PAL: Priority Access License

Spectrum availability can be checked by hovering over frequencies.

Device Sync

The Sync procedure allows user to transfer grant information from Management Tool to respective device.

For a PMP sector, the Sync action can only be performed on an AP or BHM. The SM and BHS gets synced
automatically when it comes online.

For an LTE sector, which supports a Cambium SM with a 3rd party BBU and RRH, the sync action will sync the
Cambium SMs in this sector.

1. Navigate to Services > CBRS > Management Tool and select a sector.

2. Click Sync button to perform sync procedure.

3. Click Yes on the pop-up or click NO to cancel the sync procedure.

Once Yes is clicked, the Management Tool will check the accessibility of AP/BHM before proceeding with sync.

NOTE:

l PMP SM cannot be manually synced. It is only synced automatically.

l Once the device is synced, for both PMP and LTE devices, primary management is
transferred from the tool to the device itself. However, some actions and procedures are
still supported on the tool. See the CBRS Consolidated Procedures Guide for more
details.

l Sync procedure copies complete CBRS parameters to device and enables CBRS to
transmit with configured parameters.

https://support.cambiumnetworks.com/files/cnmaestro/


Live Status Update

Once the device is Config synced, CBRS details like CBSD ID, Grant ID, CBSD Grant State, and Last Heartbeat
Time are read from the device every 5 minutes.

It displays the possible single Grant state such as:

l Authorized

l Deregistering

l Grant

l Grant Suspended

l Grant Terminate

l Registered

l Registering

l Relinquished Spectrum

l Relinquishing Spectrum

l Unregistered

l Unknown

Domain Proxy View
In Domain Proxy view, Sectors and Non-Sector page helps check CBRS-complaint devices connected through
this server and On-Premises server using the token ID of this server. This page displays all the devices
connected to CBRS.

l Sectors Page: displays the devices according to the parenting AP list.

l Non-Sector Page: displays each individual AP and SM of LTE and PMP.

Searching a Domain Proxy Sector
To search a sector:

1. Navigate to Services > CBRS > Domain Proxy View > Sector page.

2. Select search option CBSD or MAC.

l For CBSD: Search by CBSD ID

l For MAC: Search by MAC ID.
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3. Enter text in search box.

NOTE:

l If AP device is entered , it displays the both AP devices and the related SM device in
the search result.

l If SM devices is entered , it displays only the SM devices in the search result.

4. Filtered device can be cleared by clicking Clear button.

Domain Proxy Sector view
1. Click a Sector from Sector AP column to get the list of devices.

2. All the devices of the sector will be displayed.

3. CBSD state shows current status of device and whether it is registered or deregistered with SAS.

4. User can use the click Deregister button to Deregister the device from CBRS.

5. The Sectors view displays the following columns by default:

Device Name, Device Name, Mode, Health, MSN, Latitude, Longitude, Height, Status, and Actions.

NOTE:

User can select the additional columns by clicking on top bar Column Chooser to include
additional fields.

Searching a Domain Proxy Non Sector View
To search for a Non sector:

1. Navigate to Services > CBRS > Domain Proxy View > Non Sector page.

2. Select search option CBSD or MAC.

l For CBSD: search by CBSD ID

l For MAC: search by MAC ID.



CBRS State Diagram

NOTE:

GRANT_SUSPENDED is a temporary suspend state where HEARTBEAT message will be
sent for an extended period of time prior to getting AUTHORIZED.

The CBRS procedure has the following states:
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CBRS Device Parameters

Category Parameter Details

Common

Channel
BandWidth (MHz)

Channel Bandwidth of AP or BHM in MHz.

Center Frequency
(MHz)

Center frequency of AP or BHM in MHz.

Device Name Name given to device on SAS Admin (max 120
characters. It does not get copied to the device
via sync.

Device Type Drop-down selection of supported devices types.

MAC Address MAC address of the device.

MSN Serial number of device.

User ID Unique identifier is assigned by the SAS. The User
ID is part of the registration request message. The
wrong User ID leads to REGISTRATION_FAILED.

Location

Height Device antenna height in meters.

Height Type Should be AGL or AMSL as follows:

l AGL height is measured relative to the ground
level.

l AMSL height is measured relative to the mean
sea level.

Horizontal
Accuracy

A positive number in meters to indicate the
accuracy of the device antenna horizontal
location.

Latitude Latitude of the device antenna location in
degrees.

Longitude Longitude of the CBSD antenna location in
degrees.

Vertical Accuracy A positive number in meters to indicate the
accuracy of the device antenna vertical location.

Co-Existence
Related
Parameters

Sector ID The default AP MAC address (allows editing the
default MAC).

Spectrum Reuse ID  The Spectrum Reuse ID defined in the network.

Include User ID Prefixes the User ID to the Sector ID and
Spectrum reuse ID.



Category Parameter Details

ECGI Related
Parameters

PLMN ID Public and Mobile Network Identifier.

ECI E-UTRAN Cell Identifier. It is a length of 28 bits
and contains the eNodeB-ID.

ECGI Enter the both PLMN ID and ECI parameters and
it displays in the ECGI field.

Antenna
Parameters

Azimuth (degrees) Boresight direction of the horizontal plane of the
antenna in degrees with respect to True North.

Beamwidth
(degree)

3-dB antenna beam width of the antenna in the
horizontal-plane in degrees.

Downtilt (degrees) Antenna downtilt in degrees.

External Antenna
Gain (dBi)

Peak gain of external antenna connected to
device in dBi.

Integrated Antenna
Gain (dBi)

Peak gain of integrated antenna in dBi.

Add
Certificate

Certificate File CPI (Certified Professional Installer) certificate.

CPIR Name CPI registered name.

File Password CPI private password.

Actions for Existing CBRS On-Premises Users
Current CBRS On-Premises customers maintain their CBRS billing and SAS configuration in an NMS Account.
This must be updated to support Anchor accounts. To create an anchor account, refer to Manage Instances.

If an action is required for existing Cloud NMS users, the UI will display the following notification:

After clicking the notice, navigate to Services.

l Link an Anchor Account to this Account: Select if managing CBRS devices in both Cloud and On-Premises. It
creates an Organization that shares configuration between a Primary NMS account and a Secondary Anchor
account (without deregistering existing CBRS devices).

l Convert this Account to Anchor Account: Select only if managing devices On-Premises and NMS do not
have any devices. It converts the existing NMS Account to an Anchor Account.
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Link an Anchor Account to this Account
Select this to manage CBRS devices in both Cloud and On-Premises. An Anchor account must be created to
manage the CBRS On-Premises devices without deregistration.

NOTE:

Cambium recommends selecting this option when the user is managing devices in both
cnMaestro Cloud and On-Premises.

Before linking an Anchor account, please do the following:

l Ensure the cnMaestro Anchor account is linked to the cnMaestro On-Premises instance(s).

l Add the Anchor account as a Secondary account to Primary NMS account. Refer to Create Organization.

To convert the existing account:

1. Navigate to Services > CBRS > Account page.

2. Select Anchor Account from the drop-down list.

NOTE:

Users are allowed to select only one Anchor account from the drop-down list.



3. Enable I authorize Cambium Networks to make changes to the selected account.

4. Click Request Support and a Success window pops up.

NOTE:

The Cambium Support team validates the request and creates an Organization from the
NMS and Anchor accounts within 24 hours. Alternately, you can create the Organization
yourself using the directions specified earlier in this document.

Convert this Account to Anchor Account
Select this to manage CBRS devices in On-Premises only. It converts an existing NMS account to an Anchor
account.

NOTE:

Cambium recommends selecting this option when the user only plans to manage devices
using cnMaestro On-Premises. Cloud account devices must be deregisted and deleted from
the NMS account and registered back to On-Premises before the conversion.

To convert the existing account:

1. Navigate to Services > CBRS > Account page.

2. Select Convert this Account to Anchor Account.

NOTE:

l Deregister and remove all devices from the NMS account before the conversion.

l All NMS configuration will be lost when the account is converted to Anchor, including:

n Guest Access Portal

n Templates

n Performance Graph Data, etc.

l The process of converting an NMS account to an Anchor account cannot be reversed.

3. Enable I authorize Cambium Networks to make changes to the selected account.

4. Click Request Support and a Success window pops up.
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NOTE:

The Cambium Support team validates the request and create an Organization from the NMS
and Anchor accounts within 24 hours.

Organizations for CBRS

An Organization allows multiple accounts to share CBRS billing and SAS ID. The Primary Account owns this
configuration, and the Secondary Account can optionally share it. Both accounts must authorize the sharing.

NOTE:

l There is only one Primary Account in an Organization.

l CBRS configuration can be set in the Primary Account and optionally shared to
Secondary Accounts.

This chapter provides the following information:

l Create an Organization

l Remove Accounts

l Disable Secondary Account Services

l Edit Services

l Share CBRS Configuration with the On-Premises Instance

l Organization History

Create an Organization

Primary Account
Perform the following steps on the Primary Account:

1. Navigate to Network Services > Organization > Accounts.

2. Click Add Secondary Account.

n Navigate to the planned Secondary Account and copy the Account ID of the Secondary Account using
the Copy to Clipboard.



3. Paste the copied Account ID in the Secondary Account ID text box.

4. Once the Secondary Account is validated, the Cambium ID is displayed as shown below.

5. The Primary Account can offer services such as:

l Shared SAS ID: This allows the Secondary Account to use the CBRS SAS ID configured in the Primary
Account.

l Unified Payments: This allows the Secondary Account to use payment details configured in the Primary
Account.

NOTE:

Sharing the SAS ID automatically enables Unified Payments.

6. Enable the Services Shared SAS ID or Unified Payments.

7. Click Add. It displays the Success message as shown below:
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NOTE:

The Secondary Account administrator must approve this request from
the Primary Account to join the Organization.

8. In the Secondary Accounts table, the Approval Status is displayed as Waiting for approval.

Secondary Account
Login to the Secondary Account to complete Organization creation. The Secondary Account must approve the
request and authorize the shared services. The Secondary Account can also request additional services (which
must be approved by the Primary Account).

Perform the following steps in the Secondary Account:

1. Navigate to Network Services > Organization > Accounts.

2. Click Approve.

3. The Approve Services window pops up. Review the services requested and click Approve.



Additional service requests from the Secondary Account
Additional services can be added after the Secondary Account joins the Organization, such as including the
Unified Payments Service.

Perform the following steps on the Secondary Account:

1. Navigate to Network Services > Unified Payments and click Enable.

NOTE:

This generates a request to the Primary Account to provide support for
Unified Payments.
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2. Once the services are enabled and approved in the Primary Account, the following displays in the Secondary
Account.



3. The enabled services will be displayed in the Primary Account.

Removing Accounts

Remove through Primary Account
Perform the following steps on the Primary Account to remove the Secondary Account:

1. Navigate to Network Services > Organization > Accounts.

2. In the Secondary Accounts, click Delete ( ) icon.
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3. The Remove From Organization window pop up.

4. Enter the Reason.

5. Click Proceed.

Without Active Services

n If services such as Shared SAS ID or Unified Payments are inactive in the Secondary Account, it can be
deleted without any approval.

n The following message displays if successful.

With Active Services

n If services such as Shared SAS ID or Unified Payments are active in the Secondary Account, the
services need to be disabled from the Secondary Account, and the request must be approved by the
Secondary Account administrator.

NOTE:

l User needs to disable the active services such as Shared SAS ID and Unified
Payments before removing the Secondary Account, or an Error message is
shown.

l Shared SAS ID can be removed by contacting Cambium support to deactivate
the current CBRS account to stop using Shared SAS ID.

l Active Services will be highlighted in Green color.

n The following message displays if successful.

#DisablingServicesSharedSASID
#Disabling_Services_(With_Active_Unified_Payments_Services)
#Disabling_Services_(With_Active_Unified_Payments_Services)


n In the Secondary Accounts table, the UI displays the Approval Status as Delete Pending.

The Secondary Account administrator must approve the remove request from the Primary
Account. For more details, refer to Approve Remove Request (with active services).

Remove Organization from Secondary Account
Perform the following steps on the Secondary Account to remove an Organization:

1. Navigate to Network Services > Organization > Accounts.

a. Click Remove From Organization (without active services).

n To remove the Secondary Account from an Organization with no active services.

n Click Yes in Please confirm window to remove this account.

b. Approve Remove Request (with active services).
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NOTE:

Disable active services before Approve Remove Request.

n If the Secondary Account is using services such as Shared SAS ID or Unified Payments, the following
message displays.

n Click Yes in Please confirm window to approve the request.



2. The following message displays if successful.

Disable Secondary Account services
With no active services
The Secondary Account user can disable services without leaving the Organization.

1. Navigate to Services > Organization > Accounts and select Services.

2. Click Disable.

3. Click Yes in the Please confirm window.
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4. After disabling, the following displays.

5. Click Enable to reactivate the services.

With active shared SAS ID services

NOTE:

Active Services are highlighted in Green color.

The Secondary Account user can disable the Shared SAS ID services.

1. Navigate to Services > Organization > Accounts and select Services.



2. Click Disable in the Shared SAS ID.

3. Click Yes in the Please confirm window.

4. If CBRS account is active in Secondary Account, while disabling it displays the following error message.
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If an Error message pops up, the user needs to raise a request to Cambium Support for the SAS vendor
cancellation. Cambium Support will disable the CBRS services and deregister all devices associated to the
Secondary Account.

Once disabled, the Secondary Account user can view the SAS vendor page and create a new CBRS account as
shown below.

For further information on creating a new CBRS account, refer to CBRS.

NOTE:

Services in the Secondary Account cannot be disabled unless CBRS is inactive in Secondary
Account. Contact Cambium Support to disable CBRS operation or change SAS Vendor.

With active Unified Payments
The Secondary Account user can disable Unified Payments.

1. Navigate to Services > Organization > Accounts and select Services.



2. Click Disable within Unified Payments.

3. Click Yes in Please confirm window.

4. If Unified Payments is active in CBRS of the Secondary Account, it displays an Error message.

If this happens, the user needs to add new CBRS payment details into the Secondary Account.

882 | Organizations for CBRS Cambium cnMaestro Cloud 5.0.1 | User Guide



883 | Organizations for CBRS Cambium cnMaestro Cloud 5.0.1 | User Guide

For further information on Payment details, refer to CBRS.

The user can disable the Unified Payments once the new payment details are added successfully to the
Secondary Account.

Edit Services
Enable services in the Primary Account
The Primary Account can edit or disable services shared with the Secondary Account as shown below:

NOTE:

When the services are active in CBRS of the Secondary Account, the
Primary Account cannot disable those services.

1. Navigate to Accounts > Secondary Accounts tab.

2. Click Edit ( ) icon.

3. Edit Secondary Account window pops up.

4. Disable the Services and click Update.



5. The following message displays if successful.

Request services from Secondary Account
If the services are disabled, the Secondary Account needs to make a request to the Primary Account to activate
them.

To request activation, perform the following on the Secondary Account:

1. Navigate to Network Services > Organization > Accounts.

2. Click Request.

3. Click Yes in Please confirm window.
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4. It displays the Success message as shown below:

5. Once requested, login to the Primary Account page and Approve the request.

The Primary Account administrator must approve this request from the Secondary Account in order to enable
the services.

Review service request in Primary Account
Perform the following steps on the Primary Account.

1. Navigate to Services > Secondary Accounts tab.

2. Click Review in Pending Service Request.

3. The Review window pops up. Click Approve.

4. Once approved, the requested services are enabled in the Secondary Account.



Share CBRS Configuration with the On-Premises Instance

NOTE:

Starting with version 3.0.3, cnMaestro supports synchronizing CBRS Configuration to On-
Premises instance.

Once On-Premises is connected to the Anchor Account, the user can synchronize CBRS details (SAS ID, Token)
to the cnMaestro On-Premises instance to register CBRS devices.

n If the user shares (sync) CBRS details configured on Anchor account to connected On-Premises and if
any devices are registered in On-Premises with different CBRS token or SAS ID it displays the deregister
error as shown below.

886 | Organizations for CBRS Cambium cnMaestro Cloud 5.0.1 | User Guide



887 | LTE Cambium cnMaestro Cloud 5.0.1 | User Guide

Organization History
In Organization History user can view changes to the Organization status over time. This includes details of
Primary Account, Secondary Account, Action, Performed by, and Reason.

To view Organization History:

Navigate to Network Services > Organization > History tab.

LTE

cnMaestro supports LTE as part of its cnMaestro deployment. LTE allows customers to onboard the SM with
IMSI into cnMaestro.

System access in cnRanger is dependent on installation of SIM credentials on every BBU in the operator
network. To ease the operations aspects of SIM card management, cnMaestro provides utilities for claiming,
managing, and distributing Cambium Networks cnRanger SIM card credentials (3rd party SIM cards are not
currently supported on cnRanger).

Adding SIM Cards
To add a SIM card, complete the following steps:

1. Navigate to Services > LTE.

2. Click ADD. The following window appears.



3. Enter proper Serial Number of SIM package and click Validate then Add.

NOTE:

User can download the .CSV file from the Cloud account once the Serial Number is validated
from the cnMaestro Cloud data base.

Delete SIM Cards
To delete a SIM card from the list, click Delete. The following window appears.

Note:

IMSI numbers get deleted with the mapped Serial Number.

Viewing BBU SIM Status
Allows the users to view the status of the SIM connected to the BBU:

1. Navigate to Services > LTE.

2. Click View BBU SIM Status.

888 | LTE Cambium cnMaestro Cloud 5.0.1 | User Guide



889 | Managing Edge Controller Cambium cnMaestro Cloud 5.0.1 | User Guide

Managing Edge Controller

This chapter provides the details about how Edge Controllers are configured to discover PTP 820/850 devices
in a network using SNMP protocol. To view the onboarded Edge Controllers in cnMaestro, perform the following
steps:

1. Navigate to Network Services > Edge Controller.

A list of onboarded Edge Controllers in a table format is displayed, as shown in Figure 405.

Figure 405 Edge Controllers

The following parameters are available to view in a table format: Name, IP Address, Status, Managed Account,
Version, Duration, and Topology Sync Status. You can perform the following actions in the Edge Controller
page.

l Topology Sync

l Edit

l Delete

Select the required Edge Controller name in the page, to perform the following actions:

Topology Sync
Click on the TopologySync ( ) icon to run topology synchronization for the required Edge Controller.

Edit
1. Click the edit ( ) icon in the Edge Controller page.

The Edit name window appears, edit the name of the Edge Controller.

2. Click Save.

Delete
1. Click the delete ( ) icon in the Edge Controller page.

The delete confirmation window appears.



2. Click Yes.

In the Edge Controller page, you can navigate to the following tabs:

l Dashboard

l Configuration

l Tools

l Monitoring

To view the Edge Controller dashboard, click on the name of the Edge Controller. The Edge Controller
dashboard page appears as shown in Figure 406.

Figure 406 The Edge Controller dashboard

Dashboard
The dashboard page displays status of managed and unmanaged PTP 820/850 devices, details of Edge
Controller, disk space availability, and network details of Edge Controller as shown in Table 124.

Figure 407 Edge Controller and PTP 820/850 devices status
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Field Description

Host name Name of the host.

Virtualization Type of virtualization such as VMware or Oracle.

Distribution Type of distribution such as Ubuntu and CentOS versions.

Architecture CPU and Operating System installed.

Number of CPUs Total number of CPUs utilized.

CPU Model Type of CPU model.

Memory Available memory.

Timezone Current timezone.

Date & Time Current date and time.

System Clock Sync Configuration of System Clock Synchronization.

Disk Current Disk space usage.

Status Status of Network Interface Online or Offline.

Name Name of the Network Interface.

IPv4 Address Configured IPv4 Address.

IPv4 Gateway Configured IPv4 Gateway.

IPv6 Address Configured IPv6 Address.

IPv6 Gateway Configured IPv6 Gateway.

MTU Maximum Transmission Unit of network interface of Edge Controller.

License Failures Displays MAC, IP Address, and Reason. The reasons for license failure are as
follows:

When the discovery exceeds the slot availability.

When the individual devices are already onboarded in other Cloud account.

Topology Sync Status of Topology Sync.

Version Software version of the device.

Table 124: Fields in the Edge Controller dashboard

Configuration
In the Configuration page, you need to configure SNMP rules to discover and onboard PTP 820/850 devices.
The SNMP tab in the Configuration page displays Configuration Status. TheConfiguration Status displays when



the Edge Controller is In Sync or Not Sync with cnMaestro. The synchronization status is shown in days, hours
and minutes. Next discovery and Previous discovery ran is displayed in minutes as shown in Figure 408.

Figure 408 Configuration Status

Rules
To add a new rule, perform the following steps:

1. Click Add New.

The Add New Network Discovery Rule window appears.

2. Type Subnet range in CIDR format (for example, 10.204.88.0/28) to discover PTP 820/850 devices.

The range of IP addresses in the Network Address Range field is displayed.

3. Type Port number.

4. Choose SNMP Version:

For SNMP Version v2, perform the following:
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a. Enter preferred community string when you create a SNMP discovery rule.

b. Click Add.

NOTE:

Default community string is private.

For SNMP Version v3, perform the following:

a. Choosing SNMP v3 version allows you to enter the parameters as shown in the following figure.

b. Enter the following fields:

l Username.

l Context Name field is optional.

c. Choose any one of the Authentication Protocol.

l None

l SHA

l MD5

d. Choose any one of the Privacy Protocol.

l None

l AES128

l DES

e. Type Privacy Password.

f. Click Add.



SNMP Rules added are listed in the Rules table as shown in the following figure.

5. Click Rerun Discovery to start SNMP discovery for the rules added in the table or select specific
Subnet/Range in the table and manually run Rerun Discovery ( ) icon.

Import
To import SNMP rules, perform the following steps:

1. Click Import.

Import window appears.

2. Browse to Select File or Download Sample Template to change or configure the SNMP as per the
requirements in Downloaded Sample Template.

3. Click Import.

Export
To export SNMP rules, perform the following steps:

1. Select one or more SNMP rules required to export.

2. Click Export.

3. It exports .csv file format as shown in the following figure.

NOTE:

By default all SNMP rules are exported, if none of the rules are selected from the table.
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Delete
To delete SNMP rules in the table, perform the following steps:

1. Select one or more SNMP rules in the table.

2. Click Delete, to delete one or more entries in the table or click Delete ( ) icon to delete specific rule in the

table.

Edit
To edit SNMP rule in the table, perform the following steps:

1. Click Edit ( ) icon to edit SNMP rule.

Edit Network Discovery Rule window appears. Edit the required field values.

2. Click Save.

Blacklist
To blacklist PTP 820/850 devices, perform the following steps:

1. Click Add New.

Add Blacklist IP Address window appears.

2. Type IP Address.

3. Click Save.



Blacklisted IP Addresses are displayed in the table.

4. Select one or more blacklisted IP addresses in the table.

5. Click Delete, to delete one or more entries in the table or click Delete ( ) icon to delete specific blacklist

entry in the table.

Advanced Settings
In Advanced Settings section, configure the following parameters:

NOTE:

l By default, Auto Discovery option is disabled.

l By default, Auto Discovery Interval option is 24 hours, when enabled and fields are auto-
filled.

Enable Auto Discovery if you want to run SNMP discovery rules manually and perform the following steps:

1. Select Auto Discovery Interval option from the drop-down.

2. Enter Timeout in seconds between 5 to 60 seconds.

3. Enter Retries values between 0 and 3.

4. Click Save.

Tools
The Tools page allows you to perform the following actions:

l Diagnostics

l Operations

l Services
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Diagnostics
Diagnostics page allows you to gather technical support dump which can be downloaded and sent to Cambium
Networks support team.

Technical Support Dump
The Technical Support Dump gathers important runtime and configuration information from the Edge
Controller. It can be sent to Cambium Support to aid in resolving issues.

1. Navigate to Edge Controller > Tools > Diagnostics.

2. Click Download under Technical Support Dump.

Figure 409 Diagnostics

Logging Severity
The Logging Severity level of Edge Controller diagnose issues on the running system. The logging severity
should be set to the default (Information) and it should only be changed under guidance of the technical
support team.

1. Navigate to Edge Controller > Tools > Diagnostics.

2. In Logging Severity section, select one of the log level from Log level drop-down.

l Error

l Information

l Debug



3. Click Save.

4. Click Reset to revert to the previous Log level option.

Service Logs
The Service Logs allows you to diagnose any issues in the services running in the Edge Controller.

1. Select Service and Duration from the drop-down.

The following list of service and duration (5 minutes, 15 minutes, 30 minutes and last 1 hour) are available from
the drop-down:

l Edge Agent

l Device SNMP

l Core Metadata

l Core Command

l RabbitMQ

l MariaDB

l SFTP

2. Click Show Logs.

The output for the selected criteria appears as shown:

3. Click download ( ) icon to download the generated output.

4. Click clear ( ) icon to clear the output.

Operations
In the Operations page, you can view the current software version of the Edge Controller. You can also view
history of the last five software updates.

1. Navigate to Tools > Operations.

2. Click Check for new software update, checks for any new available software update.
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Services
In Services page you can view the services running in the Edge Controller.

Figure 410 Services



Monitoring
In the Monitor page, you can view details of CPU utilization, CPU Load, Process Activity, Memory Usage, Swap
Usage, and File System.

cnArcher Installation Summary

cnArcher is a mobile application used to install PMP Subscriber Modules (SMs), ePMP (SMs), and cnRanger SMs.
The installation summary provides an overview of the data collected by cnArcher during the installation
process.

NOTE

l cnArcher Installation Summary is a cnMaestro X feature.

l cnArcher Installation summary of PMP SM is available for users in cnMaestro Cloud and
OnPremises from 3.1.0 release.

l cnArcher Installation summary of ePMP SM is available for users in cnMaestro Cloud and
OnPremises from 3.1.1 release.

l ePMP PTP 550 (two radio devices) and ePMP Elevate are not supported for cnArcher
Installation Summary.

To view the installation summary:

1. Navigate to Network Services > cnArcher Installation Summary.

The cnArcher Installation Summary page appears.

2. You can Search cnArcher Summary details by using MAC Address, Name at Installation, Date and Time,
Added By, and Comments.
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Field Description

MAC Address MAC address of the device.

Name at Installation Name given to the device when installed.

Date and Time Date and time of installation.

Installation Duration Duration of installation.

Added By Name of the user adding the device.

Comments Comments about the installation.

State Current state of the device such as Managed or Deleted.

Table 125: Fields in cnArcher Installation Summary

3. Click View Details icon to view detailed Installation Summary.



Field Description

SM Name Name of the device.

MAC Address MAC address of SM.

MSN Serial number of device.

Table 126: Summary fields in cnArcher Installation
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Field Description

Product Device model and type.

Software Version Software version of device.

RSSI Receiver Signal Strength Indicator (RSSI) of SM.

SSR Signal Strength Ratio (SSR).

External Antenna Peak gain of external antenna connected to the device.

Start Timestamp Start time of the summary.

End Timestamp End time of the summary.

Added By Name of the user adding the device.

Comment Comments about the installation process.

Table 126: Summary fields in cnArcher Installation

Configuration

IP Address/Setting IP settings such as for DHCP or Static IP allocation.

Subnet Subnet mask of the device.

Gateway IP address of the gateway.

DNS Name of the DNS server.

Management VLAN Configured Management VLAN.

Data VLAN Configured Data VLAN.

Security Security settings.

PSK Type of PSK (Pre-Shared Key): WPA or WPA2.

Status Current SM state such as Onboarded or Already Onboarded.

Software Update Software version provided to upgrade.

Template Name of the configuration template to apply.

Onboarding Details Onboarding details related to SM.

Field Description

Table 127: Configuration fields in cnArcher Installation



Photos and Location
Photos and Location displays the photos taken during installation. You can view a maximum of four photos at a
time.

Link Test Result
Link Test Result displays the link related test results with respect to throughput.

Field Description

Time Time at which the link test was performed.

Mode Modes such as Extrapolated Link Test or Link Test with Bridging.

Throughput Uplink/Downlink Uplink and Downlink Throughput.

Modulation Uplink/Downlink Uplink and Downlink Modulation.

Table 128: Link Test Results fields

AP Scan Result
AP Scan Result displays a list of scanned APs.

Field Description

AP MAC MAC address of the AP.

AP Bandwidth Bandwidth of the AP.

AP Frequency Frequency of the AP.

Registered Details of the registered SM.

Table 129: Fields in AP Scan Result

4. Click Delete icon to delete single or multiple entries from the cnArcher Installation Summary page.

5. Click Yes to proceed to delete.

6. A confirmation message is displayed on a successful delete.
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NOTE

cnArcher uploads Installation Summary with cnMaestro when Internet connection is
available to users mobile device. This feature is support only in Android.

Spectrum Analyzer X

The Spectrum Analyzer feature monitors and analyzes wireless spectrum for PMP AP and SM devices, allowing
users to optimize network performance.

NOTE

l The Spectrum Analyzer is a cnMaestro X feature.

l Spectrum Analysis is supported on devices running PMP software version 22.1.0 and
above.

l Spectrum Analyzer feature is available for users in cnMaestro Cloud and On-Premises.

To view Spectrum Analyzer page:

1. Navigate to Network Services > Spectrum Analyzer.

2. You can view the Spectrum Analyzer details by using Name, Status, Type, Sector Count, Start Time, and
End Time.

Field Description

Name The user-defined name for the spectrum analysis job or scan.

Status The current status of the spectrum analysis.

Type The type of analysis performed (for example, Now, Weekly).

Sector Count The number of sectors or wireless areas analyzed in the spectrum scan.

Start Time The scheduled start time for the spectrum analysis job.

End Time The scheduled end time for the spectrum analysis job.

Table 130: Fields in Spectrum Analyzer



3. Click View Result icon on top right corner to view the detailed Spectrum Analyzer summary.

Field Description

Name The user-assigned name for the analysis job.

Tower Count The number of towers included in the analysis.

AP Count The number of APs in the analysis.

SM Count The number of SMs in the analysis.

Bands The frequency bands under analysis.

Scanning Bandwidth The width of the frequency band being scanned.

Duration The duration of the analysis job.

Scan Range The spectrum range analyzed.

Scan Status The current status of the analysis job.

Schedule The scheduling details for the analysis job.

Table 131: Job Summary parameters

Field Description

Date and Time The specific date and time when the spectrum analysis is conducted.

Bands The frequency bands included in the analysis.

View Options The viewing options for analyzing the spectrum.

Table 132: Filters parameters

906 | Spectrum Analyzer X Cambium cnMaestro Cloud 5.0.1 | User Guide



907 | Spectrum Analyzer X Cambium cnMaestro Cloud 5.0.1 | User Guide

Field Description

l Uplink (AP)

l Downlink (SM)

l Downlink (Average SM)

l Unavailable Channels

Data Path The data path used for the analysis.

l Combined: Combines data from Path A and Path B for analysis.

l Average: Calculates the average and maximum values for the analysis
data.

Table 132: Filters parameters

4. Scan Result displays the scanning result graph.

5. To view the last scan results at the device level:

a. Navigate to PMP device Dashboard > Spectrum Analyzer Last Scan.

b. The dashboard automatically generates the appropriate graph for AP and SM based on the device
type.

c. The default data path for displayed graphs is Combined, and users can customize it to their
preferences.

d. The dashboard displays Noise Floor, which provides noise floor information for both Path A and



Path B. These two graphs are displayed for both AP and SM that are part of the scan.

6. Unmapped APs display any APs that are not assigned to a tower.

7. Click Delete icon on the top right corner to delete a job.

To set Alarm Threshold:

1. Navigate to Network Services > Spectrum Analyzer.

2. Click on the Set Alarm Threshold on the top right corner of the Spectrum Analyzer page.
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3. Users can set band-specific alarms by configuring threshold values and alarm triggers for specific
frequency bands (for example, 5 GHz, 3 GHz, 2.4 GHz, and 900 MHz).

4. These alarms are applied globally to all PMP devices operating in the same frequency band.

5. After configuration, the alarms are displayed on the alarm page, enabling easy monitoring and timely
responses to network issues.

6. User can override alarm threshold for AP at the device level:

a. Navigate to Dashboard > Override Alarm Threshold.

b. Before overriding, users can review the global alarm threshold values that apply to the entire
network.

c. Choose the specific AP device for which you want to set custom alarm thresholds.

d. Configure and set individual threshold values for the selected device, overriding the global
thresholds only for that specific device.

To create a new job:

1. Navigate to Network Services > Spectrum Analyzer.

2. Click on Add New on the top right corner of the Spectrum Analyzer page.



Field Description

Name Job name to distinguish the analysis job within the Spectrum Analyzer.

Schedule Scheduling options, including:

l Now: Immediate execution of the spectrum analysis.
l Daily: Set up a daily schedule for the analysis job.
l Weekly: Configure a weekly schedule for the analysis job.
l Monthly: Create a monthly schedule for the analysis job.

Scan Range The desired scan range from a drop-down with two options:

l Full Scan: Perform a comprehensive analysis of the entire spectrum.
l Custom Scan: Set the Min Frequency and Max Frequency to precisely

choose the frequency range for a more accurate spectrum analysis.

Scanning Bandwidth The specific scanning bandwidth from the available options to adjust the
spectrum analysis.

Note: Scanning Bandwidth is not applicable for PMP 450m AP.

Duration The analysis duration in seconds, ranging from 10 to 1000 seconds.

Table 133: Add Spectrum Scan parameters

4. After creating the job, it appears on the home page with a Scheduled status.
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Administration
This section includes the following topics:

l Managing Users

l Cloud Anchor Account

l Settings

l Audit Logs

Users

This chapter provides the following details:

l Managing Users

l Session Management

Managing Users
cnMaestro allows you to add Users using the Administration > Users page.

NOTE:

l cnMaestro X account supports up to 200 users.

l cnMaestro Essentials account supports only up to 10 users.

Figure 411 Adding Users

Role-Based Access
cnMaestro supports the following user Roles:

l Super Administrator – Super Administrators can perform all operations.

l Administrator – Administrators can modify cnMaestro application functionality, but they are not able to edit
User, API, or Server configuration.

l Operator – Operators are able to configure device-specific parameters and view all configuration.

l Monitor - Monitors have only the view access.

l CPI - CPI can perform on-boarding the devices using the CBRS tool and has the view access only.
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NOTE:

l cnMaestro allows one to limit the number of concurrent sessions for each Role and
display current active user sessions.

l CPI role is authorized only when the CBRS is Enabled.

Role-Mappings
The table below defines how Roles are authorized to access specific features.

Feature Description

Application Operations Application level operations such as to create, update and delete
operations for Networks, Towers/Sites. Bulk device configuration.

l Super Administrator - All

l Administrator - All

l Operator - None

l Monitor - None

l CPI - None

Application Settings Change global application configuration and onboarding key.

l Super Administrator - All

l Administrator - All

l Operator - None

l Monitor - None

l CPI - None

Configuration/Software Update Manage configuration/software update jobs.

l Super Administrator - All

l Administrator - All

l Operator - All

l Monitor - None

l CPI - None

Device Operations Device operations such as reboot device, link test, connectivity test,
tech support file download, and Wi-Fi performance test.

l Super Administrator - All

l Administrator - All

l Operator - All

l Monitor - None

l CPI - None

Device Overrides Per-device configuration, including updating AP Group and applying
configuration.

l Super Administrator - All

Table 134: Role-Mappings



Feature Description

l Administrator - All

l Operator - All

l Monitor - None

l CPI - None

Floor Plan Floor Plan configuration

l Super Administrator - All

l Administrator - All

l Operator - View

l Monitor - View

l CPI - None

Global Configuration The ability to create and apply configuration for global features such
as Templates, WLANs, AP Groups, and bulk sync configuration.

l Super Administrator - All

l Administrator - All

l Operator -View

l Monitor - None

l CPI - None

Guest Portal Guest Portal configuration.

l Super Administrator - All

l Administrator - All

l Operator -View

l Monitor - View (Sessions Only)

l CPI - None

Monitoring Display of monitoring data at all levels.

l Super Administrator - All

l Administrator - All

l Operator - All

l Monitor - View

l CPI - View

Notifications Alarms and Events management.

l Super Administrator - All

l Administrator - All

l Operator - All

l Monitor - View

l CPI - View

Table 134: Role-Mappings

913 | Users Cambium cnMaestro Cloud 5.0.1 | User Guide



914 | Users Cambium cnMaestro Cloud 5.0.1 | User Guide

Feature Description

Onboarding Device approval, modifying individual device configuration, and
performing software update.

l Super Administrator - All

l Administrator - All

l Operator - All

l Monitor - None

l CPI - All

Reporting Report generation.

l Super Administrator - All

l Administrator - All

l Operator - All

l Monitor - All

l CPI - All

Session Management Capability to view and logout other users sessions.

l Super Administrator - All

l Administrator - All

l Operator - None

l Monitor - None

l CPI - None

Software Upgrade Upgrade the device with the latest software.

l Super Administrator - All

l Administrator - All

l Operator - All

l Monitor - None

l CPI - None

User Management User management operations such as manage users and roles.

l Super Administrator - All

l Administrator - View

l Operator - None

l Monitor - None

l CPI - None

Table 134: Role-Mappings

Creating Users and Configuring User Roles
To add an administrator:

1. Navigate to Administration > Users page.

2. Click Add User button. The following window is displayed:



3. Enter the ID in the Email textbox.

4. To configure the User Role, select any one of the role for the user from the Role drop-down list:

l Super Administrator

l Administrator

l Operator

l Monitor

l CPI

5. Click Send button to add this user.

To edit or delete a user, click the Edit icon or the Delete icon against the user in the Administration > Users
page.

Whitelisting specific domains
Using the Administration > Users page, you can allow (or whitelist) a specific domain (for example, gmail.com).
When users from the whitelisted (or allowed) domain are added, an invite email is sent directly to them. When
the users accept the invite, they are allowed to access a particular cnMaestro UI account.

You can also blacklist or disallow a specific domain to prohibit all users of that domain from accessing the UI
account.

NOTE:

l Domain whitelisting is not applicable to NFR User accounts.

l For users from the whitelisted domains, you can create the MSP user account.

To whitelist or blacklist a specific domain, perform the following steps:

1. Navigate to Administration > Users page.

The Manage Users page appears.
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2. To add a new domain (for example, a gmail ID ), click on the Add User button.

The Add User window appears. You must set the fields, as described in the Creating Users and Configuring User
Roles section. The Add User window also displays that the email ID used is a new domain, as shown in the
following example (in this case, gmail.com is the new domain):

3. Select the Allow users in "gmail.com" domain check box (the domain name varies based on the email ID you
add).

The new domain is added to the database.

When users who belong to this allowed domain (for example, gmail.com) are added (using the Add User
button), an invite email is directly sent to the users. When the users accept the invite, they can access a
particular cnMaestro UI account. The Allow users in "gmailail.com" domain check box is available only when you
are adding a new domain.

when you are adding users from that allowed domain.

4. To blacklist or disallow a specific domain, click on the Allowed Domains button on the Manage Users page.

The Allowed Domain window appears with a list of whitelisted domains.



5. Uncheck the required domain check box to blacklist hat specific domain.

6. Select Update.

All users from that blacklisted domain are not allowed to access the UI. To allow the blacklisted domain, you
must check the required domain check box on the Allowed Domain window.

Session Management
View and optionally log out current cnMaestro administrator sessions. The users with Super Administrator role
can logout all other users sessions and the users with Administrator roles can logout Operator and Monitor
accounts.

Sessions
Displays the detailed information on the user sessions.

Cloud Anchor Account

This chapter provides the following details:

l Manage Instances

l Inventory

l Administration

l Network Services

l Manage Subscriptions
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Manage Instances
Registration of On-Premise customer accounts to Cloud is addressed by this feature. This will allow us to do
many synchronization things in On-Premises instances, similar to Cloud will have the inventory stats from
instances.

Manage Instances describes the following

l Onboarding

l On-Premises Instances

l Notifications

Onboarding
To onboard the devices to the Cloud Anchor Account, you need to create the Cloud account before connecting
to cnMaestro On-Premises:

1. Log in to the cnMaestro UI https://cloud.cambiumnetworks.com.

2. In Account Type, select Anchor.

3. Enter the On-Premises Onboarding Key.

4. Click I agree to the cnMaestro Terms of Service.

5. Click Create Account.

https://cloud.cambiumnetworks.com/


6. When the Anchor Account is created, an Onboarding Key must be set to allow On-Premises instances to
connect.

7. Navigate to the Manage Instances page as shown below and allows you to change the Onboarding Key and
Disable Onboarding.

This key needs to be entered in the cnMaestro On-Premises UI to connect to the Anchor Account.

On-Prem Instances
Once the On-Premises server has been onboarded with the Key, it will be included in the On-Prem Instances
page. Multiple On-Premises installations can be added to a single Anchor Account.

By clicking the instance host name, you can see the On-Premises server details such as General, Features,
System, and CBRS:
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Notifications
Notification page displays the history of the most recent events notification of On-Premises instances with
Severity, Source, Name, Raised Time, and Message.

Click View Details to view the Event Details as shown below:

Inventory
The Inventory page displays a list of devices under the selected Node. It presents health and maintenance
information provides a tabular view that allows for sorting and filtering. When selected for a single device, it
presents a detailed customized page of that device.

Administration
Administration provides the following details:

l Users

l Audit Logs



Users
cnMaestro allows to add Users using the Administration > Users page. A maximum of ten users are currently
allowed in the system.

Figure 412 Adding Users

Role-Based Access
On successful authentication, every request from this user is processed in light of their Role.

cnMaestro supports the user Role:

l Super Administrator – Super Administrators can perform all operations.

Creating Users and Configuring User Roles
To add an administrator:

1. Navigate to Administration > Users page.

2. Click Add User button. The following window is displayed:

3. Enter the ID in the Email text box.

4. Click Send button to add this user.

To delete click the Delete icon against the user in the Administration > Users page.

Session Management
View and optionally log out current cnMaestro administrator sessions. The users with Super Administrator role
can logout all other users sessions and the users with Administrator role can log out Operator and Monitor
accounts.

921 | Cloud Anchor Account Cambium cnMaestro Cloud 5.0.1 | User Guide



922 | Cloud Anchor Account Cambium cnMaestro Cloud 5.0.1 | User Guide

Network Services
Network Services provide the following details:

l CBRS

l Organization

CBRS
Citizens Broadband Radio Service subscription for the CBRS-compliant devices in 3.6 GHz band (3550 MHz to
3700 MHz).

For further information, refer to CBRS.

Organization
An Organization allows multiple accounts to share CBRS billing and SAS ID. The Primary account owns this
configuration, and the Secondary account can optionally share it. Both accounts must authorize the sharing.

For further information, refer to Organization.

Manage Subscriptions
Manage Subscriptions provide the following details:

l Subscriptions

l Devices

l On-Premises Instances

Subscriptions
Subscriptions page describes about the usage summary and a list of pending, active, and expired subscriptions.
It aids planning for renewals and the purchase of new subscriptions.



By clicking the Slot icon , you can view the Slot usage per On-Premises Instance as shown below:

It also supports editing the system generated subscription names to more user-friendly names for ease of
tracking.

To edit the Subscriptions perform the following steps:

1. click edit icon.

Edit window pops up as shown below.

2. Enter Name and Description.

3. Click Save.
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Devices
Devices page manages device subscriptions. It is beneficial when a slots deficit exists to accommodate all the
expired devices or if one wants to swap an expired device subscription with another active device of less
importance. For more info refer to Subscription Management.

On-Prem Instances

Note:

On-Premises Instance page is applicable for On-Premises Instance running OVA version
3.2.0 and above.

On-Prem Instances page provides break-up of slots usage per On-Premises instance connected to this Anchor
account such as cnMaestro X, Onboarding, and Essentials.



cnMaestro X - lists the devices that are subscribed and upgraded to cnMaestro X.

Onboarding - lists the devices that are upgraded from On-Premises 3.1.0 and in cnMaestro Trial period.

Essentials - lists the devices that are in the Essentials.

Audit Logs

Note:

Audit Logs are supported only for the cnMaestro X features.

Audit Logs record administration activities through both the Web UI and the RESTful API. Audit Log entries
usually include destination and source addresses, a timestamp and user login information. User can access
Audit Logs in the Administration > Audit Logs page.
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Figure 413 Audit Logs

The following table describes the Audit Logs parameters and their descriptions.

Parameter Description

Action Displays the action performed by the user (create, delete, download, etc).

Description Textual description of the task.

Export Enable export as CSV or PDF.

IP Address IP address of the Web browser or API application.

Module Module generating entry (AAA, administrator, alarm).

Result The result of the audit log as Success or Failed.

Source Administrator or API client name.

Source Type Entity making the update: administrator or API client.

Time The time when the action was performed.

Type Type of the log entry (configuration, operation, onboarding, security).

Table 135: Audit Log Parameters

Log Action

An action log contains a set of transactions. Each transaction contains one or more Actions. Each Action has a
name and input parameters. Some Actions have output parameters.

The following Actions will be supported for individual Audit Log entries. Each activity performed in the server is
detailed in this table.

Parameter Description

Claim Claim a device in the network operator.

Cloud-Connect Provides the status of the On-Premises to Cloud account connection.

Create Create an object in the network device.

Table 136: Log Action Parameters



Parameter Description

Delete Delete an object in the network device.

Download Download a file.

Edit Edit an existing device detail.

Link Test Perform a Link Test.

Login Login to a device.

Logout Logout from a device.

Mail Mail ID of a device.

Move Move a device from the server.

Reboot Reboot a device.

Reset To reset a device

Upload Upload a file on the server.

Table 136: Log Action Parameters

Audit Modules

Auditing activity is mapped to individual modules within cnMaestro. A breakdown of the available modules is
listed below.

Module Type (s) Description

ACL provisioning Adding Editing Removing the ACL Entries.

administrator provisioning

operations

security

User Management: Login, Users, Roles, Email, etc.

alarm provisioning Alarms and Alarm History.

api provisioning API Management: API Clients and Webhooks.

auditing provisioning Auditing Infrastructure.

auto-provision provisioning Auto-Provisioning.

CBRS Services CBRS.

Cloud- Sync Services Synchronizing the Cloud to On-Premises Instances.

data-tunnel provisioning Data Tunneling.

device provisioning Device management.
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Module Type (s) Description

operations

Email-
Notifications

operations Add or edit Email notification.

guest-portal provisioning Guest Portal.

infrastructure provisioning Site, Network, Tower Management.

jobs provisioning

operations

Jobs Infrastructure.

license licensing Update license details.

MSP operations Operations covering Managed Services and Managed Account.

onboard provisioning

operations

Onboarding Queue.

report provisioning

operations

Data Reports.

Profile provisioning Create or update a profile.

SIM provisioning SIM claim and delete.

system provisioning

operations

security

System Services: VM management, change log level, system upgrade,
system monitoring, software images, system settings.

template provisioning Template-Based Configuration.

tools provisioning

operations

Technical support dump, networking operations, etc.

webhooks provisioning Webhooks configuration and management.

Wi-Fi provisioning

operations

security

AP Groups, WLANs: edit W-Fi configuration objects.



Settings

Email Notifications
The Email Notifications feature allows the Super Administrator and the Administrator users to add subscribers
(Email IDs) for receiving different types of alerts by means of Emails.

NOTE:

l Only 2 email recipients can be added per cnMaestro Essentials account.

l Up to 10 email recipients can be added per MSP, Base Infra, and system level scope. For
example, if there is 1 MSP, you can create 10 recipients at MSP, 10 at Base Infra, and 10
at system level (All accounts scope).

The severity of alerts are classified as follows:

l Critical

l Major

l Minor

The content of the email alert will be in JSON or HTML format. The subscriber will get email alert only when the
global setting is enabled.

Figure 414 Email notifications when MSP is disabled

Figure 415 Email notifications when MSP is enabled

user can use the filter option for the following fields:

l Email

l Severity

l Status

l Ignore Notification

User can use the sorting option for the following fields:

l Content Type

l Last Modified Date

Adding Recipient to Subscriber Table
1. Navigate to Administration > Settings > Notifications page and click Add Recipient button.
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Figure 416 Adding Subscribers

The following window is displayed:

2. Enter the Email ID of the subscriber in the Email textbox.

3. Select the severity level from the Severity list.

4. Select the Managed Account type from the Managed Account list.

5. Choose HTML or JSON radio button for the Content Type.

6. Select the appropriate option (s) for Ignore Notification.

7. Click Add and the entry reflects in the subscriber table.

All alarms of chosen severity and above are sent through email as explained below:

l If severity Critical is selected, then we receive only critical alarms.

l If severity Major is selected, then we receive critical and major alarms.

l If severity Minor is selected, then we receive critical, major, and minor alarms.



HTML Email Example

JSON Email Example

Account Type
cnMaestro supports three separate account types, based upon the composition of devices installed. The type is
set when the account is created initially, but it can be changed later through the Administration > Settings page.

For more information, please refer Navigating the cnMaestro UI.

Managing Device software images under Automatically
Update Device Software section
cnMaestro cloud allows one to update the device software during onboarding and for managed devices.

Adding update device software is a manual process as follows:

1. Navigate to Administration > Settings > Software Images > Automatically Update Device Software tab.
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2. Select the version file and then click onboarding/Managed Devices check Box.

NOTE:

Enable the onboarding check box, in order to avoid the failure of onboarding devices with
minimum supported version rather than the recommended version.

3. Enable the checkbox as follows:

l Enable Managed Devices flag only for wifi devices (E-Series, R-Series and XV-Series).

l Enable Sequential Site Update and Both Partitions flag only for only E-Series and XV-Series devices.

4. click Apply Settings.

NOTE:

Once auto software update job for managed devices is triggered, it will automatically abort
any manually created running/scheduled software update jobs.

In order to avoid failures in onboarding devices having minimum supported version other than
recommended version enable the onboarding check.

Figure 417 Software Images



Appendix
This section includes the following topics:

l Network Port Requirements

l XMS-Enterprise to cnMaestro X

l Converting Tier 2 Unused Slots

Network Port Requirements

Network Port Requirements for Outbound
The following table provides information about network port requirements for outbound:

Port Number Port Type Purpose

443 TCP HTTPS Web Access and Device communication

Table 137: Outbound Port Details

XMS-Enterprise to cnMaestro X

This section describes the process of migration from XMS-Enterprise (XMS-E) to cnMaestro X.

Before you begin migration, upgrade the following to the latest version:

l XMS-E to version 8.4.0

l Xirrus APs to version 8.7.0

Perform the following steps for migration:

1. In XMS-E do the following:

l Export Golden Configuration

l Migrate to cnMaestro X

2. In cnMaestro X do the following:

l Create Wi-Fi AP Group

l Approve APs into Wi-Fi AP Group

l Import and Apply AP configuration

XMS-E system
To login to XMS-E, complete the following steps:

1. Launch the Web login page.

2. Enter the username and password.

3. Click Login.
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Export Golden Configuration
Export Golden Configuration for one of the APs. It is saved as a zipped file in the local file system.

To start export golden configuration in XMS-E, navigate to Configure tab > Export.

1. Select Export to cnMaestro.

2. Select the AP to create the golden configuration for a group of APs and click Next.

NOTE:

l Select the AP with the maximum radios and the highest capability.

l During the migration of an AP from XMS-E to cnMaestro, the AP configurations are not
modified.



4. Select group of APs to be added to the spreadsheet and click Next.

5. Click Export.

In Local System unzip the directory and files to local directory.

6. Download the zip files from the browser window.

7. Go to the folder where the zipped files are saved and extract the contents to a folder.

8. Open the directory path where the file has been stored and double-click on the zipped file.
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9. Click Extract all.

10. Extract the folder to the path.

11. Make a note of the folder or file location as you will require this file later.



Migrate to cnMaestro X
Select APs to migrate to cnMaestro X. Perform the following steps:

1. Navigate to the More menu > select Migrate APs to cnMaestro.

2. Enter the IP address or Hostname mapped in DNS for cnMaestro X.

3. Select Delete AP or Put AP(s) out of Service and click OK.
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NOTE:

l Out of service APs are not removed from XMS-E, so if there is an issue, select the Return
APs to Service option and they will return to XMS-E.

l You must reset using the snmp trap host 1 Xirrus-XMS AP CLI command on the
AP for the return to service to work.

l If you select Delete APs, they will be removed and you must rediscover them on the
network to return them to XMS-E.

l You should also remove the Device Network from the Device discovery section to
clean up XMS-E.

A success message from XMS-E for each of the APs migrated to cnMaestro X is displayed.

Create Wi-Fi AP Group
Create Wi-Fi AP Group and Import CLI command file from exported directory.

1. Navigate to Wi-Fi AP Group > Base Infrastructure > click action ( ) icon to add Add AP Group.

2. In the Basic Information page, select Type as Enterprise Wi-Fi (Xirrus-Series) from the drop-down.

3. Select the Auto-Sync.

4. Click Save.



3. In the Full Configuration page, click the Import option.

5. Select the CLI command file from the unzipped directory.

5. Click Import.

The configuration file is displayed.
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6. Click Save.

Approve APs into Wi-Fi AP Group

APs pending for approval in cnMaestro X based on the Migrate APs to cnMaestro X steps as described above.

You can claim APs to approve from the Onboard > Devices page.

Perform the following steps to approve APs from the Onboard > Devices page.

1. Navigate to the Onboard > Devices page and click Approve All (to approve all devices at once) or Approve
(to approve devices individually.)

2. Enter the required details, provision the device for location, and assign to an AP Group.



7. Click Save.

8. In the Onboard > Devices page, select Approval All (to approve all devices at once) or Approve (to approve
devices individually.)

Import and Apply AP configuration
APs imported are ready for basic configuration. Import AP configuration using the CSV file from the exported
directory.

1. Navigate to Wi-Fi AP Group > select AP Group > AP Configuration.

2. Select all APs to configure, click Configure.
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3. In Device Override table, verify AP details and click Import.

NOTE:

Email and Phone fields are auto populated from the .csv file.

4. Select the .csv import file from the unzipped directory folder and click Apply.

All the configuration values from the CSV file are populated for each AP. The data is auto populated to the User
Defined Variables tab. The APs receive complete configurations including all IAP settings.



5. Click Apply Configuration.

When the APs are completely configured, Sync Status is displayed as In Sync.

You have to refresh the page to view the updated Sync Status.
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Converting Tier 2 Unused Slots

Cambium Networks has introduced new product family-based cnMaestro X SKUs and pricing for devices such
as Fixed Wireless Broadband APs, cnRanger, cnReach, cnVision, PMP, ePMP, and PTP. Earlier, the Tier 2
subscription was used to control these devices (pricing). To simplify the purchase and onboarding for these
devices, Cambium Networks has decided to remove the Tier 2 subscription and introduce new four tiers (Tier
21, Tier 22, Tier 23, and Tier 24).

The Tier 2 subscription is no longer valid now. Due to Tier 2 subscription removal, there can be unused Tier 2
slots in your account (purchased during the Tier 2 subscription). As a solution, Cambium Networks provides an
option to convert these unused Tier 2 slots into new tiers based on the device family and requirements. You can
manually convert the unused Tier 2 slots to Tier 21, Tier 22, Tier 23, and Tier 24 using the icon located on the

Manage Subscriptions page (cnMaestro UI). This solution helps in better mapping and device management.

NOTE:

The Convert Tier 2 option is effective from March 1, 2024 for Fixed Wireless Broadband APs,
cnRanger, cnReach, cnVision, and PTP devices. You must convert the unused Tier 2 slots in
your account to the new Tier 2x slots before onboarding the devices.

When you convert the unused Tier 2 slots into new tiers, you cannot change the new tiers
back to Tier 2.

You can convert the unused Tier 2 slots to new tiers, for example, as described in Table 138.

New Tier Device Family and Type

Tier 21 cnVision FLEXr, HUB360

ePMP All AP Models

Tier 22 PMP All AP Models except 450m and 450mv

Tier 23 PMP 450m

Tier 24 cnRanger All BBU Models

cnReach All cnReach Models

PTP All PTP Models

Table 138: Example of converting unused Tier 2 slots

To manually convert the unused Tier 2 slots for a device family, complete the following steps:

1. Log in to your respective cnMaestro UI account.

The Home page appears with a banner, as shown in Figure 418.



Figure 418 The Tier 2 conversion-specific banner

2. From the home page, navigate to the Manage Subscriptions page.

The Manage Subscriptions page appears (as shown in Figure 419), displaying the same banner and details of
tiers.

Figure 419 The Manage Subscriptions page with tier information

3. Select the Tier 2 subscription and click the corresponding icon (as shown in Figure 419).

The Tier 2 subscription window appears with details of unused slots and options to convert to new tiers (Tier
21, Tier 22, Tier 23, and Tier 24).
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Figure 420 The Convert Tier 2 window

4. Check the unused slot count and enter a valid value (in integers) in Tier 21, Tier 22, Tier 23, or Tier 24 text
boxes (based on your requirements).

5. Click the Save button (as shown in Figure 420) to apply the changes.



Cambium cnMaestro Cloud 5.0.1 User GuideReference Guide



948 |  Cambium cnMaestro Cloud 5.0.1 | User Guide

Contacting Cambium Networks

Support Website https://support.cambiumnetworks.com/

Main Website http://www.cambiumnetworks.com

cnMaestro Community http://community.cambiumnetworks.com/t5/cnMaestro/bd-p/cnMaestro

Sales Enquiries solutions@cambiumnetworks.com

Support Enquiries support@cambiumnetworks.com

Telephone Number List http://www.cambiumnetworks.com/support/contact-support

Address Cambium Networks Limited,

Linhay Business Park,

Eastern Road,

Ashburton,

Devon, TQ13 7UP

United Kingdom

https://support.cambiumnetworks.com/
http://www.cambiumnetworks.com/
http://community.cambiumnetworks.com/t5/cnMaestro/bd-p/cnMaestro
mailto:solutions@cambiumnetworks.com
mailto:support@cambiumnetworks.com
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